Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
dispositivo /dev/dsp nao existe
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
amsrn
n00b
n00b


Joined: 20 Aug 2004
Posts: 1

PostPosted: Fri Aug 20, 2004 5:27 pm    Post subject: dispositivo /dev/dsp nao existe Reply with quote

Bem pessoal o negocio é o seguinte, instalei o gentoo a pouco tem e quando entro no kde recebo uma msg dizendo q /dev/dsp não foi encontrado ou não existe, realmente fui lah no /dev e constatei que não existe mesmo o dsp. Dando uma pesquisada vi q dando um MAKEDEV possivelmente resolveria meu problema, soh q qnd dou o comando recebo a seguinte msg ".devfsd presence implies active DevFS. Aborting MAKEDEV invocation."

O q faço???


[]'s
Adriano
Back to top
View user's profile Send private message
pilla
Administrator
Administrator


Joined: 07 Aug 2002
Posts: 7692
Location: Pelotas, BR

PostPosted: Fri Aug 20, 2004 7:24 pm    Post subject: Reply with quote

Instalações Gentoo geralmente usam devfsd (como parece ser teu caso) que cria automaticamente as entradas em /dev para os teus dispositivos.

O que deve estar acontecendo é que o teu hardware de som não está corretamente instalado, provavelmente faltando a opção correta no kernel ou na configuração do devfsd.

Veja http://www.gentoo.org/doc/en/devfs-guide.xml e http://www.gentoo.org/doc/en/alsa-guide.xml para ver como fazer isso.
_________________
"I'm just very selective about the reality I choose to accept." -- Calvin
Back to top
View user's profile Send private message
ashtophet
Guru
Guru


Joined: 08 Aug 2004
Posts: 396
Location: Galiza

PostPosted: Fri Aug 20, 2004 7:39 pm    Post subject: Reply with quote

qual é a sua placa de som (marca e modelo)?
Back to top
View user's profile Send private message
ashtophet
Guru
Guru


Joined: 08 Aug 2004
Posts: 396
Location: Galiza

PostPosted: Fri Aug 20, 2004 7:46 pm    Post subject: Reply with quote

não vi a mensagem de pilla... Nos links que lhe oferece tem toda a informação...

saúde...
Back to top
View user's profile Send private message
fernandotcl
Veteran
Veteran


Joined: 20 Nov 2003
Posts: 1396
Location: Sao Paulo, Brazil

PostPosted: Fri Aug 20, 2004 9:30 pm    Post subject: Reply with quote

Se não me engano, /dev/dsp é um dispositivo do OSS. Se você tem alsa, deve ser necessário ativar a emulação OSS.
Back to top
View user's profile Send private message
Xterminator
n00b
n00b


Joined: 26 Sep 2003
Posts: 12

PostPosted: Tue Aug 24, 2004 4:27 pm    Post subject: Reply with quote

Veja se ajuda...

http://www.linuxbsd.com.br/forum/viewtopic.php?t=3413&highlight=criar+dsp

Quote:
opa verifique se você tem estes 2 dispositivos...
snd-pcm-oss ; snd-mixer-oss <--o alsa cria os 2 ...
daí basta adicionar ao modules.conf,modprobe.conf ou rc.modules depende da distro ...
aqui o que eu adicionei ao meu :-) até hoje tá funcionando beleza...com o 2.4 e 2.6...

alias /dev/mixer snd-mixer-oss
alias /dev/dsp snd-pcm-oss


logicamente deve ser adicionado a linha pra carregar os modulos em algum script de configuração...por exemplo rc.local
modprobe -v snd-mixer-oss
modprobe -v snd-pcm-oss


Espero que funcione comigo funfa de boua...
Code:

[root@Zumbi edson]# lsmod | grep snd
snd-pcm-oss            40740   0  (autoclean)
snd-mixer-oss          13496   0  (autoclean) [snd-pcm-oss]
snd-sonicvibes         13604   0
snd-pcm                74980   0  [snd-pcm-oss snd-sonicvibes]
snd-page-alloc          7636   0  [snd-pcm]
snd-opl3-lib            7492   0  [snd-sonicvibes]
snd-timer              17412   0  [snd-pcm snd-opl3-lib]
snd-hwdep               6208   0  [snd-opl3-lib]
gameport                3076   0  [snd-sonicvibes]
snd-mpu401-uart         4384   0  [snd-sonicvibes]
snd-rawmidi            16960   0  [snd-mpu401-uart]
snd-seq-device          5580   0  [snd-opl3-lib snd-rawmidi]
snd                    37668   0  [snd-pcm-oss snd-mixer-oss snd-sonicvibes snd-pcm snd-opl3-lib snd-timer snd-hwdep snd-mpu401-uart snd-rawmidi snd-seq-device]soundcore               5796   6  [snd]
[root@Zumbi edson]#
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum