Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200408-16 ] glibc: Information leak with LD_DEBUG
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Moderator
Moderator


Joined: 13 Jun 2003
Posts: 4078
Location: Barcelona, Spain

PostPosted: Tue Aug 17, 2004 9:10 pm    Post subject: [ GLSA 200408-16 ] glibc: Information leak with LD_DEBUG Reply with quote

Gentoo Linux Security Advisory

Title: glibc: Information leak with LD_DEBUG (GLSA 200408-16)
Severity: low
Exploitable: local
Date: August 16, 2004
Updated: May 28, 2006
Bug(s): #59526
ID: 200408-16

Synopsis


glibc contains an information leak vulnerability allowing the debugging of
SUID binaries.


Background


The GNU C library defines various Unix-like "system calls" and other
basic facilities needed for a standard POSIX-like application to
operate.


Affected Packages

Package: sys-libs/glibc
Vulnerable: <= 2.3.2-r10
Unaffected: >= 2.3.2-r11
Architectures: alpha arm hppa ia64 sparc s390

Package: sys-libs/glibc
Vulnerable: <= 2.3.3.20040420
Unaffected: >= 2.3.3.20040420-r1
Architectures: x86 ppc

Package: sys-libs/glibc
Vulnerable: <= 2.3.3.20040420
Unaffected: >= 2.3.4.20040619-r1
Architectures: mips

Package: sys-libs/glibc
Vulnerable: <= 2.3.4.20040619
Unaffected: >= 2.3.4.20040619-r1
Architectures: amd64

Package: sys-libs/glibc
Vulnerable: <= 2.3.4.20040605
Unaffected: >= 2.3.4.20040808
Architectures: ppc64


Description


Silvio Cesare discovered a potential information leak in glibc. It
allows LD_DEBUG on SUID binaries where it should not be allowed. This
has various security implications, which may be used to gain
confidentional information.


Impact


An attacker can gain the list of symbols a SUID application uses and
their locations and can then use a trojaned library taking precendence
over those symbols to gain information or perform further exploitation.


Workaround


There is no known workaround at this time. All users are encouraged to
upgrade to the latest available version of glibc.


Resolution


All glibc users should upgrade to the latest version:
Code:
# emerge sync
   
    # emerge -pv your_version
    # emerge your_version


References

CVE-2004-1453


Last edited by GLSA on Mon Jul 16, 2012 4:17 am; edited 5 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum