Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problemas no gnome após atualizar glibc [SOLVED]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
Gotterdammerung
l33t
l33t


Joined: 11 Feb 2004
Posts: 627
Location: Rio de Janeiro, Brazil

PostPosted: Wed Aug 11, 2004 4:13 am    Post subject: Problemas no gnome após atualizar glibc [SOLVED] Reply with quote

Após atualizar a glibc para a versão 2.3.3.20040420-r1 comecei a ter problemas com o metacity (2.8.1). Quando entro no Gnome ele parece não ser carregado, não aparecendo os ícones no desktop. O gnome-panel (2.6.2) também está com problemas: não fica transparente. Esse mesmo problema também pode ser observado no gnome-terminal. Eu já fiz um emerge -e system e um emerge -e world.

Alguém sabe como posso resolver isso?



Code:
Portage 2.0.50-r9 (default-x86-2004.0, gcc-3.3.3, glibc-2.3.3.20040420-r1, 2.6.8-rc2-mm2)
=================================================================
System uname: 2.6.8-rc2-mm2 i686 AMD Athlon(tm) XP 2400+
Gentoo Base System version 1.4.16
ccache version 2.3 [enabled]
Autoconf: sys-devel/autoconf-2.59-r4
Automake: sys-devel/automake-1.8.3
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-O3 -march=athlon-xp -pipe"
CHOST="i686-pc-linux-gnu"
COMPILER="gcc3"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O3 -march=athlon-xp -pipe"
DISTDIR="/mnt/hdc/distfiles"
FEATURES="autoaddcvs ccache fixpackages sandbox"
GENTOO_MIRRORS="http://gentoo.oregonstate.edu http://distro.ibiblio.org/pub/Linux/distributions/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow X alsa apm avi berkdb cdr cmipci crypt cups encode foomaticdb gdbm gif gnome gpm gtk gtk2 imlib java jpeg libg++ libwww mad mikmod mmx motif mozilla moznocompose moznoirc moznomail mpeg ncurses nls nptl oggvorbis opengl oss pam pdflib perl png python quicktime readline sdl slang spell sse ssl svga tcpd threads truetype x86 xml2 xmms xv zlib"

_________________
A mind that is stretched by a new experience can never go back to its old dimensions. - Oliver Wendell Holmes


Last edited by Gotterdammerung on Tue Nov 29, 2005 2:47 am; edited 1 time in total
Back to top
View user's profile Send private message
Matheus Villela
Apprentice
Apprentice


Joined: 25 Oct 2003
Posts: 263

PostPosted: Wed Aug 11, 2004 4:42 am    Post subject: Reply with quote

Não tenho certeza mas vou chutar :o

Se tu fez tudo isso e não reiniciou o computador tenta sair do X e ver se tem algum processo do gnome rodando, se tiver mata o processo e entra no gnome de novo
Back to top
View user's profile Send private message
Gotterdammerung
l33t
l33t


Joined: 11 Feb 2004
Posts: 627
Location: Rio de Janeiro, Brazil

PostPosted: Wed Aug 11, 2004 12:40 pm    Post subject: Reply with quote

Matheus Villela wrote:
Não tenho certeza mas vou chutar :o

Se tu fez tudo isso e não reiniciou o computador tenta sair do X e ver se tem algum processo do gnome rodando, se tiver mata o processo e entra no gnome de novo


Matheus, eu gostaria muito de te dizer que era só isso, mas infelizmente eu já tinha dado uns dois boots na máquina e o problema não se resolveu.
_________________
A mind that is stretched by a new experience can never go back to its old dimensions. - Oliver Wendell Holmes
Back to top
View user's profile Send private message
Mythos
l33t
l33t


Joined: 02 May 2004
Posts: 953
Location: Portugal

PostPosted: Wed Aug 11, 2004 1:58 pm    Post subject: Reply with quote

Code:
echo "sys-libs/glibc ~x86" >> /etc/portage/package.keywords
emerge glibc


Latest version installed: 2.3.4.20040619-r1 é a que eu tenho, e não me deparei com esse s problemas.
_________________
Best Regards,
Sérgio Henrique
Linux dune 3.0.6-gentoo #1 SMP Thu Oct 27 16:47:29 WEST 2011 x86_64 Intel(R) Core(TM)2 Duo CPU T7500 @ 2.20GHz GenuineIntel GNU/Linux
Back to top
View user's profile Send private message
Matheus Villela
Apprentice
Apprentice


Joined: 25 Oct 2003
Posts: 263

PostPosted: Wed Aug 11, 2004 4:10 pm    Post subject: Reply with quote

Que pena que não é, tive um problema semelhante e era exatamente isso pra resolver.

O problema ocorre com qualquer usuário? Já tentou deletar teu ~/.gnome2/sessions?
Back to top
View user's profile Send private message
fernandotcl
Veteran
Veteran


Joined: 20 Nov 2003
Posts: 1396
Location: Sao Paulo, Brazil

PostPosted: Wed Aug 11, 2004 5:17 pm    Post subject: Reply with quote

Você consegue carregar o Metacity por dentro do Gnome sem erros? Suponho que o painel esteja visível, se não estiver, adicione "xterm &" antes de tudo no ~/.xinitrc e do xterm tente carregar o Metacity pra ver se ele dá erros.
Back to top
View user's profile Send private message
Gotterdammerung
l33t
l33t


Joined: 11 Feb 2004
Posts: 627
Location: Rio de Janeiro, Brazil

PostPosted: Thu Aug 12, 2004 2:23 am    Post subject: Reply with quote

Matheus Villela wrote:
Que pena que não é, tive um problema semelhante e era exatamente isso pra resolver.

O problema ocorre com qualquer usuário? Já tentou deletar teu ~/.gnome2/sessions?


Eu tinha ficado receoso de apagar esse arquivo. Não lembro bem o porque, mas resolveu. Valeu, Matheus! Ótima dica!
_________________
A mind that is stretched by a new experience can never go back to its old dimensions. - Oliver Wendell Holmes
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum