Joined: 23 Sep 2003
Location: Sat in front of my computer
|Posted: Tue Aug 10, 2004 11:10 pm Post subject: [ GLSA 200408-08 ] Cfengine: RSA Authentication Heap Corrupt
|Gentoo Linux Security Advisory
Title: Cfengine: RSA Authentication Heap Corruption (GLSA 200408-08)
Date: August 10, 2004
Updated: May 22, 2006
Cfengine is vulnerable to a remote root exploit from clients in AllowConnectionsFrom.
Cfengine is an agent/software robot and a high level policy language for building expert systems to administrate and configure large computer networks.
Vulnerable: <= 2.1.7
Unaffected: >= 2.1.8
Unaffected: < 2.0.0
Architectures: All supported architectures
Two vulnerabilities have been found in cfservd. One is a buffer overflow in the AuthenticationDialogue function and the other is a failure to check the proper return value of the ReceiveTransaction function.
An attacker could use the buffer overflow to execute arbitrary code with the permissions of the user running cfservd, which is usually the root user. However, before such an attack could be mounted, the IP-based ACL would have to be bypassed. With the second vulnerability, an attacker could cause a denial of service attack.
There is no known workaround at this time. All users are encouraged to upgrade to the latest available version of Cfengine. (It should be noted that disabling cfservd will work around this particular problem. However, in many cases, doing so will cripple your Cfengine setup. Upgrading is strongly recommended.)
All Cfengine users should upgrade to the latest version:
|# emerge sync
# emerge -pv ">=net-misc/cfengine-2.1.8"
# emerge ">=net-misc/cfengine-2.1.8"
Last edited by GLSA on Tue May 23, 2006 4:17 am; edited 2 times in total