Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Пропал звук !
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Russian
View previous topic :: View next topic  
Author Message
Camp
Tux's lil' helper
Tux's lil' helper


Joined: 31 May 2004
Posts: 82
Location: Moscow

PostPosted: Mon Aug 09, 2004 12:18 pm    Post subject: Пропал звук ! Reply with quote

после перезагрузки пропал звук
пишется Couldn't open mixer device /dev/sound/mixer
а еще в папке /dev/sound был файл dsp который тоже исчез !
lspci мою звуковую (cmedia8738) находит но звука нет !
что делать ?
_________________
registered Linux user #357267
GENTOO
Back to top
View user's profile Send private message
icedank
Apprentice
Apprentice


Joined: 15 Apr 2004
Posts: 190

PostPosted: Mon Aug 09, 2004 1:35 pm    Post subject: Reply with quote

Опять люди с `папками`...

Что делать:
1. проверить пущена ли алса - /etc/init.d/alsasound status
2. если нет - стартануть - /etc/init.d/alsasound start
3. добавить её в boot runlevel (или на default если нет udev) - rc-update add alsasound boot
4. Если не помогло - втыкать на dmsg
Back to top
View user's profile Send private message
Camp
Tux's lil' helper
Tux's lil' helper


Joined: 31 May 2004
Posts: 82
Location: Moscow

PostPosted: Mon Aug 09, 2004 3:18 pm    Post subject: Reply with quote

icedank wrote:
Опять люди с `папками`...

Где ?
себя такими не считаю :D
перекомпилил ядро и все стало на места
я дyмаю чтото намудрил с ядром при установке vmware
а алсой и не пользуюсь )
_________________
registered Linux user #357267
GENTOO
Back to top
View user's profile Send private message
icedank
Apprentice
Apprentice


Joined: 15 Apr 2004
Posts: 190

PostPosted: Mon Aug 09, 2004 5:24 pm    Post subject: Reply with quote

Quote:

а еще в папке /dev/sound был файл dsp который тоже исчез !
Back to top
View user's profile Send private message
Camp
Tux's lil' helper
Tux's lil' helper


Joined: 31 May 2004
Posts: 82
Location: Moscow

PostPosted: Mon Aug 09, 2004 5:29 pm    Post subject: Reply with quote

каталогами и директориями я их считаю когда в них чтото есть 8)
_________________
registered Linux user #357267
GENTOO
Back to top
View user's profile Send private message
chiko
n00b
n00b


Joined: 22 Jan 2004
Posts: 52
Location: Achinsk, Krasnoyarsky kray, Russia

PostPosted: Tue Aug 10, 2004 7:53 am    Post subject: Re: Пропал звук ! Reply with quote

Camp wrote:
после перезагрузки пропал звук ...


Отверткой в это время ухо не ковырял? :)
Если трабла решится - скажи как решил, у моего кента на мандраке то же самое было.
_________________
Athlon-XP 1900+
Fluxbox 0.99
Back to top
View user's profile Send private message
Camp
Tux's lil' helper
Tux's lil' helper


Joined: 31 May 2004
Posts: 82
Location: Moscow

PostPosted: Tue Aug 10, 2004 9:39 am    Post subject: Reply with quote

пересобрал ядро и в новом ядре файлы устройств появились
но почему звук пропал в старом ядре никак не пойму, его и до сих пор нету. :?
_________________
registered Linux user #357267
GENTOO
Back to top
View user's profile Send private message
rusxakep
Guru
Guru


Joined: 09 Jul 2004
Posts: 458
Location: Moscow, Russia

PostPosted: Tue Aug 10, 2004 12:07 pm    Post subject: Reply with quote

Надо отрубать весь звук в ядре и emerge alsa-driver

.... и будет звук .....
Back to top
View user's profile Send private message
deadlyFROZEN
Tux's lil' helper
Tux's lil' helper


Joined: 11 Jun 2004
Posts: 114

PostPosted: Wed Aug 11, 2004 6:31 am    Post subject: Reply with quote

rusxakep wrote:
Надо отрубать весь звук в ядре и emerge alsa-driver

.... и будет звук .....

все-таки поддержку звука как модуль надо оставить
_________________
...whether tis nobler? from the win to suffer,
from the bugs ´n issues of a commercial system
or to raise your mind against a sea of troubles,
and by a LINUX end them?...
Back to top
View user's profile Send private message
rusxakep
Guru
Guru


Joined: 09 Jul 2004
Posts: 458
Location: Moscow, Russia

PostPosted: Wed Aug 11, 2004 7:29 am    Post subject: Reply with quote

незнаю, я вырубаю все - и пока пашет :)

2.6.7-r13

P.S: alsa-driver сам использует исходники 2.5-2.6 ядер и сам делает модуль. Так что можно смело вырубать все звуковое в ядре >2.5.0
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Russian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum