Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Fluidportage ebuilds for CVS/SVN programs
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4 ... 12, 13, 14  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
gungholady
Guru
Guru


Joined: 19 Oct 2003
Posts: 392

PostPosted: Tue Aug 17, 2004 9:35 am    Post subject: Reply with quote

Redeeman wrote:
could you try attach strace to the process?


This is something I've never done before. How do I do an strace on the process?
Back to top
View user's profile Send private message
gungholady
Guru
Guru


Joined: 19 Oct 2003
Posts: 392

PostPosted: Tue Aug 17, 2004 9:37 am    Post subject: Reply with quote

Jeremy_Z wrote:
Maybe it just takes ages ... had someting similar with Eclipse, javadoc was taking more time than compilation.


I have let it sit for 10 minutes or longer and it never gets past this point where it has stalled.
Back to top
View user's profile Send private message
Jeremy_Z
l33t
l33t


Joined: 05 Apr 2004
Posts: 671
Location: Shanghai

PostPosted: Tue Aug 17, 2004 12:19 pm    Post subject: Reply with quote

10 min is not much but well you may have a problem.
_________________
"Because two groups of consumers drive the absolute high end of home computing: the gamers and the porn surfers." /.
My gentoo projects, Kelogviewer and a QT4 gui for etc-proposals
Back to top
View user's profile Send private message
BNoise
n00b
n00b


Joined: 10 Feb 2003
Posts: 53
Location: Argentina

PostPosted: Tue Aug 17, 2004 8:18 pm    Post subject: Reply with quote

Code:

athas local # svn co http://kaspersandberg.com/fluidportage
svn: REPORT request failed on '/fluidportage/!svn/vcc/default'
svn: REPORT of '/fluidportage/!svn/vcc/default': 400 Bad Request (http://kaspersandberg.com)


why is that?
Back to top
View user's profile Send private message
sn4ip3r
Guru
Guru


Joined: 14 Dec 2002
Posts: 325
Location: Tallinn, Estonia

PostPosted: Tue Aug 17, 2004 10:32 pm    Post subject: Reply with quote

gungholady wrote:
Redeeman wrote:
could you try attach strace to the process?


This is something I've never done before. How do I do an strace on the process?


First make sure you have strace (emerge strace if there is no such command). Running "strace emerge hal-cvs" might be a bit too much, so first just run "emerge hal-cvs" and if it starts "stalling" just ctrl-c or kill it somehow. Then "cd /var/tmp/portage/hal-cvs-<version>/work/hal/doc/spec" and run "make", if it again starts stalling kill it again and then try "strace make", this should stop at some point (start stalling again, but you should see a _very long_ output of what the program was doing and hopefully some of it reveals why the program is stalling (if you can't figure it out yourself post the end (a few "pages") of the output here).
Back to top
View user's profile Send private message
sn4ip3r
Guru
Guru


Joined: 14 Dec 2002
Posts: 325
Location: Tallinn, Estonia

PostPosted: Tue Aug 17, 2004 10:36 pm    Post subject: Reply with quote

BNoise wrote:
Code:

athas local # svn co http://kaspersandberg.com/fluidportage
svn: REPORT request failed on '/fluidportage/!svn/vcc/default'
svn: REPORT of '/fluidportage/!svn/vcc/default': 400 Bad Request (http://kaspersandberg.com)


why is that?


Works just fine here, the server was probably down for a small (?) while.
Back to top
View user's profile Send private message
Redeeman
l33t
l33t


Joined: 25 Sep 2003
Posts: 957
Location: Denmark

PostPosted: Tue Aug 17, 2004 10:40 pm    Post subject: Reply with quote

nope, it was not down tonight at all :>
_________________
Sandberg Enterprises
Back to top
View user's profile Send private message
gungholady
Guru
Guru


Joined: 19 Oct 2003
Posts: 392

PostPosted: Wed Aug 18, 2004 2:00 am    Post subject: Reply with quote

sn4ip3r wrote:
gungholady wrote:
Redeeman wrote:
could you try attach strace to the process?


This is something I've never done before. How do I do an strace on the process?


First make sure you have strace (emerge strace if there is no such command). Running "strace emerge hal-cvs" might be a bit too much, so first just run "emerge hal-cvs" and if it starts "stalling" just ctrl-c or kill it somehow. Then "cd /var/tmp/portage/hal-cvs-<version>/work/hal/doc/spec" and run "make", if it again starts stalling kill it again and then try "strace make", this should stop at some point (start stalling again, but you should see a _very long_ output of what the program was doing and hopefully some of it reveals why the program is stalling (if you can't figure it out yourself post the end (a few "pages") of the output here).


I'm trying something else first. I got to looking at the hal-cvs ebuild and there were dependencies for gnome. I had -gnome in my cflags. I'm trying USE="gnome" emerge hal-cvs. It finished all the gnome dependencies but at the moment it can't access the url to get hal-cvs. I'll have to wait a little bit and try it again. Then if that doesn't solve the problem, I'll try the strace. I already emerged strace just iin case I need it.
Back to top
View user's profile Send private message
gungholady
Guru
Guru


Joined: 19 Oct 2003
Posts: 392

PostPosted: Wed Aug 18, 2004 2:13 am    Post subject: Reply with quote

Here is the result of the strace:

gungholady spec # strace make
execve("/usr/bin/make", ["make"], [/* 44 vars */]) = 0
uname({sys="Linux", node="gungholady", ...}) = 0
brk(0) = 0x806c000
open("/etc/ld.so.preload", O_RDONLY) = -1 ENOENT (No such file or directory)
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1,0) = 0x40016000
open("/etc/ld.so.cache", O_RDONLY) = 3
fstat64(3, {st_mode=S_IFREG|0644, st_size=101435, ...}) = 0
mmap2(NULL, 101435, PROT_READ, MAP_PRIVATE, 3, 0) = 0x40017000
close(3) = 0
open("/lib/librt.so.1", O_RDONLY) = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\0 \0\000"...,512) = 512
fstat64(3, {st_mode=S_IFREG|0755, st_size=49198, ...}) = 0
mmap2(NULL, 31272, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 3, 0) = 0x40030000
mmap2(0x40037000, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x6) = 0x40037000
close(3) = 0
open("/lib/libc.so.6", O_RDONLY) = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0@P\1\000"..., 512) = 512
fstat64(3, {st_mode=S_IFREG|0755, st_size=1472721, ...}) = 0
mmap2(NULL, 1136044, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 3, 0) = 0x40038000
mmap2(0x40148000, 12288, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x110) = 0x40148000
mmap2(0x4014b000, 9644, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x4014b000
close(3) = 0
open("/lib/libpthread.so.0", O_RDONLY) = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\260I\0"..., 512) = 512
fstat64(3, {st_mode=S_IFREG|0755, st_size=115797, ...}) = 0
mmap2(NULL, 69548, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 3, 0) = 0x4014e000
mmap2(0x4015c000, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0xd) = 0x4015c000
mmap2(0x4015d000, 8108, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x4015d000
close(3) = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1,0) = 0x4015f000
set_thread_area({entry_number:-1 -> 6, base_addr:0x4015f280, limit:1048575, seg_32bit:1, contents:0, read_exec_only:0, limit_in_pages:1, seg_not_present:0, useable:1}) = 0
munmap(0x40017000, 101435) = 0
set_tid_address(0x4015f2c8) = 4083
rt_sigaction(SIGRTMIN, {0x40152600, [], SA_SIGINFO}, NULL, 8) = 0
rt_sigprocmask(SIG_UNBLOCK, [RTMIN], NULL, 8) = 0
getrlimit(RLIMIT_STACK, {rlim_cur=8192*1024, rlim_max=RLIM_INFINITY}) = 0
_sysctl({{CTL_KERN, KERN_VERSION}, 2, 0xbffff0e8, 31, (nil), 0}) = 0
open("/dev/urandom", O_RDONLY) = 3
read(3, "s\311\21\17", 4) = 4
close(3) = 0
brk(0) = 0x806c000
brk(0x808d000) = 0x808d000
rt_sigaction(SIGHUP, {0x804b3a0, [HUP], SA_RESTART}, {SIG_DFL}, 8) = 0
rt_sigaction(SIGQUIT, {0x804b3a0, [QUIT], SA_RESTART}, {SIG_DFL}, 8) =0
rt_sigaction(SIGINT, {0x804b3a0, [INT], SA_RESTART}, {SIG_DFL}, 8) = 0
rt_sigaction(SIGTERM, {0x804b3a0, [TERM], SA_RESTART}, {SIG_DFL}, 8) =0
rt_sigaction(SIGXCPU, {0x804b3a0, [XCPU], SA_RESTART}, {SIG_DFL}, 8) =0
rt_sigaction(SIGXFSZ, {0x804b3a0, [XFSZ], SA_RESTART}, {SIG_DFL}, 8) =0
rt_sigaction(SIGCHLD, {SIG_DFL}, {SIG_DFL}, 8) = 0
getcwd("/var/tmp/portage/hal-cvs-20040522/work/hal-cvs/doc/spec", 4096) = 56
stat64("/usr/include", {st_mode=S_IFDIR|0755, st_size=16576, ...}) = 0
stat64("/usr/gnu/include", 0xbfffda70) = -1 ENOENT (No such file or directory)
stat64("/usr/local/include", 0xbfffda70) = -1 ENOENT (No such file or directory)
stat64("/usr/include", {st_mode=S_IFDIR|0755, st_size=16576, ...}) = 0
rt_sigaction(SIGCHLD, {0x80531f0, [CHLD], SA_RESTART}, {SIG_DFL}, 8) =0
rt_sigaction(SIGUSR1, {0x80554a0, [USR1], SA_RESTART}, {SIG_DFL}, 8) =0
stat64(".", {st_mode=S_IFDIR|0755, st_size=624, ...}) = 0
open(".", O_RDONLY|O_NONBLOCK|O_LARGEFILE|O_DIRECTORY) = 3
fstat64(3, {st_mode=S_IFDIR|0755, st_size=624, ...}) = 0
fcntl64(3, F_SETFD, FD_CLOEXEC) = 0
mmap2(NULL, 135168, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x40160000
getdents64(3, /* 19 entries */, 131072) = 680
getdents64(3, /* 0 entries */, 131072) = 0
munmap(0x40160000, 135168) = 0
close(3) = 0
open("Makefile", O_RDONLY|O_LARGEFILE) = 3
fstat64(3, {st_mode=S_IFREG|0644, st_size=8423, ...}) = 0
mmap2(NULL, 131072, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x40160000
read(3, "# Makefile.in generated by autom"..., 131072) = 8423
read(3, "", 131072) = 0
close(3) = 0
munmap(0x40160000, 131072) = 0
stat64("RCS", 0xbfffda20) = -1 ENOENT (No such file or directory)
stat64("SCCS", 0xbfffda20) = -1 ENOENT (No such file or directory)
stat64("Makefile", {st_mode=S_IFREG|0644, st_size=8423, ...}) = 0
clock_gettime(0, {1092794818, 538328000}) = 0
stat64("hal-spec.html", 0xbfffd840) = -1 ENOENT (No such file or directory)
stat64("hal-spec.xml", {st_mode=S_IFREG|0644, st_size=112866, ...}) = 0
stat64("../../config.status", {st_mode=S_IFREG|0755, st_size=42562, ...}) = 0
stat64("../..", {st_mode=S_IFDIR|0755, st_size=1336, ...}) = 0
open("../..", O_RDONLY|O_NONBLOCK|O_LARGEFILE|O_DIRECTORY) = 3
fstat64(3, {st_mode=S_IFDIR|0755, st_size=1336, ...}) = 0
fcntl64(3, F_SETFD, FD_CLOEXEC) = 0
mmap2(NULL, 135168, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x40160000
getdents64(3, /* 48 entries */, 131072) = 1504
getdents64(3, /* 0 entries */, 131072) = 0
munmap(0x40160000, 135168) = 0
close(3) = 0
stat64("../../RCS", 0xbfffd410) = -1 ENOENT (No such file or directory)
stat64("../../SCCS", 0xbfffd410) = -1 ENOENT (No such file or directory)
stat64("hal-spec.xml.in", {st_mode=S_IFREG|0644, st_size=112875, ...})= 0
stat64("hal-arch.png", {st_mode=S_IFREG|0644, st_size=63932, ...}) = 0
stat64("hal-devices1.png", {st_mode=S_IFREG|0644, st_size=123919, ...}) = 0
stat64("hal-fdi-example1.png", {st_mode=S_IFREG|0644, st_size=109771, ...}) = 0
stat64("hal-fdi-example2.png", {st_mode=S_IFREG|0644, st_size=110108, ...}) = 0
stat64("hal-fdi-example3.png", {st_mode=S_IFREG|0644, st_size=103893, ...}) = 0
stat64("hal-linux26.png", {st_mode=S_IFREG|0644, st_size=72656, ...}) = 0
fstat64(1, {st_mode=S_IFCHR|0600, st_rdev=makedev(136, 6), ...}) = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1,0) = 0x40160000
write(1, "/usr/bin/docbook2html --nochunks"..., 51/usr/bin/docbook2html --nochunks hal-spec.xml -o .
) = 51
pipe([3, 4]) = 0
close(4) = 0
fcntl64(3, F_SETFD, FD_CLOEXEC) = 0
rt_sigprocmask(SIG_BLOCK, [HUP INT QUIT TERM XCPU XFSZ], NULL, 8) = 0
vfork() = 4084
rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
wait4(-1, Using catalogs: /usr/share/sgml/docbook/sgml-dtd-3.0/catalog, /usr/share/sgml/docbook/sgml-dtd-3.1/catalog, /usr/share/sgml/docbook/sgml-dtd-4.0/catalog, /usr/share/sgml/docbook/sgml-dtd-4.1/catalog, /usr/share/sgml/docbook/sgml-dtd-4.2/catalog, /usr/share/sgml/docbook/dsssl-stylesheets-1.77/catalog, /usr/share/sgml/xml-iso-entities-8879.1986/catalog, /usr/share/sgml/sgml-iso-entities-8879.1986/catalog, /usr/share/sgml/openjade-1.3.2/dsssl/catalog, /usr/share/sgml/openjade-1.3.2/catalog, /usr/share/sgml/opensp-1.5.1/OpenSP/catalog
Using stylesheet: /usr/share/sgml/docbook/utils-0.6.12/docbook-utils.dsl#html
Working on: /var/tmp/portage/hal-cvs-20040522/work/hal-cvs/doc/spec/hal-spec.xml
Back to top
View user's profile Send private message
gungholady
Guru
Guru


Joined: 19 Oct 2003
Posts: 392

PostPosted: Wed Aug 18, 2004 8:38 am    Post subject: Reply with quote

Jeremy_Z wrote:
10 min is not much but well you may have a problem.


I let it set for 5 hours and it was still stalled at the same point.

Edit:

Apparently the problem may be with the ebuild as sys-apps/hal-0.2.97 emerges without a problem.
Back to top
View user's profile Send private message
Redeeman
l33t
l33t


Joined: 25 Sep 2003
Posts: 957
Location: Denmark

PostPosted: Wed Aug 18, 2004 2:17 pm    Post subject: Reply with quote

or the cvs source
_________________
Sandberg Enterprises
Back to top
View user's profile Send private message
gungholady
Guru
Guru


Joined: 19 Oct 2003
Posts: 392

PostPosted: Thu Aug 19, 2004 1:54 am    Post subject: Reply with quote

An email from the hal mailing list says it needs to have doxygen and doc disabled which is done by the ebuild for hal-0.2.97. That is why it works. The email said to bug my distribution about this.
Back to top
View user's profile Send private message
sn4ip3r
Guru
Guru


Joined: 14 Dec 2002
Posts: 325
Location: Tallinn, Estonia

PostPosted: Thu Aug 19, 2004 3:16 am    Post subject: Reply with quote

gungholady wrote:
An email from the hal mailing list says it needs to have doxygen and doc disabled which is done by the ebuild for hal-0.2.97. That is why it works. The email said to bug my distribution about this.


The next update of fluidcvs will have docbook/doxygen docs disabled. The strange thing is that I have no problem with the current ebuild.
btw. The next update to fluidcvs might take a while because there have been a lot of cleanups/refactoring, changes which affect almost all ebuilds, and I'm still not sure if I have fixed all the possible problems.
Back to top
View user's profile Send private message
teutzz
Guru
Guru


Joined: 22 Apr 2004
Posts: 333
Location: .ro

PostPosted: Thu Aug 19, 2004 9:26 am    Post subject: Reply with quote

for the past 3 days i've been getting this error:
Code:
svn: REPORT request failed on '/fluidportage/!svn/vcc/default'
svn: REPORT of '/fluidportage/!svn/vcc/default': 400 Bad Request (http://kaspersandberg.com)
and i have no ideea why. can someone help?
_________________
Cand nu stii ce sa raspunzi sau ce sa spui un simplu BLA ajunge... lolz
Back to top
View user's profile Send private message
Q-collective
Advocate
Advocate


Joined: 22 Mar 2004
Posts: 2056

PostPosted: Thu Aug 19, 2004 1:05 pm    Post subject: Reply with quote

Code:
# ls trunk
ls: trunk: No such file or directory

Now, I did do "svn co http://kaspersandberg.com/fluidportage", so, why is it that I don't have a trunk dir? :oops:
Back to top
View user's profile Send private message
Redeeman
l33t
l33t


Joined: 25 Sep 2003
Posts: 957
Location: Denmark

PostPosted: Thu Aug 19, 2004 1:23 pm    Post subject: Reply with quote

because you checkout fluidportage, instead of fluidportage/trunk, so trunk will be a subdir to fluidportage
_________________
Sandberg Enterprises
Back to top
View user's profile Send private message
Zyne
Guru
Guru


Joined: 08 Jun 2004
Posts: 334

PostPosted: Thu Aug 19, 2004 6:16 pm    Post subject: Reply with quote

thanks a LOT for this kickass new portage overlay Redeeman!!!
also a big thanks to andrewski for taking the time to write this little howto. I had a bunch of trouble emerging the subversion, but I managed to fix that by changing a few things here and there...


thanks a lot guys!
Back to top
View user's profile Send private message
Redeeman
l33t
l33t


Joined: 25 Sep 2003
Posts: 957
Location: Denmark

PostPosted: Thu Aug 19, 2004 6:41 pm    Post subject: Reply with quote

well thank sn4ip3r too
_________________
Sandberg Enterprises
Back to top
View user's profile Send private message
Fanatic
Apprentice
Apprentice


Joined: 02 May 2004
Posts: 173
Location: Stocktown

PostPosted: Thu Aug 19, 2004 7:03 pm    Post subject: Reply with quote

Thanks for the guide, now I can finally run a version of beep-media-player that doesn't crash every other second 8)
Back to top
View user's profile Send private message
Redeeman
l33t
l33t


Joined: 25 Sep 2003
Posts: 957
Location: Denmark

PostPosted: Thu Aug 19, 2004 7:28 pm    Post subject: Reply with quote

yeah, the cvs version of beep-media-player seems to be pretty stable
_________________
Sandberg Enterprises
Back to top
View user's profile Send private message
BNoise
n00b
n00b


Joined: 10 Feb 2003
Posts: 53
Location: Argentina

PostPosted: Fri Aug 20, 2004 12:14 am    Post subject: Reply with quote

redeeman, is the repository down at this moment?
Back to top
View user's profile Send private message
Zyne
Guru
Guru


Joined: 08 Jun 2004
Posts: 334

PostPosted: Fri Aug 20, 2004 6:50 am    Post subject: Reply with quote

Redeeman wrote:
well thank sn4ip3r too


well... I just read that in the README... I didn't have the time to do it yesterday though...

so here goes:

thanks for all your hard work sn4ip3r!!!!
you guys are the best! now I finally have xorg running from cvs :p
Back to top
View user's profile Send private message
Redeeman
l33t
l33t


Joined: 25 Sep 2003
Posts: 957
Location: Denmark

PostPosted: Fri Aug 20, 2004 4:45 pm    Post subject: Reply with quote

repo not down
_________________
Sandberg Enterprises
Back to top
View user's profile Send private message
Moonlight-Flower
Tux's lil' helper
Tux's lil' helper


Joined: 15 Sep 2003
Posts: 135

PostPosted: Sat Aug 21, 2004 5:18 am    Post subject: Reply with quote

Code:
svn co http://redeeman.kaspersandberg.com/fluidportage/trunk/
svn: REPORT request failed on '/fluidportage/!svn/vcc/default'
svn: REPORT of '/fluidportage/!svn/vcc/default': Could not read status line: Connection reset by peer (http://redeeman.kaspersandberg.com)


It doesn't matter what argument I put into the svn checkout command, I keep getting "Connection reset by peer". Is there some configuration I must do for subversion client to work?
Back to top
View user's profile Send private message
gungholady
Guru
Guru


Joined: 19 Oct 2003
Posts: 392

PostPosted: Sat Aug 21, 2004 12:39 pm    Post subject: Reply with quote

I had to remove your ebuilds for hal-cvs and ivman-cvs this morning in order to do "emerge -uDa world". It kept finding problems with the hal-cvs ebuild. I'm having to revert to the bmg-main ebuilds for hal-cvs and ivman-cvs.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3, 4 ... 12, 13, 14  Next
Page 3 of 14

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum