Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Fluidportage ebuilds for CVS/SVN programs
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 12, 13, 14  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Rainmaker
Veteran
Veteran


Joined: 12 Feb 2004
Posts: 1650
Location: /home/NL/ehv/

PostPosted: Mon Feb 20, 2006 11:58 pm    Post subject: Reply with quote

Getting this error:

Quote:
root@Medusa# emerge -v xine-ui mplayer (/home/dannie)
Calculating dependencies ...done!
>>> emerge (1 of 3) media-libs/xine-lib-20101010 to /
* Please upgrade your package (xine-lib-20101010) to use toolchain-funcs.eclass>>> checksums files ;-) xine-lib-20101010.ebuild
>>> checksums files ;-) files/digest-xine-lib-20101010
* Please upgrade your package (xine-lib-20101010) to use toolchain-funcs.eclass * Please upgrade your package (xine-lib-20101010) to use toolchain-funcs.eclass>>> Unpacking source...

!!! ERROR: media-libs/xine-lib-20101010 failed.
Call stack:
ebuild.sh, line 1894: Called dyn_unpack
ebuild.sh, line 694: Called src_unpack
ebuild.sh, line 1609: Called fluidcvs_src_unpack

!!! ERROR: Offline mode specified, but directory /var/tmp/portage/xine-lib-20101010/distdir/cvs-src/xine-lib/xine-lib not found. Aborting.


Manually creating var/tmp/portage/xine-lib-20101010/distdir/cvs-src/xine-lib/xine-lib does NOT fix this.

As far as I can tell, this is only with xine-lib.
_________________
If you can't dazzle them with brilliance, baffle them with bullshit.
Back to top
View user's profile Send private message
sn4ip3r
Guru
Guru


Joined: 14 Dec 2002
Posts: 325
Location: Tallinn, Estonia

PostPosted: Tue Feb 21, 2006 12:28 am    Post subject: Reply with quote

Rainmaker wrote:
...


As already said, noone has actively maintained fluidportage for quite a few months and more complex packages (unlike xfce or some gnome things) are expected to fail. xine-lib is a very good example of an ebuild that has not been updated as it even shows warnings about using deprecated eclass. Also a reason why many ebuilds could fail is that the customized fluidcvs eclass has not been updated to work with newer portage.

For your xine-lib, the problem seems to be that ECVS_SERVER for some reason is commented out in the ebuild, you could try uncommenting it.
Back to top
View user's profile Send private message
fireball-13
n00b
n00b


Joined: 05 Sep 2005
Posts: 61
Location: Moscow, RU

PostPosted: Mon Feb 27, 2006 10:25 am    Post subject: Reply with quote

There is broken dependency for xorg-x11-20101010: package `ttmkfdir` was moved from x11-misc to x11-apps
This is the patch
Code:
--- xorg-x11/xorg-x11-20101010.ebuild   2006-02-27 13:15:47.575988000 +0300
+++ trunk/x11-base/xorg-x11/xorg-x11-20101010.ebuild    2006-02-27 13:19:39.952118000 +0300
@@ -88,7 +88,7 @@
        >=media-libs/freetype-2.1.8
        >=media-libs/fontconfig-2.1-r1
        opengl? ( >=x11-base/opengl-update-2.2.0 )
-       !nocxx? ( >=x11-misc/ttmkfdir-3.0.9-r2 )
+       !nocxx? ( >=x11-apps/ttmkfdir-3.0.9-r2 )
        >=sys-apps/sed-4
        userland_GNU? ( sys-apps/util-linux )
        dev-lang/perl
@@ -105,7 +105,7 @@
                >=media-libs/freetype-2.1.8
                >=media-libs/fontconfig-2.1-r1
                opengl? ( >=x11-base/opengl-update-2.2.0 )
-               !nocxx? ( >=x11-misc/ttmkfdir-3.0.9-r2 )
+               !nocxx? ( >=x11-apps/ttmkfdir-3.0.9-r2 )
                media-libs/libpng
                >=sys-libs/ncurses-5.1
                !<=app-emulation/emul-linux-x86-xlibs-1.2-r3
Back to top
View user's profile Send private message
linuxinit
Tux's lil' helper
Tux's lil' helper


Joined: 27 Mar 2006
Posts: 84
Location: Bumkcuf, Egypt

PostPosted: Fri Mar 31, 2006 10:11 am    Post subject: Reply with quote

juppe22 wrote:
I have problems with xffm. I get this error:

Code:

Calculating dependencies ...done!
>>> emerge (1 of 21) xfce-base/xffm-20101010 to /
>>> md5 files   ;-) xffm-20101010.ebuild
>>> md5 files   ;-) files/digest-xffm-20101010
>>> Unpacking source...
 * subversion update start -->
 *    update from: http://svn.xfce.org/svn/xfce/xffm/trunk
Skip updating...
 *     updated in: /usr/portage/distfiles/svn-src/xffm/trunk
 *      copied to: /var/tmp/portage/xffm-20101010/work/xffm

>>> Source unpacked.
QA Notice: USE Flag 'debug' not in IUSE for xfce-base/xffm-20101010

!!! ERROR: xfce-base/xffm-20101010 failed.
!!! Function autotool_eautogen, Line 55, Exitcode 1
!!! no ./autogen.sh or ./configure script found
!!! If you need support, post the topmost build error, NOT this status message.


Ok then I checked /var/tmp/portage/xffm-20101010/work/xffm and there is not ./autogen.sh or ./configure script.
Anybody know solution this problem?


Okay... What you do is... cd to the xffm work directory, and run ./installer.sh. You will want to put after it whatever you would put if you were doing autogen or configure. installer.sh is just configuring every sub-package. Once they all configure run the ./make script. Once that is done, run it again with install: ./make install

You have now installed xffm, the only problem now is that if you want to install anything that depends on xffm, you will need to manually modify the ebuild and remove the line that tells it to depend on xffm. Now you'll need to regenerate the md5 for the ebuild file and get the size, and modify the Manifest file with the new values. Then just emerge as usual. To make sure you did everything right, use emerge -av CATEGORY/PACKAGENAME

Sorry if this is bad grammar/crappy... It's 4am. I haven't slept in like almost 3 days now. :(

Happy hacking! :)

Cheers...
Back to top
View user's profile Send private message
Pajarico
Guru
Guru


Joined: 01 May 2004
Posts: 493
Location: Madrid, España.

PostPosted: Sat Apr 15, 2006 3:30 pm    Post subject: Reply with quote

Is this finally abandoned?
_________________
Gentoo: the only software worth paying that is free.
Back to top
View user's profile Send private message
sn4ip3r
Guru
Guru


Joined: 14 Dec 2002
Posts: 325
Location: Tallinn, Estonia

PostPosted: Sat Apr 15, 2006 3:33 pm    Post subject: Reply with quote

Pajarico wrote:
Is this finally abandoned?

It has been (almost completely) abandoned for quite a while already.
Back to top
View user's profile Send private message
seren
Guru
Guru


Joined: 27 Aug 2005
Posts: 448
Location: Wisconsin

PostPosted: Mon Apr 17, 2006 6:19 am    Post subject: Reply with quote

what and where can one get cvs overlays this complete that aren't abandoned?
Back to top
View user's profile Send private message
sn4ip3r
Guru
Guru


Joined: 14 Dec 2002
Posts: 325
Location: Tallinn, Estonia

PostPosted: Mon Apr 17, 2006 10:23 am    Post subject: Reply with quote

seren wrote:
what and where can one get cvs overlays this complete that aren't abandoned?


I've never heard of any other, there has been one attempt to fork this one, but I don't think it got anywhere. You're welcome to try to update this one though. It's usually quite simple, you mostly just have to compare the cvs ebuilds to the leatest in portage and see if anything important has changed.
Back to top
View user's profile Send private message
ugus
Apprentice
Apprentice


Joined: 23 Jul 2004
Posts: 213
Location: Darmstadt, Germany

PostPosted: Tue Jul 04, 2006 11:24 am    Post subject: Reply with quote

i have seen this page just today :oops: an of course i tried it on xfce4. 8)
it works great !. Thank you very much guys..
_________________
while(!sleep())
{
sheep++;
}
My Desktop
Back to top
View user's profile Send private message
sn4ip3r
Guru
Guru


Joined: 14 Dec 2002
Posts: 325
Location: Tallinn, Estonia

PostPosted: Tue Jul 04, 2006 12:09 pm    Post subject: Reply with quote

ugus wrote:
i have seen this page just today :oops: an of course i tried it on xfce4. 8)
it works great !. Thank you very much guys..


Nice to hear that it still works:) as the xfce ebuilds have not been updated for a long time.
Back to top
View user's profile Send private message
ugus
Apprentice
Apprentice


Joined: 23 Jul 2004
Posts: 213
Location: Darmstadt, Germany

PostPosted: Tue Jul 04, 2006 1:14 pm    Post subject: Reply with quote

i don't know how recent is the code which is installed :lol:, but it has worked.. Anyway, i have also mplayer updated. I hope the code was fresh :D

But I think, because the code is gotten over svn repository, it must be the recent code. Or am i wrong ?
_________________
while(!sleep())
{
sheep++;
}
My Desktop
Back to top
View user's profile Send private message
bigbob73
Guru
Guru


Joined: 31 Dec 2004
Posts: 332
Location: Under the Lone Star

PostPosted: Tue Jul 04, 2006 2:26 pm    Post subject: Reply with quote

i believe fluidportage is going to be updated very soon. There is a new maintainer, so hopefully it won't be long.
_________________
A computers attention span is only as long as it's electrical cord (Murphy)
Back to top
View user's profile Send private message
joecool
n00b
n00b


Joined: 31 Aug 2004
Posts: 30

PostPosted: Wed Jul 05, 2006 12:52 am    Post subject: Reply with quote

I want to announce that I had been maintaining fluidportage for a very short time (like just this past week), however due to it being a little difficult to commit on its current host, I will be forking the whole tree.

Gonne need all the QA I can get, you can check out the current tree, I fixed nano, bmpx, mplayer, ffmpeg, nvclock, and a few other odds and ends in just the past week, the new fork will be hosted by oldos.org, just like no-sources is.

While I'm not 100% sure of the name yet, the two most probably candidates are noportage or neoportage.

If you need to contact me I'll be in #no-sources on Freenode. I'm looking for a GNOME ebuild writer as I won't test that stuff myself. It's a lot of work, but I hope with a little help I can get the overlay back on its feet.
Back to top
View user's profile Send private message
sn4ip3r
Guru
Guru


Joined: 14 Dec 2002
Posts: 325
Location: Tallinn, Estonia

PostPosted: Wed Jul 05, 2006 1:09 am    Post subject: Reply with quote

joecool, if you fork, I'd suggest not copying everything verbatim and then fixing, instead you should copy only the things that you have fixed. Fluidportage currently contains just too many out-of-date packages which noone seems to be interested in fixing. Also, I'd suggest using 9999 instead of 20101010 as a version as the former seems to be the standard in portage.
Back to top
View user's profile Send private message
jorgepeixoto
Apprentice
Apprentice


Joined: 27 Apr 2006
Posts: 218
Location: São José dos Campos, São Paulo, Brasil

PostPosted: Sat Sep 16, 2006 1:11 am    Post subject: What is the state of neoportage? Reply with quote

Why doesn't it show in layman?
I one needs help to mantain it, I'm in.
Back to top
View user's profile Send private message
sn4ip3r
Guru
Guru


Joined: 14 Dec 2002
Posts: 325
Location: Tallinn, Estonia

PostPosted: Sat Sep 16, 2006 1:59 am    Post subject: Re: What is the state of neoportage? Reply with quote

jorgepeixoto wrote:
Why doesn't it show in layman?
I one needs help to mantain it, I'm in.


Try #fluidportage @ irc.freenode.net
Back to top
View user's profile Send private message
jorgepeixoto
Apprentice
Apprentice


Joined: 27 Apr 2006
Posts: 218
Location: São José dos Campos, São Paulo, Brasil

PostPosted: Sat Sep 16, 2006 6:14 am    Post subject: Re: What is the state of neoportage? Reply with quote

sn4ip3r wrote:
jorgepeixoto wrote:
Why doesn't it show in layman?
I one needs help to mantain it, I'm in.


Try #fluidportage @ irc.freenode.net


If only I could access irc from behing this firewall...
Back to top
View user's profile Send private message
pacho2
Developer
Developer


Joined: 04 Mar 2005
Posts: 2599
Location: Oviedo, Spain

PostPosted: Thu Sep 28, 2006 10:49 am    Post subject: Reply with quote

I also have problems with supertux CVS :-/
Back to top
View user's profile Send private message
pacho2
Developer
Developer


Joined: 04 Mar 2005
Posts: 2599
Location: Oviedo, Spain

PostPosted: Thu Sep 28, 2006 11:25 am    Post subject: Reply with quote

Thanks to redeeman and zamorate in IRC channel.

I will post a fixed ebuild soon
Back to top
View user's profile Send private message
pacho2
Developer
Developer


Joined: 04 Mar 2005
Posts: 2599
Location: Oviedo, Spain

PostPosted: Thu Sep 28, 2006 12:58 pm    Post subject: Reply with quote

Ebuild released ;)
https://forums.gentoo.org/viewtopic-t-502560-start-0-postdays-0-postorder-asc-highlight-.html
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 12, 13, 14
Page 14 of 14

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum