Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
iptables & limit option and hwclock on Sun Ultra Sparc 5
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc
View previous topic :: View next topic  
Author Message

Joined: 27 Oct 2002
Posts: 1

PostPosted: Sun Oct 27, 2002 9:20 pm    Post subject: iptables & limit option and hwclock on Sun Ultra Sparc 5 Reply with quote


Installing Gentoo on a Sun Ultra Sparc 5 (PCI& IDE version).

The problem:

When I use iptables with any limit command e.g.
$IPTABLES -A OUTPUT -m limit --limit 3/minute --limit-burst 3 -j LOG \
--log-level DEBUG --log-prefix "IPT OUTPUT packet died: "

iptables reacts with:
invalid argument.

I tried this also with a Debian Woody installation on the same sparc and also got a "invalid argument". On the internet I found one guy having the same problem (still not solved) (see: )

I already tried several things:
-) recompiled ipt_limit modules several times
-) recompiled iptables several times
-) switched from iptables 1.26a to 1.27a and vice versa
-) tried Gentoo (great distribution; as you see every nasty thing, brings something nice :lol: )

However the problem still remains.

After experimenting several nights I thought the problem could be with the internal clock. Since, in my opinion, the limit option has to make contact to the internal clock to know what 3 times a minute is.

Whenever I start Debian or Gentoo, it says something like: RTC no PC_RTC found. In contrast to this message, for some strange reason it's capable of displaying time and date correct, even after power-off.

Another funny thing is that when I try to boot OpenBSD, the startup-script of OpenBSD mentions that the date and time are 373 days ago (somewhere in 2001) and that I should reset and check time and date. (the "somewhere in 2001" is when I removed solaris i geuss). Thus, in my opinion OpenBSD is able to see two times&dates, since it is able to talk about 373 days ?!


Now I was wondering:
1) Could it be the hardware clock which makes the limit option within iptables a problem or did I just smoke too much? (please don't blame me for not talking C-tech-talk, I am a statistician, not a programmer :roll: )
2) Is anyone familiar with this problem?
3) Does it occur on other sparcs?
4) Has anyone the foggiest idea how to correctly set the hardware clock in the kernel (till know I found out that I should enable the Mostek driver, however it also mentions to set "enhanced real time clock support" in character devices, but the "enhanced real time clock support" is unfortunately not mentioned anywhere in the kernel)
5) Does the ultra sparc 5 have two clock devices? In other words how does it come that OpenBSD sees another time&date than Debian or Gentoo.

hope someone can help me.

grtz Yoda2
Back to top
View user's profile Send private message

Joined: 16 Jul 2002
Posts: 393
Location: Sigma 957

PostPosted: Mon Oct 28, 2002 9:20 am    Post subject: Reply with quote

I've never used iptables, but as far as your clock problem, when I've tried booting FreeBSD or NetBSD (before I tried gentoo linux), I'd also get funny errors regarding the clock.

FreeBSD 5.0-CURRENT/sparc64 simply informed me that the clock was invalid, check and reset the date, then it spat out about 50 lines of assembler garbage, and the whole machine froze.

NetBSD did roughly the same thing as far as the Clock, but after informing me the clock was out of date, it then asked what terminal would I like to use, and then the whole machine froze up.

I never even bothered to try OpenBSD, but I think this is some kinda glitch with all of the BSDs. I was able to boot up the existing Solaris install, and the clock was correctly set. After getting Gentoo installed, the clock also reported correct time.

"The past tempts us, the present confuses us, the future frightens us. And our lives slip away, moment by moment, lost in that vast, terrible in-between."
--Emperor Turhan, Centauri Republic
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum