Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[COMO] HP-nx5000 centrino wireless intel/pro 2200BG (Soluc.)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
Gentoosiastix
Guru
Guru


Joined: 10 Oct 2003
Posts: 510
Location: Palencia-España

PostPosted: Sat Jul 17, 2004 6:31 pm    Post subject: [COMO] HP-nx5000 centrino wireless intel/pro 2200BG (Soluc.) Reply with quote

despues de echarle "horas" y bajarme el "ndiswrapper" (drivers hasefrochs) y los "iwp2200bg" de sourceforge.net el cual pop cierto, no he sido capaz de cargar/instalar?? me da error... creo que el "make" no compila bien.

si alguien tiene una sugerencia? estare encantado de intentarlo :roll: :roll:
(mientras no sea que lo tire a la basura :? )

Ahora que lo tengo "fresco" y como veo que es un tema que "cuesta" un poco.....
intentare que sea algo mas fácil para los demás.
El metodo: con ndiswrapper

Esta hecho sobre un Portatil hp-nx5000-centrino con una pci Intel-pro 2200BG kernel 2.6.7-gentoo-r10
para los que tiene la "misma" tarjeta pero 2100 sabed que podéis "emerger" el driver para Linux.

1º compilamos el kernel (damos por hecho, que todos sabemos como)
nos aseguramos de quitar el soporte SMP


Quote:
Procesor Type and features---->
[ NO ] Symetric multi-processing support

nos aseguramos de tener soporte para la PCMCIA
Quote:
Bus options (PCI, PCMCIA, EISA......) ----->
PCMCIA/CardBus support ----> marcamos todo como "modulos"

Ahora toca "non-hamradio"
Quote:
Device Drivers ---->
[*] Networking support ------>
Wireless LAN (non-hamradio) ---->
[*] Wireless LAN drivers (non-hamradio) & Wireless extensions
solo necesitamos marcar esta opción las demás NO


Compilamos nuestro nuevo kernel y seguimos....
tened en cuenta que solo pongo las opciones necesarias para la pci-wireless

Ya tenemos nuestro kernel y vamos a por el "ndiswrapper"
Quote:

#ACCEPT_KEYWORDS="~x86" emerge ndiswrapper

ahora nos bajamos las "herramientas" necesarias.
Quote:
#emerge wireless-tools

otra posibilidad (la que he elegido yo) es..
Quote:
# emerge hostap-drivers

este además de las wireless-tools te instala los pcmcia_cs
O.K. ya tenemos lo que necesitamos................ pues no.
nos faltan los drivers para "hasefrochs XP" (léase W-XP) aqui lo mas facil es coger el CD que nos ha venido con el Portatil (uno que pone drivers) y buscarlos.... no tiene perdida.

Vale.. por si no quereis sacarlos del CD Bajadlos de aqui

Repasemos: tenemos instalado el "ndiswrapper" nuestro kernel compilado... y los drivers del "maligno" bien.
Quote:
1º- # mkdir /lib/windrivers
#cp driver.inf /lib/windrivers
#cp driver.sys /lib/windrivers
en teoría con estos dos archivos es suficiente, pero yo los copie todos... (la 1ª vez me dijo que le faltaba una DLL?)
Quote:
#ndiswrapper -i /lib/windrivers/driver.inf
esto cargara el driver.

Quote:
#ndiswrapper -l
Installed ndis drivers:
w22n51 present
nos dice que driver tiene cargado.

Quote:
#modprobe ndiswrapper
cargamos el modulo-ndiswrapper
Quote:
#loadndisdriver w22n51
esto carga el driver, y deberíamos poder hacer..
#iwconfig y ver la red.. no olvides darle al botoncito (el de la antena) del portátil.

Ahora ya es cosa de configurar la red.. aquí como en todo cada uno sigue un método.
yo prefiero hacer un enlace a "eth0" que copiarlo y renombrarlo a "wlan0"

Quote:
#ln -sf /etc/init.d/net.eth0 /etc/init.d/net.wlan0

con esto, cogerá la configuración que tengas para tu tarjeta eth0.

Lo demás, esta suficientemente explicado en los foros, pero si tenéis alguna duda intentare contestarla.

un saludo

Gracias a scootersmk y otros foreros, que son los que con sus post me han ayudado. casi todo lo he sacado de este Post y google :wink:

EDITO: bueno aqui estoy de nuevo, he editado por si alguien hace una busqueda y quiere usar este post como referencia.

Quote:
a partir del kernel-2.6.14-gentoo tenemos soporte directo para ipw2100 e ipw2200 lo unico que hago ahora es marcarlo "et voila" a funcionar


saludos a la aficcion
_________________
Siempre seremos novatos en algo


Last edited by Gentoosiastix on Thu Dec 22, 2005 10:18 pm; edited 3 times in total
Back to top
View user's profile Send private message
psm1984
l33t
l33t


Joined: 14 Oct 2003
Posts: 919

PostPosted: Sun Jul 18, 2004 11:59 am    Post subject: Reply with quote

mirate este post:
https://forums.gentoo.org/viewtopic.php?t=122435

PD: por el titulo parece que ya lo has solucionado :P
Back to top
View user's profile Send private message
Gentoosiastix
Guru
Guru


Joined: 10 Oct 2003
Posts: 510
Location: Palencia-España

PostPosted: Sun Jul 18, 2004 2:42 pm    Post subject: Reply with quote

si ya lo he solucionado... gracias, ahora me estoy currando un pequeño "como" para que la gente pueda orientarse en "castellano" Wink
_________________
Siempre seremos novatos en algo
Back to top
View user's profile Send private message
Overpeer
Apprentice
Apprentice


Joined: 17 Mar 2004
Posts: 200
Location: Valencia

PostPosted: Wed Jul 21, 2004 6:48 pm    Post subject: Reply with quote

Humm ... a lo mejor pregunto una chorrada pero ... ¿como descomprimo o como estraigo los ficheros del archivo .EXE :roll: :roll:

Un saludo.
Back to top
View user's profile Send private message
Gentoosiastix
Guru
Guru


Joined: 10 Oct 2003
Posts: 510
Location: Palencia-España

PostPosted: Wed Jul 21, 2004 8:15 pm    Post subject: Reply with quote

no preguntas ninguna chorrada... :D :D o por lo menos somos 2 los que nos preguntamos la misma ja,ja,ja
lo mejor, es que metas el CD de los drivers y despues de montarlo, te vas al directorio:
Quote:
# cd /mnt/cdrom/ (aqui hacemos ls para localizar la carpeta que nos interesa)
#cd "carpeta drivers" (otra vez ls)
# cp /mnt/cdrom/carpetadrivers/drivers /lib/windrivers


yo la verdad es que para estas cosas uso el "mc" (Midnight Commander)
otra forma es hacerlo desde el WinXP, boton derecho raton "explorar CD" y copias los susodichos drivers a una carpeta accesible desde Gentoo...
a todas luces la menos "elegante" pero igual de eficaz.... :wink: :wink:
_________________
Siempre seremos novatos en algo
Back to top
View user's profile Send private message
Overpeer
Apprentice
Apprentice


Joined: 17 Mar 2004
Posts: 200
Location: Valencia

PostPosted: Wed Jul 21, 2004 8:37 pm    Post subject: Reply with quote

No me funciona, no me deja introducir algunos parametros :O

Code:

Gentrinoo root # lsmod
Module                  Size  Used by
ndiswrapper            73152  0
rtc                    10424  0
nvidia               4817332  12

Gentrinoo root # ndiswrapper -l
Installed ndis drivers:
w22n51  present

Gentrinoo root # iwconfig
eth0      no wireless extensions.

lo        no wireless extensions.

wlan0     IEEE 802.11b  ESSID:""
          Mode:Managed  Access Point: FF:FF:FF:FF:FF:FF  Bit Rate:54Mb/s
          RTS thr:1600 B   Fragment thr:2304 B
          Encryption key:off
          Power Management:off
          Link Quality:0/100  Signal level:24/154  Noise level:0/154
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

Gentrinoo root # ifconfig
eth0      Link encap:Ethernet  HWaddr 00:08:0D:94:59:F8
          inet addr:81.202.78.27  Bcast:255.255.255.255  Mask:255.255.224.0
          UP BROADCAST NOTRAILERS RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1935909 errors:0 dropped:0 overruns:0 frame:0
          TX packets:69767 errors:0 dropped:0 overruns:0 carrier:0
          collisions:12005 txqueuelen:1000
          RX bytes:196666500 (187.5 Mb)  TX bytes:5773323 (5.5 Mb)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:24 errors:0 dropped:0 overruns:0 frame:0
          TX packets:24 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1200 (1.1 Kb)  TX bytes:1200 (1.1 Kb)

wlan0     Link encap:Ethernet  HWaddr 00:0E:35:1F:28:E9
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:11 Memory:c2005000-c2005fff

Gentrinoo root # iwlist scan
eth0      Interface doesn't support scanning : Operation not supported

lo        Interface doesn't support scanning : Operation not supported

wlan0     Scan completed :
          Cell 01 - Address: 00:0F:66:45:DE:A8
                    ESSID:"Nodo-1"
                    Protocol:IEEE 802.11g
                    Mode:Managed
                    Frequency:2.437GHz
                    Quality:0/100  Signal level:-46 dBm  Noise level:-256 dBm
                    Encryption key:on
                    Bit Rate:1Mb/s
                    Bit Rate:2Mb/s
                    Bit Rate:5.5Mb/s
                    Bit Rate:11Mb/s
                    Bit Rate:18Mb/s
                    Bit Rate:24Mb/s
                    Bit Rate:36Mb/s
                    Bit Rate:54Mb/s
                    Bit Rate:6Mb/s
                    Bit Rate:9Mb/s
                    Bit Rate:12Mb/s
                    Bit Rate:48Mb/s
          Cell 02 - Address: 00:04:E2:9D:75:52
                    ESSID:"KZWLAN"
                    Protocol:IEEE 802.11g
                    Mode:Managed
                    Frequency:2.437GHz
                    Quality:0/100  Signal level:-83 dBm  Noise level:-256 dBm
                    Encryption key:on
                    Bit Rate:1Mb/s
                    Bit Rate:2Mb/s
                    Bit Rate:5.5Mb/s
                    Bit Rate:11Mb/s
                    Bit Rate:6Mb/s
                    Bit Rate:9Mb/s
                    Bit Rate:12Mb/s
                    Bit Rate:18Mb/s
                    Bit Rate:24Mb/s
                    Bit Rate:36Mb/s
                    Bit Rate:48Mb/s
                    Bit Rate:54Mb/s

Gentrinoo root # iwconfig wlan0 essid "Nodo-1"

Gentrinoo root # iwconfig wlan0 channel 6
Error for wireless request "Set Frequency" (8B04) :
    SET failed on device wlan0 ; Invalid argument.


No entiendo que pasa, parecia funcionar todo ok pero ... :S

Un saludo.
Back to top
View user's profile Send private message
Gentoosiastix
Guru
Guru


Joined: 10 Oct 2003
Posts: 510
Location: Palencia-España

PostPosted: Wed Jul 21, 2004 8:48 pm    Post subject: Reply with quote

vamos por partes.... (como dijo jack the ripper)
tu PC tiene botoncito que conmuta el wireless (tiene una antenita) el mio si y una vez cargado el driver tienes que darle y debe encenderse una lucecita.

si es asi y no se enciende... es que el driver no esta cargado, y toca hacer
Quote:

#loadndisdriver w22n51
por lo que dices, puede que sean solo problemas de configuracion.

hiciste el enlace simbolico a "eth0" y en /etc/conf.d copia la linea que tienes configurada como "eth0" y la pones exactamente igual debajo pero como "wlan0"

dame algun dato mas
_________________
Siempre seremos novatos en algo
Back to top
View user's profile Send private message
Overpeer
Apprentice
Apprentice


Joined: 17 Mar 2004
Posts: 200
Location: Valencia

PostPosted: Wed Jul 21, 2004 9:06 pm    Post subject: Reply with quote

ermmerm ...... xD

Ya funciona, el error parece estar en el orden en que se introducen los comandos :O

Tiene que ser: essid - mode - key - channel :O

No tiene ningun sentido, y no creo que sea ese el problema, pero ahora mismo estoy haciendo ping al servidor via wireless :lol:

Queria ponerte una lista de los parametros que me fallaban y probando probando uno por uno empezando por los que sabia que funcionaban (essid y mode) al poner channel fallo ... pero al poner key no, volvi a poner channel y al ver que cuela .... pues ping al server ... OK 8O

En fin, historias para no dormir, muchas gracias por tu ayuda ;)

Por cierto, ¿con añadir ndiswrapper al /etc/modules.autoload ya se carga el driver automaticamente al inicio no? ¿como salvo la configuracion de iwconfig?

Un saludo y gracias de nuevo ;)
Back to top
View user's profile Send private message
Gentoosiastix
Guru
Guru


Joined: 10 Oct 2003
Posts: 510
Location: Palencia-España

PostPosted: Wed Jul 21, 2004 9:51 pm    Post subject: Reply with quote

te cargara el "ndiswrapper" pero no el driver... (otra vez loadndisdriver xxxx)
en cuanto a la configuracion... yo lo he hecho como te puse arriba y me funcina perfectamente (solo cargo el driver con ndiswrapper cadad vez) la verdad, es que no me he preocupado por arreglarlo porque no me molesta... pero habra que buscar solucion :roll:
_________________
Siempre seremos novatos en algo
Back to top
View user's profile Send private message
Overpeer
Apprentice
Apprentice


Joined: 17 Mar 2004
Posts: 200
Location: Valencia

PostPosted: Thu Jul 22, 2004 1:39 pm    Post subject: Reply with quote

Creo que la solucion va a ser crear un script de arranque, pero ahora mismo no se en que runlevel ni en que momento se ha de realizar todo esto, claro, que no siempre se querra usar el wireless. Hum, creo que un script con sintaxis "wifi start" "wifi stop" por ejemplo valdria :D

Esta tarde me pongo a ello.

Un saludo.
Back to top
View user's profile Send private message
Gentoosiastix
Guru
Guru


Joined: 10 Oct 2003
Posts: 510
Location: Palencia-España

PostPosted: Thu Jul 22, 2004 3:44 pm    Post subject: Reply with quote

pues no olvides colgarlo aquí :wink:
_________________
Siempre seremos novatos en algo
Back to top
View user's profile Send private message
Overpeer
Apprentice
Apprentice


Joined: 17 Mar 2004
Posts: 200
Location: Valencia

PostPosted: Thu Jul 22, 2004 7:49 pm    Post subject: Reply with quote

Ahi va 8)

Code:

#!/bin/bash

# iwconfig
DEV=wlan0                       # Dispositivo inalambrico
ESSID="Nodo-1"                  # ESSID de la red
MODE=Managed                    # Modo de la red
KEY=1111111111                  # Clave WEP
CHANNEL=6                       # Canal usado en la red

# ifconfig
IP=192.168.1.78                 # Direccion IP de la interfaz
MS=255.255.255.0                # Mascara de subred
BC=192.168.1.255                # Direccion de Broadcast
DG=192.168.1.1                  # Ruta por defecto

DNS1=80.58.0.33                # Primer servidor de nombres
DNS2=80.58.32.97               # Segundo servidor de nombres

# Driver
INF=/lib/windrivers/w22n51.INF  # Driver Mircro$oft
NDIS=w22n51                     # Driver NDIS

# Funciones

function inicio()
{
 echo Iniciando Wireless!
 ndiswrapper -i $INF
 modprobe ndiswrapper
 loadndisdriver $NDIS

 iwconfig $DEV essid $ESSID mode $MODE
 iwconfig $DEV key $KEY
 iwconfig $DEV channel $CHANNEL

 ifconfig $DEV up
 ifconfig $DEV $IP netmask $MS broadcast $BC
 route add default gw $DG

 echo "nameserver $DNS1" > /etc/resolv.conf
 echo "nameserver $DNS2" >> /etc/resolv.conf
}

function parada()
{
 echo "Parando Wireless!"

 ifconfig $DEV down
 route del default gw $DW
 ndiswrapper -e $NDIS
 rmmod ndiswrapper
}

function estado()
{
 echo "Driver:"
 ndiswrapper -l |grep $NDIS
 echo
 echo "WLAN:"
 iwconfig $DEV
 echo
 cat /proc/net/wireless
 echo
 echo "INTERFACE:"
 ifconfig $DEV

}

case "$1" in

start)
inicio
echo;;
stop)
parada
echo;;
status)
estado
echo;;
*)
echo "Opcion Incorrecta"
echo "Uso: "
echo "     start : Inicia Wireless"
echo "     stop  : Detiene Wireless"
echo "     status: Muestra el estado";;
esac


Yo lo he estado probando y chuta bien :D

Un saludo
Back to top
View user's profile Send private message
Gentoosiastix
Guru
Guru


Joined: 10 Oct 2003
Posts: 510
Location: Palencia-España

PostPosted: Thu Jul 22, 2004 9:50 pm    Post subject: Reply with quote

realmente creo que el script que necesito puede ser bastante mas cortito... no?
veamos... el ndiswrapper se carga en "default" pero! no me carga el driver w22n51 por lo cual el script que necesito, solo tiene que encargarse de que el ndiswrapper "cargue" el driver.

a ver si soy capaz de hacerlo.... (me parece mucho para mi 1º script)
_________________
Siempre seremos novatos en algo
Back to top
View user's profile Send private message
asph
l33t
l33t


Joined: 25 Aug 2003
Posts: 737
Location: Barcelona, Spain

PostPosted: Tue Aug 17, 2004 9:25 am    Post subject: Reply with quote

yo tambien tengo una intel pro 2200bg en mi portatil, y configurarla ha sido de lo más fácil (los drivers ya estan en portage para la 2100 y 2200):

Code:
ACCEPT_KEYWORDS="~x86" emerge wireless-tools ipw2200


luego ya configurarla (en mi caso por dhcp)

Code:
iwconfig eth1 ESSID wlan
dhcpcd eth1

(cambiando los scripts de inicio lo hace automaticamente al iniciar)
_________________
gentoo sex is updatedb; locate; talk; date; cd; strip; look; touch; finger; unzip; uptime; gawk; head; emerge --oneshot condom; mount; fsck; gasp; more; yes; yes; yes; more; umount; emerge -C condom; make clean; sleep
Back to top
View user's profile Send private message
dmery
Apprentice
Apprentice


Joined: 15 Sep 2004
Posts: 225
Location: Coral Gables, Florida, USA

PostPosted: Tue Sep 27, 2005 4:08 am    Post subject: [ndiswrapper] problema cannot read device..... Reply with quote

Gentoonitas,

Aqui estoy en la agotadora tarea de tratar de que funcione el wireless :( . Es una notebook HP Pavilion zv6015us, AMD-64 3500, 1 giga ram.
La tarjeta es la maldicion llamada Broadcom :twisted: . Realizo el siguiente orden

emerge ndiswrapper
emerge wireless-tools
luego baje unos driver para 64 de Broadcom (netbc564.inf y BCMWL564.SYS), esto a traves de Gentoo wikipedia, ademas tome los drivers de la particion Windows (bcmwl5.inf y bcml5.sys)
Realice:
ndiswrapper -i path/bcmwl5.inf
los instala pero en dmesg me dice que esos drivers no son de 64 bits ??????, son los que usa windows y el wireless fuinciona perfecto :?: :!: :!:
entonces utilizo los otros:
ndiswrapper -i path/netbc564.inf
pero cuando reralizo ndiswrapper - l :
cannot read device descriptor no such device (19) :?:
.

Realmente estoy perdido y cuando mas leo peor es la cosa, ya que por ahi alguien sugiere wp_supplicant y bla bla.......
La informacion esta realmente caotica.
Si alguien tiene una idea por donde pueda orientarme lo agradezco
gracias en avance
Salu2
Daniel Mery
_________________
"El conocimiento es patrimonio de la humanidad, por lo tanto no tiene propietarios ni necesita de licencias"
Usuario linux registrado: 364487
Gentoo user
Arch user
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum