Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Limpieza del sistema]no puedo compilar (resuelto)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
carlos plaza
Apprentice
Apprentice


Joined: 22 Jan 2005
Posts: 209
Location: Venezuela

PostPosted: Tue Oct 27, 2009 12:12 am    Post subject: [Limpieza del sistema]no puedo compilar (resuelto) Reply with quote

Hola a toda esta gran familia del mejor foro Gentoo :wink:

Bueno amigos el caso es que hice una limpieza primero para quitar versiones viejas
Code:
emerge --prune
Luego para las dependencias
Quote:
emerge --depclean
y por ultimo
Code:
revdep-rebuild

Ok hasta aquí, pero cuando revdep-rebuild quiso emerger para arreglar las dependencias :evil:
Quote:
All prepared. Starting rebuild
emerge --oneshot app-emulation/emul-linux-x86-soundlibs:0
dev-libs/klibc:0
sys-apps/coreutils:0
..........
Calculating dependencies ... done!

>>> Verifying ebuild manifests

>>> Starting parallel fetch

>>> Emerging (1 of 3) sys-apps/coreutils-7.6
* coreutils-7.6.tar.gz RMD160 SHA1 SHA256 size ;-) ... [ ok ]
* coreutils-7.6-patches-2.tar.lzma RMD160 SHA1 SHA256 size ;-) ... [ ok ]
* checking ebuild checksums ;-) ... [ ok ]
* checking auxfile checksums ;-) ... [ ok ]
* checking miscfile checksums ;-) ... [ ok ]
sandbox:main signal SIGQUIT already had a handler ...

mv: error while loading shared libraries: libselinux.so.1: cannot open shared object file: No such file or directory
* ERROR: sys-apps/coreutils-7.6 failed:
* error processing environment
*
* Call stack:
* ebuild.sh, line 1757: Called die
* The specific snippet of code:
* preprocess_ebuild_env || \
* die "error processing environment"
*
* If you need support, post the output of 'emerge --info =sys-apps/coreutils-7.6',
* the complete build log and the output of 'emerge -pqv =sys-apps/coreutils-7.6'.
* The complete build log is located at '/var/log/portage/sys-apps:coreutils-7.6:20091026-234108.log'.
* The ebuild environment file is located at '/var/tmp/portage/sys-apps/coreutils-7.6/temp/environment'.
* S: '/var/tmp/portage/sys-apps/coreutils-7.6/work/coreutils-7.6'

>>> Failed to emerge sys-apps/coreutils-7.6, Log file:

>>> '/var/log/portage/sys-apps:coreutils-7.6:20091026-234108.log'

* Messages for package sys-apps/coreutils-7.6:

* ERROR: sys-apps/coreutils-7.6 failed:
* error processing environment
*
* Call stack:
* ebuild.sh, line 1757: Called die
* The specific snippet of code:
* preprocess_ebuild_env || \
* die "error processing environment"
*
* If you need support, post the output of 'emerge --info =sys-apps/coreutils-7.6',
* the complete build log and the output of 'emerge -pqv =sys-apps/coreutils-7.6'.
* The complete build log is located at '/var/log/portage/sys-apps:coreutils-7.6:20091026-234108.log'.
* The ebuild environment file is located at '/var/tmp/portage/sys-apps/coreutils-7.6/temp/environment'.
* S: '/var/tmp/portage/sys-apps/coreutils-7.6/work/coreutils-7.6'
* revdep-rebuild failed to emerge all packages.
* you have the following choices:
* - If emerge failed during the build, fix the problems and re-run revdep-rebuild.
* - Use /etc/portage/package.keywords to unmask a newer version of the package.
* (and remove 5_order.rr to be evaluated again)
* - Modify the above emerge command and run it manually.
* - Compile or unmerge unsatisfied packages manually,
* remove temporary files, and try again.
* (you can edit package/ebuild list first)
* To remove temporary files, please run:
* rm /var/cache/revdep-rebuild/*.rr
* Found some broken files that weren't associated with known packages
* The broken files are:
* /usr/lib32/libAMDXvBA.so.1.0
Trate de ver si era problema de gcc-config (ya me había pasado :wink:) hago gcc-config 1 y me sale esto
Quote:
id: error while loading shared libraries: libselinux.so.1: cannot open shared object file: No such file or directory
* gcc-config: Must be root.
he leído y leído pero no se como solucionar, y creo que el problema es con esta librería ya que todo lo que quiero compilar comienza con este error
Quote:
mv: error while loading shared libraries: libselinux.so.1: cannot open shared object file: No such file or directory
Alguna ayuda por favor. :idea:
_________________
“La amabilidad es un idioma que el sordo puede oír y el ciego puede ver.”

linux user 384810


Last edited by carlos plaza on Thu Oct 29, 2009 2:06 am; edited 1 time in total
Back to top
View user's profile Send private message
carlos plaza
Apprentice
Apprentice


Joined: 22 Jan 2005
Posts: 209
Location: Venezuela

PostPosted: Tue Oct 27, 2009 1:39 am    Post subject: Reply with quote

Para colmo, reinicie para para levantar con livecd haber si podía solucionar algo y nada :cry: ahora cuando reinicie un montón de errores
Quote:
error while loading shared libraries: libselinux.so.1: cannot open shared object file: No such file or directory
y no tengo consola en X :evil: :evil: :evil: desastre total 8O
_________________
“La amabilidad es un idioma que el sordo puede oír y el ciego puede ver.”

linux user 384810
Back to top
View user's profile Send private message
ZaPa
l33t
l33t


Joined: 13 Feb 2007
Posts: 711

PostPosted: Tue Oct 27, 2009 3:12 am    Post subject: Reply with quote

Hola.

La solución es sencilla...

Emerge el paquete coreutils con la use selinux...

Code:

USE=selinux emerge coreutils


Si no consigues emerger coreutils, haz un downgrade de la version del paquete coreutils y seguro te funcionara.

Un saludo, ya nos cuentas.
_________________
--
http://www.monovarlinux.org
Pagina web del proyecto AutoLinux (Autodetección e instalación de drivers para linux) y tutoriales
En Mantenimiento...
Back to top
View user's profile Send private message
pelelademadera
Veteran
Veteran


Joined: 14 Jul 2008
Posts: 1034
Location: La Plata, Argentina

PostPosted: Tue Oct 27, 2009 9:54 am    Post subject: Reply with quote

ZaPa wrote:
Hola.

La solución es sencilla...

Emerge el paquete coreutils con la use selinux...

Code:

USE=selinux emerge coreutils


Si no consigues emerger coreutils, haz un downgrade de la version del paquete coreutils y seguro te funcionara.

Un saludo, ya nos cuentas.


no hagan eso de use=* emerge
agreguenlo al portage.use.... en el proximo emerge --DuNav world vuelve a tener quilombos....
_________________
el pelado de la gente
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3705

PostPosted: Tue Oct 27, 2009 10:09 am    Post subject: Reply with quote

Quote:
La solución es sencilla...


me temo que no : selinux sólo se selecciona desde el perfil del mismo nombre y de cualquier manera, si coreutils no funciona, emerge tampoco.

En el tinderbox no he visto que haya un paquete de libselinux, asi que me temo que o bien buscas a alguien que te pueda facilitar un paquete libselinux o usas un paquete de coreutils del tinderbox ( sin soporte para selinux eso si) para ir tirando mientras arreglas el sistema.

http://tinderbox.x86.dev.gentoo.org/default-linux/

de verdad necesitas selinux ?

saluetes
_________________
Error: Failing not supported by current locale
Back to top
View user's profile Send private message
ZaPa
l33t
l33t


Joined: 13 Feb 2007
Posts: 711

PostPosted: Tue Oct 27, 2009 11:46 am    Post subject: Reply with quote

Hola.

Gringo cuanto tiempo sin verte por aqui amigo :D .

Pero a nuestro amigo si le funciona emerge,no? o tampoco te funciona emerge?

Un saludo.
_________________
--
http://www.monovarlinux.org
Pagina web del proyecto AutoLinux (Autodetección e instalación de drivers para linux) y tutoriales
En Mantenimiento...
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3705

PostPosted: Tue Oct 27, 2009 12:19 pm    Post subject: Reply with quote

Quote:
Gringo cuanto tiempo sin verte por aqui amigo


si, paso poco por aqui últimamente, pero no os libraréis fácilmente de mi :-P

Quote:
Pero a nuestro amigo si le funciona emerge,no?


en el título dice que no puede compilar y en la salida de arriba cuando quiere compilar coreutils se ve que no funciona : en el momento que emerge llama a mv se la pega porque no funciona ;-)

saluetes
_________________
Error: Failing not supported by current locale
Back to top
View user's profile Send private message
pelelademadera
Veteran
Veteran


Joined: 14 Jul 2008
Posts: 1034
Location: La Plata, Argentina

PostPosted: Tue Oct 27, 2009 2:38 pm    Post subject: Reply with quote

me parece que el problema esta en el prune o en el depclean....
desde que salio python 3.* cuando haces depclean, te borra el 2.6* y sin pyython 2.6 no anda emerge....
para mi el problema biene x ahi y no por selinux.

a mi me paso eso con python. lo solucione con una imagen, hice el chroot, y me cree un binario... despues lo agregue al world, asi no me lo borra el depclean.
por ahi no es lo mismo que me paso a mi, pero creo q si
_________________
el pelado de la gente
Back to top
View user's profile Send private message
Txema
l33t
l33t


Joined: 20 May 2008
Posts: 767
Location: Granada

PostPosted: Tue Oct 27, 2009 3:24 pm    Post subject: Reply with quote

¿¿¿¿Pero a quíen se le ocurre hacer un --prune y --depclean sin un --ask???? a veces creo que sois suicidas o masocas xD

Empieza por mirar el log de emerge (/var/log/emerge.log) a ver qué paquetes se han cargado --prune y --depclean tan alegremente...

Saludos.
Back to top
View user's profile Send private message
carlos plaza
Apprentice
Apprentice


Joined: 22 Jan 2005
Posts: 209
Location: Venezuela

PostPosted: Tue Oct 27, 2009 10:30 pm    Post subject: Reply with quote

Gracias a todos por su pronta respuesta.

El caso no necesito pero para nada selinux que yo sepa :?: mi perfil:
Quote:
Available profile symlink targets:
[1] default/linux/amd64/10.0 *
[2] default/linux/amd64/10.0/desktop
[3] default/linux/amd64/10.0/developer
[4] default/linux/amd64/10.0/no-multilib
[5] default/linux/amd64/10.0/server
[6] hardened/linux/amd64/10.0
[7] hardened/linux/amd64/10.0/no-multilib
[8] selinux/2007.0/amd64
[9] selinux/2007.0/amd64/hardened
[10] selinux/v2refpolicy/amd64
[11] selinux/v2refpolicy/amd64/desktop
[12] selinux/v2refpolicy/amd64/developer
[13] selinux/v2refpolicy/amd64/hardened
[14] selinux/v2refpolicy/amd64/server
la version de python:
Quote:
Available python interpreters:
[1] python2.6 *
[2] python3.1
Se que hice una gran metida de pata pero fíjense lo que hice hace poco lo pude solucionar pero esto de libselinux.so.1 me tiene con catarro :evil:.
Bueno el caso es que me puedo bajar el sys-libs/libselinux-2.0.85 pero y como lo compilo :?: :?:
También tengo instalado sys-app/coreutils-7.6 :roll:
_________________
“La amabilidad es un idioma que el sordo puede oír y el ciego puede ver.”

linux user 384810
Back to top
View user's profile Send private message
ZaPa
l33t
l33t


Joined: 13 Feb 2007
Posts: 711

PostPosted: Tue Oct 27, 2009 10:40 pm    Post subject: Reply with quote

Hola..

No quiero interumpir el transcurso de este post pero...

Que es lo que hace emerge --prune y emerge --ask? ¿Y que es tinderbox?

Sobre este post... lo que podrias hacer es, iniciar con el live cd minimal de gentoo, y desde allí hacer un chroot y compilar coreutils de nuevo.

En una ocasión, me paso algo similar, y coreutils tampoco lo podia instalar .Lo que tube que hacer es, montar la carpeta contenedora de los programas "cat, mv,cd" (coreutils) del live cd dentro de la carpeta de ejecutables de mi gentoo, despues d esto hacer un chroot y ahi ya tenia probisionalmente todos los programas de coreutils disponibles.

Ya pudé compilar, reiniciar y solucionado.

Un saludo.
_________________
--
http://www.monovarlinux.org
Pagina web del proyecto AutoLinux (Autodetección e instalación de drivers para linux) y tutoriales
En Mantenimiento...
Back to top
View user's profile Send private message
carlos plaza
Apprentice
Apprentice


Joined: 22 Jan 2005
Posts: 209
Location: Venezuela

PostPosted: Wed Oct 28, 2009 12:16 am    Post subject: Reply with quote

Hola amigo
ZaPa wrote:
Hola..

No quiero interumpir el transcurso de este post pero...

Que es lo que hace emerge --prune y emerge --ask? ¿Y que es tinderbox?

Sobre este post... lo que podrias hacer es, iniciar con el live cd minimal de gentoo, y desde allí hacer un chroot y compilar coreutils de nuevo.

En una ocasión, me paso algo similar, y coreutils tampoco lo podia instalar .Lo que tube que hacer es, montar la carpeta contenedora de los programas "cat, mv,cd" (coreutils) del live cd dentro de la carpeta de ejecutables de mi gentoo, despues d esto hacer un chroot y ahi ya tenia probisionalmente todos los programas de coreutils disponibles.

Ya pudé compilar, reiniciar y solucionado.

Un saludo.

Disculpa mi ignorancia pero me imagino que debe ser en /usr/sbin o /sbin pero no se cual es la carpeta contenedora de los programas :?:
_________________
“La amabilidad es un idioma que el sordo puede oír y el ciego puede ver.”

linux user 384810
Back to top
View user's profile Send private message
ZaPa
l33t
l33t


Joined: 13 Feb 2007
Posts: 711

PostPosted: Wed Oct 28, 2009 9:34 am    Post subject: Reply with quote

Hola.

La carpeta que contiene dichos programas esta en /bin/.

Esa es la carpeta que tendras que montar del live cd a la carpeta donde vas a montar tu gentoo. Montar tu gentoo en esa carpeta y hacer un chroot.

¿Entiendes la idea?




Saludos.
_________________
--
http://www.monovarlinux.org
Pagina web del proyecto AutoLinux (Autodetección e instalación de drivers para linux) y tutoriales
En Mantenimiento...
Back to top
View user's profile Send private message
i92guboj
Moderator
Moderator


Joined: 30 Nov 2004
Posts: 9752
Location: Córdoba (Spain)

PostPosted: Wed Oct 28, 2009 11:56 am    Post subject: Reply with quote

El caso es que tus binarios están enlazados con la librería de selinux. Las únicas explicaciones sencillas que se me ocurren para esto es que, o bien has tenido un perfil erróneo durante algún tiempo sin saberlo, o bien has instalado binarios prefabricados que no son correctos para tu sistema.

La forma más sencilla de arreglar el problema que se me ocurre es ir viendo los binarios que fallan y rescatarlos desde un stage o desde paquetes binarios de tinderbox o alguna fuente de confianza. Una vez que tengas lo suficiente para echar a andar emerge, el resto es fácil:

Code:
emerge -e system


Y luego lo demás.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
carlos plaza
Apprentice
Apprentice


Joined: 22 Jan 2005
Posts: 209
Location: Venezuela

PostPosted: Wed Oct 28, 2009 11:41 pm    Post subject: Reply with quote

Gracias amigo ZaPa y a todos los que me han prestado su colaboración.

Bueno copie los archivos cat mv pero el cd no lo encontré. Hice el chroot y trate de compilar pero sigue el mensaje fatal error while loading shared libraries: libselinux.so.1: cannot open shared object file: No such file or directory :evil: :evil: :?:

i92guboj wrote:
La forma más sencilla de arreglar el problema que se me ocurre es ir viendo los binarios que fallan y rescatarlos desde un stage o desde paquetes binarios de tinderbox o alguna fuente de confianza. Una vez que tengas lo suficiente para echar a andar emerge, el resto es fácil:

Me baje el ultimo stage3-amd64-20091022.tar.bz2 pero no se como hacer lo que dices con el stage y me imagino que si lo descomprimo con tar xvjpf me puede sobreescribir todo el árbol del sistema :?: y eso es como comenzar desde cero no :!:.

He hecho todo lo que me han sugerido, Me he paseado por todo el foro ingles alemán buscando y sincera mente lo que hice no fue una gran metida de pata fue la peor pero la peor BURRADA :evil: :evil: :evil: :evil: :evil: .
Menos mal que la portátil es súper rápida si no consigo arreglar esto, pues ni modo salvo mis archivos de configuración que tanto me costaron afinar y en dos días de compilación como nueva :wink: pero me gustaría arreglarla como debe ser elegantemente.
_________________
“La amabilidad es un idioma que el sordo puede oír y el ciego puede ver.”

linux user 384810
Back to top
View user's profile Send private message
i92guboj
Moderator
Moderator


Joined: 30 Nov 2004
Posts: 9752
Location: Córdoba (Spain)

PostPosted: Thu Oct 29, 2009 12:14 am    Post subject: Reply with quote

carlos plaza wrote:
Gracias amigo ZaPa y a todos los que me han prestado su colaboración.

Bueno copie los archivos cat mv pero el cd no lo encontré.


Muchos de los comandos base son builtins de bash. O sea, simplemente copia /bin/bash desde el cd a tu disco duro. Eso habilitará la gran mayoría de los comandos base (suponiendo que bash sea tu shell predeterminado).

Quote:
Hice el chroot y trate de compilar pero sigue el mensaje fatal error while loading shared libraries: libselinux.so.1: cannot open shared object file: No such file or directory :evil: :evil: :?:


El chroot por si solo no arreglará nada, ya que una vez que se hace efectivo pasas a usar los binarios del sistema que está roto, y seguirán dándote el mismo problema.

Quote:
i92guboj wrote:
La forma más sencilla de arreglar el problema que se me ocurre es ir viendo los binarios que fallan y rescatarlos desde un stage o desde paquetes binarios de tinderbox o alguna fuente de confianza. Una vez que tengas lo suficiente para echar a andar emerge, el resto es fácil:

Me baje el ultimo stage3-amd64-20091022.tar.bz2 pero no se como hacer lo que dices con el stage y me imagino que si lo descomprimo con tar xvjpf me puede sobreescribir todo el árbol del sistema :?: y eso es como comenzar desde cero no :!:.

He hecho todo lo que me han sugerido, Me he paseado por todo el foro ingles alemán buscando y sincera mente lo que hice no fue una gran metida de pata fue la peor pero la peor BURRADA :evil: :evil: :evil: :evil: :evil: .
Menos mal que la portátil es súper rápida si no consigo arreglar esto, pues ni modo salvo mis archivos de configuración que tanto me costaron afinar y en dos días de compilación como nueva :wink: pero me gustaría arreglarla como debe ser elegantemente.


La opción de fuerza bruta que describes es viable si tu sistema y el stage que uses están muy cercanos en cuanto a versiones se refieren. Pero no lo aconsejo a no ser que sepas bien lo que haces, porque es difícil predecir si habrá algún efecto negativo. Por ahora, copia solamente los binarios que necesites para que lo más básico vaya funcionando, comenzando por bash. Luego prueba si emerge funciona o no, recuerda que casi todo usa bash internamente en Gentoo, incluyendo al propio portage (los ebuilds son scripts de shell, ni más ni menos), así que es posible que solo bash esté roto.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
carlos plaza
Apprentice
Apprentice


Joined: 22 Jan 2005
Posts: 209
Location: Venezuela

PostPosted: Thu Oct 29, 2009 1:12 am    Post subject: Reply with quote

Gracias
i92guboj wrote:

Muchos de los comandos base son builtins de bash. O sea, simplemente copia /bin/bash desde el cd a tu disco duro. Eso habilitará la gran mayoría de los comandos base (suponiendo que bash sea tu shell predeterminado).

Quote:
i92guboj wrote:
La forma más sencilla de arreglar el problema que se me ocurre es ir viendo los binarios que fallan y rescatarlos desde un stage o desde paquetes binarios de tinderbox o alguna fuente de confianza. Una vez que tengas lo suficiente para echar a andar emerge, el resto es fácil:

Quote:
La opción de fuerza bruta que describes es viable si tu sistema y el stage que uses están muy cercanos en cuanto a versiones se refieren. Pero no lo aconsejo a no ser que sepas bien lo que haces, porque es difícil predecir si habrá algún efecto negativo. Por ahora, copia solamente los binarios que necesites para que lo más básico vaya funcionando, comenzando por bash. Luego prueba si emerge funciona o no, recuerda que casi todo usa bash internamente en Gentoo, incluyendo al propio portage (los ebuilds son scripts de shell, ni más ni menos), así que es posible que solo bash esté roto.
Es bueno cometer burradas a veces, como se aprende :wink:
Termine copiando todo /bin y se me arreglo un poco las cosas pude levantar la portatil sin el poco de errores y ya tengo consola en X, pero haciendo
Code:
 revdep-rebuild -v -- --ask
me dice
Quote:
* Configuring search environment for revdep-rebuild
* Temporary cache files are located in /var/cache/revdep-rebuild
* Environment mismatch from previous run, deleting temporary files...

revdep-rebuild environment:
SEARCH_DIRS="/bin
/lib
/lib32
/lib64
/opt/bin
/opt/flash-libcompat
/opt/fmodex/api/lib
/opt/xulrunner
/sbin
/usr/bin
/usr/games/bin
/usr/games/lib
/usr/games/lib32
/usr/games/lib64
/usr/kde/3.5/bin
/usr/kde/3.5/lib
/usr/kde/3.5/lib32
/usr/kde/3.5/lib64
/usr/kde/3.5/sbin
/usr/kde/4.2/bin
/usr/kde/4.2/lib
/usr/kde/4.2/lib32
/usr/kde/4.2/lib64
/usr/kde/4.2/sbin
/usr/kde/4.3/bin
/usr/kde/4.3/lib
/usr/kde/4.3/lib32
/usr/kde/4.3/lib64
/usr/kde/4.3/sbin
/usr/lib
/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.2
/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.2/32
/usr/lib/qt4
/usr/lib32
/usr/lib32/libstdc++-v3/
/usr/lib32/opengl/xorg-x11/lib
/usr/lib32/qt4
/usr/lib64
/usr/lib64/fltk-1.1
/usr/lib64/nspr
/usr/lib64/nss
/usr/lib64/opengl/xorg-x11/lib
/usr/lib64/qca2
/usr/lib64/qt4
/usr/lib64/seamonkey
/usr/lib64/xulrunner-1.9.1
/usr/libexec
/usr/local/lib
/usr/local/lib32
/usr/local/lib64
/usr/qt/3
/usr/qt/3/bin
/usr/qt/3/lib
/usr/qt/3/lib32
/usr/qt/3/lib64
/usr/sbin
/usr/x86_64-pc-linux-gnu/gcc-bin/4.4.2
/usr/x86_64-pc-linux-gnu/lib"
SEARCH_DIRS_MASK="/lib/modules
/lib64/modules
/opt/opera/lib/opera/plugins
/opt/sun-jdk-1.5.0.18
/opt/sun-jdk-1.6.0.16
/opt/xulrunner
/usr/lib32/real
/usr/lib32/win32"
LD_LIBRARY_MASK="libjava.so
libjawt.so
libjvm.so
libodbc.so
libodbcinst.so"
PORTAGE_ROOT="/"
EMERGE_OPTIONS="--ask"
ORDER_PKGS="1"
FULL_LD_PATH="1"

* Checking reverse dependencies
* Packages containing binaries and libraries broken by a package update
* will be emerged.

* Collecting system binaries and libraries
* Generated new 1_files.rr
* Collecting complete LD_LIBRARY_PATH
* Generated new 2_ldpath.rr
* Checking dynamic linking consistency
* broken /bin/vstp (requires libbrlapi.so.0.5)
[ 5% ] * broken /usr/bin/chcon (requires libselinux.so.1)
[ 11% ] * broken /usr/bin/id (requires libselinux.so.1)
[ 12% ] * broken /usr/bin/install (requires libselinux.so.1)
[ 18% ] * broken /usr/bin/runcon (requires libselinux.so.1)
[ 20% ] * broken /usr/bin/stat (requires libselinux.so.1)
[ 24% ] * broken /usr/kde/3.5/lib32/libqtmcop.so.1.0.0 (requires libqt-mt.so.3)
[ 100% ]
* broken /usr/lib32/libAMDXvBA.so.1.0 (no version information available)
* Generated new 3_broken.rr
* Assigning files to packages
* !!! /bin/vstp not owned by any package is broken !!!
* /bin/vstp -> (none)
* /usr/bin/chcon -> sys-apps/coreutils
* /usr/bin/id -> sys-apps/coreutils
* /usr/bin/install -> sys-apps/coreutils
* /usr/bin/runcon -> sys-apps/coreutils
* /usr/bin/stat -> sys-apps/coreutils
* /usr/kde/3.5/lib32/libqtmcop.so.1.0.0 -> app-emulation/emul-linux-x86-soundlibs
* !!! /usr/lib32/libAMDXvBA.so.1.0 not owned by any package is broken !!!
* /usr/lib32/libAMDXvBA.so.1.0 -> (none)
* Generated new 4_raw.rr and 4_owners.rr
* Cleaning list of packages to rebuild
* Generated new 4_pkgs.rr
* Assigning packages to ebuilds
* Generated new 4_ebuilds.rr
* Evaluating package order
* Generated new 5_order.rr
* All prepared. Starting rebuild
emerge --oneshot --verbose --ask app-emulation/emul-linux-x86-soundlibs:0
sys-apps/coreutils:0
..........

These are the packages that would be merged, in order:

Calculating dependencies ... done!
[ebuild R ] sys-apps/coreutils-7.6 USE="acl gmp nls -caps (-selinux) -static -vanilla -xattr" 0 kB
[ebuild R ] app-emulation/emul-linux-x86-soundlibs-20080418 USE="alsa arts esd" 0 kB

Total: 2 packages (2 reinstalls), Size of downloads: 0 kB
y yo para que necesito libselinux.so.1 si no es mi perfil, como hago para que no busque linkear a libselinux, que lo que me esta dando problemas. :?: voy a tratar de emerge -e system a ver :wink:
Ha y muchas gracias
_________________
“La amabilidad es un idioma que el sordo puede oír y el ciego puede ver.”

linux user 384810
Back to top
View user's profile Send private message
carlos plaza
Apprentice
Apprentice


Joined: 22 Jan 2005
Posts: 209
Location: Venezuela

PostPosted: Thu Oct 29, 2009 1:35 am    Post subject: Reply with quote

Nada no puedo compilar todavía por error while loading shared libraries: libselinux.so.1: cannot open shared object file: No such file or directory Sera que voy a tener que cambiarme al perfil selinux/2007.0/amd64 :?: y depues volver al default/linux/amd64/10.0 :?: :?:
_________________
“La amabilidad es un idioma que el sordo puede oír y el ciego puede ver.”

linux user 384810
Back to top
View user's profile Send private message
carlos plaza
Apprentice
Apprentice


Joined: 22 Jan 2005
Posts: 209
Location: Venezuela

PostPosted: Thu Oct 29, 2009 2:04 am    Post subject: Reply with quote

Resuelto mi problema, muchas gracias a todos por su gran atención.

Solución, simple copie del livecd a mi disco
Quote:
/usr/bin/chcon
/usr/bin/id
/usr/bin/install
/usr/bin/runcon
/usr/bin/stat
Dios como me gusta Gentoo y que grande es este FORO. La mejor gente del mundo se encuentra en este foro :wink: :lol: de nuevo muchas gracias a todos.
_________________
“La amabilidad es un idioma que el sordo puede oír y el ciego puede ver.”

linux user 384810
Back to top
View user's profile Send private message
Inodoro_Pereyra
Advocate
Advocate


Joined: 03 Nov 2006
Posts: 2630
Location: En la otra punta del cable

PostPosted: Thu Oct 29, 2009 3:02 am    Post subject: Reply with quote

Gentoo nunca muere, como dicen...

Salud!
_________________
Mi Blog.

Si no fuera por C, estaríamos escribiendo programas en BASI, PASAL y OBOL.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum