Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Fontes no Firefox
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
lobo
Tux's lil' helper
Tux's lil' helper


Joined: 07 Oct 2003
Posts: 100
Location: São Paulo, Brasil

PostPosted: Sun Jul 04, 2004 10:41 pm    Post subject: Fontes no Firefox Reply with quote

Meu firefox não esta mais mostrando as letras com acento, ç, etc... Tentei mudar as fontes e o encoding mas parece que não está mudando nada... Que configuração eu devo por para poder ler adequadamente as páginas em portugues??


tnx,
Lobo

P.S. Engraçado que minha mensagem aparece sem problemas...
Back to top
View user's profile Send private message
fernandotcl
Veteran
Veteran


Joined: 20 Nov 2003
Posts: 1396
Location: Sao Paulo, Brazil

PostPosted: Mon Jul 05, 2004 12:09 am    Post subject: Re: Fontes no Firefox Reply with quote

lobo wrote:
Meu firefox não esta mais mostrando as letras com acento, ç, etc... Tentei mudar as fontes e o encoding mas parece que não está mudando nada... Que configuração eu devo por para poder ler adequadamente as páginas em portugues??


Certifique-se de que o charset selecionado seja o ISO-8859-15. Com a fonte, você lembrou de aplicar as configurações para todas as páginas ("Always use my: [X] fonts")?

Existem outras variáveis que possam estar afetando. LC_ALL e LANG devem estar como "pt_BR". LESS_CHARSET tem que estar como "iso8859". Talvez as variáveis tivessem que ser setadas antes de compilar o Firefox (se é que você o compilou).

No xorg.conf, certifique-se de que o modelo do teclado seja "abnt2" e a variante de layout "br". Só essas já são suficientes pra um teclado padrão ABNT-2, mais do que isso pode trazer problemas.

Verifique se somente o Firefox apresenta o problema, se não é algo comum à todas as aplicações GTK, ou tudo no X.

lobo wrote:
P.S. Engraçado que minha mensagem aparece sem problemas...


Lol, só pra você, aqui elas estão completamente embaralhadas. :D
Back to top
View user's profile Send private message
lobo
Tux's lil' helper
Tux's lil' helper


Joined: 07 Oct 2003
Posts: 100
Location: São Paulo, Brasil

PostPosted: Mon Jul 05, 2004 2:49 pm    Post subject: Reply with quote

Acho que sei o q houve... Eu mantenho meu sistema up-to-date e compilei o release novo xfree... tinha lá uma mensagem sobre fontes e eu achei que não ia dar problemas... Bem deve ser algo no XF86config, sei lá... Valeu ai! Se bem que eu to faz tempo pra instalar o X.org, derrepente é a deixa!


tnx,
Lobo
Back to top
View user's profile Send private message
lobo
Tux's lil' helper
Tux's lil' helper


Joined: 07 Oct 2003
Posts: 100
Location: São Paulo, Brasil

PostPosted: Mon Jul 05, 2004 3:44 pm    Post subject: Reply with quote

Bem, acrescentei umas fontes no XF86config e mudei o encoding no firefox, ai funcionou! O meu linux tem me pregado umas peças, preciso para de mexer nele bebado! :)


[]'s
Lobo
Back to top
View user's profile Send private message
seventhguardian
Apprentice
Apprentice


Joined: 10 May 2004
Posts: 261
Location: Portugal

PostPosted: Wed Jul 07, 2004 1:59 pm    Post subject: Reply with quote

boas!

eu tenho o mesmo problema, mas é só em algumas páginas......

por exemplo nesta pagina do forum n consigo ver direito os acentos (aparecem todos trocados...). Em outras aparecem quadradinhos com quatro letrinhas pequeninas dentro..... e em outras da perfeitamente.

Provavelmente é do charset.. n deve tar a ser detectado em condições... mas afinal como é k se escolhe o charset do firefox?? eu tenho o 0.8 e n dou c ele nas opçoes...

brigado!!
Back to top
View user's profile Send private message
seventhguardian
Apprentice
Apprentice


Joined: 10 May 2004
Posts: 261
Location: Portugal

PostPosted: Wed Jul 07, 2004 2:00 pm    Post subject: Reply with quote

........outra coisa:

qual é a vantagem do x.org? eu tenho o xfree porque n quis pensar muito nisso.. mas agora k tou mais a vontade com linux queria saber quais são as diferenças e vantagens de um e de outro.. e de outros semelhantes.. porque decidiste mudar?

brigado!
Back to top
View user's profile Send private message
lobo
Tux's lil' helper
Tux's lil' helper


Joined: 07 Oct 2003
Posts: 100
Location: São Paulo, Brasil

PostPosted: Wed Jul 07, 2004 3:30 pm    Post subject: Reply with quote

Para consertar as fontes o q eu fiz foi ir em
Preferences>>General>>Fonts&Colors>>Fonts For=Western e

Preferences>>General>>Languages>>Default Caracter Encoding=Western(ISO-8859-15)

No XF86config acrescente a linha(caso não tenha)

FontPath "/usr/X11R6/lib/X11/fonts/encodings/"

Junto com as outros FontPath.

Quanto ao X.org, é um fork recente do xfree, então são parecidos, mas a principal diferença é na licensa de uso... Mas tem gente que diz que é mais rápido...

[]'s
Lobo
Back to top
View user's profile Send private message
seventhguardian
Apprentice
Apprentice


Joined: 10 May 2004
Posts: 261
Location: Portugal

PostPosted: Wed Jul 07, 2004 4:26 pm    Post subject: Reply with quote

n funcionou......

ja tinha o "fonts for" definido para western mas n encontro o menu "language".. o meu firefox é o 0.8.. kual é k tu tens?

para tirar duvidas abri a mesma pagina com o konqueror, e o problema é geral.. n tem nada a ver com o firefox. Abri as fontes da pagina com o kwrite e os caracteres não são reconhecidos.. deve ser problema das paginas.... não sei se em windows funcionam bem, mas para ver isso tem k ser noutro pc... :)

mesmo assim ainda bem k fui ver a XF86Config :) acrescentei a linha 'encodings" e reparei k tinha a 'truetype' comentada :) descomentei e agora ja tenho o simbolo do euro :D € hehe...

brigado na mesma!

isso da licença do xfree ja deu muita conversa.. se calhar mudo tambem.. até porque a versão xfree ainda sob gpl deve ficar na mesma, enquanto que provavelmente a x.org deve evoluir, por isso deve ser melhor mudar... vou pensar nisso. brigado pela dica!
Back to top
View user's profile Send private message
fernandotcl
Veteran
Veteran


Joined: 20 Nov 2003
Posts: 1396
Location: Sao Paulo, Brazil

PostPosted: Wed Jul 07, 2004 4:47 pm    Post subject: Reply with quote

Se lembre que o XFree 4.4 não vai entrar na árvore do portage, então você pode ficar com uma atualização estagnada se não mudar. Em breve o Xorg deve passar a ser considerado estável para o Gentoo (embora já esteja mais que estável).
Back to top
View user's profile Send private message
lobo
Tux's lil' helper
Tux's lil' helper


Joined: 07 Oct 2003
Posts: 100
Location: São Paulo, Brasil

PostPosted: Thu Jul 08, 2004 11:08 pm    Post subject: Reply with quote

Opa! Se o problema é geral, então acho que voce precisa mexer nas fontes do seu gerenciador de janelas e colocar Western(ISO-8859-15) . Bem o meu Firefox é o 9.1!! Eu gosto de usar o portage! :)

Na realidade eu não sei se existe algum lugar em que vc define que encoding vc quer usar para o sistema todo... Mas acho que pelo menos para web vc precisa achar o menu languages e mudar seu characeter encoding.


[]'s
Lobo
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum