Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Enable On-Board Audio on Sun Blade 100
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc
View previous topic :: View next topic  
Author Message
rsidler
n00b
n00b


Joined: 21 Jun 2004
Posts: 10

PostPosted: Tue Jun 29, 2004 11:37 am    Post subject: Enable On-Board Audio on Sun Blade 100 Reply with quote

Hi All!

I know, this is possible a beginners question. Sorry about that.

I successfully installed gentoo 2.4 on my Sun Blade 100 including Xorg.
Now I want to enable the sound. How can I do that? I want to use the
on board Soundchip (AD1881A).

Is there a step by step guide for the Sun Blade 100?

Thanks very much for helping!

Regards,
Roman
Back to top
View user's profile Send private message
Weeve
Retired Dev
Retired Dev


Joined: 30 Oct 2002
Posts: 641

PostPosted: Wed Jun 30, 2004 5:35 am    Post subject: Reply with quote

There's no step by step guide that I'm aware of. The sound module you will want is trident under the regular OSS sound section (you won't find this under SPARC audio). Be aware that this driver does not always produce usable sound for all Blade 100 users.

As a side note, sound under 2.6 for Blade 100 users has gotten several positive reports. If you decide to go this route, use the ALI5451 ALSA module in the kernel tree (and be sure to enable oss emulation for pcm and mixer so you can use the sound device).
Back to top
View user's profile Send private message
rsidler
n00b
n00b


Joined: 21 Jun 2004
Posts: 10

PostPosted: Wed Jun 30, 2004 6:33 am    Post subject: Reply with quote

Thanks, Jason! It works with Kernel 2.4. All I have to check now is the audio quality and how to disable the internal speaker;-)!

Regards,
Roman
Back to top
View user's profile Send private message
petrasl
n00b
n00b


Joined: 18 May 2004
Posts: 66
Location: Swiss

PostPosted: Thu Sep 23, 2004 7:53 pm    Post subject: Reply with quote

Weeve wrote:

As a side note, sound under 2.6 for Blade 100 users has gotten several positive reports. If you decide to go this route, use the ALI5451 ALSA module in the kernel tree (and be sure to enable oss emulation for pcm and mixer so you can use the sound device).


Yes ; the on board sound card works quite well on a Sunblade 100.
I use alsa modules with alsa-oss with kernel-2.6.9-rc2:

Following the alsa-guide

The kernel config file look like :
Code:
#
# Sound
#
CONFIG_SOUND=y
#
# Advanced Linux Sound Architecture
#
CONFIG_SND=m
CONFIG_SND_TIMER=m
CONFIG_SND_PCM=m
CONFIG_SND_HWDEP=m
CONFIG_SND_RAWMIDI=m
CONFIG_SND_SEQUENCER=m
CONFIG_SND_SEQ_DUMMY=m
CONFIG_SND_OSSEMUL=y
CONFIG_SND_MIXER_OSS=m
CONFIG_SND_PCM_OSS=m
CONFIG_SND_SEQUENCER_OSS=y
CONFIG_SND_BIT32_EMUL=m
#
# PCI devices
#
CONFIG_SND_AC97_CODEC=m
CONFIG_SND_ALI5451=m


Next ; emerge alsa-utils, alsa-oss

Code:

emerge alsa-utils && emerge alsa-oss


Edit /etc/modules.d/alsa and add those 2 lines

Code:

alias snd-card-0 snd-ali5451
alias sound-slot-0 snd-card-0


run
Code:

modules-update && /etc/init.d/alsasound start


Check if the modules are been loaded
Code:

lsmod

Code:

nd_ali5451            27176  0
snd_ac97_codec         80388  1 snd_ali5451
snd_seq_oss            39592  0
snd_seq_midi_event     10048  1 snd_seq_oss
snd_seq                64600  4 snd_seq_oss,snd_seq_midi_event
snd_seq_device          9232  2 snd_seq_oss,snd_seq
snd_pcm_oss            64744  0
snd_pcm               109836  2 snd_ali5451,snd_pcm_oss
snd_page_alloc         14096  1 snd_pcm
snd_timer              29456  2 snd_seq,snd_pcm
snd_mixer_oss          20928  1 snd_pcm_oss
snd                    59240  10 snd_ali5451,snd_ac97_codec,snd_seq_oss,snd_seq_midi_event,snd_seq,snd_seq_device,snd_pcm_oss,snd_pcm,snd_timer,snd_mixer_oss


Now, we have to unmute Master and Pcm :
Code:

aumix

note : I coul'd get amixer working

Finally, I can play mp3s with mpg321 only; but It plays well :)

From linux.debian.ports.sparc

Any other application with alsa-oss-emulation besides mpg321 and aumix
produces a terrible amount of noise, and any application that tries to
use alsa native, complains that it can't open the device.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum