Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Проблемы с запуском KDE
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Russian
View previous topic :: View next topic  
Author Message
Torgovec
n00b
n00b


Joined: 23 Jun 2004
Posts: 15
Location: Moscow

PostPosted: Wed Jun 23, 2004 8:30 am    Post subject: Проблемы с запуском KDE Reply with quote

Настроил XF86Config (пока правда с дровами nv)
набираю:
#startx - стартуют иксы в них открыто три консоли
в одной из консолей набираю:
#startkde
startkde: startingup
startkde: running kpersoanailyzer
/usr/kde/3.2/bin/startkde:
line 179: 3591 illegal instruction kwin -lock
line 179: 3592 illegal instruction kpersoanalyzer --before-session...
.....
DCOP aborting call
from 'anonymous' - 3959 to 'kded'
kded: ERROR: Communication problem with knotify
it probably crashed.
DCOP aborting call for 'anonymous' -3962 to 'knotify'
ERROR: Communication problem with 'knotify',
it probably crashed.
startkde: shutting down...
klauncher: Exiting on signal 1
Running shutdown scripts.

И усё, интерпретатор ждёт следующей команды.
Может кто сталкивался...

З.Ы.
над файлом /etc/make.conf
не измывался.
Заранне спасибо
_________________
Сколько волка не корми, а у слона всё-равно больше !
Back to top
View user's profile Send private message
Dr.crooked.hand
n00b
n00b


Joined: 19 Feb 2004
Posts: 11
Location: Russia

PostPosted: Wed Jun 23, 2004 3:35 pm    Post subject: Re: Reply with quote

I would try making another user (nonroot) and try logging in as them. If you can get into kde then something in your .kde directory for your other user is borked. to fix that you can delete the .kde directory then login to recreate your settings that will have been lost.
Good Luck

Это взято с http://www.dslreports.com/forum/remark,9524469~mode=flat
Back to top
View user's profile Send private message
Torgovec
n00b
n00b


Joined: 23 Jun 2004
Posts: 15
Location: Moscow

PostPosted: Thu Jun 24, 2004 1:08 pm    Post subject: Reply with quote

Блин чё за фигня !, у меня каталога .kde в ~/ директории аще нету,
поставил себе гнома, решил его запустить, делаю gdm в консоли,
#gdm -> несклолько попыток зайти в иксы потом возврат обратно в консоль делаю alt+F7 что-бы посмотреть что там, а там вот что:
на чёрном экране надпись - missing DISPLAY and a console dialog could not be found, чё я не так делаю не могу понять. Хотя startx пашет нормально :(
_________________
Сколько волка не корми, а у слона всё-равно больше !
Back to top
View user's profile Send private message
Torgovec
n00b
n00b


Joined: 23 Jun 2004
Posts: 15
Location: Moscow

PostPosted: Thu Jun 24, 2004 1:35 pm    Post subject: Reply with quote

Вот файл /var/log/kdm.log
********************************************************************************
Note that your system uses syslog. All of kdm's internally generated messages
(i.e., not from libraries and external programs/scripts it uses) go to the
daemon.* syslog facility; check your syslog configuration to find out to which
file(s) it is logged. PAM logs messages related to authentication to authpriv.*.
********************************************************************************


This is a pre-release version of XFree86, and is not supported in any
way. Bugs may be reported to XFree86@XFree86.Org and patches submitted
to fixes@XFree86.Org. Before reporting bugs in pre-release versions,
please check the latest version in the XFree86 CVS repository
(http://www.XFree86.Org/cvs).

XFree86 Version 4.3.0.1
Release Date: 15 August 2003
X Protocol Version 11, Revision 0, Release 6.6
Build Operating System: Linux 2.6.4-wolk-2.3 i686 [ELF]
Build Date: 15 April 2004
Before reporting problems, check http://www.XFree86.Org/
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Thu Jun 24 17:28:34 2004
(==) Using config file: "/root/XF86Config"
(WW) NV(0): Failed to set up write-combining range (0xd8000000,0x2000000)
Symbol __glXActiveScreens from module /usr/X11R6/lib/modules/extensions/libdri.a is unresolved!
Symbol __glXActiveScreens from module /usr/X11R6/lib/modules/extensions/libdri.a is unresolved!
_________________
Сколько волка не корми, а у слона всё-равно больше !
Back to top
View user's profile Send private message
Torgovec
n00b
n00b


Joined: 23 Jun 2004
Posts: 15
Location: Moscow

PostPosted: Thu Jun 24, 2004 2:03 pm    Post subject: Reply with quote

Закоментил строчку dri в XF86Config
теперь лог такой:

XFree86 Version 4.3.0.1
Release Date: 15 August 2003
X Protocol Version 11, Revision 0, Release 6.6
Build Operating System: Linux 2.6.4-wolk-2.3 i686 [ELF]
Build Date: 15 April 2004
Before reporting problems, check http://www.XFree86.Org/
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Thu Jun 24 17:28:34 2004
(==) Using config file: "/root/XF86Config"
(WW) NV(0): Failed to set up write-combining range (0xd8000000,0x2000000)

подозреваю что проблема в последней строке, но что это такое без понятия

P.S.
Последняя строка присутствует и в XF86Config.log
_________________
Сколько волка не корми, а у слона всё-равно больше !
Back to top
View user's profile Send private message
Python
n00b
n00b


Joined: 25 Jan 2004
Posts: 18

PostPosted: Fri Jun 25, 2004 6:04 am    Post subject: Reply with quote

Ю ЙЮЙНИ ДПЮИБЕП С РЕАЪ ОПНОХЯЮМ Б XF86Config:
Driver "nv" ХКХ Driver "nvidia" (ДНКФЕМ АШРЭ БРНПНИ)
Back to top
View user's profile Send private message
Torgovec
n00b
n00b


Joined: 23 Jun 2004
Posts: 15
Location: Moscow

PostPosted: Fri Jun 25, 2004 1:42 pm    Post subject: Reply with quote

прописан сейчас NV,а с Nvidia не проходит, ругается судя по-всему на ядро 2.6, но с ним я позже разбираться буду, мне - бы KDE-шник поднять !
Пиши пожайлуста в koi8, а то читать трудно.
_________________
Сколько волка не корми, а у слона всё-равно больше !
Back to top
View user's profile Send private message
chernousov
Tux's lil' helper
Tux's lil' helper


Joined: 30 May 2004
Posts: 117

PostPosted: Fri Jun 25, 2004 2:03 pm    Post subject: Reply with quote

А вот этот совет разве не помог тебе с установкой родных драйверов NVidia? Я именно так лечил проблему со своей NVidia с ядром 2.6.
Кстати, убедись, что в ядре у тебя CONFIG_4KSTACKS выключено. NVidia-драйвера с 4к-стэком работать не будут.
Ну и, конечно, в XF86Config надо Driver "nvidia". Модули какие-попало тоже работать не будут. Вот у меня, например так:
Code:
Section "Module"
    Load        "dbe"
    Load        "glx"
    Load        "type1"
    Load        "freetype"
    SubSection "extmod"
    EndSubSection
EndSection

Попробуй, напиши, что получилось.
Back to top
View user's profile Send private message
Torgovec
n00b
n00b


Joined: 23 Jun 2004
Posts: 15
Location: Moscow

PostPosted: Thu Jul 01, 2004 11:07 am    Post subject: Reply with quote

Nvidia здесь ни причём, эта скатина даже с vesa не работает.
Я сделал проще: :evil:
Code:
 # rm -rf /

Ставлю систему заново, если будет такая-же бадяга, я распишу прямо по шагам, здесь, в форуме как я устанавливаю и чё делаю, тады разберёмся, а пока спасибо за советы. :)
_________________
Сколько волка не корми, а у слона всё-равно больше !
Back to top
View user's profile Send private message
Torgovec
n00b
n00b


Joined: 23 Jun 2004
Posts: 15
Location: Moscow

PostPosted: Fri Jul 02, 2004 12:41 pm    Post subject: Reply with quote

Переустановил, всё ОК иксы запустились с первого раза, KDE тоже.
В этот раз я не рискнул делать emerge nvidia-kernel, а всё остальное делал то-же самое (!!вроде!!) . Поставил шрифты нормальные, всё хорошо работает. Правда не могу протокол нормальный для мыши подобрать - но это дело времени :D :!:
_________________
Сколько волка не корми, а у слона всё-равно больше !
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Russian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum