Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200406-15 ] Usermin: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Bodhisattva
Bodhisattva


Joined: 25 Feb 2003
Posts: 3827
Location: Essen, Germany

PostPosted: Fri Jun 18, 2004 7:44 pm    Post subject: [ GLSA 200406-15 ] Usermin: Multiple vulnerabilities Reply with quote

Gentoo Linux Security Advisory

Title: Usermin: Multiple vulnerabilities (GLSA 200406-15)
Severity: normal
Exploitable: remote
Date: June 18, 2004
Updated: May 22, 2006
Bug(s): #54030
ID: 200406-15

Synopsis

Usermin contains two security vulnerabilities which could lead to a Denial of Service attack and information disclosure.

Background

Usermin is a web-based administration tool for Unix. It supports a wide range of user applications including configuring mail forwarding, setting up SSH or reading mail.

Affected Packages

Package: app-admin/usermin
Vulnerable: <= 1.070-r1
Unaffected: >= 1.080
Architectures: All supported architectures


Description

Usermin contains two security vulnerabilities. One fails to properly sanitize email messages that contain malicious HTML or script code and the other could allow an attacker to lock out a valid user by sending an invalid username and password.

Impact

By sending a specially crafted e-mail, an attacker can execute arbitrary scripts running in the context of the victim's browser. This can be lead to cookie theft and potentially to compromise of user accounts. Furthermore, an attacker could lock out legitimate users by sending invalid login information.

Workaround

There is no known workaround at this time. All users are encouraged to upgrade to the latest available version.

Resolution

Usermin users should upgrade to the latest version:
Code:
# emerge sync
# emerge -pv ">=app-admin/usermin-1.080"
# emerge ">=app-admin/usermin-1.080"


References

Bugtraq Announcement
SNS Advisory
CVE-2004-0583
CVE-2004-0588


Last edited by GLSA on Tue May 23, 2006 4:16 am; edited 2 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum