Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200406-09 ] Horde-Chora: Remote code execution
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Moderator
Moderator


Joined: 13 Jun 2003
Posts: 4078
Location: Barcelona, Spain

PostPosted: Tue Jun 15, 2004 7:23 pm    Post subject: [ GLSA 200406-09 ] Horde-Chora: Remote code execution Reply with quote

Gentoo Linux Security Advisory

Title: Horde-Chora: Remote code execution (GLSA 200406-09)
Severity: high
Exploitable: remote
Date: June 15, 2004
Updated: December 30, 2007
Bug(s): #53800
ID: 200406-09

Synopsis

A vulnerability in Chora allows remote code execution and file upload.

Background

Chora is a PHP-based SVN/CVS repository viewer by the HORDE project.

Affected Packages

Package: www-apps/horde-chora
Vulnerable: < 1.2.2
Unaffected: >= 1.2.2
Architectures: All supported architectures


Description

A vulnerability in the diff viewer of Chora allows an attacker to inject shellcode. An attacker can exploit PHP's file upload functionality to upload a malicious binary to a vulnerable server, chmod it as executable, and run the file.

Impact

An attacker could remotely execute arbitrary binaries with the permissions of the PHP script, conceivably allowing further exploitation of local vulnerabilities and remote root access.

Workaround

There is no known workaround at this time.

Resolution

All users are advised to upgrade to the latest version of Chora:
Code:
# emerge sync
# emerge -pv ">=www-apps/horde-chora-1.2.2"
# emerge ">=www-apps/horde-chora-1.2.2"


References

e-matters Advisory


Last edited by GLSA on Mon Dec 31, 2007 4:16 am; edited 2 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum