Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
xfree 4.2.99
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
carlivar
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jul 2002
Posts: 92
Location: Burbank, California

PostPosted: Mon Oct 14, 2002 7:24 pm    Post subject: xfree 4.2.99 Reply with quote

I'm pretty sure I need xfree 4.2.99 to support the video on my Intel 845 chipset. That's according to numerous newsgroup posts and such and surfing xfree86's CVS tree, which indicates this support has been added very recently.

I'm happy to see Gentoo has xfree 4.2.99. When I go to /usr/portage/x11-base/xfree and do a 'emerge -p xfree-4.2.99.ebuild' it looks good.

BUT, when I tell it I want fluxbox also (emerge -p xfree-4.2.99.ebuild fluxbox) it says it is going to install xfree 4.2.0-r12 after xfree 4.2.99! Why? xfree 4.2.99 should satisfy the X requirement and I can't see any dependencies on any of the to-be-installed packages that would specifically require xfree 4.2.0-r12.

Or is it because xfree-4.2.99 isn't in the "official" package list? Maybe I need to read the docs!

Carl
_________________
"It is difficult to make our material condition better by the best law, but it is easy enough to ruin it by bad laws." - Theodore Roosevelt
Back to top
View user's profile Send private message
carlivar
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jul 2002
Posts: 92
Location: Burbank, California

PostPosted: Mon Oct 14, 2002 7:47 pm    Post subject: Reply with quote

Okay, reading about profiles in the portage system. I found the 'packages' file for my profile (/usr/portage/profiles/default-x86-1.4/packages) and I tried changing x11-base/xfree from:

>=x11-base/xfree-4.1.0-r12

to:

>=x11-base/xfree-4.2.99

But now an 'emerge -p fluxbox' says that all ebuilds that could satisfy "virtual/x11" have been masked. But this is not right - xfree-4.2.99 satisfies virtual/x11.

I'm confused.

Carl
_________________
"It is difficult to make our material condition better by the best law, but it is easy enough to ruin it by bad laws." - Theodore Roosevelt
Back to top
View user's profile Send private message
carlivar
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jul 2002
Posts: 92
Location: Burbank, California

PostPosted: Mon Oct 14, 2002 7:50 pm    Post subject: Reply with quote

Ah. Just found the package.mask file. xfree 4.2.99 is masked due to being very experimental. I unmasked it and now my system is ready to use 4.2.99. We'll see what happens!

Carl
_________________
"It is difficult to make our material condition better by the best law, but it is easy enough to ruin it by bad laws." - Theodore Roosevelt
Back to top
View user's profile Send private message
taskara
Advocate
Advocate


Joined: 10 Apr 2002
Posts: 3763
Location: Australia

PostPosted: Mon Oct 14, 2002 10:43 pm    Post subject: Reply with quote

I think you'll find that if you compile 4.2.99 FIRST, then seperately emerge fluxbox, it will not compile 4.1.0r12.

but if you try to do them together, it thinks it needs 4.1.0r12 because x isn't installed yet.
Back to top
View user's profile Send private message
BradB
Apprentice
Apprentice


Joined: 18 Jun 2002
Posts: 190
Location: Christchurch NZ

PostPosted: Mon Oct 14, 2002 10:45 pm    Post subject: Reply with quote

carlivar - I'd just like to comment that I appreciate you posting followups. I wish more people did it - really helps out others.

Brad
Back to top
View user's profile Send private message
carlivar
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jul 2002
Posts: 92
Location: Burbank, California

PostPosted: Tue Oct 15, 2002 12:29 am    Post subject: Reply with quote

Yeah I like the followups because writing things down helps me sort of organize my thoughts.

I think that's right re: installing 4.2.99. If I would have just installed 4.2.99 and then fluxbox seperately, it probably would have been happy with dependencies installed.

4.2.99 installation barfed. I got some sort of nasty internal gcc error towards the end.

I'm not sure if 4.2.99 has the video support I need anyway. I'm going to try xfree86 from CVS. See my Intel 845G thread in "Hardware & Laptops" for further info. I might just try changing the 4.2.99 ebuild to use the CVS version, although I'm not very optimistic.

Carl
_________________
"It is difficult to make our material condition better by the best law, but it is easy enough to ruin it by bad laws." - Theodore Roosevelt
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum