Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200406-05 ] Apache: Buffer overflow in mod_ssl
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Moderator
Moderator


Joined: 13 Jun 2003
Posts: 4078
Location: Barcelona, Spain

PostPosted: Wed Jun 09, 2004 7:44 pm    Post subject: [ GLSA 200406-05 ] Apache: Buffer overflow in mod_ssl Reply with quote

Gentoo Linux Security Advisory

Title: Apache: Buffer overflow in mod_ssl (GLSA 200406-05)
Severity: high
Exploitable: remote
Date: June 09, 2004
Updated: December 30, 2007
Bug(s): #51368
ID: 200406-05

Synopsis

A bug in mod_ssl may allow a remote attacker to execute remote code when Apache is configured a certain way.

Background

Apache is the most popular Web server on the Internet. mod_ssl provides Secure Sockets Layer encryption and authentication to Apache 1.3. Apache 2 contains the functionality of mod_ssl.

Affected Packages

Package: net-www/mod_ssl
Vulnerable: < 2.8.18
Unaffected: >= 2.8.18
Architectures: All supported architectures

Package: www-servers/apache
Vulnerable: <= 2.0.49-r2
Unaffected: < 2.0
Unaffected: >= 2.0.49-r3
Architectures: All supported architectures


Description

A bug in the function ssl_util_uuencode_binary in ssl_util.c may lead to a remote buffer overflow on a server configured to use FakeBasicAuth that will trust a client certificate with an issuing CA with a subject DN longer than 6k.

Impact

Given the right server configuration, an attacker could cause a Denial of Service or execute code as the user running Apache, usually"apache". It is thought to be impossible to exploit this to execute code on the x86 platform, but the possibility for other platforms is unknown. This does not preclude a DoS on x86 systems.

Workaround

A server should not be vulnerable if it is not configured to use FakeBasicAuth and to trust a client CA with a long subject DN.

Resolution

Apache 1.x users should upgrade to the latest version of mod_ssl:
Code:
# emerge sync
# emerge -pv ">=net-www/mod_ssl-2.8.18"
# emerge ">=net-www/mod_ssl-2.8.18"
Apache 2.x users should upgrade to the latest version of Apache:
Code:
# emerge sync
# emerge -pv ">=www-servers/apache-2.0.49-r3"
# emerge ">=www-servers/apache-2.0.49-r3"


References

CAN-2004-0488


Last edited by GLSA on Mon Dec 31, 2007 4:16 am; edited 2 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum