Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
anothe4 qt and qt-block query
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
thecooptoo
Veteran
Veteran


Joined: 27 Apr 2003
Posts: 1353
Location: UK

PostPosted: Tue Jan 27, 2009 10:16 pm    Post subject: anothe4 qt and qt-block query Reply with quote

ive read the stuff i could find and have goit this far :
Code:
skippy paul # cat /etc/portage/package.mask
>=dev-util/netbeans-5.5.1
<x11-libs/qt-3.3.8b
skippy paul #     

and then when i try to emerge qt by itself
Code:
skippy paul # emerge -puv qt

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ] x11-libs/qt-core-4.4.2  USE="qt3support ssl -debug -doc -glib -pch" 102,858 kB
[ebuild  N    ] x11-libs/qt-sql-4.4.2  USE="mysql qt3support sqlite -debug -firebird -odbc -pch -postgres" 0 kB
[ebuild  N    ] x11-libs/qt-dbus-4.4.2  USE="-debug -pch" 0 kB
[ebuild  N    ] x11-libs/qt-script-4.4.2  USE="-debug -pch" 0 kB
[ebuild  N    ] x11-libs/qt-xmlpatterns-4.4.2  USE="-debug -pch" 0 kB
[ebuild  N    ] x11-libs/qt-test-4.4.2  USE="-debug -pch" 0 kB
[ebuild  N    ] x11-libs/qt-gui-4.4.2-r1  USE="accessibility cups dbus qt3support tiff -debug -glib -mng -nas -nis -pch -xinerama" INPUT_DEVICES="-wacom" 0 kB
[ebuild  N    ] x11-libs/qt-qt3support-4.4.2  USE="accessibility -debug -pch" 0 kB
[ebuild  N    ] x11-libs/qt-webkit-4.4.2  USE="-debug -pch" 0 kB
[ebuild  N    ] x11-libs/qt-opengl-4.4.2  USE="qt3support -debug -pch" 0 kB
[ebuild  N    ] x11-libs/qt-svg-4.4.2  USE="-debug -pch" 0 kB
[ebuild  N    ] x11-libs/qt-assistant-4.4.2-r1  USE="webkit -debug -pch" 0 kB
[ebuild     U ] x11-libs/qt-4.4.2 [4.3.3] USE="dbus opengl qt3support (-accessibility%*) (-cups%*) (-debug%) (-doc%) (-examples%) (-firebird%) (-gif%*) (-glib%) (-jpeg%*) (-mng%) (-mysql%*) (-nas%) (-nis%) (-odbc%) (-pch%) (-png%*) (-postgres%) (-sqlite%*) (-sqlite3%*) (-ssl%*) (-tiff%*) (-xinerama%) (-zlib%*)" INPUT_DEVICES="(-wacom%)" 0 kB
[blocks b     ] x11-libs/qt-core ("x11-libs/qt-core" is blocking x11-libs/qt-4.3.3)
[blocks b     ] <=x11-libs/qt-4.4.0_alpha:4 ("<=x11-libs/qt-4.4.0_alpha:4" is blocking x11-libs/qt-qt3support-4.4.2, x11-libs/qt-script-4.4.2, x11-libs/qt-dbus-4.4.2, x11-libs/qt-gui-4.4.2-r1, x11-libs/qt-xmlpatterns-4.4.2, x11-libs/qt-assistant-4.4.2-r1, x11-libs/qt-sql-4.4.2, x11-libs/qt-svg-4.4.2, x11-libs/qt-test-4.4.2, x11-libs/qt-core-4.4.2, x11-libs/qt-webkit-4.4.2, x11-libs/qt-opengl-4.4.2)



i assume i need to upgrade qt from 4.3.3 tp 4.4.2 and the other problems with go +/- a revdep-reuild ?

but how ? [/quote]
_________________
join the optout - http://nhsconfidentiality.org
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Wed Jan 28, 2009 12:33 am    Post subject: Reply with quote

Actually, there's a little detail that many people miss about that upgrade:
as x11-libs/qt became a metapackage, there's no need to actually have it
- by now I think all packages depend on the actual components (qt-core,
qt-gui, etc.).
Back to top
View user's profile Send private message
Gambit89
n00b
n00b


Joined: 28 Jan 2009
Posts: 22

PostPosted: Wed Jan 28, 2009 5:42 am    Post subject: Reply with quote

I figured it out! In short, the commands that I typed are:
Code:
emerge -av --unmerge x11-libs/qt:4
revdep-rebuild -- -av
emerge -avuDNt world

And I am happily emerging world! :D I also have "<x11-libs/qt-4.4:4" in my package.mask for good measure (recommended from here, though it didn't pick up any problems on my system).

The hint for me was the mysterious, but very specific block: "<=x11-libs/qt-4.4.0_alpha:4". Output from "eix x11-libs/qt" showed that I had qt-4.3.4-r1 installed, but it was masked, along with the other qt-4.3 versions. This block had to have come from an ebuild, so to test, I ran:
Code:
grep -ri "<=x11-libs/qt-4.4.0_alpha:4" /usr/portage/

and it output results like
Code:
/usr/portage/metadata/cache/x11-libs/qt-svg-4.4.2:~x11-libs/qt-gui-4.4.2 !<=x11-libs/qt-4.4.0_alpha:4

for most, if not all, of the qt-4.4 ebuilds. It seemed that qt-4.3 is "blocked" twice, once in package.mask, and another time in the qt-4.4 ebuilds! In retrospect, this is probably because the portage maintainers *really* wanted us to upgrade! So I ran the first command to unmerge qt-4.3 (hint from here), but this more likely than not broke something, so I did a revdep-rebuild right after. Even though I didn't explicitly emerge qt-4.4, the revdep-rebuild would pick it up as a dependency and emerge it. As a result, the last command, emerge world, won't have any qt-4.4 related packages in its list, as the revdep-rebuild already emerged them.

Be sure to do the revdep-rebuild, as it'll pick up those packages depending on qt-4 that aren't in the emerge world list. I also didn't have to mess with my qt-3.3.8b-r1 install during all this, but YMMV. Good luck. :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum