Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
swap not working
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc
View previous topic :: View next topic  
Author Message
dayul
Apprentice
Apprentice


Joined: 02 Jun 2004
Posts: 180
Location: Blackpool, England

PostPosted: Wed Jun 02, 2004 6:18 pm    Post subject: swap not working Reply with quote

hi, i have recently installed gentoo on a Sparcstation 5 with 178MB of RAM and two 1GB disks.
the system has installed successfully, however i cannot get the swap partition to work.

my partitions are as follows:

/dev/sda1 = ext2
/dev/sda2 = swap (swap takes up roughly 256MB)
/dev/sdb1 = ext2

i have checked my fstab against the install guide and it appears to be correct (i have installed on x86 machines before with no problems).

the problem does not appear to be with the partition but with the swapon command in general.
whenever i run swapon i get the message:

swapon /dev/sda2: cannot allocate memory

i modified the localmount init script to output to a file (by default it redirects to /dev/null) and received the same message, there is a problem with the swapon command at boot.

i have tried searching the forums but have not managed to find anything. the system runs ok without the swap, except for the fact that modules cannot be loaded by modprobe/insmod (they also produce the error about memory, i think likely due to there being no swap).
i would also like to put X on the system, but would like to fix this problem first, as i think X may have problems running with no swap partition.

i also read an item on how to create a swap file. again this gave me the error message (in both cases i did an mkswap before swapon, with no errors)

has anyone else experienced this? any help would be much appreciated,

thanks,

d
Back to top
View user's profile Send private message
moocha
Watchman
Watchman


Joined: 21 Oct 2003
Posts: 5722
Location: Cluj-Napoca, Romania

PostPosted: Wed Jun 02, 2004 9:52 pm    Post subject: Reply with quote

https://forums.gentoo.org/viewtopic.php?t=177837
_________________
Military Commissions Act of 2006: http://tinyurl.com/jrcto

"Those who would give up essential liberty to purchase a little temporary safety deserve neither liberty nor safety."
-- attributed to Benjamin Franklin
Back to top
View user's profile Send private message
dayul
Apprentice
Apprentice


Joined: 02 Jun 2004
Posts: 180
Location: Blackpool, England

PostPosted: Wed Jun 02, 2004 10:06 pm    Post subject: Reply with quote

thanks moocha, i will give the deleting and recreating of the partition a try tomorrow,

regards

D
Back to top
View user's profile Send private message
dayul
Apprentice
Apprentice


Joined: 02 Jun 2004
Posts: 180
Location: Blackpool, England

PostPosted: Wed Jun 02, 2004 10:09 pm    Post subject: Reply with quote

actually another point i forgot to add is that swapon works fine for the partition when running the command from the livecd, so im not sure if the problem is the same as the link that was posted.

i will still give it a try however
Back to top
View user's profile Send private message
moocha
Watchman
Watchman


Joined: 21 Oct 2003
Posts: 5722
Location: Cluj-Napoca, Romania

PostPosted: Thu Jun 03, 2004 2:22 am    Post subject: Reply with quote

Uh, although this may sound silly - have you compiled swap support into the kernel? Some kernel patchsets allow you to select swap (aka anonymous memory mapped blahblah) - and maybe you turned it off.
_________________
Military Commissions Act of 2006: http://tinyurl.com/jrcto

"Those who would give up essential liberty to purchase a little temporary safety deserve neither liberty nor safety."
-- attributed to Benjamin Franklin
Back to top
View user's profile Send private message
dayul
Apprentice
Apprentice


Joined: 02 Jun 2004
Posts: 180
Location: Blackpool, England

PostPosted: Thu Jun 03, 2004 10:39 am    Post subject: Reply with quote

Thanks for the suggestion, but i cannot find any option for swap in my kernel configuration. I am currently using sparc-sources-2.4.26 from portage.

I did a grep on the config file, and the only other thing i could see was that at the top CONFIG_HIGHMEM was set to Y.

Would vanilla-sources be a better option? I was about to try that to see if there were any additional options concerning swap, unfortunately it will be a while to get back on this one as the kernel takes ~4 hours to compile.
Back to top
View user's profile Send private message
moocha
Watchman
Watchman


Joined: 21 Oct 2003
Posts: 5722
Location: Cluj-Napoca, Romania

PostPosted: Thu Jun 03, 2004 12:15 pm    Post subject: Reply with quote

Yes... For now, trying another kernel is the only thing that may give further clues :(
_________________
Military Commissions Act of 2006: http://tinyurl.com/jrcto

"Those who would give up essential liberty to purchase a little temporary safety deserve neither liberty nor safety."
-- attributed to Benjamin Franklin
Back to top
View user's profile Send private message
dayul
Apprentice
Apprentice


Joined: 02 Jun 2004
Posts: 180
Location: Blackpool, England

PostPosted: Tue Jun 15, 2004 9:39 am    Post subject: Reply with quote

sorry for the late reply, my disk got corrupted and i decided to start again.
decided to go for a stage 1 install this time (hence it taking 2 weeks), have emerged vanilla-sources this time and it works perfectly now; maybe it was something with gentoo-sparc-sources that was causing the problem.

any way thanks very much for all your help moocha :D
Back to top
View user's profile Send private message
moocha
Watchman
Watchman


Joined: 21 Oct 2003
Posts: 5722
Location: Cluj-Napoca, Romania

PostPosted: Tue Jun 15, 2004 10:33 am    Post subject: Reply with quote

I'm glad to hear you've got it sorted out :)
_________________
Military Commissions Act of 2006: http://tinyurl.com/jrcto

"Those who would give up essential liberty to purchase a little temporary safety deserve neither liberty nor safety."
-- attributed to Benjamin Franklin
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum