Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
2.6.7_rc2-love1 aka "Texas Shotguns of Play Doh"
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3, 4  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
OneOfOne
Guru
Guru


Joined: 28 May 2003
Posts: 368
Location: Alexandria, Egypt

PostPosted: Tue Jun 01, 2004 9:56 pm    Post subject: 2.6.7_rc2-love1 aka "Texas Shotguns of Play Doh" Reply with quote

here comes a new and enhanced love sources.
*i'll try to make a changelog next time :P*
Quote:

dmi.h-rc2-mm1.patch.bz2 | mm1 fixes
sysctl.c-rc2-mm1.patch.bz2 | mm1 fixes
sr_ioctl.c-rc2-mm1.1.patch.bz2 | mm1 fixes
sr_ioctl.c-rc2-mm1.2.patch.bz2 | mm1 fixes
perfctr.h-rc2-mm1.patch.bz2 | mm1 fixes
have-xfs-use-kernel-provided-qsort.patch.bz2 | xfs' qsort
have-xfs-use-kernel-provided-qsort-fix.patch.bz2 | xfs' qsort fix
patch-2.6.7-rc2-s5.5.bz2 | Con's staircase scheduler
2.6.7-rc2-mm1-add-nickvm.patch.bz2 | nick's vm work (replacement for auto-swappiness)
squashfs2.0-linux-2.6.6.patch.bz2 | SquashFS v2
*U* acpi-dsdt-initrd-patch-v0.5-2.6.5-eric.patch.bz2 | Custom acpi dsdt patch
subfs-genstef.bz2 | SubFS (death to supermount!)
*U* bootsplash-3.1.4-2.6.7-rc2-r2.diff.bz2 | bootsplash (send your hugs and kisses to bootsplash.de)
2.6.x-bring-up-compiler-option.patch.bz2 | extra CFLAGS hack
orinoco-cvs-20040527.patch.bz2 | updated orinoco patch
force-config_regparm-to-y.patch.bz2 | reversed for binary drivers' sake
BadRAM-2.6.5.2.patch.bz2 | a workaround bad ram
config-nr-tty-devices.patch.bz2 | for a cleaner /dev
layer7-kernelpatch-nf-0.4.0.bz2 | layer7 netfilter target
linux-2.6.4-Walken.diff.bz2 | bootlogo
love_ppm.patch.bz2 | love-sources' logo
linux-2.6.0.dxr3.20031229.diff.bz2 | DXR3
iteraid_1.44.patch.bz2 | Giga Raid
viafb_02.diff.bz2 | via framebuffer
via-v4l-1.4a-drm.patch.bz2 | via v4l stuff
patch-2.4.x-vesafb-rrc.bz2 | vesafb refresh hack
bd-claim.patch.bz2 | EVMS fix
acerhk.patch.bz2 | Acer Hotkeys
lirc-2.6.5-mm1-20040406.bz2 | new lirc patch
2110_bcm5700_broadcom_gigabit_drvr_11272003.patch | bcm5700 driver
4905_speakup_accessibility.patch | speakup patch
4720_gcloop-2.6-20040330.patch | gcloop
iriver-love1.5.patch.bz2 | iriver patch
lufs-0.9.7-2.6.0-test9.patch.bz2 | lufs
menuconfig-NAME-v1.0.patch.bz2 | name in menuconfig patch
acx100-0.2.0pre7-linux2.6.2.diff.bz2 | ACX100 Driver (upped to _pre8 by hand)
packet-2.6.5.patch.bz2 | packet cd/dvd writing
sii-3512-update.patch.bz2 | siimage patch
ipw2100-0.44 | ipw2100
mki-adapter26_1_3_5.patch.bz2 | stuff needed by win4lin
Kernel-Win4Lin3-2.6.6.patch.bz2 | Win4Lin *sigh*, why can't people use vmware?

bootsplash works
this release uses Nick's vm work instead of Con's Auto Swappiness and Con's staircase instead of nicksched (a mix, eh?)
win4lin compiles.
and again no reiser4, sorry folks.
http://oneofone.limitlessfx.com/love-sources/2.6.7-rc2-love1.bz2
http://oneofone.limitlessfx.com/love-sources/love-sources-2.6.7_rc2-r1.ebuild
http://oneofone.limitlessfx.com/love-sources/love-sources-2.6.7_rc2-r1.notes

peace


Last edited by OneOfOne on Tue Jun 01, 2004 10:29 pm; edited 1 time in total
Back to top
View user's profile Send private message
ikaro
Advocate
Advocate


Joined: 14 Jul 2003
Posts: 2526
Location: Denmark

PostPosted: Tue Jun 01, 2004 10:07 pm    Post subject: Reply with quote

whoooo , first post
_________________
linux: #232767
Back to top
View user's profile Send private message
ryceck
Apprentice
Apprentice


Joined: 13 Jan 2004
Posts: 195

PostPosted: Tue Jun 01, 2004 10:37 pm    Post subject: Reply with quote

The "No reiser4" makes me not wanna jump to this one :(
Thnx for 2.6.6-love4 I completely turned my system to reiser4 (except the / ofcourse :)) so this one is of no use...

Can it be possible btw for Swsusp2 to be included in the loves??? Tha would be groovin' :p
I myself cant seem to be able to patch the love-sources with the swsusp patch, or patch a swsusp-kernel with love-patches :(
Back to top
View user's profile Send private message
OneOfOne
Guru
Guru


Joined: 28 May 2003
Posts: 368
Location: Alexandria, Egypt

PostPosted: Tue Jun 01, 2004 10:59 pm    Post subject: Reply with quote

ryceck wrote:
The "No reiser4" makes me not wanna jump to this one :(
Thnx for 2.6.6-love4 I completely turned my system to reiser4 (except the / ofcourse :)) so this one is of no use...

Can it be possible btw for Swsusp2 to be included in the loves??? Tha would be groovin' :p
I myself cant seem to be able to patch the love-sources with the swsusp patch, or patch a swsusp-kernel with love-patches :(

i hear you :-/
i'm on reiser4 myself.
About swsup i tried before and unless they release a new patch there's no chance.

@everyone else, does it lag the sound in ut2k4? and does it take forever during init?

peace
Back to top
View user's profile Send private message
neenee
Veteran
Veteran


Joined: 20 Jul 2003
Posts: 1786

PostPosted: Tue Jun 01, 2004 11:00 pm    Post subject: Reply with quote

note about this release:

if you're an UT2004 player - please report back with any problems
with sound and this love-sources release.

my own findings are that UT2004 has terrible sound with this release;
music stops, stutters, crackles and pops... as do all the sounds in-
game.
_________________
proud to be a scout and a chronic penguin hugger
Legion of Lore - site
Back to top
View user's profile Send private message
VolcomPimp
Tux's lil' helper
Tux's lil' helper


Joined: 11 Mar 2004
Posts: 135
Location: Newark, CA

PostPosted: Tue Jun 01, 2004 11:18 pm    Post subject: Reply with quote

bah... I need reiser4 as well...
Im using 2.6.6-love4 and I have a feeling its the reason
why my bootsplash doesnt work correctly on startup.
Back to top
View user's profile Send private message
ryceck
Apprentice
Apprentice


Joined: 13 Jan 2004
Posts: 195

PostPosted: Tue Jun 01, 2004 11:22 pm    Post subject: Reply with quote

VolcomPimp wrote:
bah... I need reiser4 as well...
Im using 2.6.6-love4 and I have a feeling its the reason
why my bootsplash doesnt work correctly on startup.


I got that too (read above ^^) but dont have any probs with bootsplashes :/
Works like a charm here including FB-console and everything...
Back to top
View user's profile Send private message
kali
n00b
n00b


Joined: 30 Sep 2002
Posts: 39
Location: Rome, Italy

PostPosted: Tue Jun 01, 2004 11:43 pm    Post subject: Reply with quote

there is a reason to add bcm 5700 gigabit driver?

I am using tg3 driver of vanilla kernel with various bcm 570x cards without any problem
Back to top
View user's profile Send private message
hjlane3
Guru
Guru


Joined: 22 Feb 2003
Posts: 377
Location: Wilmington, DE USA

PostPosted: Wed Jun 02, 2004 12:07 am    Post subject: Reply with quote

still no config_hz patch :-( I need this for my laptop or it gives me an annoying hissing sound, bleh.
_________________
I wish hell would freeze over already. :-(
EDIT: w00t, it has!
Back to top
View user's profile Send private message
steel300
Veteran
Veteran


Joined: 10 Jul 2003
Posts: 1155

PostPosted: Wed Jun 02, 2004 12:28 am    Post subject: Reply with quote

hjlane3 wrote:
still no config_hz patch :-( I need this for my laptop or it gives me an annoying hissing sound, bleh.


That's not needed anymore. It's done automatically. Any problems you're having aren't related to config_hz.
_________________
Rationality is the recognition of the fact that nothing can alter the truth and nothing can take precedence over that act of perceiving it.
Back to top
View user's profile Send private message
thenapalm
n00b
n00b


Joined: 14 Jul 2003
Posts: 17

PostPosted: Wed Jun 02, 2004 3:21 am    Post subject: Reply with quote

Code:
  CC      mm/bootmem.o
  CC      mm/filemap.o
  CC      mm/mempool.o
  CC      mm/oom_kill.o
  CC      mm/fadvise.o
  CC      mm/page_alloc.o
  CC      mm/page-writeback.o
  CC      mm/pdflush.o
  CC      mm/prio_tree.o
  CC      mm/readahead.o
  CC      mm/slab.o
  CC      mm/swap.o
  CC      mm/truncate.o
  CC      mm/vmscan.o
mm/vmscan.c: In function `shrink_all_memory':
mm/vmscan.c:1196: error: `priority' undeclared (first use in this function)
mm/vmscan.c:1196: error: (Each undeclared identifier is reported only once
mm/vmscan.c:1196: error: for each function it appears in.)
make[1]: *** [mm/vmscan.o] Error 1
make: *** [mm] Error 2


Here's a new one :?
I played with it for a little bit, but couldn't find anything. Perhaps I'm just too tired and missed it.
_________________
demux_viv.c:308:2: warning: #warning "Calculate PTS from picture header!" OH NO!!!!! :o
Back to top
View user's profile Send private message
metalh34d
Tux's lil' helper
Tux's lil' helper


Joined: 04 Feb 2004
Posts: 126

PostPosted: Wed Jun 02, 2004 4:55 am    Post subject: reiser4 Reply with quote

Ah man, this kernel was sounding perfect... too good to be true. Unfortunately I run a root and home reiser4 system =(. 2.6.6-love4 has an awful memory leak in it or something because I can't keep my system running smoothly for long on it. I'd be tempted to go back to 2.6.4-ck2 except the reiser4 patch is old and does not seem to load on my system... Dark days in the kernel world... nvidia driver problems... reiser4 problems.... Every day I wait for my good ol reiser4 support. Glad to hear bootsplash is stable in this release.
Back to top
View user's profile Send private message
Kevin72594
Guru
Guru


Joined: 30 Dec 2003
Posts: 307

PostPosted: Wed Jun 02, 2004 5:13 am    Post subject: Reply with quote

I need an ebuild for love-sources 2.6.6-love4, I need reiser4 and I just had to reinstall. Sorry if I'm being stupid in not being able to find it, I've had a kinda long day reinstalling. Where is it though? I've been goin crazy!!! Thanks
Back to top
View user's profile Send private message
Kevin72594
Guru
Guru


Joined: 30 Dec 2003
Posts: 307

PostPosted: Wed Jun 02, 2004 5:32 am    Post subject: Reply with quote

Nevermind, I found one for Lokean-Sources 2.6.6-r1 that is patched with reiser4, I'll just that for now at least...thanks
Back to top
View user's profile Send private message
Sgaduuw
Tux's lil' helper
Tux's lil' helper


Joined: 17 Sep 2002
Posts: 133
Location: Rotterdam, Netherlands

PostPosted: Wed Jun 02, 2004 7:06 am    Post subject: Reply with quote

kali wrote:
there is a reason to add bcm 5700 gigabit driver?

I am using tg3 driver of vanilla kernel with various bcm 570x cards without any problem

The tg3 driver doesn't work for me unfortunately, I actually need the bcm drivers
_________________
my website
Back to top
View user's profile Send private message
zerojay
Veteran
Veteran


Joined: 09 Aug 2003
Posts: 1033

PostPosted: Wed Jun 02, 2004 7:37 am    Post subject: Reply with quote

neenee wrote:
note about this release:

if you're an UT2004 player - please report back with any problems
with sound and this love-sources release.

my own findings are that UT2004 has terrible sound with this release;
music stops, stutters, crackles and pops... as do all the sounds in-
game.


I have the exact same problem here playing music with XMMS. I use the XMMS crossfading plugin which has always worked flawlessly. In this kernel, switching songs stops the music for about a quarter of a second, enough to be a huge annoyance. Audio everywhere else occasionally pops and crackles as well. This kernel is the only variable that has changed on my system.
Back to top
View user's profile Send private message
danone
Guru
Guru


Joined: 18 Jan 2004
Posts: 398
Location: Germany

PostPosted: Wed Jun 02, 2004 7:55 am    Post subject: Reply with quote

There is a newer patch for vesafb refresh hack than the 2.4 patch

Quote:

patch-2.6.6-vesafb.patch it can be found @ Getting higher refresh rate@ orginal thread in this forum

_________________
[:: Processor: Intel Core 2 Duo E6300 ]::[ Mainboard: ASUS P5B Deluxe ]::[ GPU: nVidia 7900GTO ::]
[:: RAM: HyperX DDR2 800 ]::[ Samsung SH-183A SATA:: CREATiVE X-Fi XtremeMusic :: ]
Back to top
View user's profile Send private message
hjlane3
Guru
Guru


Joined: 22 Feb 2003
Posts: 377
Location: Wilmington, DE USA

PostPosted: Wed Jun 02, 2004 8:14 am    Post subject: Reply with quote

steel300 wrote:
hjlane3 wrote:
still no config_hz patch :-( I need this for my laptop or it gives me an annoying hissing sound, bleh.


That's not needed anymore. It's done automatically. Any problems you're having aren't related to config_hz.


What? What do you mean done automatically? All I know is, that when I have that patch applied and I change the hz to 100 I don't have my problem.
_________________
I wish hell would freeze over already. :-(
EDIT: w00t, it has!
Back to top
View user's profile Send private message
PrakashP
Veteran
Veteran


Joined: 27 Oct 2003
Posts: 1246
Location: C.C.A.A., Germania

PostPosted: Wed Jun 02, 2004 8:24 am    Post subject: Reply with quote

@hjlane3

The hissing sound you are experiencing is a hardware problem: Search at lkml... Some capacitors or a like are making that sound. Another guy therfore changed his Hz to something like 10000 or alike so that hiss frequency goes beyond his hearing.
Back to top
View user's profile Send private message
fallow
Bodhisattva
Bodhisattva


Joined: 08 Jan 2004
Posts: 2206
Location: Poland

PostPosted: Wed Jun 02, 2004 9:07 am    Post subject: Reply with quote

staircase 5.5 :) in love
i love staircase hehe 8)

maybe selectable scheduler beetwen nick`s and staircase...?
i think this is good idea:)
_________________
"Time is a companion that goes with us on a journey. It reminds us to cherish each moment, because it will never come again. What we leave behind is not as important as how we have lived" J-L. Picard ;)
Back to top
View user's profile Send private message
grzewho
l33t
l33t


Joined: 31 Dec 2002
Posts: 626
Location: /home/g

PostPosted: Wed Jun 02, 2004 1:12 pm    Post subject: Reply with quote

everything works perfectly for me
_________________
Code:
USE="freedom -software_patents" emerge --deep --update world
Back to top
View user's profile Send private message
steel300
Veteran
Veteran


Joined: 10 Jul 2003
Posts: 1155

PostPosted: Wed Jun 02, 2004 1:27 pm    Post subject: Reply with quote

hjlane3 wrote:
steel300 wrote:
hjlane3 wrote:
still no config_hz patch :-( I need this for my laptop or it gives me an annoying hissing sound, bleh.


That's not needed anymore. It's done automatically. Any problems you're having aren't related to config_hz.


What? What do you mean done automatically? All I know is, that when I have that patch applied and I change the hz to 100 I don't have my problem.


It's not config_hz related. It changed the values between 1000, 512, and 100 automatically now. The noises you're hearing aren't timer related.
_________________
Rationality is the recognition of the fact that nothing can alter the truth and nothing can take precedence over that act of perceiving it.
Back to top
View user's profile Send private message
Sgaduuw
Tux's lil' helper
Tux's lil' helper


Joined: 17 Sep 2002
Posts: 133
Location: Rotterdam, Netherlands

PostPosted: Wed Jun 02, 2004 1:59 pm    Post subject: Reply with quote

this love-sources release managed to slow down my worklaptop to a crawl, simple things like "Setting up lo" took about 3 minutes to complete.

I'll experiment a bit with my kernel configs to see what the cause was.
_________________
my website
Back to top
View user's profile Send private message
silverter
Guru
Guru


Joined: 10 Apr 2002
Posts: 491
Location: Ulm, DE

PostPosted: Wed Jun 02, 2004 2:39 pm    Post subject: Reply with quote

Sgaduuw wrote:
this love-sources release managed to slow down my worklaptop to a crawl, simple things like "Setting up lo" took about 3 minutes to complete.

I'll experiment a bit with my kernel configs to see what the cause was.

Same observation over here, I really don't know what's happening...

regards,
_________________
-- A Guru was once a Beginner --


Last edited by silverter on Wed Jun 02, 2004 2:47 pm; edited 1 time in total
Back to top
View user's profile Send private message
OneOfOne
Guru
Guru


Joined: 28 May 2003
Posts: 368
Location: Alexandria, Egypt

PostPosted: Wed Jun 02, 2004 2:44 pm    Post subject: Reply with quote

silverter wrote:
Sgaduuw wrote:
this love-sources release managed to slow down my worklaptop to a crawl, simple things like "Setting up lo" took about 3 minutes to complete.

I'll experiment a bit with my kernel configs to see what the cause was.

Same observation over here, I really don't what's happening...

regards,

I blame staircase i guess.
i'm sorry about that guys, i emailed nick to send us a new scheduler, if he doesn't do it by tomorrow i'll make a new release based on v30f or something.

peace
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page 1, 2, 3, 4  Next
Page 1 of 4

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum