Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
xorg-server-1.1.1-r1 build fails
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64
View previous topic :: View next topic  
Author Message
orionbelt
Tux's lil' helper
Tux's lil' helper


Joined: 05 Apr 2006
Posts: 87
Location: Brussels, Belgium

PostPosted: Sun Oct 15, 2006 6:47 pm    Post subject: xorg-server-1.1.1-r1 build fails Reply with quote

Hello,

Building xorg-server-1.1.1-r1 on a hardened amd64 with gcc-3.4.6:

Code:
# cat /etc/make.conf
CFLAGS="-march=k8 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CXXFLAGS="${CFLAGS}"
MAKEOPTS="-j3"
USE="unicode hardened pic fam"
FEATURES="sandbox ccache distlocks parallel-fetch"

INPUT_DEVICES="keyboard mouse"
VIDEO_CARDS="fglrx"

# emerge -a x11-base/xorg-server

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] x11-base/xorg-server-1.1.1-r1  INPUT_DEVICES="-evdev*" VIDEO_CARDS="fglrx* -apm* -ark* -chips* -cirrus* -cyrix* -dummy* -fbdev* -glint* -i128* -i810* -mga* -neomagic* -nv* -rendition* -s3* -s3virge* -savage* -siliconmotion* -sis* -sisusb* -tdfx* -tga* -trident* -tseng* -v4l* -vesa* -vga* -via* -vmware* -voodoo*"


fails as follows:

Code:
x86_64-pc-linux-gnu-gcc -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -fno-strict-aliasing -D_BSD_SOURCE -DHAS_FCHOWN -DHAS_STICKY_DIR_BIT -I../../../../include -I../../../../include -I../../../../Xext -I../../../../composite -I../../../../damageext -I../../../../xfixes -I../../../../Xi -I../../../../mi -I../../../../miext/shadow -I../../../../miext/damage -I../../../../render -I../../../../randr -I../../../../fb -march=k8 -O2 -pipe -Wl,-z -Wl,lazy -o gtf gtf-gtf.o  -lm
/usr/lib/gcc/x86_64-pc-linux-gnu/3.4.6/../../../../x86_64-pc-linux-gnu/bin/ld: gtf-gtf.o: relocation R_X86_64_32 against `a local symbol' can not be used when making a shared object; recompile with -fPIC
gtf-gtf.o: could not read symbols: Bad value


Is this a problem with the ebuild as suggested in section 3.f here:

http://www.gentoo.org/proj/en/base/amd64/howtos/index.xml?part=1&chap=3#doc_chap6

or could i be doing something wrong?

Code:
# emerge --info
Portage 2.1.1-r1 (default-linux/amd64/2005.1, gcc-3.4.6, glibc-2.3.6-r4, 2.6.17-gentoo-r8 x86_64)
=================================================================
System uname: 2.6.17-gentoo-r8 x86_64 AMD Opteron(tm) Processor 248
Gentoo Base System version 1.12.5
Last Sync: Sun, 15 Oct 2006 17:20:01 +0000
ccache version 2.3 [enabled]
app-admin/eselect-compiler: [Not Present]
dev-java/java-config: 1.3.7, 2.0.30
dev-lang/python:     2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.3
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.13-r4
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=k8 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-march=k8 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache distlocks metadata-transfer parallel-fetch sandbox sfperms strict"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="amd64 X alsa berkdb bitmap-fonts cli crypt cups dlloader dri eds elibc_glibc emboss encode fam foomaticdb fortran gif gnome gpm gstreamer gtk gtk2 hardened imlib input_devices_keyboard input_devices_mouse ipv6 isdnlog jpeg kde kernel_linux linguas_el linguas_en linguas_fr lzw lzw-tiff mp3 mpeg ncurses nls opengl pam pcre perl pic png pppd python qt3 qt4 quicktime readline reflection sdl session spell spl ssl tcpd tiff truetype-fonts type1-fonts unicode usb userland_GNU video_cards_fglrx xorg xpm xv zlib"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Back to top
View user's profile Send private message
whig
l33t
l33t


Joined: 27 Nov 2004
Posts: 970
Location: New Zealand

PostPosted: Sun Oct 15, 2006 8:56 pm    Post subject: Reply with quote

Your base system is old. Upgrade to gentoo 2006.1, you might have to go via 2006.0 here. It could be simplier and easier to reinstall from a 2006.1 image.
Back to top
View user's profile Send private message
orionbelt
Tux's lil' helper
Tux's lil' helper


Joined: 05 Apr 2006
Posts: 87
Location: Brussels, Belgium

PostPosted: Sun Oct 15, 2006 9:03 pm    Post subject: Reply with quote

Thanks for the response.

Could you perhaps spell out what exactly is it that is old with my base system?

I've been keeping up with all package updates except the switch to gcc 4, which i understand is not mandatory at this point.

I think it's legitimate to not want to undertake such a major task unless there are some very good reasons...
Back to top
View user's profile Send private message
whig
l33t
l33t


Joined: 27 Nov 2004
Posts: 970
Location: New Zealand

PostPosted: Mon Oct 16, 2006 2:50 am    Post subject: Reply with quote

Code:
# emerge --info
Portage 2.1.1-r1 (default-linux/amd64/2005.1, gcc-3.4.6, glibc-2.3.6-r4, 2.6.17-gentoo-r8 x86_64)

You are on gentoo 2005.1, that's unsupported now. See http://www.gentoo.org/doc/en/gentoo-upgrading.xml
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64 All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum