Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Eclipse start-up error
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc
View previous topic :: View next topic  
Author Message
petrasl
n00b
n00b


Joined: 18 May 2004
Posts: 66
Location: Swiss

PostPosted: Mon May 24, 2004 12:26 pm    Post subject: Eclipse start-up error Reply with quote

Hello!
I just emerged Eclipse 2.1.2-r1 on a sunblade...

When I run eclipse (or eclipse-motif), an error occured, notified with the typical message
Quote:
Problem during start-up. Check the ".log" file in the ".metadata" directory of your workspace

This is the .log file :
Code:

!SESSION ----------------------------------------------------------------------
!ENTRY org.eclipse.core.launcher 4 0 May 24, 2004 14:04:36.321
!MESSAGE Exception launching the Eclipse Platform:
!STACK
java.lang.reflect.InvocationTargetException
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:324)
        at org.eclipse.core.launcher.Main.basicRun(Main.java:291)
        at org.eclipse.core.launcher.Main.run(Main.java:747)
        at org.eclipse.core.launcher.Main.main(Main.java:583)
Caused by: java.lang.reflect.InvocationTargetException
        at org.eclipse.core.internal.boot.InternalBootLoader.run(InternalBootLoader.java:861)
        at org.eclipse.core.boot.BootLoader.run(BootLoader.java:461)
        ... 7 more
Caused by: java.lang.UnsatisfiedLinkError: no swt-pi-gtk-2135 in java.library.path
        at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1403)
        at java.lang.Runtime.loadLibrary0(Runtime.java:788)
        at java.lang.System.loadLibrary(System.java:832)
        at org.eclipse.swt.internal.Library.loadLibrary(Library.java:108)
        at org.eclipse.swt.internal.gtk.OS.<clinit>(OS.java:19)
        at org.eclipse.swt.widgets.Display.createDisplay(Display.java:482)
        at org.eclipse.swt.widgets.Display.create(Display.java:469)
        at org.eclipse.swt.graphics.Device.<init>(Device.java:111)
        at org.eclipse.swt.widgets.Display.<init>(Display.java:303)
        at org.eclipse.swt.widgets.Display.<init>(Display.java:299)
        at org.eclipse.ui.internal.Workbench.run(Workbench.java:1361)
        at org.eclipse.core.internal.boot.InternalBootLoader.run(InternalBootLoader.java:858)
        ... 8 more


This is my java-config -L output :
Quote:
[blackdown-jre-1.4.1] "Blackdown JRE 1.4.1" (/etc/env.d/java/20blackdown-jre-1.4.1) *
[blackdown-jdk-1.4.1] "Blackdown JDK 1.4.1" (/etc/env.d/java/20blackdown-jdk-1.4.1)
Back to top
View user's profile Send private message
Ferris
Retired Dev
Retired Dev


Joined: 13 Jan 2003
Posts: 426
Location: N. Virginia (USA)

PostPosted: Mon May 24, 2004 6:09 pm    Post subject: Reply with quote

I have made eclipse work on sparc linux, but not with this ebuild. It was pretty messy, and I am somewhat surprised
the ebuild does as well as it does, unless the eclipse maintainers have access to a sparc system.

The problem you are seeing is doubtless related to the shared libraries (that is, to their not
being built, not in the right place, being the solaris versions, or similar.)

Please submit a bug report describing just what you have reported here, please copy me on it
(fmccor@gentoo.org) because I am writing you this note.
Back to top
View user's profile Send private message
Ferris
Retired Dev
Retired Dev


Joined: 13 Jan 2003
Posts: 426
Location: N. Virginia (USA)

PostPosted: Wed May 26, 2004 11:41 pm    Post subject: Reply with quote

Thanks to karltk, the cvs version of eclipse-sdk-2.1.3-r3 seems to build, install, and run correctly. At least, it gets beyond the start-up error and gives you the correct eclipse GUI.

After your next 'emerge sync', please look at the ebuild for dev-utll/eclipse-sdk-2.1.3-r3, and if has the '~sparc' keyword, please try it in place of 2.1.2-r1.

Please report back how it works for you. Report either on this forum or as a comment to bug
https://bugs.gentoo.org/show_bug.cgi?id=52048

Thanks,
Ferris
Back to top
View user's profile Send private message
petrasl
n00b
n00b


Joined: 18 May 2004
Posts: 66
Location: Swiss

PostPosted: Fri May 28, 2004 1:48 pm    Post subject: Reply with quote

I just remplaced the 2.1.2-r1 with the eclipse-sdk-2.1.3-r3 :

I run eclipse and everythink is fine.

Thanks!

luca.
Back to top
View user's profile Send private message
Ferris
Retired Dev
Retired Dev


Joined: 13 Jan 2003
Posts: 426
Location: N. Virginia (USA)

PostPosted: Fri May 28, 2004 7:48 pm    Post subject: Reply with quote

Thank you for the report and for the feedback. I've passed it on to karltk.
Back to top
View user's profile Send private message
ThorstenHirsch
Tux's lil' helper
Tux's lil' helper


Joined: 25 Sep 2003
Posts: 111

PostPosted: Fri Jul 01, 2005 12:07 pm    Post subject: Reply with quote

I see that the latest version that I can emerge on my sparc is still eclipse 2.1.
What about eclipse 3.0 or 3.1? I'd like to check out the perl plugin for eclipse and it needs at least eclipse 3.0. :(
Back to top
View user's profile Send private message
gust4voz
Retired Dev
Retired Dev


Joined: 09 Sep 2003
Posts: 373
Location: Buenos Aires, Argentina

PostPosted: Fri Jul 01, 2005 12:50 pm    Post subject: Reply with quote

Eclipse 3.0+ requires java 1.4.2 and at the moment the latest available on linux/sparc is 1.4.1.
_________________
Gustavo Zacarias
Gentoo/SPARC monkey
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum