Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Tip for installing on Alpha
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures
View previous topic :: View next topic  
Author Message

Joined: 28 Aug 2003
Posts: 4

PostPosted: Fri May 14, 2004 1:58 pm    Post subject: Tip for installing on Alpha Reply with quote

I've just finished installing Gentoo on an Compaq Alpha ES40 and found and worked around a problem with during the bootstrap from stage1 to stage2; I thought I'd share this workaround with any other Gentoo Alpha users. (Of course, I will fully admit that I might have done something wrong which caused the problems with the bootstrap...)

First, I started with the most recent (at the time) LiveCD for Alpha:
gentoo-alpha-2004.0-20040313.iso. This booted fine, detected all of my hardware -- a perfect start. I then worked through the install docs (which, by the way, are the best by far of any Linux distro I've used; docs for many OpenSource projects usually -- with all considerable due respect for the developers -- suck, but gentoo seems to be an exception). I used the stage1 tarball that seemed to go with the LiveCD I was using: stage1-alpha-20040313.tar.bz2. However, part way through the bootstrap process, the installation died with lots of errors about a missing /dev/null. At first I thought something weird had happened and that my root partition had been corrupted, so I started over from scratch: I encountered the same problem with this second attempt.

Examination of the stage1-alpha-20040313.tar.bz2 tarball shows that it does not contain /dev.

I searched around and found the experimental stage1 tarball: stage1-alpha-1.4-r1.tbz2, released last autumn. This tarball contained /dev, but crashed with what looked like source errors early in the bootstrap process (apologies: I did not take note of what the errors were).

In the end I used both tarballs: I started from scratch again and, when I got to the point in the installation when I was supposed to extract the stage1 tarball, I first extracted the experimental tarball (stage1-alpha-1.4-r1.tbz2 - the one with a viable /dev but broken otherwise) and then I extracted the more up-to-date tarball (stage1-alpha-20040313.tar.bz2 - no /dev). The bootstrap process completed without a hitch after that.

Hope this is helpful.
#include <cunning_sig.h>
Back to top
View user's profile Send private message

Joined: 26 Jun 2004
Posts: 13
Location: Ft. Lauderdale, FL

PostPosted: Sat Jun 26, 2004 9:48 pm    Post subject: Reply with quote


After untaring the stage* tarball then do

> touch /mnt/gentoo/dev/null

It worked for me.

Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum