Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problema a correr Mozilla Firefox :cry:
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
neon_pipe
n00b
n00b


Joined: 30 Mar 2004
Posts: 24

PostPosted: Tue May 11, 2004 10:30 pm    Post subject: Problema a correr Mozilla Firefox :cry: Reply with quote

fiz emerge do firefox e do firefox-bin (não percebi a diferença!)

mas continuo com este erro:

    quando estou em user é este o erro:
      Code:
       
      (Gecko:2821): Gtk-WARNING **: Unable to locate theme engine in module_path: "thinice",
       
      (Gecko:2821): Gtk-WARNING **: Unable to locate theme engine in module_path: "redmond95",
       
      (Gecko:2821): Gtk-WARNING **: Unable to locate theme engine in module_path: "redmond95",
    e o firefox não liga.


quando estou em root o firefox liga mas não consigo ver os videos de por exemplo esta pagina:nao sei se é por estar em wma se é prob do firefox.

HELP!!! PLEASE!!! 8O 8O 8O 8O 8O 8O 8O
Back to top
View user's profile Send private message
vmc
n00b
n00b


Joined: 30 Mar 2004
Posts: 29
Location: Leiria - PT

PostPosted: Tue May 11, 2004 10:57 pm    Post subject: Re: Problema a correr Mozilla Firefox :cry: Reply with quote

neon_pipe wrote:
fiz emerge do firefox e do firefox-bin (não percebi a diferença!)


O primeiro (emerge mozilla-firefox) instala-te o firefox a partir do código fonte (download das sources + processo de compilação que poderá demorar algum tempo).

O segundo, instala-te o binário (como não compila é mais rápido a instalar mas não fará uso das tuas CFLAGs...)

neon_pipe wrote:

mas continuo com este erro:

    quando estou em user é este o erro:
      Code:
       
      (Gecko:2821): Gtk-WARNING **: Unable to locate theme engine in module_path: "thinice",
       
      (Gecko:2821): Gtk-WARNING **: Unable to locate theme engine in module_path: "redmond95",
       
      (Gecko:2821): Gtk-WARNING **: Unable to locate theme engine in module_path: "redmond95",
    e o firefox não liga.



Apenas um warning. Não devia ser um impeditivo para correr o firefox. De qq forma experimenta fazer o emerge do engine redmond95
Code:

emerge gtk-engines-redmond95


neon_pipe wrote:

quando estou em root o firefox liga mas não consigo ver os videos de por exemplo esta pagina:nao sei se é por estar em wma se é prob do firefox.


Para veres ficheiros wmv instala o xine (apesar dos codecs instalados nem sempre funcionarem bem). De qq forma o problema está na propria página que é IE only. Um pequeno excerto do código HTML dessa página:
Quote:
OBJECT ID="Player" width="320" height="253"
CLASSID="CLSID:6BF52A52-394A-11d3-B153-00C04F79FAA6">
<param name="URL" value="http://infop.cidadevirtual.pt/surftotal/video13.wmv">
<param name="rate" value="1">



No windows com o firefox tb não conseguirias ver o filme (i.e. se utilizares o firefox tal como foi instalado). Uma forma de veres os filmes é efectuar o download dos mesmos e visualizá-los através do xine.

Espero ter ajudado...
_________________
Full-working gentoo installation on Toshiba Satellite M30 - 204
[Centrino 1.6 + nVidia Fx 5200 64MB]
Back to top
View user's profile Send private message
neon_pipe
n00b
n00b


Joined: 30 Mar 2004
Posts: 24

PostPosted: Tue May 11, 2004 11:40 pm    Post subject: Reply with quote

Obrigado,

agora so me dá este warning
Code:

(Gecko:6566): Gtk-WARNING **: Unable to locate theme engine in module_path: "thinice",


tentei fazer o emerge do gtk-engines-thinice mas nao dá.

e continua sem correr sem ser em modo root
ele apenas mostra o warning e depois volta para a prompt, não percebo?????
:?
Back to top
View user's profile Send private message
vmc
n00b
n00b


Joined: 30 Mar 2004
Posts: 29
Location: Leiria - PT

PostPosted: Wed May 12, 2004 1:52 am    Post subject: Reply with quote

neon_pipe wrote:

agora so me dá este warning
Code:

(Gecko:6566): Gtk-WARNING **: Unable to locate theme engine in module_path: "thinice",


tentei fazer o emerge do gtk-engines-thinice mas nao dá.


Estranho... O ebuild está na pasta do portage (/usr/portage/x11-themes). Portanto, o seguinte emerge deveria funcionar:
Code:
emerge gtk-engines-thinice


neon_pipe wrote:

e continua sem correr sem ser em modo root
ele apenas mostra o warning e depois volta para a prompt, não percebo?????
:?


Experimenta executar o firefox com o caminho completo (o problema pode estar no script de lançamento). Qualquer coisa do tipo:
Code:
/opt/firefox/firefox-bin


Acho mt estranho teres efectuado o emerge do bin e da source dado que um bloqueia o outro e vice-versa. Eu apenas instalei as sources e não precisei de instalar o gtk-engines-redmond95/thinice.

Se nada disto funcionar e tiveres tempo sugiro que desinstales e voltes a instalar (e desta vez a partir das fontes):
Code:
emerge --unmerge mozilla-firefox-bin
emerge --unmerge mozilla-firefox
emerge mozilla-firefox


Depois diz-me se funcionou ou não...
_________________
Full-working gentoo installation on Toshiba Satellite M30 - 204
[Centrino 1.6 + nVidia Fx 5200 64MB]
Back to top
View user's profile Send private message
neon_pipe
n00b
n00b


Joined: 30 Mar 2004
Posts: 24

PostPosted: Wed May 12, 2004 9:38 am    Post subject: Reply with quote

vmc wrote:
neon_pipe wrote:

agora so me dá este warning
Code:

(Gecko:6566): Gtk-WARNING **: Unable to locate theme engine in module_path: "thinice",


tentei fazer o emerge do gtk-engines-thinice mas nao dá.


Estranho... O ebuild está na pasta do portage (/usr/portage/x11-themes). Portanto, o seguinte emerge deveria funcionar:
Code:
emerge gtk-engines-thinice




eu consigo fazer o emerge, de resto já o fiz mas continua com o erro

quanto ao novo caminho
Code:
/opt/firefox/firefox-bin

funciona!!! :) só não percebo qual é o problema com o antigo (visto que funciona em root)
Code:
/usr/bin/firefox


MUITO OBRIGADO
Back to top
View user's profile Send private message
vmc
n00b
n00b


Joined: 30 Mar 2004
Posts: 29
Location: Leiria - PT

PostPosted: Wed May 12, 2004 3:24 pm    Post subject: Reply with quote

Então está confirmado que o problema está no script (/usr/bin/firefox). Quando tiveres tempo sugiro que faças o unmerge do mozilla-firefox-bin e o emerge do mozilla-firefox.

Se tivesse feito o emerge do binário poderia dar-te mais alguma ajuda...mas como instalei a partir das sources não faço a mínima ideia do erro que o script possa conter.

Procura nos fórums porque penso que o teu caso não é um caso isolado.
_________________
Full-working gentoo installation on Toshiba Satellite M30 - 204
[Centrino 1.6 + nVidia Fx 5200 64MB]
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum