Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KDE missing from session list
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Thoreau
n00b
n00b


Joined: 29 Apr 2004
Posts: 38

PostPosted: Mon May 17, 2004 2:02 pm    Post subject: KDE missing from session list Reply with quote

So I loged out of gnome, after upgrading to 2.6, and i found that my KDE was no longer on the sessions list. So i thought..meh, okay i'll re-emerge KDE, no big deal. That still didn't work. It didn't emerge anything, it took about 5 minutes and then it was done. Any hints? I have my USE flags to include "qt kde" Thanks for your help :)
Back to top
View user's profile Send private message
Stormy Eyes
Veteran
Veteran


Joined: 09 Apr 2003
Posts: 1064
Location: Watching God spit-shine my boots.

PostPosted: Mon May 17, 2004 2:10 pm    Post subject: Reply with quote

You're barking up the wrong tree. The GDM included with GNOME 2.6 places its session files in a different place, and uses a different format for session files. If you're willing to wait until I go home for lunch, I'll post more detailed information.
Back to top
View user's profile Send private message
Thoreau
n00b
n00b


Joined: 29 Apr 2004
Posts: 38

PostPosted: Mon May 17, 2004 2:40 pm    Post subject: Reply with quote

yeah i'm willing to wait. I get paid by the hour ;)
Back to top
View user's profile Send private message
Stormy Eyes
Veteran
Veteran


Joined: 09 Apr 2003
Posts: 1064
Location: Watching God spit-shine my boots.

PostPosted: Mon May 17, 2004 4:04 pm    Post subject: Reply with quote

OK, here's the info you need. First, GDM for GNOME 2.6 keeps session files in /usr/share/xsessions. When you change to that directory, open up gnome.desktop in less. You'll see something similar to this:

Code:
[Desktop Entry]
Encoding=UTF-8
Name=GNOME
Comment=This session logs you into GNOME
Exec=gnome-session
TryExec=gnome-session
# no icon yet, only the top three are currently used
Icon=
Type=Application


So, with this in mind, you want to create similar .desktop file for KDE. Do the following:

Code:
nano -w /usr/share/xsessions/kde.desktop


Insert the following text:

Code:
[Desktop Entry]
Encoding=UTF-8
Name=KDE
Comment=This session logs you into KDE
Exec=startkde
TryExec=startkde
# no icon yet, only the top three are currently used
Icon=
Type=Application


Then save the file, restart GDM with /etc/init.d/xdm restart, and you should be able to login to KDE now. Hope this helps.
Back to top
View user's profile Send private message
Thoreau
n00b
n00b


Joined: 29 Apr 2004
Posts: 38

PostPosted: Tue May 18, 2004 5:16 pm    Post subject: Reply with quote

that doesn't work either. My gnome.desktop is filled with (what looks like to me)different lang support???. It's pretty long, but i'll post it anywho.
Code:

[Desktop Entry]
Encoding=UTF-8
Name=GNOME
Name[az]=GNOME
Name[be]=GNOME
Name[ca]=GNOME
Name[cs]=GNOME
Name[cy]=GNOME
Name[da]=Gnome
Name[de]=GNOME
Name[el]=GNOME
Name[es]=GNOME
Name[et]=GNOME
Name[fi]=Gnome
Name[fr]=GNOME
Name[he]=GNOME
Name[hi]=गनोम
Name[hu]=GNOME
Name[it]=GNOME
Name[ja]=GNOME
Name[ko]=그놈
Name[lt]=GNOME
Name[mn]=ГНОМЕ
Name[ms]=GNOME
Name[nl]=GNOME
Name[nn]=GNOME
Name[no]=GNOME
Name[pl]=GNOME
Name[pt]=GNOME
Name[pt_BR]=GNOME
Name[ro]=GNOME
Name[ru]=GNOME
Name[sk]=GNOME
Name[sl]=GNOME
Name[sq]=GNOME
Name[sr]=Гном
Name[sr@Latn]=Gnom
Name[sv]=GNOME
Name[tr]=GNOME
Name[uk]=GNOME
Name[vi]=GNOME
Name[wa]=GNOME
Name[zh_CN]=GNOME
Name[zh_TW]=GNOME
Comment=This session logs you into GNOME
Comment[az]=Bu iclas sizi GNOME'a daxil edəcək
Comment[be]=Гэтая сэсыя завядзе вас у GNOME
Comment[ca]=Aquesta sessió entra en GNOME
Comment[cs]=Toto sezení vás přihlásí do GNOME
Comment[cy]=Mae'r sesiwn hwn yn eich mewngofnodi i GNOME
Comment[da]=Denne session logger dig på Gnome
Comment[de]=Diese Sitzung meldet Sie an GNOME an
Comment[el]=Αυτή η συνεδρία σας εισάγει στο GNOME
Comment[es]=Con esta sesión accede a GNOME
Comment[fi]=Tämä istunto kirjaa sisään Gnomeen
Comment[fr]=Cette session vous connectera dans GNOME
Comment[he]=תצורת הפעלה זו מחברת אותך ל GNOME
Comment[hi]=यह सत्र गनोम में लॉगिन होगा
Comment[hu]=Ez a környezet a GNOME-ba jelentkeztet be
Comment[it]=Sessione di lavoro con GNOME
Comment[ja]=GNOME セッションにログインします
Comment[ko]=GNOME세션으로 로그인합니다
Comment[lt]=Ši sesija prijungia Jus į GNOME
Comment[mn]=Энэ суултаар та ГНОМЕ руу нэвтрэнэ.
Comment[ms]=Sesi ini akan log anda  ke GNOME
Comment[nl]=Deze sessie meldt u aan bij GNOME
Comment[nn]=Denne økta loggar på GNOME
Comment[no]=Denne sesjonen logger deg inn til GNOME
Comment[pl]=Sesja logowania do GNOME
Comment[pt]=Esta sessão inicia-o no GNOME
Comment[pt_BR]=Logar no ambiente GNOME
Comment[ro]=Această sesiune vă va loga în GNOME
Comment[ru]=Начать сеанс GNOME
Comment[sk]=Toto sedenie vás prihlási do prostredia GNOME
Comment[sl]=Ta seja vas prijavi v GNOMe
Comment[sq]=Kjo seancë do t'ju fusë në GNOME
Comment[sr]=Ова сесија вас пријављује на Гнома
Comment[sr@Latn]=Ova sesija vas prijavljuje na Gnoma
Comment[sv]=Denna session loggar in dig i GNOME
Comment[tr]=Bu oturum ile GNOME'a giriş yaparsınız
Comment[uk]=Сеанс роботи в середовищі GNOME
Comment[vi]=Session này cho bạn đăng nhập vào GNOME
Comment[zh_CN]=此会话使您登录到 GNOME
Comment[zh_TW]=選取這個作業階段後會進入 GNOME 環境
Exec=gnome-session
TryExec=gnome-session
# no icon yet, only the top three are currently used
Icon=
Type=Application


can i just get rid of the other langs?? since i'm only going to use this in English??

here's my xmd config

Code:

#!/sbin/runscript
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
# $Header: /home/cvsroot/gentoo-x86/x11-base/xfree/files/4.3.0/xdm.start,v 1.4 2004/03/06 04:20:10 vapier Exp $

# This is here to serve as a note to myself, and future developers.
#
# Any Display manager (gdm,kdm,xdm) have the following problem:  if
# it is started before any getty, and no vt is specified, it will
# usually run on vt2.  When the getty on vt2 then starts, and the
# DM is already started, the getty will take control of the keyboard,
# leaving us with a "dead" keyboard.
#
# Resolution: add the following line to /etc/inittab
#
#  x:a:once:/etc/X11/startDM.sh
#
# and have /etc/X11/startDM.sh start the DM in daemon mode if
# a lock is present (with the info of what DM should be started),
# else just fall through.
#
# How this basically works, is the "a" runlevel is a additional
# runlevel that you can use to fork processes with init, but the
# runlevel never gets changed to this runlevel.  Along with the "a"
# runlevel, the "once" key word means that startDM.sh will only be
# run when we specify it to run, thus eliminating respawning
# startDM.sh when "xdm" is not added to the default runleve, as was
# done previously.
#
# This script then just calls "tellinit a", and init will run
# /etc/X11/startDM.sh after the current runlevel completes (this
# script should only be added to the actual runlevel the user is
# using).
#
# Martin Schlemmer
# aka Azarah
# 04 March 2002


# Start X Font Server before X
depend() {
   use xfs hotplug
}

setup_dm() {
   source /etc/profile.env
   export PATH="/bin:/sbin:/usr/bin:/usr/sbin:${ROOTPATH}"

   case "$(echo ${DISPLAYMANAGER} | awk '{ print toupper($1) }')" in
      KDM|KDE|KDE2|KDE3)
         EXE="$(which kdm)"
         ;;
      ENTRANCE*)
         EXE="$(which entranced)"
         ;;
      GDM|GNOME)
         EXE=/usr/bin/gdm
         ;;
      WDM)
         EXE=/usr/bin/wdm
         ;;      
      *)
         EXE=/usr/X11R6/bin/xdm
         ;;
   esac

   test ! -x "${EXE}" && EXE=/usr/X11R6/bin/xdm

   SERVICE="${EXE##*/}"
}

start() {
   setup_dm
   
   ebegin "Setting up ${SERVICE}"
   #save the prefered DM
   save_options "service" "${EXE}"
   #tell init to run /etc/X11/startDM.sh after current
   #runlevel is finished (should *not* be in the "boot"
   #                      runlevel).
   /sbin/telinit a &>/dev/null
   eend 0
}

stop() {
   local retval=0
   local curvt="$(fgconsole)"
   local myexe="$(get_options "service")"
   local myservice="${myexe##*/}"
   
   ebegin "Stopping ${myservice}"
   rm -f ${svcdir}/options/xdm/service
   
   if [ "$(ps -A | grep -e "${myservice}")" ]
   then
      start-stop-daemon --stop --quiet \
         --exe ${myexe} &>/dev/null
      
      retval=$?
   else
      retval=1
   fi
   
   #switch back to original vt
   chvt "${curvt}" &>/dev/null
   eend ${retval} "Error stopping ${myservice}."
   
   return ${retval}
}


# vim:ts=4


D'oh! here's my kde.desktop also
Code:

[Desktop Entry]
Encoding=UTF-8
Name=KDE
Comment=This session logs you into KDE
Exec=startkde
TryExec=startkde
# no icon yet, only the top three are currently used
Icon=
Type=Application
Back to top
View user's profile Send private message
Stormy Eyes
Veteran
Veteran


Joined: 09 Apr 2003
Posts: 1064
Location: Watching God spit-shine my boots.

PostPosted: Tue May 18, 2004 5:52 pm    Post subject: Reply with quote

Thoreau wrote:
that doesn't work either. My gnome.desktop is filled with (what looks like to me)different lang support???. It's pretty long, but i'll post it anyhow. can i just get rid of the other langs?? since i'm only going to use this in English??


Yes, you can. I didn't paste in the i18n stuff because it wasn't relevant.

Thoreau wrote:
here's my xdm config


xdm config? Are you using GDM or not?

Thoreau wrote:
D'oh! here's my kde.desktop also


That kde.desktop should have worked. You might have had to specify the exact path to startkde, but aside from that it should have worked.
Back to top
View user's profile Send private message
Thoreau
n00b
n00b


Joined: 29 Apr 2004
Posts: 38

PostPosted: Tue May 18, 2004 6:09 pm    Post subject: Reply with quote

I am using GDM here's the snipit of my rc.conf

Code:

# What display manager do you use ?  [ xdm | gdm | kdm | entrance ]
DISPLAYMANAGER="gdm"


I just followed your lead with the
Code:
 /etc/init.d/xdm restart
deal
Back to top
View user's profile Send private message
Stormy Eyes
Veteran
Veteran


Joined: 09 Apr 2003
Posts: 1064
Location: Watching God spit-shine my boots.

PostPosted: Tue May 18, 2004 6:14 pm    Post subject: Reply with quote

Thoreau wrote:
I am using GDM here's the snipit of my rc.conf


That all looks right. I wonder if I might have been wrong to put startkde in kde.desktop. At a shell prompt, type "startkde" and then hit tab; I want to know if bash tries to complete it, and how. It could be that KDE 3.2 uses startkde-3.2 instead of plain startkde, especially if you upgraded from an earlier version.
Back to top
View user's profile Send private message
Thoreau
n00b
n00b


Joined: 29 Apr 2004
Posts: 38

PostPosted: Tue May 18, 2004 6:21 pm    Post subject: Reply with quote

nope it doesn't finish it. When i hit tab i get "would you like to see all 14* possible" i hit yes. i know KDE is installed because i typed in
Code:
 startkde X11
now i'm running the KDE desktop within the Gnome desktop. :roll:

very odd
Back to top
View user's profile Send private message
Stormy Eyes
Veteran
Veteran


Joined: 09 Apr 2003
Posts: 1064
Location: Watching God spit-shine my boots.

PostPosted: Tue May 18, 2004 6:23 pm    Post subject: Reply with quote

Thoreau wrote:
nope it doesn't finish it. When i hit tab i get "would you like to see all 14* possible" i hit yes.


Would you please post the 14* possible the shell returned?
Back to top
View user's profile Send private message
Thoreau
n00b
n00b


Joined: 29 Apr 2004
Posts: 38

PostPosted: Tue May 18, 2004 6:28 pm    Post subject: Reply with quote

here you go
Code:

._cfg0000_DIR_COLORS      default                   gtk                       make.conf.example         opt                       sgml
._cfg0000_fstab           devfs.d                   gtk-2.0                   make.conf~                pam.d                     shadow
._cfg0000_gentoo-release  devfsd.conf               hostname                  make.globals              pango                     shadow-
._cfg0000_group           dhcpc                     hosts                     make.profile              paper.config              shells
._cfg0000_inputrc         dispatch-conf.conf        hotplug                   man.conf                  passwd                    skel
._cfg0000_mailer.conf     domainname                hotplug.d                 mime-magic                passwd-                   sound
._cfg0000_rc.conf         env.d                     imlib                     mime-magic.dat            profile                   ssh
._cfg0001_gentoo-release  esd                       init.d                    modprobe.conf             profile.d                 ssl
.pwd.lock                 etc-update.conf           inittab                   modprobe.conf.old         profile.env               ssmtp
DIR_COLORS                fam.conf                  inputrc                   modprobe.devfs            proftpd                   svgalib
X11                       fdprm                     ioctl.save                modprobe.devfs.old        protocols                 sysctl.conf
adjtime                   filesystems               issue                     modules.autoload.d        pwdb.conf                 syslog-ng
apm                       firestarter               issue.logo                modules.conf              rc.conf                   t1lib
bonobo-activation         fonts                     ld.so.cache               modules.conf.old          resolv.conf               terminfo
conf.d                    fstab                     ld.so.conf                modules.d                 resolv.conf.sv            updatedb.conf
cron.d                    gconf                     limits                    modules.devfs             rmt                       wget
cron.daily                gentoo-release            localtime                 mplayer.conf              rpc                       xinetd.d
cron.hourly               gimp                      login.access              mtab                      rsync                     xml
cron.monthly              gnome-vfs-2.0             login.defs                nanorc                    runlevels                 xpdfrc
cron.weekly               gnome-vfs-mime-magic      logrotate.d               networks                  samba                     yp.conf
crontab                   gpm                       lynx                      nscd.conf                 scrollkeeper.conf         yp.conf.sv
csh.cshrc                 group                     mail                      nsswitch.conf             securetty
csh.env                   group-                    mailcap                   ntp.conf                  security
csh.login                 gshadow                   mailer.conf               ntp.conf.sv               serial.conf
cups                      gshadow-                  make.conf                 openoffice                services
Back to top
View user's profile Send private message
Stormy Eyes
Veteran
Veteran


Joined: 09 Apr 2003
Posts: 1064
Location: Watching God spit-shine my boots.

PostPosted: Tue May 18, 2004 6:41 pm    Post subject: Reply with quote

Fuck me and marry me young; you shouldn't have gotten those results if you have a startkde script on your system. Since I don't use KDE, I suspect that I'm getting in over my head here. Did you try emerging KDE again?
Back to top
View user's profile Send private message
Thoreau
n00b
n00b


Joined: 29 Apr 2004
Posts: 38

PostPosted: Tue May 18, 2004 6:51 pm    Post subject: Reply with quote

yeah i did, I know it didn't emerge it all. It only took 10 minutes, compared to the 1st time i emerged it (7-8 hours)

i mean, i'm happy with Gnome, but i went to all that work to emerge KDE and can only use it within Gnome?

Thank you very much for your help!!
Back to top
View user's profile Send private message
DeadMonkey
Tux's lil' helper
Tux's lil' helper


Joined: 19 Jul 2002
Posts: 80
Location: Sitting in a Chair

PostPosted: Thu May 20, 2004 5:43 pm    Post subject: Reply with quote

Don't know if you solved this already, but:

Code:

So, with this in mind, you want to create similar .desktop file for KDE. Do the following:

Code:
nano -w /usr/share/xsessions/kde.desktop


Insert the following text:

Code:
[Desktop Entry]
Encoding=UTF-8
Name=KDE
Comment=This session logs you into KDE
Exec=startkde
TryExec=startkde
# no icon yet, only the top three are currently used
Icon=
Type=Application


Then save the file, restart GDM with /etc/init.d/xdm restart, and you should be able to login to KDE now. Hope this helps.


This works for me. The thing I had to do was make sure that the file permissions matched exactly what the permissions are of the gnome.desktop file.

Then when you get to GDM, you only need to make sure that you have a KDE entry under sessions.

Hope this helps you.
Back to top
View user's profile Send private message
fredle
n00b
n00b


Joined: 03 Mar 2004
Posts: 5
Location: Belgium

PostPosted: Sat May 22, 2004 12:14 pm    Post subject: Reply with quote

yeah, realy thx!

with litle edditing of your solution I got waimea, kahakai and enlightenment back on my list!

thx
_________________
runnin' gentoo 'cause it rules
Back to top
View user's profile Send private message
jonfr
Veteran
Veteran


Joined: 20 Jul 2003
Posts: 1006
Location: Denmark

PostPosted: Sat May 22, 2004 5:54 pm    Post subject: Reply with quote

thx for this fix :D
Back to top
View user's profile Send private message
whkinney
n00b
n00b


Joined: 03 Feb 2004
Posts: 20

PostPosted: Tue May 25, 2004 4:29 pm    Post subject: Reply with quote

This doesn't seem to work for me. I added the kde.desktop file to /usr/share/xsessions, made sure it had identical permissions to the existing gnome.desktop file (rwxr-xr-x root root), and no dice. KDE does not show up as a choice in the sessions menu.

Oddly, one user acccount on the machine, mine, starts kde successfully when I select the default session option in gdm. All other users, including root, get dumped into a failsafe session. On the one account where kde works, I am also getting notes in /var/log/messages to the effect:

May 25 12:18:53 trogdor gdmgreeter[27745]: No default session link found. Using Failsafe GNOME.

when I _stop_ kde (accompanied by a system beep), and also when I restart xdm. All of this, naturally, happened after I "upgraded" to gdm 2.4.4.7-r1. I have also tried uncommenting the following line in /etc/X11/gdm/gdm.conf, with no apparent effect:

SessionDesktopDir=/etc/X11/sessions/:/etc/X11/dm/Sessions/:/usr/share/xsessions/

Along with attempting to force the kde.desktop file to be the default:
DefaultSession=kde.desktop

Again, no apparent effect.

I do not have gnome installed on my system, just KDE. This problem exists on several machines, with different hardware and configs, all running KDE only.
Back to top
View user's profile Send private message
gringotts
n00b
n00b


Joined: 08 Apr 2004
Posts: 59

PostPosted: Tue May 25, 2004 5:05 pm    Post subject: gdm config Reply with quote

The .desktop files are to be added in '/etc/X11/dm/Sessions' dir.
There is a simple custom.desktop file to be copied and edited:
(following is an example for kde.desktop)
Name=KDE
Exec=/usr/kde/3.2/bin/startkde

Hope this will help
Back to top
View user's profile Send private message
whkinney
n00b
n00b


Joined: 03 Feb 2004
Posts: 20

PostPosted: Tue May 25, 2004 9:26 pm    Post subject: Reply with quote

gringotts wrote:
> The .desktop files are to be added in '/etc/X11/dm/Sessions' dir.
[...etc...]

Thanks. This worked for me: KDE appeared in my sessions menu, and I was able to log into a KDE session just fine. It did not, however, fix the annoying beep and accomanying "No default session link found." entry in /var/log/messages.

I might just switch to KDM and be done with it. The more Gnome advances, the more I like KDE...
Back to top
View user's profile Send private message
Becks
Tux's lil' helper
Tux's lil' helper


Joined: 06 Dec 2002
Posts: 90

PostPosted: Thu Jun 03, 2004 8:04 am    Post subject: Reply with quote

whkinney wrote:

I might just switch to KDM and be done with it. The more Gnome advances, the more I like KDE...


Full ACK. I am also searching for my kde sessions in gdm at the moment :(

Did the following to clean the mess a bit:
moved gnome.desktop from /usr/share/xsessions to /etc/X11/dm/Sessions
removed /usr/share/xsessions
ln -s /etc/X11/dm/sessions /usr/share/xsessions
made a copy of custom.desktop in /etc/X11/dm/Sessions to kde.desktop and changed the content to
Code:

[Desktop Entry]
Encoding=UTF-8
# The names/descriptions should really be better
Name=KDE 3.2.2
Comment=This starts a KDE session
Exec=startkde
Icon=
Type=Application


Now i have my KDE back and all the skriptstuff stored in /etc where it belongs
Alex
Back to top
View user's profile Send private message
lukasa
n00b
n00b


Joined: 26 Aug 2003
Posts: 5
Location: Austria

PostPosted: Thu Jun 24, 2004 8:24 am    Post subject: Reply with quote

Don't forget to set the right permissions

0755 for .dektop-files otherwise it won't work.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum