Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Compilar gnome / pango
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
iTT
n00b
n00b


Joined: 23 Apr 2004
Posts: 70
Location: Lisboa

PostPosted: Mon May 03, 2004 8:23 pm    Post subject: Compilar gnome / pango Reply with quote

ao tentar compilar o gnome usando emerge gnome o processo para saindo com a seguinte mensagem:
Quote:

pangoft2.c: In function `pango_ft2_font_get_face':
pangoft2.c:205: error: `FC_HINT_STYLE' undeclared (first use in this function)
pangoft2.c:205: error: (Each undeclared identifier is reported only once
pangoft2.c:205: error: for each function it appears in.)
pangoft2.c:206: error: `FC_HINT_FULL' undeclared (first use in this function)
pangoft2.c:208: error: `FC_HINT_NONE' undeclared (first use in this function)
pangoft2.c:212: error: `FC_HINT_SLIGHT' undeclared (first use in this function)
pangoft2.c:213: error: `FC_HINT_MEDIUM' undeclared (first use in this function)
make[4]: *** [pangoft2.lo] Error 1
make[4]: *** Waiting for unfinished jobs....
make[4]: Leaving directory `/var/tmp/portage/pango-1.4.0/work/pango-1.4.0/pango'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/var/tmp/portage/pango-1.4.0/work/pango-1.4.0/pango'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/var/tmp/portage/pango-1.4.0/work/pango-1.4.0/pango'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/pango-1.4.0/work/pango-1.4.0'
make: *** [all] Error 2

!!! ERROR: x11-libs/pango-1.4.0 failed.
!!! Function gnome2_src_compile, Line 39, Exitcode 2
!!! compile failure


ja procurei pela internet sobre o problema e mesmo ca no forum alguem conseguiu resolver o problema da seguinte forma:
"It's the pango-1.2.2-slighthint.patch that the ebuild applies. Remove that line from the ebuild and you're golden. "

eu tentei fazer o mesmo mas nao consegui
pelo que percebi foi ir a um file na pasta build... e retirar a linha onde existia algo como pango-1.2.2-slighthint.patch tentei pelo emerge pango e nada.
voltei a verificar o file e ele estava como o original ai voltei a altera-lo e tantei compilar por ./configure, make mas aqui novamente o mesmo erro...
e acho que pode ter a ver com o pentium 4
alguem me sabe dizer como resolver o problema?
Back to top
View user's profile Send private message
fernandotcl
Veteran
Veteran


Joined: 20 Nov 2003
Posts: 1396
Location: Sao Paulo, Brazil

PostPosted: Mon May 03, 2004 8:31 pm    Post subject: Reply with quote

No bugzilla um usuário apresenta uma outra solução:

Code:
emerge -v =x11-libs/pango-1.2.5-r
emerge pango


Aparentemente é um bug, e só afeta Pentium IV... :?
Back to top
View user's profile Send private message
iTT
n00b
n00b


Joined: 23 Apr 2004
Posts: 70
Location: Lisboa

PostPosted: Mon May 03, 2004 8:40 pm    Post subject: Reply with quote

acho que falta o 1 no fim
fernandotcl wrote:

Code:
emerge -v =x11-libs/pango-1.2.5-r
emerge pango


emerge -v =x11-libs/pango-1.2.5-r1


eu tb tentei isto e tb aconteceu o mesmo....
Back to top
View user's profile Send private message
Kobal
Guru
Guru


Joined: 12 Feb 2004
Posts: 323
Location: Brasil / Brazil / Brésil / Brasilien / el Brasil

PostPosted: Mon May 03, 2004 8:49 pm    Post subject: Reply with quote

Comigo acontecia problemas de compilacao, depois que comecei usar essa CFlag nao tive mais problemas:

CFLAGS="-march=pentium3 -O3 -pipe -fomit-frame-pointer"
CXXFLAGS="-march=pentium3 -O3 -pipe -fomit-frame-pointer"


Vc pode adaptar ela a sua arquitetura, mudando so o -march

Uma outra Solucao e comentar as CFlags e compilar o pacote, como no exemplo abaixo, dessa forma nunca acontece erro.

#CFLAGS="-march=pentium3 -O3 -pipe -fomit-frame-pointer"
#CXXFLAGS="-march=pentium3 -O3 -pipe -fomit-frame-pointer"
Back to top
View user's profile Send private message
iTT
n00b
n00b


Joined: 23 Apr 2004
Posts: 70
Location: Lisboa

PostPosted: Tue May 04, 2004 4:10 pm    Post subject: Reply with quote

poix tambem nao me parece problema de CFlags....
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum