Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problema com Mouse e Teclado
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
Toguro
n00b
n00b


Joined: 01 May 2004
Posts: 2

PostPosted: Sat May 01, 2004 4:43 pm    Post subject: Problema com Mouse e Teclado Reply with quote

Quando eu dou o boot do LiveCD, o mouse e o teclado funcionam perfeitamente no modo texto e no X/GNOME.

Quando eu dou o boot do HD, o mouse não é detectado (No LiveCD aparecia: Generic serial mouse found, ou algo assim), mas funciona o teclado. Só que quando eu mudo para o X, o teclado também pára de funcionar!!!

Já tentei tudo o que me sugeriram: Mudar de Kernel, replugar o teclado e o mouse, reconfigurar o X... O Estranho é que roda corretamente do LiveCD, com o mesmo XF86Config.

Alguém sabe como me ajudar?
Uso mouse serial e teclado (ABNT2) NÃO PS/2, acho que é serial também.
_________________
The last love song on this little planet
Back to top
View user's profile Send private message
fernandotcl
Veteran
Veteran


Joined: 20 Nov 2003
Posts: 1396
Location: Sao Paulo, Brazil

PostPosted: Sat May 01, 2004 5:51 pm    Post subject: Reply with quote

Só por curiosidade, que LiveCD com X e Gnome? Bom, poste o seu XF86Config pra vermos se achamos uma solução. :wink:

EDIT: Oops, me lembrei de uma coisa, acho que para mouses seriais, o correto seria "/dev/tty0" para o dispositivo na famosa COM1, e não "/dev/mouse". Você pode tentar isso, se já não tiver feito. Ou pode tentar criar um link se for esse o problema, para não causar mais dor de cabeça:

Code:
# ln -s /dev/tty0 /dev/mouse
Back to top
View user's profile Send private message
Toguro
n00b
n00b


Joined: 01 May 2004
Posts: 2

PostPosted: Sat May 01, 2004 6:18 pm    Post subject: Reply with quote

Acho que me expressei mal :(

Eu "booteio" com o LiveCD, mas daí monto os sistemas de arquivos e chrooteio e env-updateio para o HD, daí rodo o X/Gnome do HD.
O problema não pode ser no XF86Config, porque quando o boot é executado do LiveCD, funciona perfeitamente. Uso o mesmo arquivo quando booto do HD, e não funciona.
Se o mouse fosse detectado no boot do HD, acho que ele funcionaria no X, e talvez o teclado não morresse...

fernandotcl wrote:
# ln -s /dev/tty0 /dev/mouse


Já tentei, não funcionou :(
_________________
The last love song on this little planet
Back to top
View user's profile Send private message
To
Veteran
Veteran


Joined: 12 Apr 2003
Posts: 1145
Location: Coimbra, Portugal

PostPosted: Sat May 01, 2004 8:01 pm    Post subject: Reply with quote

Vê que modulos são carregados com o live-CD e vê se tens suporte para eles quando bootas pelo disco. Já agora vê se tens o suporte para o chipset da tua board.


_________________

------------------------------------------------
Linux Gandalf 3.2.35-grsec
Gentoo Base System version 2.2
------------------------------------------------
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum