Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
cryptsetup i dysk USB
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish)
View previous topic :: View next topic  
Author Message
13Homer
Guru
Guru


Joined: 12 Jul 2005
Posts: 461

PostPosted: Sun Sep 16, 2007 6:30 pm    Post subject: cryptsetup i dysk USB Reply with quote

Korzystając z tego HOWTOOzaszyfrowałem partycję root i nie mogę teraz się do niej dostać. Tzn. z poziomu LiveDVD dostęp jest bez kłopotu, ale w czesie próby zabootowania systemu dostaję komunikat:
Code:
Command failed: Invalid argument
Kłopot jest z dostępem do partycji na dysku. Jest to dysk podłączony do portu USB, partycja widziana jest jako /dev/sda3. W ramdysku utworzyłem urządzenie sda3(8,3). Utworzyłem też urządzenia dla pozostałych partycji (hda3, hdb3, ...), ale nada komenda
Code:
 cryptsetup create root /dev/xdx3
kończy się w ten sam sposób. Mam wrażenie, że czegoś brakuje - wkompilowałem wszystkie (tak sądzę) potrzebne sterowniki w jądro. Jeśli zrobię cat na nieistniejącym urzędzeniu, np. hda3, to wywala się komunikatem, że brak takiego urządzenia, a jeśli zrobie cat sda3, to na ekran lecą śmieci, czyli coś tam jest.
Czy ktoś ma jakiś pomysł, co to może być?
_________________
Lenovo ThinkPad R61 / C2D@2.6.24 / nVidia Quatro NVS 140M / 2 GB RAM
Back to top
View user's profile Send private message
mbar
Veteran
Veteran


Joined: 19 Jan 2005
Posts: 1983
Location: Poland

PostPosted: Mon Sep 17, 2007 6:41 am    Post subject: Reply with quote

To jest znacznie lepsze i działa:
http://gentoo-wiki.com/SECURITY_System_Encryption_DM-Crypt_with_LUKS
http://gentoo-wiki.com/SECURITY_Encrypting_Root_Filesystem_with_DM-Crypt_with_LUKS
Back to top
View user's profile Send private message
13Homer
Guru
Guru


Joined: 12 Jul 2005
Posts: 461

PostPosted: Mon Sep 17, 2007 6:48 am    Post subject: Reply with quote

To wyżej tez działa, tylko u mnie czegoś brakuje. Ale skoro twierdzisz, że luks jest lepszy, to spróbuję.

EDIT::
Wreszcie się udało, a przynajmniej powiodło się startowanie systemu. W HOWTO o Luksie jest niestety kilka błędów i niedomówień. Nie wiem co to za HOWTO, które trzeba korygować, bo zawiera oczywiste błędy. Komuś z Was udało się z marszu zaszyfrowac partycję za jego pomocą?
_________________
Lenovo ThinkPad R61 / C2D@2.6.24 / nVidia Quatro NVS 140M / 2 GB RAM
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum