Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Ne sozdajutsja neskol'ko nodes
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Russian
View previous topic :: View next topic  
Author Message
EvgGad
n00b
n00b


Joined: 20 Jan 2003
Posts: 21
Location: Estonia

PostPosted: Mon Apr 26, 2004 8:51 am    Post subject: Ne sozdajutsja neskol'ko nodes Reply with quote

Недавно перестали создаваться nodes для fb0, nvidia[0-7] и nvidiactl, призапуске, после начала загрузки udev через каждую строчку выдает следующее:
open /dev/fb/0 and /dev/fb0: No such file or directory
/sbin/splash: Can't find config file '/etc/bootsplash/livecd-2004.1/config/bootsplash-.cfg'... aborting !
а затем еще и иксы отказываются стартовать т.к. нет nvidiactl, хотя модуль nvidia грузится без проблем. Случилось все както само собой, что оччень интересно, - врубаю недавно комп, а тут на тебе... Пока вылечил небольшим костылем создающим эти девайсы во время local.start, так по крайней мере иксы грузятся и картинки на всех терминалах есть :D
Помогите люди добрые, вроде работе не мешает, но всетаки както не по себе смотреть на эту лабуду :)
_________________
staY haRd, staY uP f0rEvEr!
Back to top
View user's profile Send private message
EvgGad
n00b
n00b


Joined: 20 Jan 2003
Posts: 21
Location: Estonia

PostPosted: Wed Apr 28, 2004 8:24 am    Post subject: Reply with quote

Ню-ню, как всегда, придется просить буржуев о помощи... :-/
_________________
staY haRd, staY uP f0rEvEr!
Back to top
View user's profile Send private message
POMAH007
n00b
n00b


Joined: 22 Nov 2002
Posts: 22
Location: Russia, West Siberia

PostPosted: Wed Apr 28, 2004 11:02 am    Post subject: Reply with quote

devfsd хочет, а его нет? Я на такие грабли как-то наезжал после очередного синка.
Back to top
View user's profile Send private message
EvgGad
n00b
n00b


Joined: 20 Jan 2003
Posts: 21
Location: Estonia

PostPosted: Wed Apr 28, 2004 12:56 pm    Post subject: Reply with quote

Самое интересное, что я систему ставил pure udev, так сказать :), соответственно devfsd у меня никогда и не стояло, и все работало (в смысле и fb и nvidia все создавалось)
_________________
staY haRd, staY uP f0rEvEr!
Back to top
View user's profile Send private message
icedank
Apprentice
Apprentice


Joined: 15 Apr 2004
Posts: 190

PostPosted: Wed Apr 28, 2004 2:34 pm    Post subject: Reply with quote

А смысл udev ставить? Только если поиграться. IMHO - слишком уж оно альфа...
Back to top
View user's profile Send private message
EvgGad
n00b
n00b


Joined: 20 Jan 2003
Posts: 21
Location: Estonia

PostPosted: Wed Apr 28, 2004 2:47 pm    Post subject: Reply with quote

А для чего еще дома комп? :wink:
_________________
staY haRd, staY uP f0rEvEr!
Back to top
View user's profile Send private message
@lexb
Tux's lil' helper
Tux's lil' helper


Joined: 15 Dec 2003
Posts: 79
Location: Chehov

PostPosted: Thu Apr 29, 2004 8:52 am    Post subject: Reply with quote

EvgGad wrote:
Самое интересное, что я систему ставил pure udev, так сказать :), соответственно devfsd у меня никогда и не стояло, и все работало (в смысле и fb и nvidia все создавалось)

ядро надо патчить для поддержки fb udev'ом... т.е. поддержка fb есть, но udev ее не цепляет... у меня тоже такая трабла была...
кста патч еще для ядра 2.6.3 по моему... но он леХко и на 2.6.5 накладывается...
Back to top
View user's profile Send private message
EvgGad
n00b
n00b


Joined: 20 Jan 2003
Posts: 21
Location: Estonia

PostPosted: Thu Apr 29, 2004 9:35 am    Post subject: Reply with quote

Ну блин, сколько можно говорить: _с_ядром_все_в_поряде_ ведь работало, и ноды создавались, и патчить ничего не надо - у меня gentoo-dev-sources. Произошло все после какихто манипуляций, точно не помню :roll: но не с ядром, скорее всего после обновления системы, hotplug, udev и еще чето там... =)
_________________
staY haRd, staY uP f0rEvEr!
Back to top
View user's profile Send private message
ValKov
n00b
n00b


Joined: 17 May 2003
Posts: 71
Location: Russin Federation

PostPosted: Sat May 01, 2004 4:19 am    Post subject: Reply with quote

Самые последние версии udev, hotplug и baselayout решили проблемы с nodes. Сейчас в /etc/conf.d/local.start ничего нет...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Russian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum