Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Many questions (AMD-Bug, segfaults, kernel, ...)
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message

PostPosted: Fri May 03, 2002 3:04 pm    Post subject: Many questions (AMD-Bug, segfaults, kernel, ...) Reply with quote


sorry for the not so clear topic but I'm not sure myself.
First of all I'm quite a newbie and did never compile anything
except for a kernel before. But I managed to install Debian
which was said to be difficult. I don't think so. :?

Well I read about gentoo and was really impressed. :!:
So I downloaded the stage1 image, burned it and tried
to install gentoo 1.1a.

Since then I have some questions which I hope someone
can aswer:

I have an ASUS A7V with an Duron 1,2GHz on it and
384MB (256+128) of NoName SD-RAM.

I got to the step where I wanted to compile the Kernel.
Since I chose xfs for my / I emerged the xfs-kernel.

After configuring it I tried to compile but it failed.
In this forum I found a thread where one was adviced
to turn on SMP. I did that and it worked.
But WHY :?: I don't have an SMP-Board. Why does it
only compile with SMP enabled?
(The Kernel-docs also recomend to leave it off if one
has a single processor machine).

The next question is about the "AMD-Bug".
Does it only affect the Athlon?
If it has any effect on the Duron as well:
What should I do?
During the Installation process I sometimes
got strange errors and segmentation faults.
Sometimes with many numbers in rows.
Is this to attribute to the memory or the cpu?

Next thing is: What happens if an emerge stops
because of such an error?
I read the installation guide and the portage
manual, but they assume everything goes fine :)
Sometimes I got a bit further after retrying
just the same 'emerge'.
Does emerge resume where it was interrupted?

I managed to compile and install the Kernel.
(I had to disable the "Version Information"
for the modules because I got many unresolved
symbols). I even have a running X.
Also emerging blackbox, w3m and aterm
went fine (without any error or segfault) :!:
But if I try to emerge kde it always stops.
Sometimes with a "normal" error but mostly
whit a segmentation fault.
I really need help with this because I don't
understand what's going on here.
I just bougth some "high-quality" memory
(Infineon) - hope that helps.

So ... please excuse my bad english :oops:
and thank you for any help you can give me.

Back to top

PostPosted: Fri May 03, 2002 3:09 pm    Post subject: I forgot ... Reply with quote

Hi again,

since this morning even emerge rsync stopped.
It timed out connecting to the cvs-server.
Pinging it went ok (5% loss with 50 pings).

Back to top

Joined: 26 Apr 2002
Posts: 39

PostPosted: Fri May 03, 2002 4:40 pm    Post subject: Reply with quote

Have you tried the mem=nopentium option? If it is the AMD/AGP bug, it should "fix" the problem.

You also might want to consider that one or both of your memory modules are faulty. Maybe try removing one and see if you still get the same segfaults. Might want to make sure they both run at the same speed and are properly configured under your BIOS. It shouldn't take long to determine that it is the memory if this occurs as often as it seems to.

Give the memory a look first and then try the nopentium.
Back to top
View user's profile Send private message

PostPosted: Sat May 04, 2002 9:35 pm    Post subject: Ooops ... Reply with quote


many thanks for your answer Ulot,
but now it works.

The reason why I got all this errors is really sad :(:

My Duron seems to be defective.
I just bought it 2 days ago (just for gentoo :P).
After getting all those strange problems I changed
all the ram and set the most conservative BIOS
settings I could. After it still went wrong I decided
to check the memory with memtest86.
Fortunately memtest86 also checks the cache.
I got extremely many errors when chache was
used. After I switched off the cache there still
were some, but that was the noname memory
itself. So I went back to the dealer I got the
Processor from. They didn't return that one
for an exchange but send it to AMD before
I get any money back. :roll:
So I had to by just another new one.
With this new Duron and some high-quality
memory gentoo compiles just perfectly.
(Currently I'm doing the "emerge system" :))

So ... sorry for all the confusion I may have
caused :oops: but I've installed quite many cpus
in my life but have never had one where only
the cache was defective.

For my other questions I will write a seperate

Back to top
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum