Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
æ ø og å mangler i xterm
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Scandinavian
View previous topic :: View next topic  
Author Message
koeppe
n00b
n00b


Joined: 19 Apr 2004
Posts: 9

PostPosted: Fri Apr 23, 2004 11:07 am    Post subject: æ ø og å mangler i xterm Reply with quote

Jeg kan ikke få min xterm til at skrive æ, ø og å, enten skriver den slet ikke noget eller også skriver den nogle tegn der bestem ikke var tiltænkt. Jeg har ingen problemer i mine grafiske applikationer.

I min rc.conf har jeg:
KEYMAP="us"
CONSOLEFONT="lat0-16"
CONSOLETRANSLATION="8859-15_to_uni"
Back to top
View user's profile Send private message
tln
Veteran
Veteran


Joined: 24 Sep 2003
Posts: 1502

PostPosted: Fri Apr 23, 2004 11:25 am    Post subject: Reply with quote

Se till så det står rätt i /etc/X11/XF86Config eller /etc/X11/xorg.conf beroende på vad du använder.

Code:
Option "XkbLayout"  "dk"


Vissa program som t.ex. Mutt behöver också ha rätt LC_CTYPE.
Lägg till denna rad i /etc/env.d/02locale

Code:
LC_CTYPE=dk_DK


och sen gör du en env-update


Din KEYMAP i /etc/rc.conf såg inte riktigt rätt ut heller. Ändra till den här raden istället

Code:
KEYMAP="dk-latin1
Back to top
View user's profile Send private message
koeppe
n00b
n00b


Joined: 19 Apr 2004
Posts: 9

PostPosted: Fri Apr 23, 2004 12:09 pm    Post subject: Reply with quote

Jag har prøvet de ting du forslår, og de gør ikke nogen forskel æøå mangler stadig.

Det lader til at problemet er i X. Hvis jeg ikke starter X op kan jeg fint skrive æøå...

tln wrote:

Din KEYMAP i /etc/rc.conf såg inte riktigt rätt ut heller. Ändra till den här raden istället
Code:
KEYMAP="dk-latin1


Det er ikke så smart da jeg har et engelsk keyboard.
Back to top
View user's profile Send private message
tln
Veteran
Veteran


Joined: 24 Sep 2003
Posts: 1502

PostPosted: Fri Apr 23, 2004 12:20 pm    Post subject: Reply with quote

koeppe wrote:
Jag har prøvet de ting du forslår, og de gør ikke nogen forskel æøå mangler stadig

tln wrote:

Din KEYMAP i /etc/rc.conf såg inte riktigt rätt ut heller. Ändra till den här raden istället
Code:
KEYMAP="dk-latin1


Det er ikke så smart da jeg har et engelsk keyboard.


Förutom att jag använder en svensk tangentbordslayout, så ser min miljö likadan ut som din.

Är du säker på att teckensnittet du använder i xterm har stöd för æøå?
Back to top
View user's profile Send private message
koeppe
n00b
n00b


Joined: 19 Apr 2004
Posts: 9

PostPosted: Fri Apr 23, 2004 12:45 pm    Post subject: Reply with quote

tln wrote:

Är du säker på att teckensnittet du använder i xterm har stöd för æøå?


Ja, næste. Det er kun i min terminal jeg har problemer med æøå. Når jeg skriver direkte i terminalen kommer der ingen tegn, men hvis jeg køre en terminalbaseret applikation får jeg nogle meget underlige tegn. I ikke terminalbaserese app. kan jeg fint skrive æøå.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Scandinavian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum