Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
X.Org & Fonts
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
iswm
Tux's lil' helper
Tux's lil' helper


Joined: 10 Jan 2004
Posts: 139
Location: Tucson, AZ

PostPosted: Wed May 05, 2004 2:20 am    Post subject: Reply with quote

Wish it worked for me.. Even lost a 20 day uptime rebooting trying to fix this.
Back to top
View user's profile Send private message
WhO_KnOwS
Tux's lil' helper
Tux's lil' helper


Joined: 03 Oct 2003
Posts: 87
Location: Slovenia

PostPosted: Sat May 08, 2004 9:03 pm    Post subject: Reply with quote

Doesn't work for me either. I still get the ugly font on some pages in firefox. Hope this soon gets fixed.
_________________
"Does anybody know my name?" -me after a wild night
Back to top
View user's profile Send private message
CyriC
Tux's lil' helper
Tux's lil' helper


Joined: 14 Feb 2004
Posts: 117
Location: Poland, Bedzin

PostPosted: Sat May 08, 2004 9:51 pm    Post subject: Reply with quote

I have the same problem and nothing helps too
_________________

Linux Registered User: #346659
Back to top
View user's profile Send private message
CyriC
Tux's lil' helper
Tux's lil' helper


Joined: 14 Feb 2004
Posts: 117
Location: Poland, Bedzin

PostPosted: Mon May 10, 2004 12:10 am    Post subject: Reply with quote

It's strange:
When I run apps with kdesu, fonts look alright, the same is when I log to KDE as a root.
Maybe it's problem with permission, or with some user settings.
I deleted .kde directory, and tried to configure it from begining but this wasn't help.
Any sugestions ??

PS Sorry for bad english
_________________

Linux Registered User: #346659
Back to top
View user's profile Send private message
mute_dammit
n00b
n00b


Joined: 01 Jul 2003
Posts: 6

PostPosted: Tue May 11, 2004 7:00 pm    Post subject: Reply with quote

I had a similar problem; most applications looked fine, but Firebird's fonts were entirely ugly. Turns out that - somehow - my truetype fonts didn't survive the transition to xorg. The */truetype directory was still there, but had nothing inside. After some poking about (and after trying all of the suggestions in this thread) I emerged corefonts and removed the link to */TTF from my XF86Config. Now everything looks great again.
Back to top
View user's profile Send private message
Phlogiston
Veteran
Veteran


Joined: 27 Jan 2004
Posts: 1925
Location: Europe, Swizerland

PostPosted: Thu Sep 09, 2004 4:44 pm    Post subject: Reply with quote

CyriC wrote:
I have the same problem and nothing helps too


have you soved the problem?

I have also font problems... very ugly... could anybody help me...
Back to top
View user's profile Send private message
Phlogiston
Veteran
Veteran


Joined: 27 Jan 2004
Posts: 1925
Location: Europe, Swizerland

PostPosted: Thu Sep 09, 2004 4:55 pm    Post subject: Reply with quote

bengi wrote:
Wow thanks guys, deleting /usr/share/fonts/TTF and rebooting sorted out font issues for me.


yehaaaaaaaaaaa after a reboot and playing arround with some configs: it works great here :D

great thanks to all of you I'm soooo happy now

:D
Back to top
View user's profile Send private message
LostSon
Guru
Guru


Joined: 21 Nov 2003
Posts: 514
Location: Wisconsin

PostPosted: Thu Sep 09, 2004 7:33 pm    Post subject: Reply with quote

So if im reading this right i should change this

FontPath "/usr/X11R6/lib/X11/fonts/Type1/"

to

FontPath "/usr/share/fonts/Type1/"

:?:
Back to top
View user's profile Send private message
Phlogiston
Veteran
Veteran


Joined: 27 Jan 2004
Posts: 1925
Location: Europe, Swizerland

PostPosted: Fri Sep 10, 2004 1:28 pm    Post subject: Reply with quote

LostSon wrote:
So if im reading this right i should change this

FontPath "/usr/X11R6/lib/X11/fonts/Type1/"

to

FontPath "/usr/share/fonts/Type1/"

:?:


Hmm not really... what i did was:

mv -v /usr/share/fonts/TTF /tmp/TTF

and here are my working config files:

/etc/fonts/local.conf:
Code:
<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<!-- /etc/fonts/local.conf file for local customizations --><fontconfig>
<!--
  Enable sub-pixel rendering
   <match target="font">
      <edit name="rgba" mode="assign"><const>rgb</const></edit>
   </match>
   
<!-
         <match target="font">
                 <edit name="rgba" mode="assign"><const>rgb</const></edit>
         </match>
 -->
         <dir>/usr/share/fonts/corefonts/</dir>
         <dir>/usr/share/fonts/terminus/</dir>
         <dir>/usr/share/fonts/unifont/</dir>
         <dir>/usr/share/fonts/Type1/</dir>
         <dir>/usr/share/fonts/freefont/</dir>
         <dir>/usr/share/fonts/artwiz/</dir>
         <dir>/usr/share/fonts/local/</dir>
         <dir>/usr/share/fonts/misc/</dir>
         <dir>/usr/share/fonts/Speedo/</dir>
         <dir>/usr/share/fonts/CID/</dir>
         <dir>/usr/share/fonts/ttf-bitstream-vera/</dir>
         <dir>/usr/share/fonts/util/</dir>
         <dir>/usr/share/fonts/sharefont/</dir>
         <dir>/usr/share/fonts/lfp-fix/</dir>
         <dir>/usr/share/fonts/75dpi/</dir>
         <dir>/usr/share/fonts/100dpi/</dir>
   

<dir>/usr/local/share/fonts</dir>
<dir>/usr/kde/3.3/share/fonts</dir>
 </fontconfig>


and xorg.conf
Code:

...
Section "InputDevice"
   Identifier     "keyboard1"
   Driver      "kbd"
   Option      "XkbModel" "pc104"
   Option      "XkbLayout" "de_CH"
EndSection
...
       FontPath    "/usr/share/fonts"
       FontPath    "/usr/share/fonts/100dpi"
       FontPath    "/usr/share/fonts/75dpi"
        FontPath    "/usr/share/fonts/100dpi/:unscaled"
      FontPath    "/usr/share/fonts/75dpi/:unscaled"
       FontPath    "/usr/share/fonts/cyrillic"
       FontPath    "/usr/share/fonts/local"
       FontPath    "/usr/share/fonts/misc"
       FontPath    "/usr/share/fonts/Speedo"
    ###   FontPath    "/usr/share/fonts/TTF"
       FontPath    "/usr/share/fonts/Type1"
       FontPath    "/usr/share/fonts/ukr"
        FontPath   "/usr/kde/3.3/share/fonts"
   FontPath   "/usr/share/fonts/ttf-bitstream-vera/"
     FontPath   "/usr/share/fonts/terminus/"
     FontPath   "/usr/share/fonts/corefonts/"   
     FontPath   "/usr/share/fonts/freefont/"
     FontPath   "/usr/share/fonts/artwiz/"
     FontPath   "/usr/share/fonts/CID/"
     FontPath   "/usr/share/fonts/encodings/"
     FontPath   "/usr/share/fonts/util/"
     FontPath   "/usr/share/fonts/sharefont/"
     FontPath   "/usr/share/fonts/lfp-fix/"
     FontPath   "/usr/share/fonts/unifont/"



and I removed old directorys from /etc/fonts/font.conf

After a reboot, all works fine here.


Last edited by Phlogiston on Thu Sep 23, 2004 12:47 pm; edited 1 time in total
Back to top
View user's profile Send private message
Gentree
Watchman
Watchman


Joined: 01 Jul 2003
Posts: 5350
Location: France, Old Europe

PostPosted: Sat Sep 11, 2004 11:59 am    Post subject: Reply with quote

Why the knee-jerk rebooting everyone , we're not in Billville here.

Just restarting X will be enough.

HTH.
_________________
Linux, because I'd rather own a free OS than steal one that's not worth paying for.
Gentoo because I'm a masochist
AthlonXP-M on A7N8X. Portage ~x86
Back to top
View user's profile Send private message
Phlogiston
Veteran
Veteran


Joined: 27 Jan 2004
Posts: 1925
Location: Europe, Swizerland

PostPosted: Sun Sep 12, 2004 5:48 pm    Post subject: Reply with quote

Gentree wrote:
Why the knee-jerk rebooting everyone , we're not in Billville here.

Just restarting X will be enough.

HTH.


Ok... but it didn't worked in my case, I don't know why....
Back to top
View user's profile Send private message
e2k
n00b
n00b


Joined: 30 Jul 2004
Posts: 44

PostPosted: Tue Sep 14, 2004 12:44 pm    Post subject: Reply with quote

Um, don't know if this belongs here, but since I don't know what to do and it's related to xorg and fonts, I'll go for it:

I followed this tutorial (Mini-HOWTO X.org & font) and everything works pretty good, except for the fact that I can't get scands (å, ä and ö) working in eterm nor aterm. This is pretty frustrating, I speak finnish, and since I run irssi under it I just get symbols instead of the scands (other users see them as scands though). I don't know why this happened, maybe I should edit some of the font-paths to the bottom of the list in some of the configs? (I fixed a cursor-exchange with this method)
Back to top
View user's profile Send private message
makzu
n00b
n00b


Joined: 28 Jun 2004
Posts: 42

PostPosted: Tue Sep 14, 2004 9:22 pm    Post subject: Reply with quote

You say you're having problems with getting the fonts in Mozilla-based browsers? I dont' mean to toot my own horn or anything, but I've written a quick howto post in these very forums to do just that. Since "Gecko-based browsers" (including Firefox, Epiphany, Galeon, and Thunderbird) use their own font rendering system, system-wide font configuration options won't effect them at all, but these options smooth them out nicely.
_________________
'Twas brillig, and the slithy toves
Did gyre and gimble in the wabe.
All mimsey were the borogroves,
And the mome raths outgrabe.
Back to top
View user's profile Send private message
nicenpretty
n00b
n00b


Joined: 25 Oct 2004
Posts: 4

PostPosted: Mon Oct 25, 2004 3:29 pm    Post subject: Xnview problem: X Error of failed request: BadName Reply with quote

Hi there,

I have been using xnview for quite a while now but since i upgraded Xorg to 6.8 it keeps on crashing when i try to browse or view images:

X Error of failed request: BadName (named color or font does not exist)
Major opcode of failed request: 45 (X_OpenFont)
Serial number of failed request: 445
Current serial number in output stream: 597


I followed all the steps in the mini-how-to but it did not seem to work out for me.
I looked up the fonts beiing used by xnview in /etc/X11/app-defaults and they all seem to be properly installed. (using xfontsel)

But if i add my University's fontserver in xorg.conf (like: it works!!
So, is xnview then using a secretly using a font?
Why and where did that font go when upgrading xorg?

Any suggestions? I love this Programm
Back to top
View user's profile Send private message
Vann
Guru
Guru


Joined: 04 Aug 2002
Posts: 357

PostPosted: Mon Oct 25, 2004 7:26 pm    Post subject: Reply with quote

A problem for me that, for some reason, emerge xorg-x11 didn't install the corefonts package and I was using the ugly, bitmapped alternatives. So, make sure you have corefonts installed.
Back to top
View user's profile Send private message
r0ot
n00b
n00b


Joined: 25 Oct 2004
Posts: 3

PostPosted: Mon Oct 25, 2004 7:30 pm    Post subject: Reply with quote

For as long as I've been using Gentoo, emerging X has never installed the corefonts simply because the corefonts are not considered a dependency.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum