Joined: 13 Jun 2003
Location: Barcelona, Spain
|Posted: Mon Apr 19, 2004 9:36 am Post subject: [ GLSA 200404-15 ] XChat 2.0.x SOCKS5 Vulnerability
|Gentoo Linux Security Advisory
Title: XChat 2.0.x SOCKS5 Vulnerability (GLSA 200404-15)
Date: April 19, 2004
Updated: May 22, 2006
XChat is vulnerable to a stack overflow that may allow a remote attacker to run arbitrary code.
XChat is a multiplatform IRC client.
Vulnerable: < 2.0.8-r1
Unaffected: >= 2.0.8-r1
Architectures: All supported architectures
The SOCKS 5 proxy code in XChat is vulnerable to a remote exploit. Users would have to be using XChat through a SOCKS 5 server, enable SOCKS 5 traversal which is disabled by default and also connect to an attacker's custom proxy server.
This vulnerability may allow an attacker to run arbitrary code within the context of the user ID of the XChat client.
A workaround is not currently known for this issue. All users are advised to upgrade to the latest version of the affected package.
All XChat users should upgrade to the latest stable version:
Note that users of the gtk1 version of xchat (1.8.*) should upgrade to xchat-1.8.11-r1:
|# emerge sync
# emerge -pv ">=net-irc/xchat-2.0.8-r1"
# emerge ">=net-irc/xchat-2.0.8-r1"
|# emerge sync
# emerge -pv "=net-irc/xchat-1.8.11-r1"
# emerge "=net-irc/xchat-1.8.11-r1"
XChat 2.0.x SOCKS5 Vulnerability
Last edited by GLSA on Tue May 23, 2006 4:16 am; edited 2 times in total