Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
belong to wheel group, but can't su to root.
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
srain315
n00b
n00b


Joined: 22 Aug 2002
Posts: 12
Location: SoCal

PostPosted: Fri Oct 18, 2002 6:52 pm    Post subject: Similar 'su' problem Reply with quote

I have a Gentoo 1.2 box. I recently moved a bunch of stuff from disk to disk (don't ask...) and I have the same problem with su.

It worked correctly before my machinations...

Code:

bash-2.05a$ su
Password: <%rootpasswd_typed_correctly%>
su: Authentication failure
Sorry.

I re-emerged pam (0.75-r7) to no avail.

I'm wondering if it's a file permission/ownership problem, as I may have screwed something up in my file copies...

I'm also using a grsecurity-enabled (level=low) kernel.

Cheers!
_________________
Like any tool, a Corporation can be used for good or evil.
Back to top
View user's profile Send private message
borrito
n00b
n00b


Joined: 04 Jul 2002
Posts: 4
Location: Houston, TX

PostPosted: Sun Nov 03, 2002 6:14 pm    Post subject: Solution: setuid su Reply with quote

I ran into this same problem when I did a brand new install yesterday. I checked the new install against another machine with 1.2 installed and I noticed that /bin/su on the 1.2 machine had the SUID bit set, where the 1.4_rc1 /bin/su did not. I simply set the SUID bit on /bin/su

Code:
chmod +s /bin/su


and everthing worked as expected. :)
Back to top
View user's profile Send private message
pilla
Bodhisattva
Bodhisattva


Joined: 07 Aug 2002
Posts: 7716
Location: Underworld

PostPosted: Sun Nov 03, 2002 7:21 pm    Post subject: Re: Solution: setuid su Reply with quote

Looks like a bug for me. I think you should report it.

borrito wrote:
I ran into this same problem when I did a brand new install yesterday. I checked the new install against another machine with 1.2 installed and I noticed that /bin/su on the 1.2 machine had the SUID bit set, where the 1.4_rc1 /bin/su did not. I simply set the SUID bit on /bin/su

Code:
chmod +s /bin/su


and everthing worked as expected. :)
Back to top
View user's profile Send private message
torreyk
n00b
n00b


Joined: 29 Apr 2002
Posts: 12

PostPosted: Sun Nov 03, 2002 11:30 pm    Post subject: Reply with quote

I was having the same problem, getting an authentication failure. The fix in the above post: "chmod +s /bin/su" fixed it for me as well. This definitely sounds like a bug.
Back to top
View user's profile Send private message
Vlad
Apprentice
Apprentice


Joined: 09 Apr 2002
Posts: 264
Location: San Diego, California

PostPosted: Mon Nov 04, 2002 12:36 am    Post subject: Reply with quote

Had the same problem today and fixed the problem by doing a
Code:

emerge pam shadow pam-login


Having problems now trying to run KDE as a non-root user. Keeps telling me I don't have permissions to the tmp folder. Don't suppose anyone knows what the default /tmp folder permissions are?
Back to top
View user's profile Send private message
rac
Bodhisattva
Bodhisattva


Joined: 30 May 2002
Posts: 6553
Location: Japanifornia

PostPosted: Mon Nov 04, 2002 5:31 am    Post subject: Reply with quote

Vlad wrote:
Don't suppose anyone knows what the default /tmp folder permissions are?

I have 1777 root.root.
_________________
For every higher wall, there is a taller ladder
Back to top
View user's profile Send private message
ebrostig
Bodhisattva
Bodhisattva


Joined: 20 Jul 2002
Posts: 3152
Location: Orlando, Fl

PostPosted: Mon Nov 04, 2002 8:35 pm    Post subject: Reply with quote

rac wrote:
Vlad wrote:
Don't suppose anyone knows what the default /tmp folder permissions are?

I have 1777 root.root.


I posted the solution to this issue with su a couple of months ago to a similar question. I guess nobody bothered to update the sticky su thread with information pointing to my posting. It would have saved this thread since the solution was exactly the same, wrong permission on /bin/su.

Oh well...
Erik
Back to top
View user's profile Send private message
masseya
Bodhisattva
Bodhisattva


Joined: 17 Apr 2002
Posts: 2602
Location: Baltimore, MD

PostPosted: Mon Nov 04, 2002 8:45 pm    Post subject: Reply with quote

There are many things that would save extraneous threads from being posted, but they still occur. You can read about several hundred of them in the Duplicates forum if you wish. If you think you have found a solution to something that will be or is a very commonly asked question you are more than welcome to PM a moderator and ask them nicely to make your thread sticky so others will be more likely to see it.
_________________
if i never try anything, i never learn anything..
if i never take a risk, i stay where i am..
Back to top
View user's profile Send private message
pilla
Bodhisattva
Bodhisattva


Joined: 07 Aug 2002
Posts: 7716
Location: Underworld

PostPosted: Mon Nov 04, 2002 10:00 pm    Post subject: Reply with quote

Sometimes, it is just the case of searching a little bit better before asking the question. I think that we may make the point for some threads to be sticky, but if all important threads get sticky, we won't have space for new threads in the first page 8)

Usually, when I have a feeling of deja-vu, I make a search and point the older thread. But I am quite busy these weeks, you know...

So, keep searching -- I'd post this in the Forums Feedback, but it won't make sense if it was not a reply to Tristam29 post, I guess.

Tristam29 wrote:
There are many things that would save extraneous threads from being posted, but they still occur. You can read about several hundred of them in the Duplicates forum if you wish. If you think you have found a solution to something that will be or is a very commonly asked question you are more than welcome to PM a moderator and ask them nicely to make your thread sticky so others will be more likely to see it.
Back to top
View user's profile Send private message
rac
Bodhisattva
Bodhisattva


Joined: 30 May 2002
Posts: 6553
Location: Japanifornia

PostPosted: Mon Nov 04, 2002 10:43 pm    Post subject: Reply with quote

ebrostig wrote:
I posted the solution to this issue with su a couple of months ago to a similar question.

I gave you credit for it, if that's the problem.

Quote:
I guess nobody bothered to update the sticky su thread with information pointing to my posting.

At the time I first referenced your solution, it was only the second time I had seen it come up.
_________________
For every higher wall, there is a taller ladder
Back to top
View user's profile Send private message
ebrostig
Bodhisattva
Bodhisattva


Joined: 20 Jul 2002
Posts: 3152
Location: Orlando, Fl

PostPosted: Tue Nov 05, 2002 11:42 pm    Post subject: Reply with quote

rac wrote:
ebrostig wrote:
I posted the solution to this issue with su a couple of months ago to a similar question.

I gave you credit for it, if that's the problem.

Quote:
I guess nobody bothered to update the sticky su thread with information pointing to my posting.

At the time I first referenced your solution, it was only the second time I had seen it come up.

Lol, rac, I'm not after credit, I couldn't care less :)
I just wanted the poor guy to be able to su to root. One of the things that are often overlooked is the permission on certain executables. I work with a system that is very "nazi" about the permission on our main executable and I have seen some rather interesting errors based on it.

I apologize to everyone if I came across somewhat of a bitch :)

Erik
Back to top
View user's profile Send private message
rac
Bodhisattva
Bodhisattva


Joined: 30 May 2002
Posts: 6553
Location: Japanifornia

PostPosted: Tue Nov 05, 2002 11:47 pm    Post subject: Reply with quote

ebrostig wrote:
I apologize to everyone if I came across somewhat of a bitch :)

No worries, I was probably being too defensive - something about the "guess nobody bothered" just rubbed me the wrong way.
_________________
For every higher wall, there is a taller ladder
Back to top
View user's profile Send private message
tjolson
n00b
n00b


Joined: 08 Nov 2002
Posts: 4

PostPosted: Sat Nov 30, 2002 3:35 am    Post subject: Fixed my not being able to su to root Reply with quote

For what it's worth:

I added my id to the wheel group, created an /etc/suauth file with the proper entry, and could not su to root. My problem appears to have been my editing the /etc/group file by hand, because although I saw the entry in the file, "groups" did not report me as being part of the "wheel" group. When I added myself to the wheel group with usermod, all was well.

:roll:
Back to top
View user's profile Send private message
McManus
Apprentice
Apprentice


Joined: 10 Apr 2002
Posts: 176
Location: Austin, TX

PostPosted: Sun Dec 01, 2002 10:35 pm    Post subject: Reply with quote

It's been awhile, I suppose I should post my end result... turns out the CD I burned didn't come out quite perfectly :) I did an MD5SUM on the downloaded ISO, no probs, but the CD somehow didn't quite come outta the oven perfectly, go fig. Since it wasn't just 'su' that was giving me problems (X was as well), I figured I should try to reburn it, and whala, it all works.

If you just downloaded and burned the CD and installed and have this problem, one possible solution is to retry downloading and burning the ISO again :)

(this will be especially useful when 1.4 'officially' comes out, and the masses go out and download the ISO... chances are, SOME people with have bad burns or bad d/l's :D )
_________________
McManus
----
Linux user #267375 - http://counter.li.org
Back to top
View user's profile Send private message
c0ns0le
n00b
n00b


Joined: 07 Aug 2002
Posts: 8
Location: my chair

PostPosted: Tue Dec 03, 2002 8:23 pm    Post subject: This issue is resolved now.. Reply with quote

if you are still having trouble w/ this please feel free to email me or msg me

email: root@micr0s0ftsux.com
ymsg: bow4iamthebofh@yahoo.com
ymsg2: bow4iamtheroot@yahoo.com
icq: 11646412
msn: BoW4IamTheBOFH@hotmail.com
aim: BoW4IamTheROOT
_________________
ô¿ô Linux,
Bringing The World To a Brave New Front
THE RIGHT ONE
Back to top
View user's profile Send private message
bigsmoke
Tux's lil' helper
Tux's lil' helper


Joined: 09 Aug 2003
Posts: 92
Location: The city of Groningen in The Netherlands

PostPosted: Tue Mar 02, 2004 3:35 pm    Post subject: Reply with quote

rac wrote:
"newgrp -" should be sufficient if you don't want to log out.


Nice tip :!: Although I haven't had any problems with su, I've always been struck by the uglyness of having to re-login as a user after I add the user to some new group. 8)
_________________
Gentoo's kind community
has build up an immunity
for the kind of rash
that makes others bash(1)
the newer GNU/Linux user,
a man(1) that is inapt
to flawlessly adapt,
and therefore called a luser.
Back to top
View user's profile Send private message
MrBlc
n00b
n00b


Joined: 16 Mar 2004
Posts: 30

PostPosted: Wed Mar 31, 2004 5:46 pm    Post subject: Reply with quote

i would just like to say thanks to borrito for the solution.. that was what did it for me...

keep up the good work :)

-mrblc
Back to top
View user's profile Send private message
DeathAndTaxes
Tux's lil' helper
Tux's lil' helper


Joined: 27 Mar 2003
Posts: 124

PostPosted: Tue Jun 15, 2004 5:34 am    Post subject: Re: Solution: setuid su Reply with quote

borrito wrote:
I ran into this same problem when I did a brand new install yesterday. I checked the new install against another machine with 1.2 installed and I noticed that /bin/su on the 1.2 machine had the SUID bit set, where the 1.4_rc1 /bin/su did not. I simply set the SUID bit on /bin/su

Code:
chmod +s /bin/su


and everthing worked as expected. :)


Same here, I accidentally did a chown -R common_user in the wrong place (/, if you really have to know), and I guess the suid bit got b0rked. I knew it was something simple, and I'm glad once again for these forums. ;-)
Back to top
View user's profile Send private message
raid517
l33t
l33t


Joined: 06 Mar 2003
Posts: 946

PostPosted: Mon Aug 02, 2004 4:34 am    Post subject: Reply with quote

Hi I had a very similar issue - and I found this section very helpful. It certainly worked for me - although I'm not sure which part, as it may have been a combination of several of the suggestions that were made.

However now that I can su as a user I have found that several of the applications I installed as root (specifically in this instance Firefox and Thunderbird) will not launch in user mode any more. I don't know if it is just these two applications or if it is a general trend, but the console output if I try to run them from a console is:

Code:
/usr/lib/MozillaFirefox/mozilla-xremote-client: Error: Failed to find a running server.
No running windows found


The question is, what's going on? They ran fine before I came here and followed these instructions. What exatly are they telling me?

GJ
Back to top
View user's profile Send private message
raid517
l33t
l33t


Joined: 06 Mar 2003
Posts: 946

PostPosted: Sat Nov 20, 2004 2:25 am    Post subject: Reply with quote

Just in case anyone is still watching this topic or does a search and finds it, I found the answer to this after a recent reinstall.

This whole thing is about keyboard locals in KDE (and possibly Gnome?).

To prove this you should try quitting X and attempt to log in at a console as a user.

Before doing this though, attempt to write out your password so you can actually see what you are typing. Make sure it is being typed out correctly and you haven't got the wrong local set at your prompt too.

You should be able to log in normally, providing you follow the install instructions for setting your keyboard and local.

Now try to log in to whatever account is giving you trouble (it might be root, or it might be a user account, depending on the password you use) via kdm or gdm. Again check that your password is being typed out correctly, as it seems (in particular) kdm might have it's own keyboard and localization files set independently of the konsole and KDE itself. (Try for example typing your password in your username field first). Now log into KDE using your correct password and user name. Now open a console and try to log in as su. Again first check you password is being typed correctly before doing this.

Fixing this in KDE is easy, just open Kcontrol and set your keyboard and local. I haven't though figured out yet how to fix this in KDM so if anyone can tell me how to do this, please feel free. But essentially that is where the fault lay - for me at least. Kind of dumb I know - but when KDE started I'm pretty sure I did choose my correct localization, but for some weird reason it just didn't stick. I just never thought about it much again afterwards.

GJ
Back to top
View user's profile Send private message
GetLinux
Apprentice
Apprentice


Joined: 09 Nov 2005
Posts: 249
Location: USA

PostPosted: Wed Nov 09, 2005 9:26 am    Post subject: Reply with quote

HogRider wrote:
"Computers are like air conditioners, they stop working properly if you open Windows"
That is the best signature I have ever read!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum