Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200404-05 ] ipsec-tools contains an X.509 certificates vulnerability.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Moderator
Moderator


Joined: 13 Jun 2003
Posts: 4087
Location: Dresden, Germany

PostPosted: Wed Apr 07, 2004 3:09 pm    Post subject: [ GLSA 200404-05 ] ipsec-tools contains an X.509 certificate Reply with quote

Gentoo Linux Security Advisory

Title: ipsec-tools contains an X.509 certificates vulnerability. (GLSA 200404-05)
Severity: high
Exploitable: remote
Date: April 07, 2004
Bug(s): #47013
ID: 200404-05

Synopsis

ipsec-tools contains a vulnerability that affects connections authenticated with X.509 certificates.

Background

From http://ipsec-tools.sourceforge.net/ :"IPsec-Tools is a port of KAME's IPsec utilities to the Linux-2.6 IPsec implementation."

Affected Packages

Package: net-firewall/ipsec-tools
Vulnerable: <= 0.2.4
Unaffected: >= 0.2.5
Architectures: amd64


Description

racoon (a utility in the ipsec-tools package) does not verify digital signatures on Phase1 packets. This means that anybody holding the correct X.509 certificate would be able to establish a connection, even if they did not have the corresponding private key.

Impact

Since digital signatures are not verified by the racoon tool, an attacker may be able to connect to the VPN gateway and/or execute a man-in-the-middle attack.

Workaround

A workaround is not currently known for this issue. All users are advised to upgrade to the latest version of the affected package.

Resolution

ipsec-tools users should upgrade to version 0.2.5 or later:
Code:
# emerge sync
# emerge -pv ">=net-firewall/ipsec-tools-0.2.5"
# emerge ">=net-firewall/ipsec-tools-0.2.5"


Last edited by GLSA on Sun May 07, 2006 4:50 pm; edited 1 time in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum