Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Bootstrap da sempre erro de compilação [SOLVED]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
baldeante
Guru
Guru


Joined: 17 Jan 2004
Posts: 498
Location: Caldas da Rainha, Portugal

PostPosted: Mon Mar 29, 2004 5:31 pm    Post subject: Bootstrap da sempre erro de compilação [SOLVED] Reply with quote

O bootstrap falha sempre no pacote que antecede o gettext os pacotes necessarios são :

Code:

emerge --pretend gettext

[Build N ]sys-devel/patch-2.5.9
[Build N ]sys-devel/gettext-0.12.1


No boootstrap tenho sempre como resultado :

! ERROR: sys-devel/patch-2.5.9 failed
! Function src_compile, Line 23, Exitcode 2
! emake failed

Assim que inicia a instalação da patch tenho o seguinte erro :
Code:

configure : WARNING: if you wanted to set the --build type, don't use --host.
If a cross compiler is detected then cross compile mode will be used.


Eu nao defeni nada de host ou hostname, que erro é este ???
Tendo em conta o numero de vezes que ja reiniciei a instalação se houvesse alguma falha ja a teria encontrado, ou sera que me escapou alguma coisa ????


Estou a tentar fazer uma instalação atraves to stage 1 com os seguintes parametros no make.conf

Code:

USE="x86 3dnow mmx sse apm dga svga aalib mozilla samba X kde arts imagemagick gtk truetype unicode xml xml2 xmms zlib readline spell pdflib"

CHOST="i586-pc-linux-gnu"
CFLAGS="-o2 -march=pentium-mmx -fomit-frame-pointer -fforce-addr -pipe"

CXXFLAGS="${CFLAGS}"

MAKEOPTS="-j2"
AUTOCLEAN="YES"
RSYNC_RETRIES="10"



Acho que por mais que eu reduza o numero de Flags na variavel USE vai dar no mesmo tendo em conta que eu estou a fazer uma instalação baseada em KDE e este tambem precisa do gettext.


Alguem tem uma ideia ????

Tendo em conta que ja recomecei a instalação de raiz umas 15 vezes Já não sei que mais fazer só me falta fazer uma instalação a partir do stage3 para não ter de fazer o bootstrap.
_________________
Never Quit, Never Get Mad, Get Even


Last edited by baldeante on Mon Jun 07, 2004 7:47 pm; edited 1 time in total
Back to top
View user's profile Send private message
ikaro
Advocate
Advocate


Joined: 14 Jul 2003
Posts: 2526
Location: Denmark

PostPosted: Mon Mar 29, 2004 8:05 pm    Post subject: Reply with quote

USE="3dnow mmx sse apm dga svga aalib mozilla samba X kde arts imagemagick gtk truetype unicode xml xml2 xmms zlib readline spell pdflib"

CHOST="i586-pc-linux-gnu"
CFLAGS="-march=pentium-mmx -O2 -fomit-frame-pointer -fforce-addr -pipe"


tenta com isto.
se nao der, mete isto no /etc/make.conf
ACCEPT_KEYWORDS="~x86"

e tenta outra vez, se tb nao der, bugs.gentoo.org
:roll:
_________________
linux: #232767
Back to top
View user's profile Send private message
baldeante
Guru
Guru


Joined: 17 Jan 2004
Posts: 498
Location: Caldas da Rainha, Portugal

PostPosted: Tue Mar 30, 2004 9:03 am    Post subject: Reply with quote

ikaro wrote:
USE="3dnow mmx sse apm dga svga aalib mozilla samba X kde arts imagemagick gtk truetype unicode xml xml2 xmms zlib readline spell pdflib"

CHOST="i586-pc-linux-gnu"
CFLAGS="-march=pentium-mmx -O2 -fomit-frame-pointer -fforce-addr -pipe"


tenta com isto.
se nao der, mete isto no /etc/make.conf
ACCEPT_KEYWORDS="~x86"

e tenta outra vez, se tb nao der, bugs.gentoo.org
:roll:



Vou tentar agora com
Code:

ACCEPT_KEYWORDS="~x86"

no make.conf uma vez que tirar do USE nao deu em nada.

Obrigado pela resposta
_________________
Never Quit, Never Get Mad, Get Even
Back to top
View user's profile Send private message
baldeante
Guru
Guru


Joined: 17 Jan 2004
Posts: 498
Location: Caldas da Rainha, Portugal

PostPosted: Tue Mar 30, 2004 9:42 am    Post subject: Reply with quote

Tambem nao funcionou :cry: :cry:

Ja estive no bug report mas nao vejo nenhum email para enviar os logs por acaso nao e o email que aparece durante a instalação

bug-autoconfig@gnu.org
_________________
Never Quit, Never Get Mad, Get Even
Back to top
View user's profile Send private message
Enderson
Retired Dev
Retired Dev


Joined: 12 Nov 2003
Posts: 141
Location: Arapiraca/Maceió, AL, Brazil

PostPosted: Tue Mar 30, 2004 11:56 am    Post subject: Re: Bootstrap da sempre erro de compilação Reply with quote

baldeante wrote:
Estou a tentar fazer uma instalação atraves to stage 1 com os seguintes parametros no make.conf

Code:

USE="x86 3dnow mmx sse apm dga svga aalib mozilla samba X kde arts imagemagick gtk truetype unicode xml xml2 xmms zlib readline spell pdflib"

CHOST="i586-pc-linux-gnu"
CFLAGS="-o2 -march=pentium-mmx -fomit-frame-pointer -fforce-addr -pipe"

CXXFLAGS="${CFLAGS}"

MAKEOPTS="-j2"
AUTOCLEAN="YES"
RSYNC_RETRIES="10"



Acho que esta opção da CFLAGS -o2 que está errada, não deveria ser -O2 ?
Faz o teste.
_________________
--
Nothing to say here!
Back to top
View user's profile Send private message
baldeante
Guru
Guru


Joined: 17 Jan 2004
Posts: 498
Location: Caldas da Rainha, Portugal

PostPosted: Tue Mar 30, 2004 12:03 pm    Post subject: Re: Bootstrap da sempre erro de compilação Reply with quote

emaia wrote:
baldeante wrote:
Estou a tentar fazer uma instalação atraves to stage 1 com os seguintes parametros no make.conf

Code:

USE="x86 3dnow mmx sse apm dga svga aalib mozilla samba X kde arts imagemagick gtk truetype unicode xml xml2 xmms zlib readline spell pdflib"

CHOST="i586-pc-linux-gnu"
CFLAGS="-o2 -march=pentium-mmx -fomit-frame-pointer -fforce-addr -pipe"

CXXFLAGS="${CFLAGS}"

MAKEOPTS="-j2"
AUTOCLEAN="YES"
RSYNC_RETRIES="10"



Acho que esta opção da CFLAGS -o2 que está errada, não deveria ser -O2 ?
Faz o teste.



Acho que está certa é "-o2" letra "o" minuscula certo ???? Pelo menos acho que é isso mas não vá o diabo tece-las vou confirmar. :wink:
_________________
Never Quit, Never Get Mad, Get Even
Back to top
View user's profile Send private message
baldeante
Guru
Guru


Joined: 17 Jan 2004
Posts: 498
Location: Caldas da Rainha, Portugal

PostPosted: Tue Mar 30, 2004 2:13 pm    Post subject: Reply with quote

Tinhas razão.

Quando configurei o CFLAGS não usei a denominação "case sensitive" usei “-o2” enves de “-O2”.

Eu tinha criado um make.conf e copiei-o para uma disquete, sempre que chegava ao ponto de criar o make.conf eu simplesmente copiava-o da disquete para /etc/make.conf nunca me lembrei de verificar :oops: :oops: :oops: :oops: :oops:


Obrigado agora só tenho de esperar umas horas até o bootstrap acabar nem acredito que estou a 3 ou 4 dias de volta disto :oops: :cry: :oops: :oops:
_________________
Never Quit, Never Get Mad, Get Even
Back to top
View user's profile Send private message
ikaro
Advocate
Advocate


Joined: 14 Jul 2003
Posts: 2526
Location: Denmark

PostPosted: Tue Mar 30, 2004 4:38 pm    Post subject: Reply with quote

vai la ler o meu post outra vez.
_________________
linux: #232767
Back to top
View user's profile Send private message
baldeante
Guru
Guru


Joined: 17 Jan 2004
Posts: 498
Location: Caldas da Rainha, Portugal

PostPosted: Tue Mar 30, 2004 5:24 pm    Post subject: Reply with quote

ikaro wrote:
vai la ler o meu post outra vez.



Não tinha reparado na diferenca, como disse no post anterior nunca me lembrei do "case sensitive", se não tivessem mencionado directamente essa diferença ainda estava a martelar na mesma tecla.

Obrigado e desculpa a minha falta de atenção :oops: :oops:
_________________
Never Quit, Never Get Mad, Get Even
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum