Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
How I Got Wine Up and Running...
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64
View previous topic :: View next topic  
Author Message
abunai
n00b
n00b


Joined: 12 Apr 2004
Posts: 19

PostPosted: Fri May 21, 2004 8:33 am    Post subject: Reply with quote

ereptor wrote:
i'm not quite so good at what i'm doing so this might seem like a bad question but oh well

when i run wine i get the error
wine: error while loading shared libraries: libwine.so.1: cannot open shared object file: No such file or directory

it seems like something might be linked wrong to me but i'm not sure so any help would be welcomed


I had this same problem. I just made a sym link from /lib32 to lib. I had to do this for 2 files. Here is how I did that:

Quote:

cd /lib
ln -s /lib32/libwine.so.1 .
ln -s /lib32/libwine_unicode.so.1 .

_________________
Shuttle SN85G, LeadTek nForce 5700 Ultra 128DDR, 1GB DDR400, 120GB ATA133, AMD64 3200+
Back to top
View user's profile Send private message
Lv
Retired Dev
Retired Dev


Joined: 22 Jun 2003
Posts: 352

PostPosted: Fri May 21, 2004 10:29 am    Post subject: Reply with quote

drhirsch wrote:
i wanted winex, so i did it another way:

since multilib on gcc 3.4 currently doesn't work, i decided to install 32 bit chroot as mentioned in the amd64 technotes. if i remember right, i used a stage3 athlon xp tarball.

in the chroot i did emerge the tools neccessary to build wine (gcc, cvs and some minor stuff i don't remember right now), and got the winex source via cvs (in the gamers forum is a description how to obtain it), built and installed it and so far everything works fine.


multilib should work as of 3.4.0-r4... but it's still, as of yet, a big maybe. at the very least multilib support compiles...
Back to top
View user's profile Send private message
PredatorX
n00b
n00b


Joined: 22 May 2004
Posts: 55

PostPosted: Wed Sep 08, 2004 11:59 pm    Post subject: Reply with quote

I love you guys.
Thinking this is here for months!

FYI:
I am running a amd64 2.6.7 kernel.
I used the Fedora Core 1 rpm for wine and libungif, followed the instructions, works like a charm!

Gentoo rulez, peace for all your great help.
I will try to find some of the posts for people who tried to get this working.
Please keep this post here!
_________________
Boycot monopolists, they destroy quality and apparently emerge out of lack of moral. http://www.kmfms.com . Open Source 4 all :)
Back to top
View user's profile Send private message
penguins
n00b
n00b


Joined: 09 Sep 2004
Posts: 1

PostPosted: Thu Sep 09, 2004 4:53 am    Post subject: Reply with quote

I did everything you said.. could somebody please tell me what might be wrong with this?
Code:
bash-2.05b# wine
bash: /usr/bin/wine: cannot execute binary file

thanks
Back to top
View user's profile Send private message
crazycat
l33t
l33t


Joined: 26 Aug 2003
Posts: 838
Location: Hamburg, Germany

PostPosted: Thu Sep 09, 2004 5:47 am    Post subject: Reply with quote

looks like u dont have 32 bit emulation in kernel
Back to top
View user's profile Send private message
radagast
Apprentice
Apprentice


Joined: 20 Mar 2004
Posts: 217
Location: sydney, .au

PostPosted: Sat Sep 11, 2004 12:42 am    Post subject: Reply with quote

Tuinslak wrote:
hi, quite a stupid question,
but what do you mean with this:
Quote:
6. copy the files to the same locations with the exceptions of... from the wine tar.gz file in the /usr/lib directory the 4 libwine files, copy them to /lib32, and copy the 4 files in the /usr/lib directory from the libungif tar.gz file to /lib32



YAY!
i've waited months for someone to post something foolproof so i could complete my AMD64 ambitions.
and here it almost was... except i was stuck with Tuinslak.

the two .tar.gz archives start in your root directory... so if you extract them into a temp directory somewhere you'll find folders called etc and usr and usr/bin and usr/lib ... all the files belong in their proper locations in your filesystem.
so the binary files, wine and wineserver and wine-kthread (and everything else in that folder) all belong in /usr/bin
and the libraries, advapi32.dll.so and kernel32.dll.so and x11drv.dll.so (and everything else, all 230 of them) belong in /usr/lib/wine - except for libwine_unicode.so and libwine.so and libwine_unicode.so.1 and libwine.so.1, which go into /lib32

anyway, you get the picture. put everything where it belongs and it works like magic. everyone else knew that, of course, except me and Tuinslak, but maybe someone else is still stuck...


Last edited by radagast on Mon Sep 13, 2004 1:06 am; edited 1 time in total
Back to top
View user's profile Send private message
gian
Apprentice
Apprentice


Joined: 26 Jul 2004
Posts: 212
Location: Europe

PostPosted: Sat Sep 11, 2004 10:17 am    Post subject: which binary ? Reply with quote

might be a silly question...

but which binary should I download: athlon, 386 or 686 ? (I suppose Athlon, correct ?)
are there differences among the various versions (fedora core 1, core 2, RH8 etc....) ?
Back to top
View user's profile Send private message
Tuinslak
Tux's lil' helper
Tux's lil' helper


Joined: 26 Nov 2003
Posts: 129
Location: Belgium

PostPosted: Sun Sep 12, 2004 9:29 am    Post subject: Reply with quote

Yeah, it works for me now
I quite forgot about this
retryed, and worked like a charm
thx all ;)

mirc'ing with gentoo :P
_________________
Tuinslak
Back to top
View user's profile Send private message
LaserGuidedBunnyRabbit
Tux's lil' helper
Tux's lil' helper


Joined: 03 Oct 2003
Posts: 78
Location: Washington, USA

PostPosted: Sun Sep 12, 2004 11:37 pm    Post subject: Reply with quote

For those of you with a library problem, go root and run ldconfig, then try it again.
Back to top
View user's profile Send private message
dapsaille
Advocate
Advocate


Joined: 02 Aug 2004
Posts: 2364
Location: Paris

PostPosted: Wed Sep 22, 2004 4:04 pm    Post subject: Reply with quote

Hi all ...

i've tryed this funny solution but i've a little problem :

bash-2.05b# /usr/bin/wine
wine: creating configuration directory '/root/.wine'...
wine: Unhandled exception (thread 0009), starting debugger...
err:syslevel:_EnterSysLevel (0x55cee9e0, level 2): Holding 0x55e2a000, level 3.Expect deadlock!
err:syslevel:_EnterSysLevel (0x55cee9e0, level 2): Holding 0x55e2a000, level 3.Expect deadlock!
err:syslevel:_EnterSysLevel (0x55cee9e0, level 2): Holding 0x55e2a000, level 3.Expect deadlock!
err:syslevel:_CheckNotSysLevel Holding lock 0x55e2a000 level 3
err:seh:EXC_DefaultHandling Unhandled exception code 80000003 flags 0 addr 0x55a4541f
wine: wineprefixcreate failed while creating '/root/.wine'.
bash-2.05b# wineserver: could not save registry branch to /root/.wine-1H3DHk/system.reg : No such file or directory
wineserver: could not save registry branch to /root/.wine-1H3DHk/userdef.reg : No such file or directory
wineserver: could not save registry branch to /root/.wine-1H3DHk/user.reg : No such file or directory



hehehe so ... i've linked libraries to the right folder , i've emul lib x86 installed and ok and heuuu that's all ;o for info when i ran wine it doesn't create root/.wine ... snirff ...
Any clue ? is this wine problem or emul32 problem ? :p
Back to top
View user's profile Send private message
herbie
Guru
Guru


Joined: 09 Oct 2002
Posts: 319
Location: London UK

PostPosted: Wed Sep 22, 2004 4:59 pm    Post subject: Reply with quote

For an easier way to install wine some of you might want to try the wine-bin ebuild that I submitted to bugzilla:
https://bugs.gentoo.org/show_bug.cgi?id=63902
Back to top
View user's profile Send private message
pgolik
Tux's lil' helper
Tux's lil' helper


Joined: 24 Nov 2004
Posts: 125
Location: Warsaw, Poland

PostPosted: Thu Nov 25, 2004 9:14 am    Post subject: cups printing Reply with quote

Hi all,
I got wine to work using this method, but I can't get it to print via cups (cups printing works in GUI and in CLI with lpr). Print setup dialog in win apps shows no printers, and I'm getting errors like:

err:commdlg:PRINTDLG_ChangePrinterW DocumentProperties fails on L"Wine PostScript Driver"

The same wine setup (configs etc.) worked under 32 bit Slackware.
I tried wine binaries for Fedora, redhat and Slackware - they all give the same result.
Is it because 32bit wine cannot talk to 64bit CUPS? Is there a solution (other than chroot with full wine and cups install).
TIA
Pawel
Back to top
View user's profile Send private message
dylix
Apprentice
Apprentice


Joined: 20 Sep 2002
Posts: 261
Location: Atlanta

PostPosted: Fri Mar 25, 2005 7:38 pm    Post subject: Reply with quote

awesome! thx!:D
_________________

Rape is such a strong word, I prefer surprise sex.
http://plutonic.mine.nu/
Back to top
View user's profile Send private message
marco23
n00b
n00b


Joined: 22 Sep 2004
Posts: 9

PostPosted: Tue Apr 12, 2005 11:41 am    Post subject: Reply with quote

works fine for me :)

thx a lot
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64 All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum