Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ldap auth
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
mbjr
Guru
Guru


Joined: 17 Jan 2004
Posts: 531
Location: Budapest/Hungary

PostPosted: Fri Mar 19, 2004 12:11 pm    Post subject: ldap auth Reply with quote

Hi guys,

I'm about to give a chace to ldap and see what it can do on the auth side. To do this, I've decided to follow the gentoo ldap howto. I'm following it, and I got stuck and that's where I need your help :P

It describes to emerge openldap pam_ldap nss_ldap migrationtools, which I have merged with the following options:
Quote:

openldap-2.1.27 +berkdb +crypt -debug +gdbm -ipv6 +kerberos -odbc +perl +readline +samba +sasl -slp +ssl +tcpd
pam_ldap-167 +ssl
migrationtools-44-r1

so started to play around with the config files, slapd for first, where i have the schemas, tsl and dbinfo:
Quote:
snip----------->

include /etc/openldap/schema/core.schema
include /etc/openldap/schema/cosine.schema
include /etc/openldap/schema/inetorgperson.schema
include /etc/openldap/schema/nis.schema

<-----------snip
snip----------->

TLSCertificateFile /etc/ssl/mycerts/netsrv_cacert.pem
TLSCertificateKeyFile /etc/ssl/mycerts/netsrv_servercrt.pem
TLSCACertificateFile /etc/ssl/mycerts/netsrv_serverkey.pem

<-----------snip
snip----------->

database ldbm
suffix "dc=netsrv,dc=com"
rootdn "cn=Manager,dc=netsrv,dc=com"
rootpw {SSHA}uThrGi2W/Ri9MSnVIeYld7oO89gQLGyL
directory /var/lib/openldap-ldbm
index objectClass eq

<-----------snip


/etc/conf.d/slapd has the
OPTS="-h ldaps:// ldapi://%2fvar%2frun%2fopenldap%2fslapd.sock"
line in it, and the ldap.conf file the

BASE dc=netsrv, dc=com
URI ldaps://netsrv:636/

lines. So I'm now at the point where I'd start the slapd, which logs me the following:
Quote:
Mar 19 13:04:04 netsrv slapd[15537]: sql_select option missing
Mar 19 13:04:04 netsrv slapd[15537]: auxpropfunc error no mechanism available
Mar 19 13:04:04 netsrv slapd[15537]: _sasl_plugin_load failed on sasl_auxprop_plug_init for plugin: sql
Mar 19 13:04:04 netsrv slapd[15537]: bdb_initialize: Sleepycat Software: Berkeley DB 4.1.25: (December 19, 2002)
Mar 19 13:04:04 netsrv slapd[15537]: main: TLS init def ctx failed: -1
Mar 19 13:04:04 netsrv slapd[15537]: slapd stopped.
Mar 19 13:04:04 netsrv slapd[15537]: connections_destroy: nothing to destroy.


So it needs a plugin for ssl as sasl-auxprop-plug_init which I assume related to sasld, which I have:

cyrus-sasl-2.1.18 +gdbm +java +kerberos +ldap +mysql +pam +postgres +ssl -static

I doublechecked that the files linked in the configs are exists so what now? :-)
_________________
mb
Back to top
View user's profile Send private message
ikaro
Advocate
Advocate


Joined: 14 Jul 2003
Posts: 2526
Location: Denmark

PostPosted: Sat Mar 27, 2004 9:29 am    Post subject: Reply with quote

*bump*

Code:

postfix/smtpd[13977]: sql_select option missing
postfix/smtpd[13977]: auxpropfunc error no mechanism available
postfix/smtpd[13977]: _sasl_plugin_load failed on sasl_auxprop_plug_init for plugin: sql


im also getting tired of this waiting for a fix ...
anyone found whats wrong with this ?
:roll:
_________________
linux: #232767
Back to top
View user's profile Send private message
mbjr
Guru
Guru


Joined: 17 Jan 2004
Posts: 531
Location: Budapest/Hungary

PostPosted: Sat Mar 27, 2004 9:59 am    Post subject: Reply with quote

I didn't really have the chance to play more with it, but hopfully this weekend will help me out :-) Will post the results :-)
_________________
mb
Back to top
View user's profile Send private message
MarkG
Tux's lil' helper
Tux's lil' helper


Joined: 28 Apr 2002
Posts: 90
Location: Dorset, UK

PostPosted: Fri Apr 02, 2004 12:41 pm    Post subject: Reply with quote

Quote:

Code:


postfix/smtpd[13977]: sql_select option missing
postfix/smtpd[13977]: auxpropfunc error no mechanism available
postfix/smtpd[13977]: _sasl_plugin_load failed on sasl_auxprop_plug_init for plugin: sql


im also getting tired of this waiting for a fix ...
anyone found whats wrong with this ?


Try
Code:
USE="-mysql" emerge cyrus-sasl


It should get rid of the warning but I'd like a better fix

MarkG
Back to top
View user's profile Send private message
ikaro
Advocate
Advocate


Joined: 14 Jul 2003
Posts: 2526
Location: Denmark

PostPosted: Fri Apr 02, 2004 7:52 pm    Post subject: Reply with quote

indeed, http://www.gentoo.org/doc/en/virt-mail-howto.xml#doc_chap4
says the same thing, i guess last time i upgraded it used the mysql flag in it.
oh well .
Thanks for the reply.
:)
_________________
linux: #232767
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum