Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Portage 2.0.36 behavior question...
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
IvoryTiger
Tux's lil' helper
Tux's lil' helper


Joined: 27 Jun 2002
Posts: 132

PostPosted: Thu Sep 12, 2002 4:13 am    Post subject: Portage 2.0.36 behavior question... Reply with quote

If I do
Code:
emerge rsync
emerge -up world

These are the packages that I would merge, in order.

Calculating world dependencies ...done!


If I run this snipet
Code:
#!/bin/bash
WD=/var/cache/edb

mv ${WD}/world ${WD}/world.old
qpkg -nc -I>${WD}/world
emerge world -up
mv ${WD}/world.old ${WD}/world


I get this list of packages
Code:
[ebuild    U ] sys-apps/supersed-3.58-r2 to /
[ebuild    U ] app-text/docbook-sgml-utils-0.6.11-r2 to /
[ebuild    U ] sys-libs/libieee1284-0.2.1 to /
[ebuild    U ] net-misc/keychain-2.0.2 to /
[ebuild  N   ] sys-libs/libtermcap-compat-1.2.3 to /
[ebuild    U ] app-editors/vi-3.7-r3 to /
[ebuild    U ] sys-apps/reiserfsprogs-3.6.3 to /
[ebuild    U ] x11-libs/gtkglarea-1.99.0 to /
[ebuild  N   ] dev-perl/ExtUtils-MakeMaker-6.03 to /
[ebuild    U ] dev-perl/ExtUtils-F77-1.14 to /
[ebuild    U ] net-mail/procmail-3.22-r4 to /
[ebuild    U ] gnome-extra/mc-4.6.0_pre1 to /
[ebuild    U ] x11-libs/openmotif-2.2.2-r1 to /


Why the difference? Are these packages dependencies for other packages and therefore not listed as updates because the main package does not need updating?
_________________
--
For those about to compile...we salute you!
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 16134
Location: Colorado

PostPosted: Thu Sep 12, 2002 5:01 am    Post subject: Reply with quote

Have you read the Portage Manual?
_________________
lolgov. 'cause where we're going, you don't have civil liberties.

In Loving Memory
1787 - 2008
Back to top
View user's profile Send private message
IvoryTiger
Tux's lil' helper
Tux's lil' helper


Joined: 27 Jun 2002
Posts: 132

PostPosted: Thu Sep 12, 2002 5:31 am    Post subject: Looking more closely at the manual Reply with quote

I now understand the why and the wherefore of portage :D

It doesn't appear I've done any noticeable damage to the system using the code snipet, but I'll be much more careful in the future. Thanks for the nudge in the right direction.
_________________
--
For those about to compile...we salute you!
Back to top
View user's profile Send private message
TuxFriend
Apprentice
Apprentice


Joined: 14 Aug 2002
Posts: 151

PostPosted: Thu Sep 12, 2002 5:14 pm    Post subject: Reply with quote

IIUC, we will have "dependency-merging" soon.

TuxFriend

http://www.gentoo.org/cgi-bin/viewcvs.cgi/gentoo-src/portage/ChangeLog
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 16134
Location: Colorado

PostPosted: Thu Sep 12, 2002 7:35 pm    Post subject: Reply with quote

TuxFriend wrote:
IIUC, we will have "dependency-merging" soon.
Could you be more specific? I'm not sure I understand what you're getting at.
_________________
lolgov. 'cause where we're going, you don't have civil liberties.

In Loving Memory
1787 - 2008
Back to top
View user's profile Send private message
TuxFriend
Apprentice
Apprentice


Joined: 14 Aug 2002
Posts: 151

PostPosted: Thu Sep 12, 2002 8:23 pm    Post subject: Reply with quote

kanuslupus wrote:
Could you be more specific? I'm not sure I understand what you're getting at.


If we do an "emerge world -u", only the packages that are in the world-file will be updated. It seems that portage in CVS is able to update all installed packages (world + dependencies). We have to wait for an official release though.

TuxFriend
Back to top
View user's profile Send private message
t011
Tux's lil' helper
Tux's lil' helper


Joined: 05 Sep 2002
Posts: 102

PostPosted: Fri Sep 13, 2002 8:29 pm    Post subject: Reply with quote

TuxFriend wrote:

If we do an "emerge world -u", only the packages that are in the world-file will be updated. It seems that portage in CVS is able to update all installed packages (world + dependencies).


Reading your comment, it didn't seem quite right to me. So I went back to the portage manual and did some digging. This is what the portage manual says with regard to "World Update":

Quote:
A package is only upgraded if a newer version exists and the package is listed in the world profile or is a dependency of a package in the world profile.


Quote:

Portage also considers the dependencies of each package mentioned in the world profile and will try to upgrade the dependency to a newer version if one is available, matches the version ranges specified, and is not blocked by either the system profile or package.mask.


So I'm not really sure what you're referring to when you say that world update doesn't update dependencies. Both the manual and my experience with portage has demonstrated to me that dependencies are updated. I checked out the url you referenced and wasn't sure exactly what you were trying to show. Is it possibly this section?

Quote:

New (and currently unofficial and undocumented) "--deep" and "--selective" options that correspond to their respective create() parameters. Using "--deep" will enable "deep emerging" -- updating all deps even if the parent doesn't need updating.


I'm not sure, but this seems to be a parameter to force updating. Maybe I'm not seeing what you were alluding to, or I just don't understand.

t011
Back to top
View user's profile Send private message
TuxFriend
Apprentice
Apprentice


Joined: 14 Aug 2002
Posts: 151

PostPosted: Fri Sep 13, 2002 9:55 pm    Post subject: Reply with quote

To test it yourself run:
emerge world -up (update packages in your worldfile)

now try:
emerge -up `qpkg -I -nc` (update ALL installed packages)

You will see that the second command will return more packages that needs to be updated.

The current behaviour of emerge is that dependencies will be updated only if a corresponding package in your world-file needs to be updated. If only the dependency needs to be updated "emerge world -u" isn't going to do that.

The new emerge will be able to update dependencies even if there isn't a new version available of the package that depends on it.

TuxFriend
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum