Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HOWTO: Installing Internet Explorer 6 with wine
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, ... 10, 11, 12  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
Helper_Monkey
Tux's lil' helper
Tux's lil' helper


Joined: 22 Feb 2003
Posts: 141

PostPosted: Thu Mar 18, 2004 6:57 pm    Post subject: Reply with quote

An update to my previous post: I think i fixed it so that it will display pages instead of downloading them, and now I can go to "internet options".
But now I have another problem: I am behind a proxy, when I go into "LAN settings" I enter in my proxy settings, but I can't press ok (well, I can press ok, but nothing happens). I can hit cancel, but obviously the lan settings arn't used.

Is there any place where I can enter the settings by hand, or is there some reason why I can't hit 'ok'?

EDIT: Everything is working now.
_________________
It is a poverty to decide that a child must die so that you may live as you wish. -Mother Teresa


Last edited by Helper_Monkey on Thu Mar 18, 2004 7:17 pm; edited 1 time in total
Back to top
View user's profile Send private message
Mirrorball
Apprentice
Apprentice


Joined: 25 Apr 2003
Posts: 235
Location: Brazil

PostPosted: Thu Mar 18, 2004 7:10 pm    Post subject: Reply with quote

Helper_Monkey wrote:
EDIT: As for the legality, you are required to have a valid windows license to install and run internet explorer.


If I have an old Windows 98 license, can I run it?
And those people who bought Crossover Office? Can they run it?
Back to top
View user's profile Send private message
galay2
Apprentice
Apprentice


Joined: 02 Feb 2004
Posts: 208

PostPosted: Thu Mar 18, 2004 11:30 pm    Post subject: Reply with quote

can anyone tell me how to install ie6? Im using 20040309 and have tried both this first post method and also the second method on franks corner. Both doesnt work, I get the long error message on the first page if I use this board's method. If I follow franks' method, I get
Code:

Could not load 'SETUPX.DLL' required by 'W95INF16', error=2
Could not load 'SETUPX.DLL' required by 'W95INF16', error=2
Could not load 'SETUPX.DLL' required by 'W95INF16', error=2
Could not load 'SETUPX.DLL' required by 'W95INF16', error=2
Could not load 'SETUPX.DLL' required by 'W95INF16', error=2
Could not load 'SETUPX.DLL' required by 'W95INF16', error=2


then when I finally run iexplore.exe, there's no error message, but nothing pops up either.

Could anyone please povide a working solution. thanks
Back to top
View user's profile Send private message
BNoise
n00b
n00b


Joined: 10 Feb 2003
Posts: 53
Location: Argentina

PostPosted: Fri Mar 19, 2004 1:28 am    Post subject: USING A PROXY?? Reply with quote

I dont have direct connection to the Internet, so i have to go through an http proxy(squid without CONNECT support).

Does exist any way to do this?
Back to top
View user's profile Send private message
AgenT
Apprentice
Apprentice


Joined: 18 May 2003
Posts: 280

PostPosted: Fri Mar 19, 2004 1:29 am    Post subject: Reply with quote

Mirrorball wrote:
Helper_Monkey wrote:
EDIT: As for the legality, you are required to have a valid windows license to install and run internet explorer.


If I have an old Windows 98 license, can I run it?
And those people who bought Crossover Office? Can they run it?


This is exactly the sort of questons, in addition to the ones I raised, that I would like answered.

Crossover Office is no different than wine in terms of legality toward programs because it is the same thing in the eyes of Microsoft (except one is free and the other one is not).

I understand the valid key argument. That is, you must have a valid liscense for windows to use IE on it. But I do not see how this really holds outside of Windows (as in, Linux & Mac). Then again, you are using the windows version of IE on Linux while using the Mac version on the Mac... Also, what version of windows is valid? Windows 95? 98? XP? 2000? etc. And also, is MS even allowed such lockout of their software? If IE is free to download on their website, can it be restricted to only MS OS's? That again is strange (also notice the monopoly thing...) Again, it seems to me like what MS is saying (albeit confusingly on purpose) is that to use/upgrade IE on windows, you must be running a valid liscensed version. I find it hard to beleive that MS can legally not allow you to use a piece of free software on emulated systems. It's like Ford telling you that you can only use Ford tires if you own a Ford. Then again, this is the software industry we are talking about. Also, we should be clear that I am talking about what is legal and not legal in the USA, not in Europe where I am pretty sure this is not an issue.
Back to top
View user's profile Send private message
helmers
Guru
Guru


Joined: 16 Sep 2002
Posts: 548
Location: Oslo, Norway

PostPosted: Fri Mar 19, 2004 7:36 am    Post subject: Reply with quote

The thing is, as I understood it, that parts of IE is considered an update to the OS. Those are referred to as "OS Components". You are only allowed to install those on the OS they are designed for, which I listed in the quote.

Would an emulation of the OS count as the OS?
_________________
C is for Cookies!
Back to top
View user's profile Send private message
galay2
Apprentice
Apprentice


Joined: 02 Feb 2004
Posts: 208

PostPosted: Fri Mar 19, 2004 6:29 pm    Post subject: Reply with quote

anyone familiar with the error I posted above? Really needed to get IE6 working, anyone got it work recently?
Back to top
View user's profile Send private message
Daagar
Tux's lil' helper
Tux's lil' helper


Joined: 14 Mar 2003
Posts: 78

PostPosted: Fri Mar 19, 2004 9:33 pm    Post subject: Reply with quote

galay2 wrote:
can anyone tell me how to install ie6? Im using 20040309 and have tried both this first post method and also the second method on franks corner. Both doesnt work, I get the long error message on the first page if I use this board's method. If I follow franks' method, I get
Code:

Could not load 'SETUPX.DLL' required by 'W95INF16', error=2
Could not load 'SETUPX.DLL' required by 'W95INF16', error=2
Could not load 'SETUPX.DLL' required by 'W95INF16', error=2
Could not load 'SETUPX.DLL' required by 'W95INF16', error=2
Could not load 'SETUPX.DLL' required by 'W95INF16', error=2
Could not load 'SETUPX.DLL' required by 'W95INF16', error=2


then when I finally run iexplore.exe, there's no error message, but nothing pops up either.

Could anyone please povide a working solution. thanks


Get setupx.dll from http://www.dll-files.com and place it in your .wine/fake_windows/Windows/System directory.
Back to top
View user's profile Send private message
galay2
Apprentice
Apprentice


Joined: 02 Feb 2004
Posts: 208

PostPosted: Fri Mar 19, 2004 10:04 pm    Post subject: Reply with quote

Ok downloading setupx.dll solves the errors on dcom98, but IE still doesnt run.

I followed frank's second method word for word for about 6 times. No luck, wine iexplore.exe will just exit with no error output at all. But IE does not start. Does anyone have this working at all?? Thanks
Back to top
View user's profile Send private message
Mirrorball
Apprentice
Apprentice


Joined: 25 Apr 2003
Posts: 235
Location: Brazil

PostPosted: Fri Mar 19, 2004 10:08 pm    Post subject: Reply with quote

Have you downloaded the file system.reg? See step 11.

Last edited by Mirrorball on Fri Mar 19, 2004 10:08 pm; edited 1 time in total
Back to top
View user's profile Send private message
galay2
Apprentice
Apprentice


Joined: 02 Feb 2004
Posts: 208

PostPosted: Fri Mar 19, 2004 10:08 pm    Post subject: Reply with quote

yep and replaced the default one with it
Back to top
View user's profile Send private message
Mirrorball
Apprentice
Apprentice


Joined: 25 Apr 2003
Posts: 235
Location: Brazil

PostPosted: Fri Mar 19, 2004 10:11 pm    Post subject: Reply with quote

Is it legal if I install IE, zip the directory, and put the file available for download?
Back to top
View user's profile Send private message
galay2
Apprentice
Apprentice


Joined: 02 Feb 2004
Posts: 208

PostPosted: Fri Mar 19, 2004 10:13 pm    Post subject: Reply with quote

O please do! :(
Maybe you can distribute it privately only for now?
Back to top
View user's profile Send private message
helmers
Guru
Guru


Joined: 16 Sep 2002
Posts: 548
Location: Oslo, Norway

PostPosted: Fri Mar 19, 2004 11:52 pm    Post subject: Reply with quote

Mirrorball wrote:
Is it legal if I install IE, zip the directory, and put the file available for download?

I think it is a little bit out in the gray area. But, if you agree to remove it upon request, I think it would be okay. Because if it is legal to install IE6 with WINE, the .zip would be okay too, since all the parts in the .zip would come from the IE6 installation.
_________________
C is for Cookies!
Back to top
View user's profile Send private message
Cyrex56
n00b
n00b


Joined: 20 Mar 2004
Posts: 10

PostPosted: Sat Mar 20, 2004 6:24 pm    Post subject: Reply with quote

Ok i got it installed with no errors however when i run it.. rather than opening up the file.. it wants to download them..... like it wants to download http://www.google.com/index.html or http://www.msn.com/index.asp rather than display the page.. any ideas?
Back to top
View user's profile Send private message
Mirrorball
Apprentice
Apprentice


Joined: 25 Apr 2003
Posts: 235
Location: Brazil

PostPosted: Sat Mar 20, 2004 6:47 pm    Post subject: Reply with quote

Change your config file according to the instructions.
Back to top
View user's profile Send private message
Helper_Monkey
Tux's lil' helper
Tux's lil' helper


Joined: 22 Feb 2003
Posts: 141

PostPosted: Sun Mar 21, 2004 3:04 pm    Post subject: Reply with quote

Cyrex56 wrote:
Ok i got it installed with no errors however when i run it.. rather than opening up the file.. it wants to download them..... like it wants to download http://www.google.com/index.html or http://www.msn.com/index.asp rather than display the page.. any ideas?


You need to add "mshtml"="native" under [AppDefaults\\IEXPLORE.EXE\\DllOverrides] in your ~/.wine/config file.
_________________
It is a poverty to decide that a child must die so that you may live as you wish. -Mother Teresa
Back to top
View user's profile Send private message
Superfly
n00b
n00b


Joined: 09 Apr 2003
Posts: 34

PostPosted: Sun Mar 21, 2004 11:49 pm    Post subject: Reply with quote

galay2 wrote:
Ok downloading setupx.dll solves the errors on dcom98, but IE still doesnt run.

I followed frank's second method word for word for about 6 times. No luck, wine iexplore.exe will just exit with no error output at all. But IE does not start. Does anyone have this working at all?? Thanks


I had the same problem. I re-emerged the latest wine package using these use flags: "+alsa +arts +cups -debug -nas -nptl +opengl +tcltk" and then the second method posted in this topic started working. The differences in the use flags where that I did not have "opengl" or "tcltk".

So:

Code:
emerge -C wine
rm -rf ~/.wine
ACCEPT_KEYWORDS="~x86" USE="+opengl +tcltk +alsa +arts +cups" emerge wine


And then follow the modified instructions for the 200403 release of wine posted on page 1.

Everything works for me except https. Does https work for anyone?
Back to top
View user's profile Send private message
Mirrorball
Apprentice
Apprentice


Joined: 25 Apr 2003
Posts: 235
Location: Brazil

PostPosted: Mon Mar 22, 2004 1:32 am    Post subject: Reply with quote

https doesn't work for me. "Cannot find server or DNS error."
Back to top
View user's profile Send private message
Slyde
Guru
Guru


Joined: 14 Jul 2003
Posts: 314

PostPosted: Mon Mar 22, 2004 5:53 am    Post subject: Reply with quote

Wonder if this would work with Traktor Dj Studio. Let's find out....
Back to top
View user's profile Send private message
Cyrex56
n00b
n00b


Joined: 20 Mar 2004
Posts: 10

PostPosted: Mon Mar 22, 2004 6:36 am    Post subject: Reply with quote

Helper_Monkey wrote:
Cyrex56 wrote:
Ok i got it installed with no errors however when i run it.. rather than opening up the file.. it wants to download them..... like it wants to download http://www.google.com/index.html or http://www.msn.com/index.asp rather than display the page.. any ideas?


You need to add "mshtml"="native" under [AppDefaults\\IEXPLORE.EXE\\DllOverrides] in your ~/.wine/config file.


I had done this already .. double checked.. looks fine. no difference..
Back to top
View user's profile Send private message
bicolao
n00b
n00b


Joined: 05 Jan 2004
Posts: 50

PostPosted: Mon Mar 22, 2004 8:18 am    Post subject: Reply with quote

Why not create an ebuild for this? Imagine, "emerge ie6" then everything is fine :D
_________________
Bi Cờ Lao
Back to top
View user's profile Send private message
Helper_Monkey
Tux's lil' helper
Tux's lil' helper


Joined: 22 Feb 2003
Posts: 141

PostPosted: Mon Mar 22, 2004 9:11 pm    Post subject: Reply with quote

Cyrex56 wrote:
Helper_Monkey wrote:
Cyrex56 wrote:
Ok i got it installed with no errors however when i run it.. rather than opening up the file.. it wants to download them..... like it wants to download http://www.google.com/index.html or http://www.msn.com/index.asp rather than display the page.. any ideas?


You need to add "mshtml"="native" under [AppDefaults\\IEXPLORE.EXE\\DllOverrides] in your ~/.wine/config file.


I had done this already .. double checked.. looks fine. no difference..


We might be able to help if you post your wine config.
_________________
It is a poverty to decide that a child must die so that you may live as you wish. -Mother Teresa
Back to top
View user's profile Send private message
Malakin
Veteran
Veteran


Joined: 14 Apr 2002
Posts: 1692
Location: Victoria BC Canada

PostPosted: Mon Mar 22, 2004 11:04 pm    Post subject: Reply with quote

The dcom link no longer works, I used this one:
Code:
wget http://download.microsoft.com/download/4/e/d/4ed95acc-1fcf-4d94-b811-a684c0a709de/DCOM98.EXE

Using wine-20040309, everything installed fine but if I try to run IE I get the following:

Code:
# wine ~/.wine/fake_windows/Program\ Files/Internet\ Explorer/IEXPLORE.EXE
wine: Unhandled exception (thread 0009), starting debugger...
WineDbg starting on pid 8
Can't find file for ELF 'wine-kthread' ((nil))
No debug information in ELF 'wine-pthread' ((nil))
Breakpoint 1 at 0x4000bac0 (_end+0x3fef9590)
No debug information in ELF '/usr/lib/wine/lib/libwine.so.1' (0x40016000)
No debug information in ELF '/lib/libpthread.so.0' (0x4004c000)
No debug information in ELF '/lib/libc.so.6' (0x4009d000)
No debug information in ELF '/lib/libdl.so.2' (0x401ca000)
No debug information in ELF '/lib/libm.so.6' (0x401cd000)
No debug information in ELF '/lib/ld-linux.so.2' (0x40000000)
Loaded debug information from ELF '/usr/lib/wine/lib/wine/ntdll.dll.so' (0x401f0000)
No debug information in ELF '/usr/lib/wine/lib/libwine_unicode.so.1' (0x40257000)
No debug information in ELF '/lib/libnss_compat.so.2' (0x4036a000)
No debug information in ELF '/lib/libnsl.so.1' (0x40372000)
No debug information in ELF '/lib/libnss_nis.so.2' (0x40387000)
No debug information in ELF '/lib/libnss_files.so.2' (0x40390000)
Loaded debug information from ELF '/usr/lib/wine/lib/wine/kernel32.dll.so' (0x404b0000)
Loaded debug information from ELF '/usr/lib/wine/lib/wine/msvcrt.dll.so' (0x406d0000)
Loaded debug information from ELF '/usr/lib/wine/lib/wine/user32.dll.so' (0x40710000)
Loaded debug information from ELF '/usr/lib/wine/lib/wine/gdi32.dll.so' (0x4084a000)
Loaded debug information from ELF '/usr/lib/wine/lib/wine/advapi32.dll.so' (0x408c7000)
No debug information in ELF '/usr/lib/libfreetype.so.6' (0x40917000)
No debug information in ELF '/lib/libz.so.1' (0x40981000)
No debug information in ELF '/usr/lib/libfontconfig.so.1' (0x409b6000)
No debug information in ELF '/usr/lib/libexpat.so.0' (0x409dd000)
Loaded debug information from ELF '/usr/lib/wine/lib/wine/x11drv.dll.so' (0x409fd000)
No debug information in ELF '/usr/X11R6/lib/libSM.so.6' (0x40a8c000)
No debug information in ELF '/usr/X11R6/lib/libICE.so.6' (0x40a95000)
No debug information in ELF '/usr/X11R6/lib/libXxf86dga.so.1' (0x40aac000)
No debug information in ELF '/usr/X11R6/lib/libXxf86vm.so.1' (0x40ab2000)
No debug information in ELF '/usr/X11R6/lib/libXrandr.so.2' (0x40ab7000)
No debug information in ELF '/usr/X11R6/lib/libXrender.so.1' (0x40abb000)
No debug information in ELF '/usr/X11R6/lib/libXv.so.1' (0x40ac3000)
No debug information in ELF '/usr/X11R6/lib/libXext.so.6' (0x40ac8000)
No debug information in ELF '/usr/X11R6/lib/libX11.so.6' (0x40ad6000)
No debug information in ELF '/usr/X11R6/lib/libGL.so.1' (0x40bd1000)
No debug information in ELF '/usr/lib/opengl/nvidia/lib/libGLcore.so.1' (0x40c2d000)
No debug information in ELF '/usr/X11R6/lib/libXcursor.so.1' (0x41196000)
No debug information in ELF '/usr/X11R6/lib/X11/locale/lib/common/xlcDef.so.2' (0x4119f000)
No debug information in ELF '/usr/X11R6/lib/X11/locale/lib/common/ximcp.so.2' (0x411e6000)
Loaded debug information from ELF '/usr/lib/wine/lib/wine/imm32.dll.so' (0x41203000)
Loaded debug information from ELF '/usr/lib/wine/lib/wine/comctl32.dll.so' (0x41220000)
Loaded debug information from ELF '/usr/lib/wine/lib/wine/shell32.dll.so' (0x412c9000)
Loaded debug information from ELF '/usr/lib/wine/lib/wine/uxtheme.dll.so' (0x415e6000)
Loaded debug information from ELF '/usr/lib/wine/lib/wine/version.dll.so' (0x416da000)
Loaded debug information from ELF '/usr/lib/wine/lib/wine/lz32.dll.so' (0x416f4000)
No debug information in 32bit DLL 'C:\Program Files\Internet Explorer\IEXPLORE.EXE' (0x400000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\NTDLL.DLL' (0x40210000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\KERNEL32.DLL' (0x404e0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\MSVCRT.DLL' (0x406e0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\ADVAPI32.DLL' (0x408d0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\GDI32.DLL' (0x40860000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\USER32.DLL' (0x40730000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\SHLWAPI.DLL' (0x70bd0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\SHDOCVW.DLL' (0x71000000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\X11DRV.DLL' (0x40a10000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\IMM32.DLL' (0x41210000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\COMCTL32.DLL' (0x41230000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\OLE32.DLL' (0x65f00000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\SHELL32.DLL' (0x412f0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\BROWSEUI.DLL' (0x71160000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\BROWSELC.DLL' (0x718e0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\SHDOCLC.DLL' (0x71840000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\UXTHEME.DLL' (0x415f0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\RPCRT4.DLL' (0x70100000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\LZ32.DLL' (0x41700000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\VERSION.DLL' (0x416e0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\URLMON.DLL' (0x702b0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\WININET.DLL' (0x63000000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\OLEAUT32.DLL' (0x65340000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\ADVPACK.DLL' (0x715f0000)
Unhandled exception: page fault on read access to 0x00000000 in 32-bit code (0x00000000).
In 32-bit mode.
Register dump:
 CS:0073 SS:007b DS:007b ES:007b FS:003b GS:0033
 EIP:00000000 ESP:406c9e6c EBP:406ca0b0 EFLAGS:00010246(  R- 00  I  Z- -P1 )
 EAX:4041fbb8 EBX:00000000 ECX:406cab6c EDX:4041fbb8
 ESI:00000000 EDI:00000104
Stack dump:
0x406c9e6c (_end+0x11220c):  715fb931 00000000 ffffffff 00000000
0x406c9e7c (_end+0x11221c):  00000000 00000000 00000104 715f2784
0x406c9e8c (_end+0x11222c):  715fc5b4 406cab6c 406cb518 715f9f48
0x406c9e9c (_end+0x11223c):  00000000 715f2754 715f2784 00000000
0x406c9eac (_end+0x11224c):  505c3a43 72676f72 46206d61 73656c69
0x406c9ebc (_end+0x11225c):  696e555c 6174736e 49206c6c 726f666e
0x406c9ecc (_end+0x11226c):

Backtrace:
=>0 0x00000000 (ebp=406ca0b0)
  1 0x715fb931 (ADVPACK.DLL.ExecuteCab+0x65a in ADVPACK.DLL) (ebp=406ca0b0, null call assumed)
  2 0x715fcef3 (ADVPACK.DLL.FileSaveRestoreOnINF+0x5e3 in ADVPACK.DLL) (ebp=406ca63c)
  3 0x715f96bc (ADVPACK.DLL.TranslateInfString+0x41e in ADVPACK.DLL) (ebp=406cac88)
  4 0x715fb6e1 (ADVPACK.DLL.ExecuteCab+0x40a in ADVPACK.DLL) (ebp=406cb2e4)
  5 0x715f4706 (ADVPACK.DLL.AdvInstallFile+0xa2a in ADVPACK.DLL) (ebp=406cb624)
  6 0x715f47ad (ADVPACK.DLL.RegInstall+0x95 in ADVPACK.DLL) (ebp=406cb744)
  7 0x702fabc4 (URLMON.DLL.GetMarkOfTheWeb+0xef in URLMON.DLL) (ebp=406cb7a0)
  8 0x702d820f (URLMON.DLL.DllGetClassObject+0xaa3b in URLMON.DLL) (ebp=406cb7dc)
  9 0x702c3483 (URLMON.DLL.CoGetClassObjectFromURL+0xdf3 in URLMON.DLL) (ebp=406cbaa8)
  10 0x702c0500 (URLMON.DLL.EntryPoint+0xbf3 in URLMON.DLL) (ebp=406cbae4)
  11 0x702c0421 (URLMON.DLL.EntryPoint+0xb14 in URLMON.DLL) (ebp=406cbafc)
  12 0x702bf6b6 (URLMON.DLL.CoInternetGetSecurityUrl+0x556 in URLMON.DLL) (ebp=406cbb24)
  13 0x65f14078 (OLE32.DLL.CoCreateInstanceEx+0xfe in OLE32.DLL) (ebp=406cbdb4)
  14 0x65f143c4 (OLE32.DLL.CoCreateInstance+0x97 in OLE32.DLL) (ebp=406cbde0)
  15 0x65f14397 (OLE32.DLL.CoCreateInstance+0x6a in OLE32.DLL) (ebp=406cbe08)
  16 0x70c07eb4 (SHLWAPI.DLL.234+0x9a in SHLWAPI.DLL) (ebp=406cc410)
  17 0x70c07ffe (SHLWAPI.DLL.382+0x76 in SHLWAPI.DLL) (ebp=406cc46c)
  18 0x71010567 (SHDOCVW.DLL.191+0x49a7 in SHDOCVW.DLL) (ebp=406cc4bc)
  19 0x7100b7be (SHDOCVW.DLL.142+0x335a in SHDOCVW.DLL) (ebp=406cc554)
  20 0x7100b464 (SHDOCVW.DLL.142+0x3000 in SHDOCVW.DLL) (ebp=406cc578)
  21 0x407aa78f (WINPROC_wrapper+0x17 in USER32.DLL) (ebp=406cc59c)
  22 0x407aa80b (WINPROC_CallWndProc+0x6b(proc=0x7100b428, hwnd=0x1003d, msg=0x5, wParam=0x0, lParam=0x27303b8) [winpro
c.c:230] in USER32.DLL) (ebp=406cc5d0)
  23 0x407b12c5 (WINPROC_CallProc32WTo32A+0x65(func=0x7100b428, hwnd=0x1003d, msg=0x5, wParam=0x0, lParam=0x27303b8) [w
inproc.c:2902] in USER32.DLL) (ebp=406cc600)
  24 0x407b197d (CallWindowProcW+0xed(func=0x40839d8a, hwnd=0x1003d, msg=0x5, wParam=0x0, lParam=0x27303b8) [winproc.c:
3121] in USER32.DLL) (ebp=406cc630)
  25 0x407c3b40 (call_window_proc+0xe0(hwnd=0x1003d, msg=0x5, wparam=0x0, lparam=0x27303b8, unicode=0x1, same_thread=0x
1) [message.c:1450] in USER32.DLL) (ebp=406cc68c)
  26 0x407c4991 (SendMessageTimeoutW+0x161(hwnd=0x1003d, msg=0x5, wparam=0x0, lparam=0x27303b8, flags=0x0, timeout=0xff
ffffff, res_ptr=0x406cc714) [message.c:1913] in USER32.DLL) (ebp=406cc6f0)
  27 0x407c4c61 (SendMessageW+0x51(hwnd=0x1003d, msg=0x5, wparam=0x0, lparam=0x27303b8) [message.c:1994] in USER32.DLL)
 (ebp=406cc71c)
  28 0x40a46e0e (X11DRV_CreateWindow+0x53e(hwnd=0x1003d, cs=0x406cc9a0, unicode=0x0) [window.c:1101] in X11DRV.DLL) (eb
p=406cc7a4)
  29 0x407a41e1 (WIN_CreateWindowEx+0x391(cs=0x406cc9a0, classAtom=0xc07a, type=0x2) [win.c:1206] in USER32.DLL) (ebp=4
06cc884)
  30 0x407a4878 (CreateWindowExA+0x98(exStyle=0x0, className=0x406cca20, windowName=0x0, style=0x56010000, x=0x0, y=0x5
d, width=0x3b8, height=0x273, parent=0x10023, menu=0x0, instance=0x71000000, data=0x4041dba4) [win.c:1370] in USER32.DL
L) (ebp=406cc9dc)
  31 0x70bfca52 (SHLWAPI.DLL.55+0x8b in SHLWAPI.DLL) (ebp=406cce40)
  32 0x7102d6cd (SHDOCVW.DLL.171+0xde9 in SHDOCVW.DLL) (ebp=406cce94)
  33 0x7102d447 (SHDOCVW.DLL.171+0xb63 in SHDOCVW.DLL) (ebp=406ccec0)
  34 0x7102d367 (SHDOCVW.DLL.171+0xa83 in SHDOCVW.DLL) (ebp=406ccef4)
  35 0x710243e3 (SHDOCVW.DLL.179+0x314 in SHDOCVW.DLL) (ebp=406ccf98)
  36 0x7102480f (SHDOCVW.DLL.179+0x740 in SHDOCVW.DLL) (ebp=406ccfc0)
  37 0x71171dea (BROWSEUI.DLL.105+0x399f in BROWSEUI.DLL) (ebp=406ccfdc)
  38 0x71172ff6 (BROWSEUI.DLL.105+0x4bab in BROWSEUI.DLL) (ebp=406ccffc)
  39 0x71024728 (SHDOCVW.DLL.179+0x659 in SHDOCVW.DLL) (ebp=406cd040)
  40 0x710245e5 (SHDOCVW.DLL.179+0x516 in SHDOCVW.DLL) (ebp=406cd068)
  41 0x71024561 (SHDOCVW.DLL.179+0x492 in SHDOCVW.DLL) (ebp=406ce0dc)
  42 0x71171dc9 (BROWSEUI.DLL.105+0x397e in BROWSEUI.DLL) (ebp=406ce114)
  43 0x71180b2f (BROWSEUI.DLL.105+0x126e4 in BROWSEUI.DLL) (ebp=406ce188)
  44 0x71002fae (SHDOCVW.DLL.SHGetIDispatchForFolder+0x10d6 in SHDOCVW.DLL) (ebp=406ce1a0)
  45 0x71162fc2 (BROWSEUI.DLL..text+0x1fc2 in BROWSEUI.DLL) (ebp=406ce1bc)
  46 0x71165c54 (BROWSEUI.DLL..text+0x4c54 in BROWSEUI.DLL) (ebp=406ce1f8)
  47 0x71165ade (BROWSEUI.DLL..text+0x4ade in BROWSEUI.DLL) (ebp=406ce224)
  48 0x407aa78f (WINPROC_wrapper+0x17 in USER32.DLL) (ebp=406ce248)
  49 0x407aa80b (WINPROC_CallWndProc+0x6b(proc=0x71165af5, hwnd=0x10023, msg=0x1, wParam=0x0, lParam=0x406ce624) [winpr
oc.c:230] in USER32.DLL) (ebp=406ce27c)
  50 0x407b186d (CallWindowProcA+0xed(func=0x71165af5, hwnd=0x10023, msg=0x1, wParam=0x0, lParam=0x406ce624) [winproc.c
:3082] in USER32.DLL) (ebp=406ce2ac)
  51 0x407c3bd1 (call_window_proc+0x171(hwnd=0x10023, msg=0x1, wparam=0x0, lparam=0x406ce624, unicode=0x0, same_thread=
0x1) [message.c:1455] in USER32.DLL) (ebp=406ce308)
  52 0x407c4bcf (SendMessageTimeoutA+0x1ff(hwnd=0x10023, msg=0x1, wparam=0x0, lparam=0x406ce624, flags=0x0, timeout=0xf
fffffff, res_ptr=0x406ce398) [message.c:1961] in USER32.DLL) (ebp=406ce374)
  53 0x407c4cc1 (SendMessageA+0x51(hwnd=0x10023, msg=0x1, wparam=0x0, lparam=0x406ce624) [message.c:2005] in USER32.DLL
) (ebp=406ce3a0)
  54 0x40a46f17 (X11DRV_CreateWindow+0x647(hwnd=0x10023, cs=0x406ce624, unicode=0x0) [window.c:1079] in X11DRV.DLL) (eb
p=406ce428)
  55 0x407a41e1 (WIN_CreateWindowEx+0x391(cs=0x406ce624, classAtom=0xc05a, type=0x2) [win.c:1206] in USER32.DLL) (ebp=4
06ce508)
  56 0x407a4878 (CreateWindowExA+0x98(exStyle=0x100, className=0x406ce6a4, windowName=0x406ce8b8, style=0x2cf0000, x=0x
80000000, y=0x80000000, width=0x80000000, height=0x80000000, parent=0x0, menu=0x8c, instance=0x71160000, data=0x403e296
8) [win.c:1370] in USER32.DLL) (ebp=406ce660)
  57 0x70bfca52 (SHLWAPI.DLL.55+0x8b in SHLWAPI.DLL) (ebp=406ceac4)
  58 0x71181c0e (BROWSEUI.DLL.123+0x387 in BROWSEUI.DLL) (ebp=406ced48)
  59 0x71181acf (BROWSEUI.DLL.123+0x248 in BROWSEUI.DLL) (ebp=406cedd4)
  60 0x71181a86 (BROWSEUI.DLL.123+0x1ff in BROWSEUI.DLL) (ebp=406cfe50)
  61 0x7101f031 (SHDOCVW.DLL.101+0xa7 in SHDOCVW.DLL) (ebp=406cfe70)
  62 0x00401ecd (IEXPLORE.EXE..text+0xecd in IEXPLORE.EXE) (ebp=406cfec0)
  63 0x00401f7d (IEXPLORE.EXE.EntryPoint+0x97 in IEXPLORE.EXE) (ebp=406cff20)
  64 0x4052f707 (start_process+0xe7(arg=0x0) [process.c:759] in KERNEL32.DLL) (ebp=406cfff4)
  65 0x4001a8b1 (wine_switch_to_stack+0x11 in libwine.so.1) (ebp=00000000)

0x00000000: addb        %al,0x0(%eax)
Modules:
Address                 Module  Name
0x00400000-00418800     (PE)    C:\Program Files\Internet Explorer\IEXPLORE.EXE
0x40210000-40257000     (PE)    C:\WINDOWS\SYSTEM\NTDLL.DLL
0x404e0000-405b8000     (PE)    C:\WINDOWS\SYSTEM\KERNEL32.DLL
0x406e0000-40710000     (PE)    C:\WINDOWS\SYSTEM\MSVCRT.DLL
0x40730000-4084a000     (PE)    C:\WINDOWS\SYSTEM\USER32.DLL
0x40860000-408c7000     (PE)    C:\WINDOWS\SYSTEM\GDI32.DLL
0x408d0000-408f9000     (PE)    C:\WINDOWS\SYSTEM\ADVAPI32.DLL
0x40a10000-40a6e000     (PE)    C:\WINDOWS\SYSTEM\X11DRV.DLL
0x41210000-41220000     (PE)    C:\WINDOWS\SYSTEM\IMM32.DLL
0x41230000-412c9000     (PE)    C:\WINDOWS\SYSTEM\COMCTL32.DLL
0x412f0000-4133f000     (PE)    C:\WINDOWS\SYSTEM\SHELL32.DLL
0x415f0000-4160e000     (PE)    C:\WINDOWS\SYSTEM\UXTHEME.DLL
0x416e0000-416f4000     (PE)    C:\WINDOWS\SYSTEM\VERSION.DLL
0x41700000-4170a000     (PE)    C:\WINDOWS\SYSTEM\LZ32.DLL
0x63000000-6304bc00     (PE)    C:\WINDOWS\SYSTEM\WININET.DLL
0x65340000-653d2000     (PE)    C:\WINDOWS\SYSTEM\OLEAUT32.DLL
0x65f00000-65fc1800     (PE)    C:\WINDOWS\SYSTEM\OLE32.DLL
0x70100000-70153000     (PE)    C:\WINDOWS\SYSTEM\RPCRT4.DLL
0x702b0000-70329200     (PE)    C:\WINDOWS\SYSTEM\URLMON.DLL
0x70bd0000-70c34600     (PE)    C:\WINDOWS\SYSTEM\SHLWAPI.DLL
0x71000000-71149000     (PE)    C:\WINDOWS\SYSTEM\SHDOCVW.DLL
0x71160000-7125ce00     (PE)    C:\WINDOWS\SYSTEM\BROWSEUI.DLL
0x715f0000-71616600     (PE)    C:\WINDOWS\SYSTEM\ADVPACK.DLL
0x71840000-718c3200     (PE)    C:\WINDOWS\SYSTEM\SHDOCLC.DLL
0x718e0000-718f1200     (PE)    C:\WINDOWS\SYSTEM\BROWSELC.DLL
Threads:
process  tid      prio
00000008 (D) C:\Program Files\Internet Explorer\IEXPLORE.EXE
        0000000a    0
        00000009    1 <==
WineDbg terminated on pid 8
Back to top
View user's profile Send private message
steveb
Advocate
Advocate


Joined: 18 Sep 2002
Posts: 4564

PostPosted: Wed Mar 31, 2004 6:24 pm    Post subject: Reply with quote

Malakin wrote:
Using wine-20040309, everything installed fine but if I try to run IE I get the following:



i have ie version 6.0.2800.1106 runing under wine 20040309 without any problem.

i just installed the wine-20040309 version, changed the ~/.wine/config file to have the following entries:
Code:
;; Microsoft Internet Explorer
[AppDefaults\\iexplore.exe\\Version]
"Windows"           = "win98"

;; Microsoft Internet Explorer
[AppDefaults\\iexplore.exe\\DllOverrides]
"mshtml"            = "native, builtin"
"shfolder"          = "native, builtin"
"shell32"           = "native, builtin"
"shell"             = "native, builtin"
"shdocvw"           = "native, builtin"
"shlwapi"           = "native, builtin"
"urlmon"            = "native, builtin"
"crypt32"           = "native, builtin"
"wininet"           = "native, builtin"
"*comctl32"         = "builtin, native"
"mapi"              = "native, builtin"
"mapi32"            = "native, builtin"
"ole32"             = "native, builtin"
"compobj"           = "native, builtin"
"ole2"              = "native, builtin"
"ole2nls"           = "native, builtin"
"ole2conv"          = "native, builtin"
"ole2prox"          = "native, builtin"
"ole2thk"           = "native, builtin"
"storage"           = "native, builtin"
"olepro32"          = "native, builtin"
"rpcrt4"            = "native, builtin"
"oleaut32"          = "native, builtin"
"msvcrt"            = "native, builtin"
"wininet"           = "native, builtin"
"setupapi"          = "native, builtin"
"devenum"           = "native, builtin"
"quartz"            = "native, builtin"
"jscript"           = "native, builtin"
"wintrust"          = "native, builtin"
"secur32"           = "native, builtin"
"ddraw"             = "native, builtin"
"*user.exe"         = "native,builtin"
"*"                 = "builtin, native"

[AppDefaults\\msimn.exe\\DllOverrides]
"*comctl32"         = "builtin"
"mapi"              = "native, builtin"
"mapi32"            = "native, builtin"
"ole32"             = "native, builtin"
"compobj"           = "native, builtin"
"ole2"              = "native, builtin"
"ole2nls"           = "native, builtin"
"ole2conv"          = "native, builtin"
"ole2prox"          = "native, builtin"
"ole2thk"           = "native, builtin"
"storage"           = "native, builtin"
"olepro32"          = "native, builtin"
"rpcrt4"            = "native, builtin"
"oleaut32"          = "native, builtin"
"msvcrt"            = "native, builtin"
"wininet"           = "native, builtin"
"setupapi"          = "native, builtin"
"devenum"           = "native, builtin"
"quartz"            = "native, builtin"
"urlmon"            = "native"
"shdocvw"           = "native, builtin"
"jscript"           = "native, builtin"
"wintrust"          = "native, builtin"
"shlwapi"           = "native, builtin"
"secur32"           = "native, builtin"
"crypt32"           = "native, builtin"
"ddraw"             = "native, builtin"
"*user.exe"         = "native,builtin"
"*"                 = "builtin, native"

[AppDefaults\\rundll32.exe\\DllOverrides]
; to avoid mstime.dll error when installing IE
"ddraw"             = "builtin"

;; Microsoft Internet Explorer 6 Setup
[AppDefaults\\ie6setup.exe\\DllOverrides]
"*advapi32"         = "builtin"
"mshtml"            = "native"
"*comctl32"         = "builtin"
"mapi"              = "native, builtin"
"mapi32"            = "native, builtin"
"ole32"             = "native, builtin"
"compobj"           = "native, builtin"
"ole2"              = "native, builtin"
"ole2nls"           = "native, builtin"
"ole2conv"          = "native, builtin"
"ole2prox"          = "native, builtin"
"ole2thk"           = "native, builtin"
"storage"           = "native, builtin"
"olepro32"          = "native, builtin"
"rpcrt4"            = "native, builtin"
"oleaut32"          = "native, builtin"
"msvcrt"            = "native, builtin"
"wininet"           = "native, builtin"
"setupapi"          = "native, builtin"
"devenum"           = "native, builtin"
"quartz"            = "native, builtin"
"urlmon"            = "native"
"shdocvw"           = "native, builtin"
"jscript"           = "native, builtin"
"wintrust"          = "native, builtin"
"shlwapi"           = "native, builtin"
"secur32"           = "native, builtin"
"crypt32"           = "native, builtin"
"ddraw"             = "native, builtin"
"*user.exe"         = "native,builtin"
"*"                 = "builtin, native"
and i changed the userdef.reg to have the following:
Code:
[Software\\Microsoft\\Windows\\CurrentVersion\\Explorer\\Shell Folders] 986159144
"Desktop"="C:\\WINDOWS\\Desktop"
"Favorites"="C:\\WINDOWS\\Favorites"
"Fonts"="C:\\WINDOWS\\Fonts"
"NetHood"="C:\\WINDOWS\\NetHood"
"Personal"="X:\\"
"Programs"="C:\\WINDOWS\\Start Menu\\Programs"
"Recent"="C:\\WINDOWS\\Recent"
"SendTo"="C:\\WINDOWS\\SendTo"
"Start Menu"="C:\\WINDOWS\\Start Menu"
"StartUp"="C:\\WINDOWS\\Start Menu\\Programs\\Startup"
"Templates"="C:\\WINDOWS\\ShellNew"

[Software\\Microsoft\\Windows\\CurrentVersion\\Explorer\\User Shell Folders] 986159144
"Favorites"="C:\\WINDOWS\\Favorites"
"Personal"="X:\\"
in my case i use X:\ as the drive for my home directory. you maybe have another drive for that? just check the wine config file.

after that, i downloaded dcom98 and installed it.

and for ie6 to install correctly i had to copy setupx.dll from the web and copy it to the windows\system directory. after that i just installed ie 6 with sp1 by lunching ie6setup.exe. that's all. no other special tweaking was needed :)

anyway... windows update does not work :( (it worked with cxoffice). anyway... i just use the url http://v4.windowsupdate.microsoft.com/en/default.asp?corporate=true and then i download everything i need and install the stuff manually ;)

for renaming the dll's to lowercase i used the following slef made script:
Code:
#!/bin/bash
for foo in dispex.dll inseng.dll jscript.dll scrobj.dll shfolder.dll WinInet.dll
do
   bar=$(find . -iname ${foo} -type f)
   if [ "${bar} != "" ]
   then
      mv ${bar} ${bar}.lowercase
   fi
done


for installing the windows core fonts i used the following self mand script:
Code:
#!/bin/bash
http="http://umn.dl.sourceforge.net/sourceforge/corefonts/"
tmp="${TMPDIR-/tmp}/wine_tools.$RANDOM.$RANDOM.$RANDOM.$$"

if [ ! -d ~/.wine ]; then
   echo
   echo "~/.wine is missing. You need to run once the command \"wine\" to create" 1>&2
   echo "an wine configuration." 1>&2
   echo
   exit 1
fi

if [ ! -x "$(which wget 2>&1)" ]; then
   echo
   echo "Could not locate wget! Exiting." 1>&2
   echo
   exit 1
fi

for foo in andale32 arial32 arialb32 comic32 courie32 georgi32 impact32 times32 trebuc32 verdan32 webdin32
do
   [[ ! -d "${tmp}" ]] && (umask 077 && mkdir -p ${tmp})
   [[ ! -d "${tmp}" ]] && {
      echo
      echo "Could not create temporary directory! Exiting." 1>&2
      echo
      exit 1
   }
   wget -q ${http}${foo}.exe -O ${tmp}/${foo}.exe
   wine ${tmp}/${foo}.exe /Q 2>/dev/null
   wineboot 2>/dev/null
done

[[ -d "${tmp}" ]] && rm -rf ${tmp}



i installed some other stuff as well (excel 97 viewer, word 97 viewer, powerpoint 2003 viewer, visio 2002 viewer, lotus notes client/designer/admin 5.0.12, acrobat reader 5.1, and much more) but i don't know if you need that kind of info.


cheers

SteveB
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3, ... 10, 11, 12  Next
Page 2 of 12

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum