Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
SpamAssassion and Razor
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
ashak
n00b
n00b


Joined: 19 Mar 2003
Posts: 11

PostPosted: Thu Feb 19, 2004 9:45 am    Post subject: SpamAssassion and Razor Reply with quote

Hi,

I've just emerged razor v2.36-r1, which all seemed to go fine.
Then I emerged Mail-SpamAssassion v2.63, during compiling I get:

Code:
t/basic_lint................ok
t/cidrs.....................ok
t/db_awl_path...............ok
t/db_based_whitelist........ok
t/db_based_whitelist_ips....ok
t/forged_rcvd...............ok
t/gtube.....................ok
t/html_obfu.................ok
t/lang_pl_tests.............ok
t/nonspam...................ok
t/razor2....................skipped
        all skipped: no reason given
t/recips....................ok
t/reportheader..............ok
t/rule_tests................ok
t/sha1......................ok
t/spam......................ok
t/spamc.....................ok
t/spamc_B...................ok
t/spamc_c...................ok
t/spamc_c_stdout_closed.....ok
t/spamd.....................ok
t/spamd_allow_user_rules....ok
t/spamd_hup.................ok
t/spamd_maxchildren.........ok
t/spamd_maxsize.............ok
t/spamd_port................ok
t/spamd_protocol_10.........ok
t/spamd_report..............ok
t/spamd_report_ifspam.......ok
t/spamd_stop................ok
t/spamd_symbols.............ok
t/spamd_unix................ok
t/spamd_utf8................ok
t/strip2....................ok
t/stripmarkup...............ok
t/utf8......................ok
t/whitelist_addrs...........ok
t/whitelist_to..............ok
t/zz_cleanup................ok
All tests successful, 1 test skipped.
Files=39, Tests=281, 195 wallclock secs (97.57 cusr + 10.67 csys = 108.24 CPU)

Anyone have any idea why the razor2 stuff is skipped?

Thanks
Back to top
View user's profile Send private message
gautamg
n00b
n00b


Joined: 23 Feb 2004
Posts: 27
Location: New York, NY

PostPosted: Tue Mar 09, 2004 5:08 am    Post subject: 'cause the ebuild is configured that way Reply with quote

the ebuild is configured to not run razor tests during install, probably because of dns issues
look in
Code:

/usr/portage/dev-perl/Mail-SpamAssassin/Mail-SpamAssassin-2.63.ebuild

for the line
Code:

myconf="CONTACT_ADDRESS=root@localhost RUN_RAZOR_TESTS=0"

change it if you must.

A better way to check if your spamassassin is working with razor is to save an email to a text file and pipe it on the command line thru spamassassin and look for razor checks performed like so
make sure razor is initialized
Code:
 razor-admin --discover

Code:

 cat mail.txt| spamassassin -D -x 2>&1 |grep -i razor
...
debug: Found Razor2 part: part=0 engine=4 ct=0 cf=0
debug: Found Razor2 part: part=1 engine=4 ct=0 cf=0
debug: Razor2 results: spam? 0  highest cf score: 0
debug: Razor2 is available



Hope this helps
SA+Razor - kills spam dead! :-)
Back to top
View user's profile Send private message
neenee
Veteran
Veteran


Joined: 20 Jul 2003
Posts: 1786

PostPosted: Tue Mar 09, 2004 9:55 am    Post subject: Reply with quote

thanks for the info :wink:

though when i emerge, i see the following:

Code:
t/razor2....................ACCESS DENIED  mkdir:     /root/.razor
t/razor2....................ok 1/2ACCESS DENIED  mkdir:     /root/.razor     
t/razor2....................ok


i emerged razor in advance, and created an
account for my normal user; root does not
have that dir..

maybe all is well since it says ok?

*update*

Code:
All tests successful.
Files=39, Tests=283, 140 wallclock secs (47.93 cusr +  7.95 csys = 55.88 CPU)
--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE = "/tmp/sandbox-dev-perl_-_Mail-SpamAssassin-2.63-22462.log"

mkdir:     /root/.razor
mkdir:     /root/.razor
--------------------------------------------------------------------------------


it halts there.

*update*

'FEATURES="-sandbox" emerge Mail-Spamassassin' worked.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum