Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Clean out your world file
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 26, 27, 28, 29  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 5610
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Thu Jan 04, 2007 10:46 pm    Post subject: Reply with quote

just wanted to say 'thank you', ecatmur,

with dep I'm keeping my gentoo installations clean from all that unnecessary junk / old dependencies / cruft :D
_________________
Unofficial minimal livecd x86/amd64 w/reiser4+truecrypt (by Neo2)
2.6.37.2_plus_v1: BFS, CFS,THP,compaction, zcache or TOI
Hardcore Linux user since 2004 :D
Back to top
View user's profile Send private message
Dan
Veteran
Veteran


Joined: 25 Oct 2005
Posts: 1301

PostPosted: Tue Jan 30, 2007 8:32 pm    Post subject: Reply with quote

what are the oops about?

sys-process/procps-3.2.6 sys-process/procps
!!! Oops: comm_ver called with category/package: 2.4.3-r4/2.4.3-r4 dev-lang/
!!! python
dev-python/pycrypto-2.0.1-r5 >=dev-python/pycrypto-2.0.1-r5

I have a few of them
Do they each have a different cause? What exactly do they mean and can I or do I need to get rid of them?
_________________
- Failure is not an option. It's bundled with your software.
Back to top
View user's profile Send private message
Phlogiston
Veteran
Veteran


Joined: 27 Jan 2004
Posts: 1925
Location: Europe, Swizerland

PostPosted: Tue Feb 06, 2007 8:13 am    Post subject: Reply with quote

I didn't read the whole thread, but as it looks like dep can't handle package.files if they are in a directory. I mean if you have split up your package.keyword files into more than one and saved them to /etc/portage/package.keywords/.

The problem occurs when using dep with -E.
_________________
Workstation: 5.1 SurroundSound, LIRC remote control; Laptop [IBM-T43]: patched sources, s2disk/ram, fingerprint sensor
Back to top
View user's profile Send private message
batistuta
Veteran
Veteran


Joined: 29 Jul 2005
Posts: 1384
Location: Aachen

PostPosted: Sun Feb 11, 2007 10:24 pm    Post subject: Reply with quote

With portage 2.1.2-r9 some pacakges require entries in pakage.keywords like
Code:
gnome-extra/kiba-dock ** ~*

But dep -E claims they can be removed. Is this a compatibility issue or am I doing something wrong?
Back to top
View user's profile Send private message
patrickdepinguin
n00b
n00b


Joined: 18 Jan 2007
Posts: 7

PostPosted: Wed Mar 28, 2007 4:50 pm    Post subject: Reply with quote

I tried dep today, but I do not have the impression it works correctly, or I have a wrong understanding.

What I did was first prune the world file, then use the depclean option.
This cleaned quite some files.
Then I did a emerge -uaD world, and all the deleted packages would be installed again. They are indeed dependencies of other packages, which I thought dep would check.

Is there something I am doing wrong?

One example is libkexiv2 which is a dependency of digikam. libkexiv2 was removed by dep -ad, but installed again with emerge -uD world...
Back to top
View user's profile Send private message
Joseph_sys
Advocate
Advocate


Joined: 08 Jun 2004
Posts: 2359
Location: Edmonton, AB

PostPosted: Sat Mar 31, 2007 3:19 am    Post subject: Reply with quote

After running "dep -sp" it wants to remove the following packages:
Code:
To remove:
        * app-admin/eselect-oodict-20060706 app-crypt/pinentry-0.7.2-r3 app-text/hunspell-1.1.4-r1 dev-java/ant-core-1.6.5-r14 dev-java/javatoolkit-0.2.0-r1 dev-lang/swig-1.3.31 dev-libs/boost-1.33.1-r1 dev-libs/fribidi-0.10.7 dev-libs/icu-3.6 dev-libs/libevent-1.3a dev-perl/Archive-Zip-1.16 kde-base/kdeaddons-docs-konq-plugins-3.5.4 kde-base/kdenetwork-filesharing-3.5.5 kde-base/kdenetwork-kfile-plugins-3.5.5 kde-base/kdict-3.5.5 kde-base/kfilereplace-3.5.5 kde-base/kimagemapeditor-3.5.5 kde-base/klinkstatus-3.5.5 kde-base/kmailcvt-3.5.5 kde-base/kommander-3.5.5 kde-base/kpf-3.5.5 kde-base/kppp-3.5.5 kde-base/krdc-3.5.5 kde-base/kscreensaver-3.5.5 kde-base/ktalkd-3.5.5 kde-base/kxsldbg-3.5.5 kde-base/libkdeedu-3.5.4 kde-base/libkmime-3.5.3 kde-base/libkpgp-3.5.4 kde-base/libkscan-3.5.5 kde-base/libksieve-3.5.0 kde-base/librss-3.5.0 kde-base/lisa-3.5.5 kde-base/mimelib-3.5.4 media-libs/lcms-1.15 media-libs/taglib-1.4-r1 media-sound/cdparanoia-3.9.8-r5 net-libs/libnfsidmap-0.17 net-misc/curl-7.15.1-r1 net-nds/openldap-2.3.24-r1 net-nds/portmap-5b-r9 sys-apps/hotplug-base-20040401 sys-devel/distcc-2.18.3-r10 sys-libs/libstdc++-v3-3.3.4 virtual/libstdc++-3.3
\

I didn't analyze the all, but why it wants to remove: sys-devel/distcc
I need "distcc"
_________________
#Joseph
Back to top
View user's profile Send private message
mkzelda
n00b
n00b


Joined: 22 Aug 2004
Posts: 30

PostPosted: Mon May 21, 2007 11:45 am    Post subject: Reply with quote

I just discovered dep and I want to say thanks. I had 300 or so unused packages, 8O about 275 of which were deps and the other were apps I've never used since installation.

I wanted to contribute that 'dep -d' wants to remove the following:
Code:
sys-libs/timezone-data-2007f
x11-drivers/xf86-video-vesa
x11-drivers/xf86-input-mouse
x11-drivers/xf86-input-evdev


Furthermore, on one machine I get the following errors:
Code:
: No such file or directorye/local/layman/make.conf
The /var/cache/edb/dep/usr/portag gets cut off and starts at 'e/local...'
Code:
: No such file or directory: /var/cache/edb/dep//usr/local/portage
I get 100+ of these (note the double //)

I get a similar error with eix, so I believe the problem is something on my machine, though I can't figure out what. Any ideas?

A springclean found:
Code:
 media-plugins/gst-plugins-oss
    selected: 0.10.5
   protected: none
     omitted: 0.8.12

 media-plugins/gst-plugins-xvideo
    selected: 0.10.12
   protected: none
     omitted: 0.8.12

 media-libs/gst-plugins-base
    selected: 0.10.12
   protected: none
     omitted: none

 media-plugins/gst-plugins-x
    selected: 0.10.12
   protected: none
     omitted: none

 media-plugins/gst-plugins-alsa
    selected: 0.10.12
   protected: none
     omitted: 0.8.12


This isnt a problem with dep, but rather Portage which is trying to prune newer versions here. I've encountered a few other instances of this, but I failed to document them. This is a poor example however, as both versions are installed to satisfy the gstreamer use flag. These are false positives for removal.

I'm using app-portage/udept-0.5.99.0.2.95-r1
Back to top
View user's profile Send private message
termite
Guru
Guru


Joined: 06 May 2007
Posts: 466

PostPosted: Wed Jun 13, 2007 8:30 am    Post subject: Reply with quote

Code:
dep -s
runs for a while, then dies with
Code:
/usr/lib/portage/bin/ebuild.sh: line 1512: /var/db/pkg/app-arch/-MERGING-unzip-5.52-r1/-MERGING-unzip-5.52-r1.ebuild: No such file or directory

!!! ERROR: app-arch/-MERGING-unzip-5.52-r1 failed.
Call stack:
  ebuild.sh, line 1512:   Called die

!!! error sourcing ebuild
!!! If you need support, post the topmost build error, and the call stack if relevant.


To remove:
        * app-arch/-MERGING-unzip-5.52-r1
To install:
        *

>>> These are the packages that would be unmerged:

--- Couldn't find 'app-arch/-MERGING-unzip-5.52-r1' to unmerge.

>>> No packages selected for removal by unmerge


Any ideas?
Back to top
View user's profile Send private message
rhomp2002
n00b
n00b


Joined: 01 Dec 2006
Posts: 20
Location: jamaica, ny

PostPosted: Wed Jun 20, 2007 11:47 pm    Post subject: Question on redundancies Reply with quote

I just ran a pretend dep world and what I am seeing is redundancies listed and then the expression World File with an entry. Is this saying that the other redundancies will be removed and the entry in world file will handle it or just what is this saying to me. I am not really sure how to read this and would prefer to get a response before I run it for real.

Thanks.

Dick :? :? :?
Back to top
View user's profile Send private message
LordHelmchen
n00b
n00b


Joined: 10 Apr 2004
Posts: 20

PostPosted: Thu Aug 23, 2007 10:09 am    Post subject: Re: Unknown USE component errors Reply with quote

FuzzyRay wrote:
The "Unknown USE component" errors are due to the newer versions of portage implementing support for specifying default USE flags on a per package basis. (See Bug #61732)

Anyhow, I have released udept-0.5.99.0.2.95-r1 which will stop the errors from being printed. All the patched version does is add placeholders for the new portage functionality.


I have the newest version installed:
lordhelmchen@bucephalos ~ $ dep -e udept
app-portage/udept:
[ ~ ] 0.5.96.2 (0)
[ ~ ] 0.5.99.0.2.95 (0)
[ ~I] 0.5.99.0.2.95-r1 (0)

but I do get
Code:

!!! Unknown USE component: env.d

hundreds of times (after each evaluated package, it seems).
Never saw any other Unknown USE component thrown by dep, though.
Back to top
View user's profile Send private message
novazur
Guru
Guru


Joined: 19 Mar 2005
Posts: 421
Location: Martinique

PostPosted: Thu Aug 23, 2007 7:37 pm    Post subject: Reply with quote

Same problem here.
Back to top
View user's profile Send private message
embobo
Guru
Guru


Joined: 19 May 2003
Posts: 311

PostPosted: Thu Sep 06, 2007 3:08 am    Post subject: Re: Unknown USE component errors Reply with quote

LordHelmchen wrote:
FuzzyRay wrote:
The "Unknown USE component" errors are due to the newer versions of portage implementing support for specifying default USE flags on a per package basis. (See Bug #61732)

Anyhow, I have released udept-0.5.99.0.2.95-r1 which will stop the errors from being printed. All the patched version does is add placeholders for the new portage functionality.


I have the newest version installed:
lordhelmchen@bucephalos ~ $ dep -e udept
app-portage/udept:
[ ~ ] 0.5.96.2 (0)
[ ~ ] 0.5.99.0.2.95 (0)
[ ~I] 0.5.99.0.2.95-r1 (0)

but I do get
Code:

!!! Unknown USE component: env.d

hundreds of times (after each evaluated package, it seems).
Never saw any other Unknown USE component thrown by dep, though.


Same here. FuzzyRay?
Back to top
View user's profile Send private message
novazur
Guru
Guru


Joined: 19 Mar 2005
Posts: 421
Location: Martinique

PostPosted: Thu Sep 06, 2007 5:03 am    Post subject: Re: Unknown USE component errors Reply with quote

embobo wrote:
Same here.

When you re-emerge udept, you have not this problem anymore.
Back to top
View user's profile Send private message
dpetka2001
l33t
l33t


Joined: 04 Mar 2005
Posts: 804

PostPosted: Mon Sep 17, 2007 2:18 pm    Post subject: Reply with quote

i think i have a minor problem regarding "dep"...here is what it gives me
Code:
root@ ~ > dep -d
media-libs/faac 1.25
media-libs/giflib 4.1.4
media-video/mplayer-1.0_rc1_p20070824 media-video/mplayer-1.0_rc1_p20070824

>>> These are the packages that would be unmerged:

--- Couldn't find 'media-video/mplayer-1.0_rc1_p20070824-media-video/mplayer-1.0_rc1_p20070824' to unmerge.

 media-libs/faac
    selected: 1.25
   protected: none
     omitted: none

 media-libs/giflib
    selected: 4.1.4
   protected: none
     omitted: none

>>> 'Selected' packages are slated for removal.
>>> 'Protected' and 'omitted' packages will not be removed.
"dep -L faac" gives no results...but "equery d faac" gives
Code:
root@ ~ > equery d faac
[ Searching for packages depending on faac... ]
media-libs/libquicktime-0.9.10 (aac & encode? media-libs/faac)
media-video/ffmpeg-0.4.9_p20070330 (aac? media-libs/faac)
media-video/mplayer-1.0_rc1_p20070824 (encode & aac? media-libs/faac)
...so i think faac is needed because it is needed by "aac use flag"...every time i give dep -d it gives me the results mentioned above...when i leave it to unmerge those packages in the next "emerge -pvNuD world" want to be rebuilt..."-t" indicates that they are needed by mplayer probably because of the "aac use flag"...is this really a problem?? how can i overcome this?? thanks in advance...
Back to top
View user's profile Send private message
dpetka2001
l33t
l33t


Joined: 04 Mar 2005
Posts: 804

PostPosted: Wed Sep 19, 2007 6:39 pm    Post subject: Reply with quote

has anyone met the problem i'm talking about in my previous post?? for some reason dep doesn't seem to recognize mplayer as part of the world file and wants to remove it along with its dependencies...though "emerge --depclean" doesn't seem to have this kind of problem...
Back to top
View user's profile Send private message
dpetka2001
l33t
l33t


Joined: 04 Mar 2005
Posts: 804

PostPosted: Mon Sep 24, 2007 11:22 pm    Post subject: Reply with quote

anyone has dealt with issues like i described in my previous posts lately??
Back to top
View user's profile Send private message
anton_kg
Tux's lil' helper
Tux's lil' helper


Joined: 10 Feb 2007
Posts: 90
Location: Singapore

PostPosted: Thu Sep 27, 2007 6:31 am    Post subject: Reply with quote

Hi.

I've been for a while with gentoo and suspect that some packages might get "lost" in slots.
Here is the output of duplicated packages:

Code:

bash # equery l -d
[ Searching for all packages in all categories among: ]
 * installed packages
[I--] [  ] app-crypt/gnupg-1.4.7-r1 (0)
[I--] [  ] app-crypt/gnupg-1.9.21 (1.9)
[I--] [  ] dev-java/java-config-1.3.7 (0)
[I--] [  ] dev-java/java-config-2.0.33-r1 (2)
[I--] [  ] net-libs/libnet-1.0.2a-r3 (1.0)
[I--] [  ] net-libs/libnet-1.1.2.1-r1 (1.1)
[I--] [  ] sys-devel/autoconf-2.13 (2.1)
[I--] [  ] sys-devel/autoconf-2.61-r1 (2.5)
[I--] [  ] sys-devel/automake-1.4_p6 (1.4)
[I--] [  ] sys-devel/automake-1.5 (1.5)
[I--] [  ] sys-devel/automake-1.6.3 (1.6)
[I--] [  ] sys-devel/automake-1.7.9-r1 (1.7)
[I--] [  ] sys-devel/automake-1.8.5-r3 (1.8)
[I--] [  ] sys-devel/automake-1.9.6-r2 (1.9)
[I--] [  ] sys-devel/automake-1.10 (1.10)
[I--] [  ] sys-libs/db-1.85-r3 (1)
[I--] [  ] sys-libs/db-3.2.9-r11 (3)
[I--] [  ] sys-libs/db-4.2.52_p4-r2 (4.2)
[I--] [  ] sys-libs/db-4.3.29-r2 (4.3)
[I--] [  ] sys-libs/db-4.5.20_p2 (4.5)
[I--] [  ] x11-libs/qt-3.3.8-r4 (3)
[I--] [  ] x11-libs/qt-4.3.1-r1 (4)


My question is the same with everybody else. How do I verify that I do need all these packages in sufficient way?
Back to top
View user's profile Send private message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3057
Location: Redmond, WA

PostPosted: Thu Sep 27, 2007 11:33 am    Post subject: Reply with quote

anton_kg wrote:
Hi.

I've been for a while with gentoo and suspect that some packages might get "lost" in slots.
Here is the output of duplicated packages:

Code:

bash # equery l -d
[ Searching for all packages in all categories among: ]
 * installed packages
[I--] [  ] app-crypt/gnupg-1.4.7-r1 (0)
[I--] [  ] app-crypt/gnupg-1.9.21 (1.9)
[I--] [  ] dev-java/java-config-1.3.7 (0)
[I--] [  ] dev-java/java-config-2.0.33-r1 (2)
[I--] [  ] net-libs/libnet-1.0.2a-r3 (1.0)
[I--] [  ] net-libs/libnet-1.1.2.1-r1 (1.1)
[I--] [  ] sys-devel/autoconf-2.13 (2.1)
[I--] [  ] sys-devel/autoconf-2.61-r1 (2.5)
[I--] [  ] sys-devel/automake-1.4_p6 (1.4)
[I--] [  ] sys-devel/automake-1.5 (1.5)
[I--] [  ] sys-devel/automake-1.6.3 (1.6)
[I--] [  ] sys-devel/automake-1.7.9-r1 (1.7)
[I--] [  ] sys-devel/automake-1.8.5-r3 (1.8)
[I--] [  ] sys-devel/automake-1.9.6-r2 (1.9)
[I--] [  ] sys-devel/automake-1.10 (1.10)
[I--] [  ] sys-libs/db-1.85-r3 (1)
[I--] [  ] sys-libs/db-3.2.9-r11 (3)
[I--] [  ] sys-libs/db-4.2.52_p4-r2 (4.2)
[I--] [  ] sys-libs/db-4.3.29-r2 (4.3)
[I--] [  ] sys-libs/db-4.5.20_p2 (4.5)
[I--] [  ] x11-libs/qt-3.3.8-r4 (3)
[I--] [  ] x11-libs/qt-4.3.1-r1 (4)


My question is the same with everybody else. How do I verify that I do need all these packages in sufficient way?


Block one of them and do an
Code:
emerge world -epv

And see if something complains.

Honestly, most of those are definitely NOT installed by error. A whole slew of packages depend on automake and each version of automake does things differently than previous versions. The qt packages makes sense that anything with kde (asside from the unreleased version 4) uses qt3 but a lot of other qt-written crap is compatible with version 4. And db: A whole bunch of packages, again, depend on different versions of it.

But blocking them one by one then seeing what happens will tell you what depends on the version.
Back to top
View user's profile Send private message
dpetka2001
l33t
l33t


Joined: 04 Mar 2005
Posts: 804

PostPosted: Fri Sep 28, 2007 11:39 am    Post subject: Reply with quote

the problem with mplayer still remains...every time i run the program it wants to uninstall it and along some dependencies aswell...anyone??
Back to top
View user's profile Send private message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3057
Location: Redmond, WA

PostPosted: Fri Sep 28, 2007 5:21 pm    Post subject: Reply with quote

Add mplayer to your world file and dep shouldn't complain that it needs to go.

And if you don't want to go that route maybe send a PM to ecatmur since he's the guy who wrote this program.
Back to top
View user's profile Send private message
dpetka2001
l33t
l33t


Joined: 04 Mar 2005
Posts: 804

PostPosted: Fri Sep 28, 2007 5:47 pm    Post subject: Reply with quote

Code:
root@ ~ > cat /var/lib/portage/world |grep -i mplayer
media-video/mplayer
it is in the world file...that's the problem...i can't understand why udept does that...
Back to top
View user's profile Send private message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3057
Location: Redmond, WA

PostPosted: Fri Sep 28, 2007 6:12 pm    Post subject: Reply with quote

It looks like it isn't figuring out the package name/version correctly.

If you look at the output it tries to show:
category/packagename version

And for mplayer it is showing:
media-video/mplayer-1.0_rc1_p20070824 media-video/mplayer-1.0_rc1_p20070824

So it thinks the package name is media-video/mplayer-1.0_rc1_p20070824 and that is also the version.

Definitely send a message to ecatmur.
Back to top
View user's profile Send private message
jesnow
Guru
Guru


Joined: 26 Apr 2006
Posts: 449

PostPosted: Tue Nov 20, 2007 7:20 pm    Post subject: Reply with quote

I get:

Code:

!!! Cannot resolve depatom media-video/mplayer
__memoised__resolve_depatom resolve_depatom add_deps_to_required makeideal main main



buried in the output when I run dep -sp, and so mplayer and all its dependencies are on the list to be unmerged.

Jon.
Back to top
View user's profile Send private message
mroconnor
Guru
Guru


Joined: 24 Feb 2006
Posts: 402
Location: USA

PostPosted: Tue Dec 04, 2007 10:07 pm    Post subject: Reply with quote

If this is one of those dump question let me know but I am bit confused.

If I do
Code:
dep -pw
it returns this
Code:
177 packages in world:  175 valid,  2 redundant;
60 packages in system;
914 packages installed: 6% in system, 19% in world, 74% deps.


But when I do this
Code:
emerge -pve system
it tells me this
Code:

.....
[ebuild   R   ] x11-libs/qt-3.3.8-r4  USE="cups doc gif opengl -debug -examples (-firebird) -immqt -immqt-bc -ipv6 -mysql -nas -nis -odbc -postgres -sqlite -xinerama" 0 kB
[ebuild   R   ] app-doc/doxygen-1.5.4  USE="doc qt3 -debug -nodot -tetex" 0 kB
[ebuild   R   ] x11-libs/libxcb-1.1  USE="doc -debug" 0 kB
[ebuild   R   ] sys-apps/dbus-1.0.2-r2  USE="X doc -debug (-selinux)" 0 kB

Total: 210 packages (210 reinstalls), Size of downloads: 0 kB


It seems there is a big difference between 60 packages in the system that dep says and the 210 that emerge wants to emerge. Am I missing something, reading this incorrectly or something?

Thanks!
-P
Back to top
View user's profile Send private message
Ibn al-Hazardous
Tux's lil' helper
Tux's lil' helper


Joined: 02 Sep 2004
Posts: 133
Location: Somewhere deep in the desert.

PostPosted: Wed Dec 05, 2007 11:13 am    Post subject: Reply with quote

progresso wrote:
If this is one of those dump question let me know but I am bit confused.

...

It seems there is a big difference between 60 packages in the system that dep says and the 210 that emerge wants to emerge. Am I missing something, reading this incorrectly or something?

Thanks!
-P


Those 60 are the ones explicitly listed as belonging to system. When you do an emerge -pev system you get the dependencies too.
_________________
/Ibn
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 26, 27, 28, 29  Next
Page 27 of 29

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum