Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] emerge i problemy z aplikacjami pod kde
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish)
View previous topic :: View next topic  
Author Message
badzio
Tux's lil' helper
Tux's lil' helper


Joined: 16 May 2003
Posts: 144
Location: Lodz

PostPosted: Thu Feb 19, 2004 10:05 pm    Post subject: [SOLVED] emerge i problemy z aplikacjami pod kde Reply with quote

ostatnio zauwazylem dziwna rzecz.. jak probuje updatnac jakakolwiek aplikacje wspolpracujaca z kde lub jakas czesc kde - dostaje nastepujacy blad
Quote:

checking if UIC has KDE plugins available... no
configure: error: you need to install kdelibs first.
died running ./configure, kde_src_compile:configure
*
* Your KDE program installation died while running the configure script
*

!!! ERROR: kde-base/kdenetwork-3.2.0 failed.
!!! Function configure_die, Line 170, Exitcode 0
!!! (no error message)

podobnie dzieje sie w przypadku update'owania kdenetwork, k3b, kdevelop itp...
ale...
Quote:

localhost root # emerge -p kdelibs

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild R ] kde-base/kdelibs-3.2.0

zatem kdelibs jest zainstalowane. malo tego - z kde korzystam od dawna - wszystko dziala ok. ale w zwiazku z tymi bledami pomyslalem, ze moze musze updatnac sobie kde - oto wyniki badan:
Quote:

localhost root # emerge -up kde

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild U ] media-libs/svgalib-1.9.17-r3 [1.4.3-r4]
[ebuild U ] media-sound/xmms-1.2.8-r4 [1.2.7-r20]
[ebuild N ] kde-base/kdenetwork-3.2.0
[ebuild N ] kde-base/kdepim-3.2.0-r2
[ebuild U ] media-sound/mpg123-0.59s-r2 [0.59r-r3]
[ebuild N ] media-libs/xine-lib-1_rc2
[ebuild N ] media-libs/taglib-1.0
[ebuild N ] media-libs/musicbrainz-2.0.1
[ebuild N ] media-video/xanim-2.80.1-r4
[ebuild N ] kde-base/kdemultimedia-3.2.0
[ebuild N ] kde-base/kdeaddons-3.2.0
[ebuild N ] media-libs/t1lib-5.0.0-r2
[ebuild U ] app-text/xpdf-2.03 [2.02.1]
[ebuild N ] kde-base/kdegraphics-3.2.0
[ebuild N ] kde-base/kdeedu-3.2.0
[ebuild N ] kde-base/kdetoys-3.2.0
[ebuild N ] kde-base/kdeutils-3.2.0
[ebuild N ] kde-base/kdeaccessibility-3.2.0
[ebuild N ] kde-base/kdeadmin-3.2.0
[ebuild N ] kde-base/kdeartwork-3.2.0
[ebuild N ] kde-base/kdegames-3.2.0
[ebuild N ] kde-base/kde-3.2.0

co u diabla? normalnie korzystam z kde, wczesniej system stwierdzal ze jest zainstalowane - a teraz mowi ze nie jest 8O
koniec koncow - nie moga update'owac zadnej aplikacji kde:(
_________________
gouranga;-)


Last edited by badzio on Fri Feb 20, 2004 5:00 pm; edited 1 time in total
Back to top
View user's profile Send private message
roonek
n00b
n00b


Joined: 07 Feb 2004
Posts: 31

PostPosted: Fri Feb 20, 2004 1:46 am    Post subject: Re: emerge i problemy z aplikacjami pod kde Reply with quote

Quote:
!!! ERROR: kde-base/kdenetwork-3.2.0 failed.
!!! Function configure_die, Line 170, Exitcode 0
!!! (no error message)



ja dostaje tak komunikat przy kompilacji arts

!!! ERROR: kde-base/arts-1.1.5 failed.
!!! Function configure_die, Line 170, Exitcode 0
!!! (no error message)

moze ktos wie co jest nie tak ?
bo nie moge sobie kde 3.2 skompilowac ;)

dzieki
_________________
Pozdrawiam
Back to top
View user's profile Send private message
mirekm
Apprentice
Apprentice


Joined: 12 Feb 2004
Posts: 158
Location: Gliwice

PostPosted: Fri Feb 20, 2004 6:40 am    Post subject: Reply with quote

Problem polega na tym, że ebuildy są zrobione dla KDE 3.1.

Odpowiem na przykładzie krusadera:

przy zainstalowanym KDE 3.2 się nie kompiluje, bo nie może znaleźć kdelibs-3.1xxx. Ale jeśli wyedytować ebuilda i zmienić 8 i 9 linijkę:

need kde-3.1
KDEDIR=${KDEDIR/3.2/3.1}

na:

need kde-3
#KDEDIR=${KDEDIR/3.2/3.1}

to jest dobrze. Zatem popróbuj.
Back to top
View user's profile Send private message
badzio
Tux's lil' helper
Tux's lil' helper


Joined: 16 May 2003
Posts: 144
Location: Lodz

PostPosted: Fri Feb 20, 2004 11:41 am    Post subject: Reply with quote

niestety :(
Quote:

checking for KDE... libraries /usr/kde/3.2/lib, headers /usr/kde/3.2/include
checking if UIC has KDE plugins available... no
configure: error: you need to install kdelibs first.
died running ./configure, kde_src_compile:configure

pzoa tym - nie czaje czemu system wykrywa ze nie ma kde zainstalowanego :?:
_________________
gouranga;-)
Back to top
View user's profile Send private message
no4b
Bodhisattva
Bodhisattva


Joined: 18 Jan 2004
Posts: 774
Location: Tarnów, Poland

PostPosted: Fri Feb 20, 2004 2:59 pm    Post subject: Reply with quote

Po upgrade qt do 3.3.0 trzeba przebudowac kdelibs i dopioero mielic reszte.
Back to top
View user's profile Send private message
badzio
Tux's lil' helper
Tux's lil' helper


Joined: 16 May 2003
Posts: 144
Location: Lodz

PostPosted: Fri Feb 20, 2004 5:00 pm    Post subject: Reply with quote

thx, pomoglo 8)
_________________
gouranga;-)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum