Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Iptables na instalação GRP
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
flaviomlopes
n00b
n00b


Joined: 22 Jan 2004
Posts: 18
Location: Rio de Janeiro / Brasil

PostPosted: Wed Feb 11, 2004 5:12 pm    Post subject: Iptables na instalação GRP Reply with quote

Fiz uma instalação GRP mas estou com dificuldades para rodar o iptables. Inicialmente, não foi instalado o módulo ip_tables.
Pesquisando muito nos forums apliquei uma possível solução:
- rodei o make menuconfig;
- marquei (M) os módulos correspondentes ao iptables;
- fiz make dep && make clean bzImage modules modules_install;
Após isso, passou a acusar erros de unresolved simbol.
Se alguém tiver a solução eu agradeço penhoradamente.
Back to top
View user's profile Send private message
fernandotcl
Veteran
Veteran


Joined: 20 Nov 2003
Posts: 1396
Location: Sao Paulo, Brazil

PostPosted: Wed Feb 11, 2004 5:19 pm    Post subject: Reply with quote

Se os erros apareceram na compilção do kernel, esteja certo de que o link
"/usr/src/linux" está apontando pro lugar certo.
Back to top
View user's profile Send private message
flaviomlopes
n00b
n00b


Joined: 22 Jan 2004
Posts: 18
Location: Rio de Janeiro / Brasil

PostPosted: Sat Feb 14, 2004 7:39 pm    Post subject: Reply with quote

Recapitulando, após a instalação da base do sistema, frisando que é uma instalação GRP, apenas instalando o que estava no CD, sem baixar nada, e compilando o kernel através do genkernel, tentava rodar o iptables e obtinha uma mensagem de erro mais ou menos assim:

iptables v1.2.8: can't initialize iptables table `filter': Table \
does not exist (do you need to insmod?)
Perhaps iptables or your kernel needs to be upgraded.

Pesquisando nos forums, encontrei uma questão de cerca de um ano atrás onde a solução apontada foi rodar o make menuconfig, setando todos os módulos da seção netfilter, e após recompilar (make dep && make clean bzImage modules modules_install) e copiar a imagem para /boot. Assim fiz, e ao rodar o iptables passou a acusar o seguinte erro:

/lib/modules/2.4.22/kernel/net/ipv4/netfilter/ip_tables.o: unresolved symbol nf_unregister_sockopt
/lib/modules/2.4.22/kernel/net/ipv4/netfilter/ip_tables.o: unresolved symbol nf_register_sockopt

comandando modules-update, a msg de erro é a mesma para todos os demais módulos do netfilter.

outros módulos adicionais que aproveitei para inserir, como p.ex. o dispositivo para a minha placa de rede, rodam sem problemas.

Reformatei e reisntalei n vezes, com o gentto-sources e com o vanilla-sources, com os mesmos resultados.
Assim, não me parece que o problema tenha a ver com o referido link mas sim com a falta de algum outro módulo misterioso.
Espero que alguém tenha a solução.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum