Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ebuild/portage, igjen
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Scandinavian
View previous topic :: View next topic  
Author Message
andip
Tux's lil' helper
Tux's lil' helper


Joined: 18 Jun 2002
Posts: 115
Location: .no

PostPosted: Sat Feb 07, 2004 11:53 pm    Post subject: ebuild/portage, igjen Reply with quote

Heisan,

Jeg har og har hatt gjentagende problemer med portage/ebuild i det siste.

Når jeg uppgraderer til portage 2.0.50, så slutter det meste ved emerge å virke.

***********************************
emerge -up cracklib pwdb libvorbis XML-Parser intltool xmms pam ncftp cdrdao pam-login hashalot util-linux procps iptables pango mozilla findutils sox k3b

These are the packages that I would merge, in order:

Calculating dependencies |has_version() in global scope: sys-apps/util-linux-2.11z-r8
|/usr/sbin/ebuild.sh: /usr/portage/media-libs/fontconfig/fontconfig-2.2.1.ebuild: line 108: unexpected EOF while looking for matching ``'
/usr/sbin/ebuild.sh: /usr/portage/media-libs/fontconfig/fontconfig-2.2.1.ebuild: line 109: syntax error: unexpected end of file

!!! ERROR: media-libs/fontconfig-2.2.1 failed.
!!! Function , Line 1291, Exitcode 1
!!! error sourcing ebuild


aux_get(): (0) Error in media-libs/fontconfig-2.2.1 ebuild. (1)
Check for syntax error or corruption in the ebuild. (--debug)


!!! all ebuilds that could satisfy ">=media-libs/fontconfig-2" have been masked.
!!! possible candidates are:
- media-libs/fontconfig-2.1-r1 (masked by: )
/usr/sbin/ebuild.sh: /usr/portage/media-libs/fontconfig/fontconfig-2.2.1.ebuild: line 108: unexpected EOF while looking for matching ``'
/usr/sbin/ebuild.sh: /usr/portage/media-libs/fontconfig/fontconfig-2.2.1.ebuild: line 109: syntax error: unexpected end of file

!!! ERROR: media-libs/fontconfig-2.2.1 failed.
!!! Function , Line 1291, Exitcode 1
!!! error sourcing ebuild


aux_get(): (0) Error in media-libs/fontconfig-2.2.1 ebuild. (1)
Check for syntax error or corruption in the ebuild. (--debug)

- media-libs/fontconfig-2.2.0-r2 (masked by: )
!!! (dependency required by "x11-libs/pango-1.2.5-r1" [ebuild])

!!! Error calculating dependencies. Please correct.
***************************************
får mer eller mindre samme feilmelding dersom jeg bruker emerge -vu(p) world.

Har et lignende problem på en annen box også.
Dersom jeg nedgraderer til portage 2.0.49-r21 så får jeg ingen feilmelding ved emerge -vup world. Jeg får heller ikke oppdatert noe uten å oppdatere portage, og da er jeg tilbake der jeg startet.

OPPDATERING:
Kjører emerge -u world nå. Det lot seg gjøre ved å slette .ebuild-filene med påstått feil.

Lurer fortsatt på hva dette kan skyldes, så om noen har en teori, feel free :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Scandinavian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum