Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ALSA: snd-via82xx som no XMMS fica pipocando - resolvido
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
domus-br
Apprentice
Apprentice


Joined: 27 May 2003
Posts: 292
Location: Niterói-RJ,Brasil

PostPosted: Wed Feb 04, 2004 12:25 pm    Post subject: ALSA: snd-via82xx som no XMMS fica pipocando - resolvido Reply with quote

olá pessoal,

gostaria de saber pq acotence isso, é simplesmente horrivel ouvir mp3 com um som de pipoca estourando ao fundo, isso nao ocorre somente no XMMS, mas em qualquer outro aplicativo, mas no XMMS é com mais frequencia (estou usando a saida ALSA no xmms)

os procedimentos que fiz foram; instalar o alsa-driver, lib e utils, e logo em seguida, carreguei os modulos:

modprobe snd-via82xx
e
modprobe snd-pcm-oss

tem algum procedimento especifico para se configurar o alsa no gentoo eliminando esses ruidos desagradaveis??

minha placa é on-board VT82C686 AC97 audio controler


t+
_________________
http://www.mozilla.org.br

"Este site só funciona com browser IE 5 ou superior"
O Mozilla é superior!!
:=:=:=:=:=:
Forumgdh
LinuxBsd


Last edited by domus-br on Wed Feb 04, 2004 10:58 pm; edited 1 time in total
Back to top
View user's profile Send private message
Festrati
Tux's lil' helper
Tux's lil' helper


Joined: 30 Jan 2003
Posts: 105
Location: Brasil

PostPosted: Wed Feb 04, 2004 2:43 pm    Post subject: Reply with quote

Ola...

o seguinte eu tenho a mesma placa aqui..

so que com o kernel - gentoo-sources 2.4.24
e funciona na boa...

eu soube de problemas desse driver com o kernel 2.6 -

qual o kernel que vc estah usando?
Back to top
View user's profile Send private message
nafre
Guru
Guru


Joined: 27 Dec 2003
Posts: 388

PostPosted: Wed Feb 04, 2004 3:17 pm    Post subject: Reply with quote

quem sabe o problema poderá ser nas caixas de som já tentou verificar isto!
_________________
Nome- Felipe
Nick- Nafre
Idade- 25
Salvador - Bahia - Brasil
Back to top
View user's profile Send private message
domus-br
Apprentice
Apprentice


Joined: 27 May 2003
Posts: 292
Location: Niterói-RJ,Brasil

PostPosted: Wed Feb 04, 2004 4:10 pm    Post subject: Reply with quote

nafre wrote:
quem sabe o problema poderá ser nas caixas de som já tentou verificar isto!


acredito que nao seja, pq eu antes de trocar a placa mae, usava aquele modulo trident pra funcionar o som da SIS on-board e saia normal
_________________
http://www.mozilla.org.br

"Este site só funciona com browser IE 5 ou superior"
O Mozilla é superior!!
:=:=:=:=:=:
Forumgdh
LinuxBsd
Back to top
View user's profile Send private message
domus-br
Apprentice
Apprentice


Joined: 27 May 2003
Posts: 292
Location: Niterói-RJ,Brasil

PostPosted: Wed Feb 04, 2004 4:13 pm    Post subject: Reply with quote

Festrati wrote:
Ola...

o seguinte eu tenho a mesma placa aqui..

so que com o kernel - gentoo-sources 2.4.24
e funciona na boa...

eu soube de problemas desse driver com o kernel 2.6 -

qual o kernel que vc estah usando?


eu tenho compilado o 2.4.20, e tenho certeza que o modulo dessa placa esta habilitado mesmo assim, ele nao carrega diz que nao é possivel encontrar o modulo, vou tentar compilar o kernel da serie 2.4.x mais novo ou 2.4.24 e ver se resolve, outra coisa vc esta usando como modulo ou esta nativo?
_________________
http://www.mozilla.org.br

"Este site só funciona com browser IE 5 ou superior"
O Mozilla é superior!!
:=:=:=:=:=:
Forumgdh
LinuxBsd


Last edited by domus-br on Wed Feb 04, 2004 4:23 pm; edited 1 time in total
Back to top
View user's profile Send private message
fernandotcl
Veteran
Veteran


Joined: 20 Nov 2003
Posts: 1396
Location: Sao Paulo, Brazil

PostPosted: Wed Feb 04, 2004 4:18 pm    Post subject: Reply with quote

Eu também tenho alguns problemas com o driver via82xx. Uso o driver ALSA embutido no kernel 2.6.0, e sempre que ouço música no XMMS ouço um ruído e às vezes esse "pipocamento". Eu acho que é problema no driver.
Back to top
View user's profile Send private message
domus-br
Apprentice
Apprentice


Joined: 27 May 2003
Posts: 292
Location: Niterói-RJ,Brasil

PostPosted: Wed Feb 04, 2004 10:56 pm    Post subject: Reply with quote

ola pessoal venho informar a todos o seguinte, acabei de compilar o kernel 2.4.24 certifiquei e habilitei o som como modulo, abri mao do alsa e posso dizer que o som esta agora perfeito, sem ruidos e nem mesmo "pipocamento" ta excelente obrigado a todos pelas dicas!! :) 8)
_________________
http://www.mozilla.org.br

"Este site só funciona com browser IE 5 ou superior"
O Mozilla é superior!!
:=:=:=:=:=:
Forumgdh
LinuxBsd
Back to top
View user's profile Send private message
fernandotcl
Veteran
Veteran


Joined: 20 Nov 2003
Posts: 1396
Location: Sao Paulo, Brazil

PostPosted: Wed Feb 04, 2004 11:14 pm    Post subject: Reply with quote

Abriu mão do ALSA? Tá usando OSS?

Eu continuo com o chiado no XMMS com ALSA embutido no kernel... :(
Back to top
View user's profile Send private message
domus-br
Apprentice
Apprentice


Joined: 27 May 2003
Posts: 292
Location: Niterói-RJ,Brasil

PostPosted: Wed Feb 04, 2004 11:20 pm    Post subject: Reply with quote

fernandotcl wrote:
Abriu mão do ALSA? Tá usando OSS?

Eu continuo com o chiado no XMMS com ALSA embutido no kernel... :(


bom o OSS nao é aquele comercial?

bom to usando nativo do kernel 2.4.24 mesmo

Quote:
modprobe via82cxxx_audio


pelo menos este se mostrou bem melhor que do alsa
_________________
http://www.mozilla.org.br

"Este site só funciona com browser IE 5 ou superior"
O Mozilla é superior!!
:=:=:=:=:=:
Forumgdh
LinuxBsd
Back to top
View user's profile Send private message
fernandotcl
Veteran
Veteran


Joined: 20 Nov 2003
Posts: 1396
Location: Sao Paulo, Brazil

PostPosted: Wed Feb 04, 2004 11:47 pm    Post subject: Reply with quote

domus-br wrote:
fernandotcl wrote:
Abriu mão do ALSA? Tá usando OSS?

Eu continuo com o chiado no XMMS com ALSA embutido no kernel... :(


bom o OSS nao é aquele comercial?

bom to usando nativo do kernel 2.4.24 mesmo

Quote:
modprobe via82cxxx_audio


pelo menos este se mostrou bem melhor que do alsa


Eu acho que é esse mesmo. Parece que não é mais comercial, ou a licensa é bem "flexível".

O ALSA "deveria" ser melhor que o OSS. Pelo menos essa era a idéia. Eu nunca tive problemas no kernel 2.4.x, mas agora com os drivers do kernel não tem dado muito certo...

Vou tentar compilar os drivers como módulo, como o site oficial do projeto recomenda, e depois posto os resultados.
Back to top
View user's profile Send private message
fernandotcl
Veteran
Veteran


Joined: 20 Nov 2003
Posts: 1396
Location: Sao Paulo, Brazil

PostPosted: Thu Feb 05, 2004 6:26 pm    Post subject: Reply with quote

Compilei o driver como módulo, e parece que não há mais problemas. Não há mais cortes no som com o XMMS e nem em nenhum outro programa :D.
Back to top
View user's profile Send private message
Festrati
Tux's lil' helper
Tux's lil' helper


Joined: 30 Jan 2003
Posts: 105
Location: Brasil

PostPosted: Thu Feb 05, 2004 6:36 pm    Post subject: Reply with quote

alguns programs são cheio de coisas mesmo...

o rithmbox aqui roda pipocando ja o xmms não :)

entranho

agora com a live (emu10k1) roda que e uma baleza com qq um...

vai saber
Back to top
View user's profile Send private message
domus-br
Apprentice
Apprentice


Joined: 27 May 2003
Posts: 292
Location: Niterói-RJ,Brasil

PostPosted: Thu Feb 05, 2004 6:38 pm    Post subject: Reply with quote

fernandotcl wrote:
Compilei o driver como módulo, e parece que não há mais problemas. Não há mais cortes no som com o XMMS e nem em nenhum outro programa :D.


boa noticia cara!

mas foi modulo do kernel? qual serie?
_________________
http://www.mozilla.org.br

"Este site só funciona com browser IE 5 ou superior"
O Mozilla é superior!!
:=:=:=:=:=:
Forumgdh
LinuxBsd
Back to top
View user's profile Send private message
fernandotcl
Veteran
Veteran


Joined: 20 Nov 2003
Posts: 1396
Location: Sao Paulo, Brazil

PostPosted: Thu Feb 05, 2004 6:42 pm    Post subject: Reply with quote

É o 2.6.2...
Back to top
View user's profile Send private message
Scirious
Tux's lil' helper
Tux's lil' helper


Joined: 19 Jan 2004
Posts: 75
Location: Brazil

PostPosted: Thu Feb 05, 2004 6:44 pm    Post subject: Reply with quote

Bem, o problema não é com a série do kernel. Essa é uma placa da Analog Devices (uma que vem on-board na placa da ASUS, não?) e o som do ALSA com ela é bem sujo, bem pobre. O OSS possue drivers melhores para essa placa, cujo som sai limpo e sem ruido.

Scirious.
Back to top
View user's profile Send private message
domus-br
Apprentice
Apprentice


Joined: 27 May 2003
Posts: 292
Location: Niterói-RJ,Brasil

PostPosted: Thu Feb 05, 2004 6:47 pm    Post subject: Reply with quote

Scirious wrote:
Bem, o problema não é com a série do kernel. Essa é uma placa da Analog Devices (uma que vem on-board na placa da ASUS, não?) e o som do ALSA com ela é bem sujo, bem pobre. O OSS possue drivers melhores para essa placa, cujo som sai limpo e sem ruido.

Scirious.


por exempo, eu resolvi meu problema usando o modulo presente na serie 2.4.x, por acaso este mesmo modulo se encontra na serie 2.6.x? estou confundindo que nessa serie do kernel 2.6.x o pessoal optou pelos drivers ALSA, so preciso dessa confirmaçao pq ai, ja quero por um kernel melhor, sem dar treta no meu som e com DMA da placa, pois o 2.4.24 simplesmente desativa
_________________
http://www.mozilla.org.br

"Este site só funciona com browser IE 5 ou superior"
O Mozilla é superior!!
:=:=:=:=:=:
Forumgdh
LinuxBsd
Back to top
View user's profile Send private message
fernandotcl
Veteran
Veteran


Joined: 20 Nov 2003
Posts: 1396
Location: Sao Paulo, Brazil

PostPosted: Thu Feb 05, 2004 6:48 pm    Post subject: Reply with quote

Scirious wrote:
Bem, o problema não é com a série do kernel. Essa é uma placa da Analog Devices (uma que vem on-board na placa da ASUS, não?)


Exato, a minha é a A7V8X.

Scirious wrote:
e o som do ALSA com ela é bem sujo, bem pobre. O OSS possue drivers melhores para essa placa, cujo som sai limpo e sem ruido.


Interessante, com o driver ALSA como módulo o som está bem limpo.
Back to top
View user's profile Send private message
fernandotcl
Veteran
Veteran


Joined: 20 Nov 2003
Posts: 1396
Location: Sao Paulo, Brazil

PostPosted: Thu Feb 05, 2004 6:49 pm    Post subject: Reply with quote

domus-br wrote:
Scirious wrote:
Bem, o problema não é com a série do kernel. Essa é uma placa da Analog Devices (uma que vem on-board na placa da ASUS, não?) e o som do ALSA com ela é bem sujo, bem pobre. O OSS possue drivers melhores para essa placa, cujo som sai limpo e sem ruido.

Scirious.


por exempo, eu resolvi meu problema usando o modulo presente na serie 2.4.x, por acaso este mesmo modulo se encontra na serie 2.6.x? estou confundindo que nessa serie do kernel 2.6.x o pessoal optou pelos drivers ALSA, so preciso dessa confirmaçao pq ai, ja quero por um kernel melhor, sem dar treta no meu som e com DMA da placa, pois o 2.4.24 simplesmente desativa


Os kernels 2.6 vêm com ALSA, mas também com OSS. Basta desativar ALSA e habilitar OSS, que está descrito como "deprecated".
Back to top
View user's profile Send private message
domus-br
Apprentice
Apprentice


Joined: 27 May 2003
Posts: 292
Location: Niterói-RJ,Brasil

PostPosted: Thu Feb 05, 2004 6:57 pm    Post subject: Reply with quote

fernandotcl wrote:
domus-br wrote:
Scirious wrote:
Bem, o problema não é com a série do kernel. Essa é uma placa da Analog Devices (uma que vem on-board na placa da ASUS, não?) e o som do ALSA com ela é bem sujo, bem pobre. O OSS possue drivers melhores para essa placa, cujo som sai limpo e sem ruido.

Scirious.


por exempo, eu resolvi meu problema usando o modulo presente na serie 2.4.x, por acaso este mesmo modulo se encontra na serie 2.6.x? estou confundindo que nessa serie do kernel 2.6.x o pessoal optou pelos drivers ALSA, so preciso dessa confirmaçao pq ai, ja quero por um kernel melhor, sem dar treta no meu som e com DMA da placa, pois o 2.4.24 simplesmente desativa


Os kernels 2.6 vêm com ALSA, mas também com OSS. Basta desativar ALSA e habilitar OSS, que está descrito como "deprecated".


esse entao que vem na serie 2.4.x é OSS?
_________________
http://www.mozilla.org.br

"Este site só funciona com browser IE 5 ou superior"
O Mozilla é superior!!
:=:=:=:=:=:
Forumgdh
LinuxBsd
Back to top
View user's profile Send private message
fernandotcl
Veteran
Veteran


Joined: 20 Nov 2003
Posts: 1396
Location: Sao Paulo, Brazil

PostPosted: Thu Feb 05, 2004 7:00 pm    Post subject: Reply with quote

Que eu saiba sim :D.
Back to top
View user's profile Send private message
jcarlos
n00b
n00b


Joined: 13 Sep 2003
Posts: 70
Location: Sao Paulo/SP - Brazil

PostPosted: Fri Feb 06, 2004 3:20 am    Post subject: Reply with quote

Boas :P

Após atualizar meu kde /p 3.2 tive problemas /c o som que começou a ter um chiado horrível no fundo, estou usando kernel gaming-source-2.4.20-r7 e os drivers alsa e uma placa Ensoniq 1371, anteriormente estava tudo funcionando perfeito. Depios de quebrar a cabeça mexer em varias coisas percebí ser um problema no kmix, me parece que ele mexe e habilita umas coisas que trazem o chiado, aqui no meu caso o que estava habilitado era "sigmatel" ,no kmix do kde3.2 eu marquei o avançadas e fui mexendo em tudo que tinha até descobrir que o tal sigmatel estava ocasionando o chiado. Deixando ele mudo o som ficou perfeito de novo.. e ainda habilitei uns controles em 3d que tinham e deixaram o som melhor ainda..
_________________
--------------------------------
João Medrado
http://blog.joaomedrado.com
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum