Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Como ter o Gentoo todo (ou quase) em pt_BR ?
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
domus-br
Apprentice
Apprentice


Joined: 27 May 2003
Posts: 292
Location: Niterói-RJ,Brasil

PostPosted: Wed Jan 28, 2004 12:12 pm    Post subject: Reply with quote

nafre wrote:
no meu X a tecla que era pra ser o } e ou ] esta trocada pelo | e ou \.

alguma sugestao:?::?:


seu teclado é US internacional ou ABNT2?
_________________
http://www.mozilla.org.br

"Este site só funciona com browser IE 5 ou superior"
O Mozilla é superior!!
:=:=:=:=:=:
Forumgdh
LinuxBsd
Back to top
View user's profile Send private message
AngusYoung
Retired Dev
Retired Dev


Joined: 20 Dec 2002
Posts: 473
Location: Campinas, SP - Brazil

PostPosted: Wed Jan 28, 2004 4:50 pm    Post subject: Reply with quote

domus-br wrote:
AngusYoung wrote:
Gnome: permite que você selecione o idioma a partir do gdm.



se o locale ja estiver setado como pt-BR nem chega ser necessario :)

Tem certeza? Eu sempre precisei configurar o Gnome para pt_BR a partir do GDM.
emaia wrote:

O Gnome já pega do locale como foi dito pelo domus.

E onde eu configuro o teclado br-abnt2 no para o modo texto?
No X tudo bem, mas pra console não consgui.


Isso você configura no arquivo /etc/rc.conf, dentro da seção KEYMAP. A minha está assim:
Code:
KEYMAP="br-abnt2"


Não esqueça de configurar, também, o CONSOLEFONT. No meu caso:
Code:
CONSOLEFONT="lat1-14"


nafre wrote:
no meu X a tecla que era pra ser o } e ou ] esta trocada pelo | e ou \.

alguma sugestao:?:


Se apenas essas duas teclas estiverem trocadas, você pode usar o xev para descobrir o keycode delas e depois remapea-las usando o xmodmap. Se mais teclas estiverem erradas, aí o jeito é reconfigurar o seu X.
_________________
N.U.S.: A cross platform C++ application development framework
My blog (in Portuguese)
Back to top
View user's profile Send private message
domus-br
Apprentice
Apprentice


Joined: 27 May 2003
Posts: 292
Location: Niterói-RJ,Brasil

PostPosted: Wed Jan 28, 2004 4:59 pm    Post subject: Reply with quote

AngusYoung wrote:
Tem certeza? Eu sempre precisei configurar o Gnome para pt_BR a partir do GDM.


sim, inclusive o GDM ja me recepciona dando boas vindas em pt_BR
_________________
http://www.mozilla.org.br

"Este site só funciona com browser IE 5 ou superior"
O Mozilla é superior!!
:=:=:=:=:=:
Forumgdh
LinuxBsd
Back to top
View user's profile Send private message
AngusYoung
Retired Dev
Retired Dev


Joined: 20 Dec 2002
Posts: 473
Location: Campinas, SP - Brazil

PostPosted: Wed Jan 28, 2004 5:09 pm    Post subject: Reply with quote

domus-br wrote:
AngusYoung wrote:
Tem certeza? Eu sempre precisei configurar o Gnome para pt_BR a partir do GDM.


sim, inclusive o GDM ja me recepciona dando boas vindas em pt_BR

Show! Não costumo usar DEs/WMs em pt_BR, mas preciso mostrar isso para os meus amigos!
_________________
N.U.S.: A cross platform C++ application development framework
My blog (in Portuguese)
Back to top
View user's profile Send private message
nafre
Guru
Guru


Joined: 27 Dec 2003
Posts: 388

PostPosted: Fri Jan 30, 2004 1:32 pm    Post subject: Reply with quote

Quote:

Se apenas essas duas teclas estiverem trocadas, você pode usar o xev para descobrir o keycode delas e depois remapea-las usando o xmodmap. Se mais teclas estiverem erradas, aí o jeito é reconfigurar o seu X.


Apenas estas duas teclas nao estão funcionando. Mais o que acontece é que eu não sei usar esse xev nem o xmodmap.
Tem como dá uma ajuda básica ae!

VLw! :?: :!: :)
_________________
Nome- Felipe
Nick- Nafre
Idade- 25
Salvador - Bahia - Brasil
Back to top
View user's profile Send private message
fernandotcl
Veteran
Veteran


Joined: 20 Nov 2003
Posts: 1396
Location: Sao Paulo, Brazil

PostPosted: Fri Jan 30, 2004 2:16 pm    Post subject: Reply with quote

man xev && man modmap :D

Brincadeira... Abre um terminal e digita xev. Aperta a tecla que não tá funcionando. Vai aparecer um keycode, anóte-o. Faça o mesmo com a outra. Depois vc digita:

Code:
xmodmap -e keycode <keycode> = "("


E a mesma coisa com a outra.

[EDIT] Tem um geito de fazer um script com os comandos para serem executados simplesmente jogando o arquivo como argunmento, mas não sei direito, tem que ler o man...

Como são só duas teclas, coloca os comandos no ~/.xinitrc, é mais prático. [/EDIT]
Back to top
View user's profile Send private message
dmvianna
l33t
l33t


Joined: 22 Mar 2004
Posts: 742
Location: Down Underland

PostPosted: Thu Jul 22, 2004 12:36 pm    Post subject: Reply with quote

Oi. Eu tenho o X configurado para o teclado "us-acentos", e todos funcionam, menos o cedilha. Supostamente o cedilha seria '+c, mas o resultado é ć. :?
Alguém tem alguma idéia?
_________________
Proprietary is theft. Pierre-Joseph Proudhon, if he had a chance
Powered by a MacBook Pro
Back to top
View user's profile Send private message
felmasper
n00b
n00b


Joined: 16 Apr 2005
Posts: 1

PostPosted: Sat Apr 16, 2005 4:15 am    Post subject: Reply with quote

fernandotcl wrote:
nafre wrote:
vou testar aqui tambem mais estas variaveis vai mudar apenas as mensagens da bash e o que mais :?: :?: :evil:


LESS_CHARSET muda o charset à ser usado.
LC_ALL muda tudo que usa glibc. Muda convenções do tipo: formato de hora, formato de moeda, etc.
LANG=pt_BR eu acho que muda o bash :?:


Na verdade, não tem sublinhado: é LESSCHARSET. Além disso essa variável só se refere ao programa LESS.

Digite 'locale' para ver as variáveis i18n. Para saber dos detalhes de cada uma, man locale. Para continuar o assunto, Importa que delas se distinguem LANG e LC_ALL.

* LANG define um padrão para as variáveis que não têm valor.

* LC_ALL ajusta todas as variáveis de uma vez só (sobreescrevendo-as todas).

Portanto:
LANG=en_US.UTF-8
LC_CTYPE=pt_BR.UTF-8

Vai ajustar a variável LC_CTYPE para pt_BR.UTF-8 e todas as outras para en_US.UTF-8. BTW, com esse ajuste a biblioteca GTK (programas GTK incluindo mozilla) vai gerar cê cedilha em vez de cê acentuado. V. https://www.redhat.com/archives/fedora-list/2003-December/msg00145.html

Quanto a essas variáveis alterarem apenas o bash, não é verdade. Elas alteram todos os programas que usam a glibc (e qual programa que não usa? :-). Algumas bibliotecas como a GTK e a Qt podem ter esquemas mais elaborados para ajustar o locale. Por exemplo, parece que o KDE tem uma variável KDE_LANG. Mas que eu saiba essas variáveis vão ajustar o locale de todos os programas.

Neste tópico, mais pra cima, comentaram do Gentoo Way of Life de usar o /etc/env.d e o env-update. Pra mim valeu porque eu não sabia que se devia usar o arquivo 02locale. Talvez isso seja mera convenção, mas se há uma convenção, que seja adotada! Até o momento achava que devia usar o 00basic mesmo. Depois de ajustar as variáveis roda-se env-update (não confundir com etc-update). Aliás, que eu saiba, env-update gera o arquivo /etc/profile, portanto não é nada bom editá-lo manualmente, pois será sobrescrito na próxima execução de env-update. Lembrar que se deve reentrar no sistema (efetuar logout e login) para fazer valer as alterações. "source /etc/profile" vai fazer valer as alterações apenas para o shell onde o comando for executado.

Outra coisa. Alguém me confirme, mas acho que os gerenciadores de login KDM e GDM só lêem o /etc/profile depois de um certo momento da inicialização (ao contrário de um login no console, onde é o primeiro arquivo lido/executado). Isso significa que alguns programas (como os iniciados pelo .xinitrc, por exemplo) podem iniciar sem as variáveis i18n terem sido ajustadas ainda. Por exemplo, eu uso GDM e KDE; embora eu tenha as variáveis no /etc/profile, o meu KDE não fica ciente delas, pois o GDM não lê /etc/profile no início da sessão. Além disso, ambos têm esquemas próprios para definir a linguagem, que são os menus para escolha da língua.

Também o KDE e Gnome têm configurações próprias nos seus respectivos painéis de controle. Quanta coisa hein? :-)
Back to top
View user's profile Send private message
fabiano_almeida
n00b
n00b


Joined: 19 Jan 2005
Posts: 35

PostPosted: Sat Apr 16, 2005 11:04 am    Post subject: Reply with quote

pessoal eu aconselho que este topico se torne fixo,ele e de grande ajuda para aqueles naum tao esperientes com o gentoo e o linux como eu,ou pelo menos um topico que centralize todas as ideias.
Back to top
View user's profile Send private message
gesiel
Apprentice
Apprentice


Joined: 13 Feb 2005
Posts: 197
Location: Brasil - Rio de Janeiro

PostPosted: Fri Apr 22, 2005 10:52 am    Post subject: Reply with quote

Eu tenho um pequeno problema (na verdade mais de um):
configuração:

Estava eu todo satisfeito com minha instalação 2004.0, só que ainda tinha o Windows na máquina. Resolvi reparticionar, formatar e colocar o /home separado. Ficou assim:
/dev/hda1 /boot
/dev/hda2 swap
/dev/hda3 /
/dev/hda4 /home

Legal, queimei o CD Minimal 2005.0 e fiz a instalação baixando da WEB. "Antes" de compilar o system, configurei no /etc/env.d/02locale:
LESS_CHARSET="iso8859"
LANG="pt_BR"
LC_ALL="pt_BR"

e como já era de costume, no /etc/profile:
LESS_CHARSET='iso8859'
LANG='pt_BR'
LC_ALL='pt_BR'

No make.conf:
LINGUAS="pt_BR"

Fiz chroot, env-update e source /etc/profile e o nano ficou em português. Legal!

Compilei o system. Para minha surpresa, tudo no bash ficou em inglês.
Para fazer um teste, alterei as cores do export do PS1 no /etc/profile

fiz source /etc/profile e as cores passaram a refletir no prompt. Bastou eu rebootar e as cores não eram aquelas que eu tinha setadas no PS1.

Depois de muitos testes, fui obrigado a colocar o .bashrc no /root pq nem o /etc/profile fazia efeito nem o /roo/.profile era lido.
Pois bem, o .bashrc resolvel parte do problema (o PS1), mas o idoma dos programas continuou em inglês.

Outro problema é que fir emerge do KDE (USE="-kdetoys -kdeedu" emerge kde) e simplesmente alguns aplicativos deixaram de ser instalados, por exemplo o KMix (multimídia) pq na árvore do portage só tem a versão 3.4 [masked].

Tb não consegui instalar o k3b. Na instalação o tempo todo aparece uma mensagem (warning) do"perl" de uma biblioteca "C" e dos locales :
LANGUAGE=(unset)
LANG="pt_BR"
LC_ALL="pt_BR"
locales não reconhecidos.

Fui lá o /etc/profile e no /etc/env.d/02locale e coloquei a bendita LANGUAGE="pt_BR". Agora aparece a mesma mensagem do perl para a biblioteca "C" e:
LANGUAGE="pt_BR"
LANG="pt_BR"
LC_ALL="pt_BR"
locales não reconhecidos.

minha configuração é:

Pentium4 1.8
512 MB RAM
HD 7200 80 GB
DVDRW
CDROM
Conexão banda larga com dhcp de roteador local

Um pequeno detalhe: tenho mais duas máquinas identicas e depois que fiz a atualização do portage para 2005.0, nas duas tb as mensagens dos programas do bash que eram em português passaram a ser em inglês.

alguém poderia dar uma idéia de como resolver pelo menos um dos problemas?
Back to top
View user's profile Send private message
Kobal
Guru
Guru


Joined: 12 Feb 2004
Posts: 323
Location: Brasil / Brazil / Brésil / Brasilien / el Brasil

PostPosted: Fri Apr 22, 2005 12:57 pm    Post subject: Reply with quote

export LC_ALL=pt_BR
export LANG=pt_BR
Back to top
View user's profile Send private message
gesiel
Apprentice
Apprentice


Joined: 13 Feb 2005
Posts: 197
Location: Brasil - Rio de Janeiro

PostPosted: Fri Apr 22, 2005 1:58 pm    Post subject: Reply with quote

eu usei desta forma:

export LANG LC_ALL LESS_CHARSET LANGUAGE

tem o mesmo efeito?
Back to top
View user's profile Send private message
gesiel
Apprentice
Apprentice


Joined: 13 Feb 2005
Posts: 197
Location: Brasil - Rio de Janeiro

PostPosted: Fri Apr 22, 2005 9:54 pm    Post subject: Reply with quote

olha o reflexo disso: não consigo instalar o k3b. Logo no prieiro pacote ele dá este erro:

* Applying mjpegtools-1.6.2-gcc34.patch ... [ ok ]
* Applying mjpegtools-1.6.2-libquicktime094.patch ... [ ok ]
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:

LANGUAGE = "pt_BR",
LC_ALL = "pt_BR",
LANG = "pt_BR"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:

LANGUAGE = "pt_BR",
LC_ALL = "pt_BR",
LANG = "pt_BR"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").

e repete várias vezes até abortar a instalação. Ao usar o comando locale aparece:

locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory

LANG=pt_BR.ISO-8859-1
LC_CTYPE="pt_BR"
LC_NUMERIC="pt_BR"
LC_TIME="pt_BR"
LC_COLLATE="pt_BR"
LC_MONETARY="pt_BR"
LC_MESSAGES="pt_BR"
LC_PAPER="pt_BR"
LC_NAME="pt_BR"
LC_ADDRESS="pt_BR"
LC_TELEPHONE="pt_BR"
LC_MEASUREMENT="pt_BR"
LC_IDENTIFICATION="pt_BR"
LC_ALL=pt_BR

e ao usar o comando locale -a aparece:

locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_COLLATE to default locale: No such file or directory
C
POSIX
pt_BR.iso88591
pt_BR.utf8


Nas instalações anteriores isto não ocorria, inclusive tenho este problema em duas máquinas e na terceira está tudo normal, ou seja, as mensagens do bash, do nano, etc. em português.

Help me please!

UPDATE:
como não estava conseguindo instalar vários aplicativos por causa deste erro, reinstalei do zero (formatei e tudo). Não funcionou! O problema voltou a aparecer.
Vou iniciar um tópico com o título mais específico.

UPDATE:
sollucionado no tópico:
https://forums.gentoo.org/viewtopic-t-328280-start-0-postdays-0-postorder-asc-highlight-.html
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum