Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Amigos, não estou conseguindo instalar o KDE
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
Scirious
Tux's lil' helper
Tux's lil' helper


Joined: 19 Jan 2004
Posts: 75
Location: Brazil

PostPosted: Sat Jan 24, 2004 3:17 am    Post subject: Amigos, não estou conseguindo instalar o KDE Reply with quote

Bem, eu estava tentando instalar o KDE e estava tendo problemas de conflitos entre duas biliotecas. Como não conseguia usar o Portage para remover a versão anterior, decidi deletar na marra o arquivo. Mas agora tenho erro de dependências. Quando executo "emerge kde" recebi o seguinte aviso:

checking if STL implementation is SGI like... no
checking if STL implementation is HP like... no
configure: error: "no known STL type found - did you forget to install libstdc++-devel ?"

!!! ERROR: kde-base/arts-1.1.5 failed.
!!! Function kde_src_compile, Line 117, Exitcode 1
!!! died running ./configure, kde_src_compile:configure

Alguém sabe qual biblioteca eu tenho que instalar para corrigir isso? Ou tem como fazer o Portage corrigir as dependências?

Grato,
Scirious.
Back to top
View user's profile Send private message
Vanquirius
Retired Dev
Retired Dev


Joined: 14 Jun 2002
Posts: 1297
Location: Ethereal plains

PostPosted: Sat Jan 24, 2004 4:46 am    Post subject: Reply with quote

Olá,

Bom, ralar a cabeca e matar o problema manualmente vai ser difícil.
Eu acho que o jeito mais simples é instalar o gentoolkit (emerge app-portage/gentoolkit) e rodar o revdep-rebuild, que re-emerge pacotes cujas bibliotecas estejam danificadas ou pacotes linkados contra bibliotecas que foram modificadas.
_________________
Hello.
Back to top
View user's profile Send private message
nafre
Guru
Guru


Joined: 27 Dec 2003
Posts: 388

PostPosted: Sat Jan 24, 2004 12:18 pm    Post subject: Reply with quote

Qual foi o comando usado para emergir o KDE?

:?:
_________________
Nome- Felipe
Nick- Nafre
Idade- 25
Salvador - Bahia - Brasil
Back to top
View user's profile Send private message
Scirious
Tux's lil' helper
Tux's lil' helper


Joined: 19 Jan 2004
Posts: 75
Location: Brazil

PostPosted: Wed Jan 28, 2004 1:32 pm    Post subject: Reply with quote

Bem, valeu a ajuda, mas encontrei em outros fóruns a solução. Eu estava usando o comando emerge kde da forma como recmenda o tutorial. O problema, na verdade, estava com as bibliotecas do gcc e reinstalar o gcc (emerge gcc) era a solução. Valeu a todos.

Scirious.
Back to top
View user's profile Send private message
domus-br
Apprentice
Apprentice


Joined: 27 May 2003
Posts: 292
Location: Niterói-RJ,Brasil

PostPosted: Wed Jan 28, 2004 1:41 pm    Post subject: Reply with quote

Scirious wrote:
Bem, valeu a ajuda, mas encontrei em outros fóruns a solução. Eu estava usando o comando emerge kde da forma como recmenda o tutorial. O problema, na verdade, estava com as bibliotecas do gcc e reinstalar o gcc (emerge gcc) era a solução. Valeu a todos.

Scirious.



olha cara valeu a dica, estava com o memso problema no outro topico, acho que agora isso ajuda a resolver


valeu

t+
_________________
http://www.mozilla.org.br

"Este site só funciona com browser IE 5 ou superior"
O Mozilla é superior!!
:=:=:=:=:=:
Forumgdh
LinuxBsd
Back to top
View user's profile Send private message
domus-br
Apprentice
Apprentice


Joined: 27 May 2003
Posts: 292
Location: Niterói-RJ,Brasil

PostPosted: Wed Jan 28, 2004 1:42 pm    Post subject: Reply with quote

:(

estou olhando aqui minha versao é esta

Quote:
sys-devel/gcc
Latest version available: 3.2.3-r3
Latest version installed: 3.2.3-r3


qual sua versao?
_________________
http://www.mozilla.org.br

"Este site só funciona com browser IE 5 ou superior"
O Mozilla é superior!!
:=:=:=:=:=:
Forumgdh
LinuxBsd
Back to top
View user's profile Send private message
Scirious
Tux's lil' helper
Tux's lil' helper


Joined: 19 Jan 2004
Posts: 75
Location: Brazil

PostPosted: Wed Jan 28, 2004 1:52 pm    Post subject: Reply with quote

O problema em si não é o número da versão, mas alguma corrupção de algma biblioteca ou erro no processo de instalação, ou mesmo deleção dessa biblioteca pela remoção de algum outro programa. Contudo, reinstalar o gcc força a reinstalação dessas bilbiotecas, corrigindo o problema.

Scirious.
Back to top
View user's profile Send private message
nafre
Guru
Guru


Joined: 27 Dec 2003
Posts: 388

PostPosted: Wed Jan 28, 2004 3:37 pm    Post subject: Reply with quote

acho que ja existe um topico sobre isso.
procura no forum :)
este com problema se não te dava o link,
_________________
Nome- Felipe
Nick- Nafre
Idade- 25
Salvador - Bahia - Brasil
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum