Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
AMD64 - The masked applications that work .. wip
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... , 16, 17, 18  Next  
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64
View previous topic :: View next topic  
Author Message
temsa
n00b
n00b


Joined: 26 Aug 2003
Posts: 27

PostPosted: Thu Jan 06, 2005 9:48 pm    Post subject: Reply with quote

stepmania-3.9-rc2 works well in 64 bit, but it _cannot- play any mp3.

The (bad but efficient) solution is to use it only with ogg files. In order to convert songs in ogg format, you can use mp32ogg (emerge mp32ogg) and a perl script in each song folder to convert

Code:

mp32ogg --delete *.mp3 && perl -pi.bak -e s/.mp3/.ogg/g *.sm ; mp32ogg --delete*.MP3 && perl -pi.bak -e s/.MP3/.MP3.ogg/g *.sm


delete the "--delete" if you want to keep original mp3s

if you want to rename recursively all mp3 in a "group" folder (like "DDR 1st mix" and things like that) put the above script in a file that you chmod 755 (I've called it DDR-mp32ogg), then edit in a text editor another script(that I've called DDR-recursive)

Code:

#!/bin/bash
for i in *; do echo $i && cd "$i" && $1 && cd .. ;done


then chmod it 755 and go in the group folder
do a
Code:

/path/to/DDR-recursive /path/to/DDR-mp32ogg


and wait until it's finished!

then start stepmania and have fun :)
_________________
Jabber: temsa@wikibot.ma.cx

http://wikibot.ma.cx : Wikibot, c'est bon, mangez-en
Back to top
View user's profile Send private message
tnt
Veteran
Veteran


Joined: 27 Feb 2004
Posts: 1182

PostPosted: Mon Jan 10, 2005 3:50 pm    Post subject: Reply with quote

seems like this works fine:

Code:
net-im/psi-0.9.3




:)
Back to top
View user's profile Send private message
kleinsimon
n00b
n00b


Joined: 24 Mar 2003
Posts: 55
Location: Deutschland Essen

PostPosted: Thu Jan 20, 2005 11:42 am    Post subject: Reply with quote

I don't know if it's already said, but zsnes works without a problem in 64 Bit.
Back to top
View user's profile Send private message
zinion
Guru
Guru


Joined: 27 Oct 2004
Posts: 541
Location: Ruhgebietshausen

PostPosted: Thu Jan 20, 2005 2:57 pm    Post subject: Reply with quote

media-video/usb-pwc-re-10-0-6a works fine on amd64.

Users of QuickCam Silver have to pass power_save=1 as a module option when using this driver.

However, it's ~x86-masked.

Submitted a request to add the ~amd64 keyword to bugzilla.
_________________
Es ist schön und warm
hier im Gentoo-Land
Back to top
View user's profile Send private message
duralinux
n00b
n00b


Joined: 14 Sep 2004
Posts: 36
Location: Minnesota

PostPosted: Mon Jan 24, 2005 10:53 pm    Post subject: Afterstep-2 Reply with quote

Hey all. I have Afterstep-2 running. I have all the emul stuff installed, so all I did was 'ACCEPT_KEYWORDS="~x86" emerge -uDv afterstep and it's up and running. I haven't played with it much, but it appears all the faetures are working nicely... and the fact that I know have 3d acceleration helps too. If anyone needs any configs let me know.
_________________
"Be prepared... that's my moto... be prepared."
Back to top
View user's profile Send private message
ArKay
n00b
n00b


Joined: 30 Nov 2003
Posts: 61

PostPosted: Wed Jan 26, 2005 1:18 am    Post subject: Reply with quote

Just emerged gimp-2.2.3 by copying and modifying the 2.2.0 ebuild file.
No problems here so far.
Back to top
View user's profile Send private message
ketjow
Guru
Guru


Joined: 01 Apr 2004
Posts: 382
Location: Krakow, Poland

PostPosted: Fri Jan 28, 2005 2:14 pm    Post subject: Reply with quote

ppracer, a clone of the legendary Tuxracer lives once more on amd64 :twisted:
Back to top
View user's profile Send private message
stefankl
n00b
n00b


Joined: 28 Nov 2002
Posts: 6

PostPosted: Sun Jan 30, 2005 12:47 am    Post subject: Reply with quote

Hi,

net-misc/sipcalc works fine for me on AMD64.


Bye
_________________
LUG-Camp 05.05.-08.05.05 in Wuppertal!
Back to top
View user's profile Send private message
oggialli
Guru
Guru


Joined: 27 May 2004
Posts: 389
Location: Finland, near Tampere

PostPosted: Sun Jan 30, 2005 9:09 am    Post subject: Reply with quote

temsa wrote:
stepmania-3.9-rc2 works well in 64 bit, but it _cannot- play any mp3.


For me it has worked since 3.9-rc2 was released wonderfully, meaning i get videos, mp3, ogg, mad.
_________________
IBM Thinkpad T42P - Gentoo Linux
Back to top
View user's profile Send private message
Corona688
Veteran
Veteran


Joined: 10 Jan 2004
Posts: 1204

PostPosted: Tue Feb 01, 2005 4:51 am    Post subject: Reply with quote

media-libs/faad2(#61528) bugfix
_________________
Petition for Better 64-bit ATI Drivers - Sign Here
http://www.petitiononline.com/atipet/petition.html
Back to top
View user's profile Send private message
erack
n00b
n00b


Joined: 19 Oct 2004
Posts: 9
Location: Lyon, France

PostPosted: Fri Feb 04, 2005 10:20 am    Post subject: Reply with quote

app-text/pdftohtml (0.36-r2) has compiled and worked fine so far.
Although I used it just twice, I haven't seen any major bug yet.
Back to top
View user's profile Send private message
Xithix
Apprentice
Apprentice


Joined: 31 Dec 2004
Posts: 228

PostPosted: Sat Feb 12, 2005 2:50 pm    Post subject: Reply with quote

fvwm-themes (~amd64) compiles and runs smoothely

xmms-spc is masked by "-amd64" ... what does THAT keyword mean?
Back to top
View user's profile Send private message
meka
Tux's lil' helper
Tux's lil' helper


Joined: 16 Dec 2003
Posts: 85
Location: Novi Sad / Vojvodina / Srbija

PostPosted: Sat Feb 12, 2005 5:43 pm    Post subject: Reply with quote

media-libs/ftgl (no tweeking at all)
media-gfx/blender-cvs (my own ebuild, will be on the bugzilla as soon as I polish it enough)
media-sound/pd (with some tweeking, will post it here when I make a patch)

Sorry if I haven't brought any news but, I couldn't read 17 pages of posts. :)
Back to top
View user's profile Send private message
My_World
Guru
Guru


Joined: 01 Sep 2003
Posts: 339
Location: Kalahari Desert

PostPosted: Sun Feb 13, 2005 2:37 pm    Post subject: Reply with quote

* media-video/linuxvideostudio [ Masked ]
Latest version available: 0.1.7
Latest version installed: 0.1.7
Size of downloaded files: 355 kB
Homepage: http://ronald.bitfreak.net/
Description: small-'n-simple GUI for the MJPEG-tools
License: GPL-2

Well, there you have it :D
ACCEPT_KEYWORDS="~x86" emerge linuxvideostudio
_________________
"Ubuntu" - an African word meaning "Gentoo is too hard for me".
Back to top
View user's profile Send private message
wiktorw
n00b
n00b


Joined: 14 Dec 2004
Posts: 39
Location: Lodz, Poland

PostPosted: Tue Feb 15, 2005 11:33 pm    Post subject: Got Jabber client Psi 0.9.3-r1 working Reply with quote

Recently I installed
Quote:
net-im/psi-0.9.3-r1

on my
Quote:
Linux ghost 2.6.10-nitro4 #4 Mon Jan 24 07:25:42 CET 2005 x86_64 AMD Athlon(tm) 64 Processor 3000+ AuthenticAMD GNU/Linux

It compiles and works flawlessly (for several days already). I think it could be given "amd64" keyword.

Cheers
_________________
Change is the only constant in the universe.
Heraclitus
Back to top
View user's profile Send private message
wolfger
Apprentice
Apprentice


Joined: 09 Jun 2003
Posts: 254
Location: New Baltimore, MI

PostPosted: Wed Feb 16, 2005 2:34 am    Post subject: Re: Partial support for games-strategy/scorched3d Reply with quote

WillerZ wrote:
I've sent two patches to the maintainers on sf.net:

http://sourceforge.net/tracker/download.php?group_id=85144&atid=575114&file_id=105574&aid=1049522
-and-
http://sourceforge.net/tracker/download.php?group_id=85144&atid=575114&file_id=105590&aid=1049577

Apply these before compiling the source tree and you'll get a version which you can play standalone.

That second link is broken. Is there anywhere else I can find it?
Back to top
View user's profile Send private message
rzZzn
Tux's lil' helper
Tux's lil' helper


Joined: 24 Aug 2004
Posts: 96
Location: Sweden

PostPosted: Thu Feb 17, 2005 7:50 am    Post subject: Reply with quote

A.C.I.D and snort works flawless :D

I had to add ~x86 keyword to acid though

//rZn
Back to top
View user's profile Send private message
star.dancer
Tux's lil' helper
Tux's lil' helper


Joined: 18 Sep 2004
Posts: 93

PostPosted: Thu Feb 17, 2005 8:54 pm    Post subject: gnome 2.10_beta1 Reply with quote

The gnome 2.10_beta1 ebuilds in the bmg-main breakmygentoo.net repository build and run fine! You have to make a few ebuild adjustments (see my post in this thread: https://forums.gentoo.org/viewtopic-t-292537-highlight-.html ) but runs great!
Back to top
View user's profile Send private message
Sir Alaran
Apprentice
Apprentice


Joined: 11 Dec 2003
Posts: 182
Location: KSJC

PostPosted: Fri Feb 18, 2005 6:54 am    Post subject: Reply with quote

app-editors/scite-1.6.2 has been working flawlessly for weeks.
_________________
D is awesome.
Textadept is my friend.
Back to top
View user's profile Send private message
wiktorw
n00b
n00b


Joined: 14 Dec 2004
Posts: 39
Location: Lodz, Poland

PostPosted: Sun Feb 20, 2005 2:13 pm    Post subject: Success with gtk-qt-engine and dosbox Reply with quote

Hello,

Two more to the basket:

* x11-themes/gtk-qt-engine-0.6 ~amd64 ~x86
works very well on both systems (on my athlon64 it works without
any trouble for about 2 weeks already -- do I have to tell anybody
how fine Firefox looks under KDE this way?)

* games-emulation/dosbox-0.63 ~amd64
installs properly, some sound problems with specific games,
probably related to my ALSA setup -- I just had to play with
dosbox's "cycles" and "frameskip" options (this is rather normal

for this program)

Cheers,
wiktorw
_________________
Change is the only constant in the universe.
Heraclitus
Back to top
View user's profile Send private message
wzzrd
Apprentice
Apprentice


Joined: 18 Jul 2002
Posts: 245

PostPosted: Tue Feb 22, 2005 7:43 pm    Post subject: Reply with quote

Mono 1.1.4 works on amd64, (which was probably know, seen the comment in packages.mask). gtk-sharp, gnome-sharp, gconf-sharp, art-sharp work as well, resulting in succesful (yes!) building of muine on my amd64. Which, well, rocks :)
Back to top
View user's profile Send private message
Donny
n00b
n00b


Joined: 06 Jun 2004
Posts: 59

PostPosted: Wed Feb 23, 2005 11:49 pm    Post subject: Reply with quote

app-crypt/outguess-0.2.ebuild works fine. (keyword x86)
Back to top
View user's profile Send private message
StuartM
n00b
n00b


Joined: 13 Aug 2004
Posts: 19
Location: UK

PostPosted: Thu Feb 24, 2005 11:45 am    Post subject: Reply with quote

wzzrd wrote:
Mono 1.1.4 works on amd64, (which was probably know, seen the comment in packages.mask). gtk-sharp, gnome-sharp, gconf-sharp, art-sharp work as well, resulting in succesful (yes!) building of muine on my amd64. Which, well, rocks :)


How did you get mono to install I just get a build error after unmasking mono 1.1.4 :(

Also gtk-sharp seems to be masked with -amd64 so I guessed it does not work with amd64.

Would like to get mono running any tips would be appreciated,
_________________
Stuart
Back to top
View user's profile Send private message
perral1
n00b
n00b


Joined: 28 Jun 2004
Posts: 40
Location: Plano, Tx

PostPosted: Thu Feb 24, 2005 9:59 pm    Post subject: Reply with quote

synce. Just make sure and remove -Werror from all the packages (there were actually only two that you have to but I don't recall which two.) Also, you have to add -fPIC to libmimedir.
Back to top
View user's profile Send private message
tnt
Veteran
Veteran


Joined: 27 Feb 2004
Posts: 1182

PostPosted: Fri Feb 25, 2005 1:48 pm    Post subject: Reply with quote

net-p2p/dctc-0.85.9 works fine for me for two months

net-p2p/dc-qt-0.1.2 too

:wink:
_________________
gentoo user
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64 All times are GMT
Goto page Previous  1, 2, 3 ... , 16, 17, 18  Next
Page 17 of 18

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum