Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge -u error...
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
djtric714
n00b
n00b


Joined: 22 Mar 2004
Posts: 4

PostPosted: Wed Mar 24, 2004 3:32 pm    Post subject: emerge -u error... Reply with quote

i ran emerge sync...and after it was done, it said that there's a new version of portage that's already out, and it's reccomended that i update it.. but when i run emerge -up portage, i get this error..:

Performing Global Updates: /usr/portage/profiles/updates/1Q-2004
(Could take a couple minutes if you have a lot of binary packages.)
.='update pass' *='binary update' @='/var/db move'
...................portage: Update type "slotmove" not recognized.
.....................

These are the packages that I would merge, in order:

Calculating dependencies \!!! eclass 'nls' in 'sys-libs/glibc-2.3.3_pre20031210' does not exist:

!!! all ebuilds that could satisfy "virtual/glibc" have been masked.
!!! (dependency required by "sys-apps/debianutils-1.16.7-r4" [ebuild])

!!! Error calculating dependencies. Please correct.


any suggestions?=) thanks in advance for replies..=P
Back to top
View user's profile Send private message
hermes_jr
l33t
l33t


Joined: 26 Feb 2004
Posts: 701
Location: Moscow, Russia

PostPosted: Wed Mar 24, 2004 4:53 pm    Post subject: Reply with quote

In your case i'd try this:
Code:

# ACCEPT_KEYWORDS="~x86" emerge glibc
# ACCEPT_KEYWORDS="~x86" emerge debianutils
# emerge -U portage

or even
Code:

# ACCEPT_KEYWORDS="~x86" emerge -U portage
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum